zabbix-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846
  1. %bcond_with systemd
  2. %define only_agent 0
  3. %if %{only_agent}
  4. %bcond_with server
  5. %bcond_with proxy
  6. %bcond_with frontend
  7. %else
  8. %bcond_without server
  9. %bcond_without proxy
  10. %bcond_without frontend
  11. %endif
  12. %bcond_without agent
  13. %bcond_without agent2
  14. %global php_pkgname php74
  15. Summary: The Enterprise-class Monitoring Solution for Everyone
  16. Name: zabbix
  17. Version: 7.0.2
  18. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  19. Group: system
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: iwaim
  23. License: GPLv2
  24. URL: https://www.zabbix.com/
  25. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  26. Source0: https://cdn.zabbix.com/zabbix/sources/stable/%{shortver}/%{name}-%{version}.tar.gz
  27. Source1: zabbix_server.init
  28. Source2: zabbix_proxy.init
  29. Source3: zabbix_agentd.init
  30. Source4: zabbix_agent2.init
  31. Source5: zabbix_server.logrotate
  32. Source6: zabbix_proxy.logrotate
  33. Source7: zabbix_agentd.logrotate
  34. Source8: zabbix_agent2.logrotate
  35. Source9: %{name}-tmpfiles-zabbix.conf
  36. # systemd units -- Alternatives switches between them (they state their dependencies)
  37. # https://support.zabbix.com/browse/ZBXNEXT-1593
  38. Source110: %{name}-agent.service
  39. Source111: %{name}-agent2.service
  40. Source112: %{name}-proxy-mysql.service
  41. Source113: %{name}-proxy-pgsql.service
  42. Source114: %{name}-server-mysql.service
  43. Source115: %{name}-server-pgsql.service
  44. Source120: %{name}-tmpfiles-zabbixsrv.conf
  45. %if %{with agent2}
  46. # cd zabbix-7.0.2/src/go; GOPROXY=https://proxy.golang.org,direct go mod vendor
  47. Source1000: vendor.tar.xz
  48. %endif
  49. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
  50. %if %{with server}%{with proxy}
  51. BuildRequires: libpq-devel
  52. BuildRequires: libmariadb-devel
  53. %endif
  54. %if %{with agent2}
  55. BuildRequires: golang
  56. %endif
  57. BuildRequires: libevent-devel
  58. BuildRequires: pcre2-devel
  59. BuildRequires: curl-devel
  60. BuildRequires: net-snmp-devel
  61. BuildRequires: OpenIPMI-devel
  62. BuildRequires: unixODBC-devel
  63. BuildRequires: libssh2-devel
  64. BuildRequires: openssl-devel
  65. Requires(pre): glibc-common
  66. Requires(pre): shadow-utils
  67. %if %{with systemd}
  68. BuildRequires: systemd
  69. %endif
  70. %description
  71. The Enterprise-class Monitoring Solution for Everyone.
  72. %if %{with server}
  73. %package server-common
  74. Summary: common files for Zabbix Server
  75. Group: servers
  76. Requires: %{name} == %{version}-%{release}
  77. %if %{with systemd}
  78. %{?systemd_requires}
  79. %else
  80. Requires(post,preun): chkconfig
  81. Requires(preun,postun): initscripts
  82. %endif
  83. %description server-common
  84. This package include common files for Zabbix Server.
  85. %package server-mysql
  86. Summary: Zabbix Server for MySQL/MariaDB
  87. Group: servers
  88. Provides: %{name}-server
  89. Requires: %{name}-server-common == %{version}-%{release}
  90. %description server-mysql
  91. Zabbix Server for MySQL/MariaDB
  92. %package server-postgresql
  93. Summary: Zabbix Server for PostgreSQL
  94. Group: servers
  95. Provides: %{name}-server
  96. Requires: %{name}-server-common == %{version}-%{release}
  97. %description server-postgresql
  98. Zabbix Server for PostgreSQL
  99. %endif
  100. %if %{with agent}
  101. %package agent
  102. Summary: Zabbix Agent
  103. Group: system
  104. Requires: %{name} == %{version}-%{release}
  105. %if %{with systemd}
  106. %{?systemd_requires}
  107. %else
  108. Requires(post,preun): chkconfig
  109. Requires(preun,postun): initscripts
  110. %endif
  111. %description agent
  112. Zabbix Agent
  113. %endif
  114. %if %{with agent2}
  115. %package agent2
  116. Summary: Zabbix Agent2
  117. Group: system
  118. Requires: %{name} == %{version}-%{release}
  119. %if %{with systemd}
  120. %{?systemd_requires}
  121. %else
  122. Requires(post,preun): chkconfig
  123. Requires(preun,postun): initscripts
  124. %endif
  125. %description agent2
  126. Zabbix Agent2
  127. %endif
  128. %if %{with proxy}
  129. %package proxy-common
  130. Summary: common files for Zabbix Proxy
  131. Group: servers
  132. Requires: %{name} == %{version}-%{release}
  133. %if %{with systemd}
  134. %{?systemd_requires}
  135. %else
  136. Requires(post,preun): chkconfig
  137. Requires(preun,postun): initscripts
  138. %endif
  139. %description proxy-common
  140. This package include common files for Zabbix Proxy
  141. %package proxy-mysql
  142. Summary: Zabbix Proxy for MySQL/MariaDB
  143. Group: servers
  144. Provides: %{name}-proxy
  145. Requires: %{name}-proxy-common == %{version}-%{release}
  146. %description proxy-mysql
  147. Zabbix Proxy for MySQL/MariaDB
  148. %package proxy-postgresql
  149. Summary: Zabbix Proxy for PostgreSQL
  150. Group: servers
  151. Provides: %{name}-proxy
  152. Requires: %{name}-proxy-common == %{version}-%{release}
  153. %description proxy-postgresql
  154. Zabbix Proxy for PostgreSQL
  155. %endif
  156. %if %{with frontend}
  157. %package frontend-php
  158. Summary: Zabbix web frontend with PHP
  159. Group: servers
  160. Requires: %{php_pkgname}
  161. Requires: TrueType-vlgothic
  162. %description frontend-php
  163. Zabbix web frontend with PHP.
  164. %package frontend-php-mysql
  165. Summary: Zabbix web frontend with PHP and MySQL/MariaDB
  166. Group: servers
  167. Provides: %{name}-frontend-php == %{version}-%{release}
  168. Requires: %{php_pkgname}-mysql
  169. %description frontend-php-mysql
  170. Zabbix web frontend with PHP and MySQL/MariaDB.
  171. %package frontend-php-postgresql
  172. Summary: Zabbix web frontend with PHP and PostgreSQL
  173. Group: servers
  174. Provides: %{name}-frontend-php == %{version}-%{release}
  175. Requires: %{php_pkgname}-pgsql
  176. %description frontend-php-postgresql
  177. Zabbix web frontend with PHP and PostgreSQL.
  178. %endif
  179. %debug_package
  180. %prep
  181. %setup -q -T -a 0 -c -n zabbix-%{version}
  182. %if %{with agent2}
  183. pushd zabbix-%{version}/src/go
  184. tar xvf %{SOURCE1000}
  185. popd
  186. %endif
  187. mv zabbix-%{version} zabbix_mysql
  188. %if %{with server}%{with proxy}
  189. %setup -q -D -T -a 0 -n zabbix-%{version}
  190. mv zabbix-%{version} zabbix_pgsql
  191. %endif
  192. for v in mysql pgsql; do
  193. pushd zabbix_$v
  194. sed -i -e 's/DejaVuSans/VL-Gothic-Regular/g' ./ui/include/defines.inc.php
  195. sed -i \
  196. -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_agentd.pid' \
  197. -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_agentd.log|' \
  198. conf/zabbix_agentd.conf
  199. sed -i \
  200. -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_proxy.pid' \
  201. -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_proxy.log|' \
  202. conf/zabbix_proxy.conf
  203. sed -i \
  204. -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_server.pid' \
  205. -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_server.log|' \
  206. conf/zabbix_server.conf
  207. #'
  208. popd
  209. done
  210. %build
  211. Build()
  212. {
  213. perl -pi -e 's|/usr/bin/traceroute|/bin/traceroute|' \
  214. ./database/{ibm_db2,mysql,oracle,postgresql,sqlite3}/data.sql
  215. %configure \
  216. %{?with_server:--enable-server} \
  217. %{?with_proxy:--enable-proxy} \
  218. --enable-ipv6 \
  219. --sysconfdir=%{_sysconfdir}/zabbix \
  220. --with-libcurl \
  221. --with-openipmi \
  222. --with-net-snmp \
  223. --with-unixodbc \
  224. --with-ssh2 \
  225. --with-openssl \
  226. --with-libpcre2 \
  227. $@
  228. %__make
  229. }
  230. %if %{with server}%{with proxy}
  231. pushd zabbix_mysql
  232. Build \
  233. --with-mysql \
  234. %{?with_agent:--enable-agent} \
  235. %{?with_agent2:--enable-agent2} \
  236. %{nil}
  237. popd
  238. pushd zabbix_pgsql
  239. Build --with-postgresql
  240. popd
  241. %else
  242. pushd zabbix_mysql
  243. Build
  244. popd
  245. %endif
  246. %install
  247. %__rm -rf %{buildroot}
  248. pushd zabbix_mysql
  249. make DESTDIR=%{buildroot} install
  250. %if %{with server}
  251. mv -f %{buildroot}%{_sbindir}/zabbix_server %{buildroot}%{_sbindir}/zabbix_server.mysql
  252. %endif
  253. %if %{with proxy}
  254. mv -f %{buildroot}%{_sbindir}/zabbix_proxy %{buildroot}%{_sbindir}/zabbix_proxy.mysql
  255. %endif
  256. # make directories
  257. %__mkdir_p %{buildroot}%{_localstatedir}/{log,run}/%{name}
  258. # DB
  259. %__mkdir_p %{buildroot}%{_datadir}/zabbix
  260. %if %{with server}%{with proxy}
  261. %__cp -a database/postgresql %{buildroot}%{_datadir}/zabbix/
  262. %__cp -a database/mysql %{buildroot}%{_datadir}/zabbix/
  263. %endif
  264. %if %{with agent2}
  265. sed -i \
  266. -e '/^# PidFile=/a PidFile=/run/zabbix/zabbix_agent2.pid' \
  267. -e '/^# LogFile=/a LogFile=/var/log/zabbix/zabbix_agent2.log' \
  268. %{buildroot}/etc/zabbix/zabbix_agent2.conf
  269. %endif
  270. %if %{with systemd}
  271. # unit files
  272. %__mkdir_p %{buildroot}%{_unitdir}
  273. # Install different systemd units because of the requirements for DBMS daemons
  274. install -m 0644 -p %{SOURCE110} %{buildroot}%{_unitdir}/zabbix-agent.service
  275. install -m 0644 -p %{SOURCE111} %{buildroot}%{_unitdir}/zabbix-agent2.service
  276. install -m 0644 -p %{SOURCE112} %{buildroot}%{_unitdir}/zabbix-proxy-mysql.service
  277. install -m 0644 -p %{SOURCE113} %{buildroot}%{_unitdir}/zabbix-proxy-pgsql.service
  278. install -m 0644 -p %{SOURCE114} %{buildroot}%{_unitdir}/zabbix-server-mysql.service
  279. install -m 0644 -p %{SOURCE115} %{buildroot}%{_unitdir}/zabbix-server-pgsql.service
  280. # systemd tmpfiles
  281. mkdir -p %{buildroot}%{_prefix}/lib/tmpfiles.d
  282. install -m 0644 -p %{SOURCE9} %{buildroot}%{_prefix}/lib/tmpfiles.d/zabbix.conf
  283. %else
  284. # init.d
  285. %__mkdir_p %{buildroot}%{_initddir}
  286. %if %{with server}
  287. %__cp %{SOURCE1} %{buildroot}%{_initddir}/zabbix_server
  288. %endif
  289. %if %{with proxy}
  290. %__cp %{SOURCE2} %{buildroot}%{_initddir}/zabbix_proxy
  291. %endif
  292. %if %{with agent}
  293. %__cp %{SOURCE3} %{buildroot}%{_initddir}/zabbix_agentd
  294. %endif
  295. %if %{with agent2}
  296. %__cp %{SOURCE4} %{buildroot}%{_initddir}/zabbix_agent2
  297. %endif
  298. %endif
  299. # logrotate
  300. %__mkdir_p %{buildroot}%{_sysconfdir}/logrotate.d
  301. %if %{with server}
  302. %__cp %{SOURCE5} %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_server
  303. %endif
  304. %if %{with proxy}
  305. %__cp %{SOURCE6} %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_proxy
  306. %endif
  307. %if %{with agent}
  308. %__cp %{SOURCE7} %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_agentd
  309. %endif
  310. %if %{with agent2}
  311. %__cp %{SOURCE8} %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_agent2
  312. %endif
  313. %if %{with frontend}
  314. # frontend-php
  315. %__mkdir_p %{buildroot}%{_datadir}/zabbix-frontend
  316. %__cp -a ui %{buildroot}%{_datadir}/zabbix-frontend/php
  317. %__rm -f %{buildroot}%{_datadir}/zabbix-frontend/php/assets/fonts/DejaVuSans.ttf
  318. ln -s /usr/share/fonts/TrueType-vlgothic/VL-Gothic-Regular.ttf \
  319. %{buildroot}%{_datadir}/zabbix-frontend/php/assets/fonts/
  320. %endif
  321. %if %{with proxy}
  322. # proxy
  323. mkdir -p %{buildroot}%{_datadir}/zabbix-proxy
  324. ln -sf ../zabbix/mysql %{buildroot}%{_datadir}/zabbix-proxy/
  325. ln -sf ../zabbix/postgresql %{buildroot}%{_datadir}/zabbix-proxy/
  326. %endif
  327. popd
  328. %if %{with server}%{with proxy}
  329. pushd zabbix_pgsql
  330. install -m755 src/zabbix_server/zabbix_server %{buildroot}%{_sbindir}/zabbix_server.pgsql
  331. install -m755 src/zabbix_proxy/zabbix_proxy %{buildroot}%{_sbindir}/zabbix_proxy.pgsql
  332. popd
  333. %endif
  334. %pre
  335. getent group zabbix >/dev/null || groupadd -r zabbix
  336. getent passwd zabbix >/dev/null || \
  337. useradd -r -g zabbix -d %{_sysconfdir}/zabbix -s /sbin/nologin \
  338. -c "Zabbix Monitoring Solution" zabbix
  339. exit 0
  340. %if %{with server}
  341. %post server-mysql
  342. %if %{with systemd}
  343. %systemd_post zabbix-server-mysql.service
  344. %else
  345. /sbin/update-alternatives --install /usr/sbin/zabbix_server \
  346. zabbix_server /usr/sbin/zabbix_server.mysql 10
  347. %endif
  348. %post server-postgresql
  349. %if %{with systemd}
  350. %systemd_post zabbix-server-pgsql.service
  351. %else
  352. /sbin/update-alternatives --install /usr/sbin/zabbix_server \
  353. zabbix_server /usr/sbin/zabbix_server.pgsql 10
  354. /sbin/chkconfig --add zabbix_server
  355. %endif
  356. %endif
  357. %if %{with proxy}
  358. %post proxy-mysql
  359. %if %{with systemd}
  360. %systemd_post zabbix-proxy-mysql.service
  361. %else
  362. /sbin/update-alternatives --install /usr/sbin/zabbix_proxy \
  363. zabbix_proxy /usr/sbin/zabbix_proxy.mysql 10
  364. /sbin/chkconfig --add zabbix_proxy
  365. %endif
  366. %post proxy-postgresql
  367. %if %{with systemd}
  368. %systemd_post zabbix-proxy-pgsql.service
  369. %else
  370. /sbin/update-alternatives --install /usr/sbin/zabbix_proxy \
  371. zabbix_proxy /usr/sbin/zabbix_proxy.pgsql 10
  372. /sbin/chkconfig --add zabbix_proxy
  373. %endif
  374. %endif
  375. %if %{with agent}
  376. %post agent
  377. %if %{with systemd}
  378. %systemd_post zabbix-agent.service
  379. %else
  380. /sbin/chkconfig --add zabbix_agentd
  381. %endif
  382. %endif
  383. %if %{with agent2}
  384. %post agent2
  385. %if %{with systemd}
  386. %systemd_post zabbix-agent2.service
  387. %else
  388. /sbin/chkconfig --add zabbix_agent2
  389. %endif
  390. %endif
  391. %if %{with server}
  392. %preun server-mysql
  393. %if %{with systemd}
  394. %systemd_preun zabbix-server-mysql.service
  395. %else
  396. if [ "$1" -eq 0 -o -x /usr/bin/systemctl ]; then
  397. /sbin/service zabbix_server stop >/dev/null 2>&1
  398. /sbin/chkconfig --del zabbix_server
  399. /sbin/update-alternatives --remove zabbix_server \
  400. /usr/sbin/zabbix_server.mysql
  401. fi
  402. %endif
  403. %preun server-postgresql
  404. %if %{with systemd}
  405. %systemd_preun zabbix-server-pgysql.service
  406. %else
  407. if [ "$1" -eq 0 -o -x /usr/bin/systemctl ]; then
  408. /sbin/service zabbix_server stop >/dev/null 2>&1
  409. /sbin/chkconfig --del zabbix_server
  410. /sbin/update-alternatives --remove zabbix_server \
  411. /usr/sbin/zabbix_server.pgsql
  412. fi
  413. %endif
  414. %endif
  415. %if %{with proxy}
  416. %preun proxy-mysql
  417. %if %{with systemd}
  418. %systemd_preun zabbix-proxy-mysql.service
  419. %else
  420. if [ "$1" -eq 0 -o -x /usr/bin/systemctl ]; then
  421. /sbin/service zabbix_proxy stop >/dev/null 2>&1
  422. /sbin/chkconfig --del zabbix_proxy
  423. /sbin/update-alternatives --remove zabbix_proxy \
  424. /usr/sbin/zabbix_proxy.mysql
  425. fi
  426. %endif
  427. %preun proxy-postgresql
  428. %if %{with systemd}
  429. %systemd_preun zabbix-proxy-pgsql.service
  430. %else
  431. if [ "$1" -eq 0 -o -x /usr/bin/systemctl ]; then
  432. /sbin/service zabbix_proxy stop >/dev/null 2>&1
  433. /sbin/chkconfig --del zabbix_proxy
  434. /sbin/update-alternatives --remove zabbix_proxy \
  435. /usr/sbin/zabbix_proxy.pgsql
  436. fi
  437. %endif
  438. %endif
  439. %if %{with agent}
  440. %preun agent
  441. %if %{with systemd}
  442. %systemd_preun zabbix-agent.service
  443. %else
  444. if [ "$1" -eq 0 -o -x /usr/bin/systemctl ]; then
  445. /sbin/service zabbix_agentd stop >/dev/null 2>&1
  446. /sbin/chkconfig --del zabbix_agentd
  447. fi
  448. %endif
  449. %endif
  450. %if %{with agent2}
  451. %preun agent2
  452. %if %{with systemd}
  453. %systemd_preun zabbix-agent2.service
  454. %else
  455. if [ "$1" -eq 0 -o -x /usr/bin/systemctl ]; then
  456. /sbin/service zabbix_agent2 stop >/dev/null 2>&1
  457. /sbin/chkconfig --del zabbix_agent2
  458. fi
  459. %endif
  460. %endif
  461. %if %{with server}
  462. %postun server-mysql
  463. %if %{with systemd}
  464. %systemd_postun_with_restart zabbix-server-mysql.service
  465. %else
  466. if [ "$1" -ge "1" -a ! -x /usr/bin/systemctl ]; then
  467. /sbin/service zabbix_server condrestart >/dev/null 2>&1 || :
  468. fi
  469. %endif
  470. %postun server-postgresql
  471. %if %{with systemd}
  472. %systemd_postun_with_restart zabbix-server-pgsql.service
  473. %else
  474. if [ "$1" -ge "1" -a ! -x /usr/bin/systemctl ]; then
  475. /sbin/service zabbix_server condrestart >/dev/null 2>&1 || :
  476. fi
  477. %endif
  478. %endif
  479. %if %{with proxy}
  480. %postun proxy-mysql
  481. %if %{with systemd}
  482. %systemd_postun_with_restart zabbix-proxy-mysql.service
  483. %else
  484. if [ "$1" -ge "1" -a ! -x /usr/bin/systemctl ]; then
  485. /sbin/service zabbix_proxy condrestart >/dev/null 2>&1 || :
  486. fi
  487. %endif
  488. %postun proxy-postgresql
  489. %if %{with systemd}
  490. %systemd_postun_with_restart zabbix-proxy-pgsql.service
  491. %else
  492. if [ "$1" -ge "1" -a ! -x /usr/bin/systemctl ]; then
  493. /sbin/service zabbix_proxy condrestart >/dev/null 2>&1 || :
  494. fi
  495. %endif
  496. %endif
  497. %if %{with agent}
  498. %postun agent
  499. %if %{with systemd}
  500. %systemd_postun_with_restart zabbix-agent.service
  501. %else
  502. if [ "$1" -ge "1" -a ! -x /usr/bin/systemctl ]; then
  503. /sbin/service zabbix_agentd condrestart >/dev/null 2>&1 || :
  504. fi
  505. %endif
  506. %endif
  507. %if %{with agent2}
  508. %postun agent2
  509. %if %{with systemd}
  510. %systemd_postun_with_restart zabbix-agent2.service
  511. %else
  512. if [ "$1" -ge "1" -a ! -x /usr/bin/systemctl ]; then
  513. /sbin/service zabbix_agent2 condrestart >/dev/null 2>&1 || :
  514. fi
  515. %endif
  516. %endif
  517. %files
  518. %defattr(-,root,root,-)
  519. %license zabbix_mysql/COPYING
  520. %doc zabbix_mysql/AUTHORS zabbix_mysql/ChangeLog zabbix_mysql/NEWS zabbix_mysql/README
  521. %attr(0755,zabbix,zabbix) %dir %{_localstatedir}/log/%{name}
  522. %dir %{_datadir}/zabbix
  523. %if %{with server}%{with proxy}
  524. %{_datadir}/zabbix/mysql
  525. %{_datadir}/zabbix/postgresql
  526. %endif
  527. %if %{with systemd}
  528. %{_prefix}/lib/tmpfiles.d/zabbix.conf
  529. %endif
  530. %{_bindir}/zabbix_js
  531. %if %{with server}
  532. %files server-common
  533. %defattr(-,root,root,-)
  534. %dir %{_sysconfdir}/zabbix
  535. %config(noreplace) %{_sysconfdir}/zabbix/zabbix_server.conf
  536. %config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_server
  537. %if !%{with systemd}
  538. %{_initddir}/zabbix_server*
  539. %endif
  540. %{_mandir}/man8/zabbix_server.8*
  541. %files server-mysql
  542. %defattr(-,root,root,-)
  543. %{_sbindir}/zabbix_server.mysql
  544. %if %{with systemd}
  545. %{_unitdir}/zabbix-server-mysql.service
  546. %endif
  547. %files server-postgresql
  548. %defattr(-,root,root,-)
  549. %{_sbindir}/zabbix_server.pgsql
  550. %if %{with systemd}
  551. %{_unitdir}/zabbix-server-pgsql.service
  552. %endif
  553. %endif
  554. %if %{with agent}
  555. %files agent
  556. %defattr(-,root,root,-)
  557. %dir %{_sysconfdir}/zabbix
  558. %config(noreplace) %{_sysconfdir}/zabbix/zabbix_agentd.conf
  559. %config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_agentd
  560. %{_bindir}/zabbix_get
  561. %{_bindir}/zabbix_sender
  562. %{_sbindir}/zabbix_agentd
  563. %if %{with systemd}
  564. %{_unitdir}/zabbix-agent.service
  565. %else
  566. %{_initddir}/zabbix_agentd
  567. %endif
  568. %{_mandir}/man1/zabbix_get.1*
  569. %{_mandir}/man1/zabbix_sender.1*
  570. %{_mandir}/man8/zabbix_agentd.8*
  571. %endif
  572. %if %{with agent2}
  573. %files agent2
  574. %defattr(-,root,root,-)
  575. %dir %{_sysconfdir}/zabbix
  576. %config(noreplace) %{_sysconfdir}/zabbix/zabbix_agent2.conf
  577. %config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_agent2
  578. %dir %{_sysconfdir}/zabbix/zabbix_agent2.d
  579. %dir %{_sysconfdir}/zabbix/zabbix_agent2.d/plugins.d
  580. %{_sysconfdir}/zabbix/zabbix_agent2.d/plugins.d/*.conf
  581. %{_sbindir}/zabbix_agent2
  582. %{_mandir}/man8/zabbix_agent2.8*
  583. %if %{with systemd}
  584. %{_unitdir}/zabbix-agent2.service
  585. %else
  586. %{_initddir}/zabbix_agent2
  587. %endif
  588. %endif
  589. %if %{with proxy}
  590. %files proxy-common
  591. %defattr(-,root,root,-)
  592. %dir %{_sysconfdir}/zabbix
  593. %config(noreplace) %{_sysconfdir}/zabbix/zabbix_proxy.conf
  594. %config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_proxy
  595. %if !%{with systemd}
  596. %{_initddir}/zabbix_proxy
  597. %endif
  598. %{_mandir}/man8/zabbix_proxy.8*
  599. %{_datadir}/zabbix-proxy
  600. %files proxy-mysql
  601. %defattr(-,root,root,-)
  602. %{_sbindir}/zabbix_proxy.mysql
  603. %if %{with systemd}
  604. %{_unitdir}/zabbix-proxy-mysql.service
  605. %endif
  606. %files proxy-postgresql
  607. %defattr(-,root,root,-)
  608. %{_sbindir}/zabbix_proxy.pgsql
  609. %if %{with systemd}
  610. %{_unitdir}/zabbix-proxy-pgsql.service
  611. %endif
  612. %endif
  613. %if %{with frontend}
  614. %files frontend-php
  615. %defattr(-,root,root,-)
  616. %license zabbix_mysql/COPYING
  617. %doc zabbix_mysql/AUTHORS zabbix_mysql/ChangeLog zabbix_mysql/NEWS zabbix_mysql/README
  618. %dir %{_datadir}/zabbix-frontend
  619. %{_datadir}/zabbix-frontend/php
  620. %files frontend-php-mysql
  621. %files frontend-php-postgresql
  622. %endif
  623. %changelog
  624. * Mon Aug 05 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.2-1
  625. - new upstream release.
  626. * Wed Jul 24 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  627. - new upstream release.
  628. * Wed Oct 18 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.22-1
  629. - new upstream release.
  630. * Wed Jul 26 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.19-1
  631. - new upstream release.
  632. * Fri Apr 14 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.16-1
  633. - new upstream release.
  634. * Sat Dec 10 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.12-1
  635. - new upstream release.
  636. * Fri Sep 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.8-1
  637. - new upstream release.
  638. * Fri Jul 15 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.6-1
  639. - new upstream release.
  640. * Sat Jan 22 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.19-1
  641. - new upstream release.
  642. * Tue Oct 05 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.16-1
  643. - new upstream release.
  644. * Tue Aug 31 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.15-1
  645. - new upstream release.
  646. * Fri Mar 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.9-1
  647. - new upstream release.
  648. * Sun Dec 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.6-1
  649. - new upstream release.
  650. * Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.3-1
  651. - new upstream release.
  652. * Thu Jul 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-1
  653. - new upstream release.
  654. - dropped all patches: made to get the same effect by another method.
  655. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.19-2
  656. - rebuilt with libevent-2.1.11.
  657. * Mon Apr 06 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.19-1
  658. - new upstream release.
  659. - dropped Patch3: fixed in upstream.
  660. - changed R:php5 to R:php74.
  661. - added systemd support (disabled as default).
  662. * Thu Dec 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.15-1
  663. - new upstream release.
  664. - imported Patch13 from upstream to support php74.
  665. * Thu Oct 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.13-1
  666. - new upstream release.
  667. - updated patches.
  668. * Wed May 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
  669. - new upstream release.
  670. - switched to 4.0 LTS.
  671. - dropped Patch0: made to get same effect by another method.
  672. - updated Patch1 and 2.
  673. * Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.23-1
  674. - new upstream release.
  675. * Tue Jun 12 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 3.0.13-2
  676. - accept building only agent
  677. * Thu Dec 21 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.13-1
  678. - new upstream release.
  679. * Fri Apr 21 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.8-1
  680. - new upstream release.
  681. * Fri Mar 18 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.1-1
  682. - new upstream release.
  683. - disabled jabber support.
  684. * Wed Sep 9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-1
  685. - new upstream release.
  686. * Sat Apr 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.9-1
  687. - new upstream release.
  688. * Sun Jul 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.4-1
  689. - new upstream release.
  690. - built with both of mysql and postgresql.
  691. * Mon Oct 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
  692. - update to 2.0.8
  693. * Wed Feb 20 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.5-2
  694. - use %%bcond_with mysql to build with mysql
  695. * Tue Feb 19 2013 IWAI, Masaharu <iwai@alib.jp> 2.0.5-1
  696. - update to 2.0.5
  697. - add using MySQL client library switch: default no
  698. - define use_postfix and use_mysql
  699. - add BuildRequires: MySQL-devel
  700. - add configure option: --with-mysql
  701. * Thu Feb 7 2013 IWAI, Masaharu <iwai@alib.jp> 2.0.4-1
  702. - initial build for Vine Linux