jack-audio-connection-kit-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327
  1. Summary: The Jack Audio Connection Kit
  2. Name: jack-audio-connection-kit
  3. Version: 1.9.22
  4. Release: 1%{?_dist_release}
  5. Group: multimedia,system
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. # The entire source (~500 files) is a mixture of these three licenses
  9. License: GPLv2 and GPLv2+ and LGPLv2+
  10. URL: http://www.jackaudio.org
  11. #Source0: http://www.jackaudio.org/downloads/%{name}-%{version}.tar.gz
  12. Source0: https://github.com/jackaudio/jack2/archive/refs/tags/v%{version}.tar.gz#/jack2-%{version}.tar.gz
  13. Source1: %{name}-README.Fedora
  14. Source2: %{name}-script.pa
  15. Source3: %{name}-limits.conf
  16. # Build with Python >= 3.12
  17. Patch0: jack2-py312.patch
  18. # Adjust default priority. RHBZ#795094
  19. Patch1: jack-realtime-compat.patch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  21. BuildRequires: alsa-lib-devel
  22. BuildRequires: dbus-devel
  23. BuildRequires: doxygen
  24. BuildRequires: expat-devel
  25. BuildRequires: libsamplerate-devel
  26. BuildRequires: libsndfile-devel >= 1.0.0
  27. BuildRequires: ncurses-devel
  28. BuildRequires: opus-devel
  29. BuildRequires: pkgconfig
  30. BuildRequires: python3
  31. BuildRequires: readline-devel
  32. #BuildRequires: autoconf >= 2.59, automake >= 1.9.3, libtool
  33. #BuildRequires: libdb-devel
  34. #BuildRequires: libuuid-devel
  35. Obsoletes: %{name}-example-clients < 1.9.22
  36. %global groupname jackuser
  37. %global pagroup pulse-rt
  38. Requires(pre): shadow-utils
  39. %description
  40. JACK is a low-latency audio server, written primarily for the Linux
  41. operating system. It can connect a number of different applications to
  42. an audio device, as well as allowing them to share audio between
  43. themselves. Its clients can run in their own processes (ie. as a
  44. normal application), or can they can run within a JACK server (ie. a
  45. "plugin").
  46. JACK is different from other audio server efforts in that it has been
  47. designed from the ground up to be suitable for professional audio
  48. work. This means that it focuses on two key areas: synchronous
  49. execution of all clients, and low latency operation.
  50. %package dbus
  51. Summary: Jack D-Bus launcher
  52. Group: multimedia
  53. Requires: %{name} = %{version}-%{release}
  54. %description dbus
  55. Launcher to start Jack through D-Bus.
  56. %package devel
  57. Summary: Development files for %{name}
  58. Summary(ja): %{name} の開発用ファイル
  59. Group: programming
  60. Requires: %{name} = %{version}-%{release}
  61. Requires: pkgconfig
  62. %description devel
  63. Development files for the Jack Audio Connection Kit.
  64. %debug_package
  65. %prep
  66. %autosetup -p1 -n jack2-%{version}
  67. %build
  68. %set_build_flags
  69. export PREFIX=%{_prefix}
  70. # Parallel build disabled as it fails sometimes
  71. python3 ./waf configure \
  72. --mandir=%{_mandir}/man1 \
  73. --libdir=%{_libdir} \
  74. --doxygen \
  75. --dbus \
  76. --classic \
  77. --alsa \
  78. --clients 256 \
  79. --ports-per-application=2048
  80. ./waf build %{?_smp_mflags} -v
  81. %install
  82. python3 ./waf --destdir=$RPM_BUILD_ROOT install
  83. # move doxygen documentation to the right place
  84. mv $RPM_BUILD_ROOT%{_datadir}/jack-audio-connection-kit/reference .
  85. rm -rf $RPM_BUILD_ROOT%{_datadir}/jack-audio-connection-kit
  86. # install our limits to the /etc/security/limits.d
  87. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/security/limits.d
  88. sed -e 's,@groupname@,%groupname,g; s,@pagroup@,%pagroup,g;' \
  89. %{SOURCE3} > $RPM_BUILD_ROOT%{_sysconfdir}/security/limits.d/95-jack.conf
  90. # prepare README.Fedora for documentation including
  91. install -p -m644 %{SOURCE1} README.Fedora
  92. # install pulseaudio script for jack (as documentation part)
  93. install -p -m644 %{SOURCE2} jack.pa
  94. # Fix permissions of the modules
  95. chmod 755 $RPM_BUILD_ROOT%{_libdir}/jack/*.so $RPM_BUILD_ROOT%{_libdir}/libjack*.so.*.*.*
  96. %pre
  97. getent group %groupname > /dev/null || groupadd -r %groupname
  98. exit 0
  99. %files
  100. %defattr(-,root,root)
  101. %doc ChangeLog README README_NETJACK2 TODO
  102. %doc README.Fedora
  103. %doc jack.pa
  104. %config(noreplace) %{_sysconfdir}/security/limits.d/*.conf
  105. %{_bindir}/jackd
  106. %{_libdir}/jack/
  107. %{_libdir}/libjack.so.*
  108. %{_libdir}/libjacknet.so.*
  109. %{_libdir}/libjackserver.so.*
  110. %{_mandir}/man1/jackd*.1*
  111. %files dbus
  112. %defattr(-,root,root)
  113. %{_bindir}/jackdbus
  114. %{_datadir}/dbus-1/services/org.jackaudio.service
  115. %{_bindir}/jack_control
  116. %files devel
  117. %defattr(-,root,root)
  118. %doc reference/html/
  119. %{_includedir}/jack/
  120. %{_libdir}/libjack.so
  121. %{_libdir}/libjacknet.so
  122. %{_libdir}/libjackserver.so
  123. %{_libdir}/pkgconfig/jack.pc
  124. %changelog
  125. * Mon Jul 08 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.22-1
  126. - new upstream release.
  127. * Fri Mar 26 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.17-1
  128. - new upstream release.
  129. - dropped Patch0, 1, 2 and 4.
  130. - imported Patch0 from rawhide.
  131. - renumbered patches.
  132. - dropped ldconfig scriptlets.
  133. * Wed Sep 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-3
  134. - rebuilt only.
  135. * Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-1
  136. - updated to 1.9.12.
  137. - built with readline-8.0.
  138. - updated Patch0-2.
  139. - dropped Patch4-6.
  140. - imported Patch4 from rawhide.
  141. * Sat Jul 2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.10-2
  142. - rebuilt with new toolchain.
  143. - added Patch6 for gcc5.
  144. * Thu Apr 2 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.9.10-1
  145. - updated to 1.9.10
  146. - built with readline 6.3
  147. - added dbus subpackage
  148. * Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.124.1
  149. - update to 0.124.1
  150. - add BuildRequires: libdb-devel, libuuid-devel
  151. - add Patch0 (jack-audio-connection-kit-0.124.1-freebob_driver.patch)
  152. * Wed Feb 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.121.3
  153. - update to 0.121.3
  154. - add BuildRequires: celt-devel
  155. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.118.0-2
  156. - rebuild with rpm-4.8.1 for pkg-config file
  157. - add BuildRequires: libsamplerate-devel
  158. * Fri May 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.118.0-1
  159. - new upstream release
  160. * Sun Jul 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.116.1-1
  161. - new upstream release
  162. - rebuild with ncurses-devel
  163. * Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.109.2-1
  164. - initial build for Vine Linux
  165. * Wed Feb 13 2008 Andy Shevchenko <andy@smile.org.ua> 0.109.2-1.1
  166. - update to the last official release
  167. * Mon Jan 21 2008 Andy Shevchenko <andy@smile.org.ua> 0.109.0-1
  168. - update to the last official release (#429162)
  169. - shut up the postinstall script (#359291)
  170. * Sat Oct 20 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-5
  171. - fix timestamps to avoid multiarch conflicts (#341621)
  172. * Tue Sep 04 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-4
  173. - fix Source Forge's URL scheme
  174. * Thu Aug 16 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-3
  175. - fix according to new guidelines:
  176. - License tag
  177. - group creation
  178. * Wed May 23 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-1
  179. - update to the last official release
  180. - append defaults to the limits.conf (#221785, #235624)
  181. * Wed Mar 07 2007 Andy Shevchenko <andy@smile.org.ua> 0.102.20-4
  182. - drop libtermcap-devel build requirement (#231203)
  183. - create special jackuser group (#221785)
  184. * Sat Oct 28 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-3
  185. - fix BuildRequires: libfreebob -> libfreebob-devel
  186. * Tue Oct 24 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-2.1
  187. - rebuild with libfreebob (should closed #211751)
  188. * Wed Oct 11 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-2.0
  189. - update to 0.102.20
  190. - drop patch0 (already in mainstream)
  191. - no pack jack_transport (build error)
  192. - pack new JACK MIDI files
  193. * Tue Aug 29 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-13
  194. - http://fedoraproject.org/wiki/Extras/Schedule/FC6MassRebuild
  195. * Tue Aug 01 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-12
  196. - use install instead of cp (#200835)
  197. * Tue Jul 04 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-11
  198. - update URL
  199. - add BR: libtool
  200. * Tue Jun 20 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-10
  201. - add BRs: autoconf, automake
  202. (http://fedoraproject.org/wiki/QA/FixBuildRequires)
  203. * Sat May 27 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-9
  204. - remove --enable-stripped-jackd and --enable-optimize (use default flags)
  205. * Fri May 19 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-8
  206. - uniform directories items at %files section
  207. * Wed May 17 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-7
  208. - change License tag to GPL/LGPL
  209. - remove --enable-shared (it should be default)
  210. - add a -p flag to the line that copies README.Fedora
  211. * Wed May 10 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-6
  212. - apply clock fix for AMD X2 CPUs (please, refer to
  213. http://sourceforge.net/mailarchive/forum.php?thread_id=8085535&forum_id=3040)
  214. * Wed May 03 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-5
  215. - adjust spec after reviewing
  216. * Thu Apr 27 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-4
  217. - reformatting README.Fedora to 72 symbols width
  218. * Wed Apr 26 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-3
  219. - add README.Fedora
  220. - remove useless BRs
  221. * Mon Apr 24 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-2
  222. - disable oss and portaudio engines
  223. - use /dev/shm as jack tmpdir
  224. - remove capabilities stuff
  225. * Tue Apr 04 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-1
  226. - update to 0.101.1
  227. * Mon Mar 27 2006 Andy Shevchenko <andriy@asplinux.com.ua>
  228. - update to 0.100.7 (#183912)
  229. - adjust BR (add versions)
  230. - replace files between examples and main packages
  231. - own jack tmpdir
  232. * Fri Mar 17 2006 Andy Shevchenko <andriy@asplinux.com.ua>
  233. - no libs subpackage
  234. - From Fernando Lopez-Lezcano <nando@ccrma.stanford.edu>:
  235. - added configuration variable to build with/without capabilities
  236. - added --enable-optimize flag to configure script
  237. - disabled sse/mmx instructions in i386 build
  238. - create temporary directory as /var/lib/jack/tmp
  239. - create and erase tmp directory at install or uninstall
  240. - try to umount the temporary directory before uninstalling the package
  241. * Fri Mar 03 2006 Andy Shevchenko <andriy@asplinux.com.ua>
  242. - fix spec for extras injection
  243. * Fri Nov 18 2005 Andy Shevchenko <andriy@asplinux.ru>
  244. - exclude *.la files
  245. - use dist tag
  246. * Fri Oct 14 2005 Andy Shevchenko <andriy@asplinux.ru>
  247. - 0.100.0
  248. - no optimization
  249. * Tue Sep 28 2004 Andy Shevchenko <andriy@asplinux.ru>
  250. - 0.99.1
  251. * Fri Aug 20 2004 Andy Shevchenko <andriy@asplinux.ru>
  252. - rebuild from Mandrake