ristretto-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257
  1. # Review at https://bugzilla.redhat.com/show_bug.cgi?id=351531
  2. %global majorversion 0.8
  3. %global xfceversion 4.12.0
  4. Name: ristretto
  5. Version: 0.8.0
  6. Release: 1%{?_dist_release}
  7. Summary: Image-viewer for the Xfce desktop environment
  8. Summary(ja): Xfce デスクトップ環境向けの画像ビューア
  9. Summary(de): Bildbetrachter für die Xfce Desktop-Umgebung
  10. Group: Application/Graphics
  11. License: GPLv2+
  12. URL: http://goodies.xfce.org/projects/applications/ristretto/
  13. Source0: http://archive.xfce.org/src/apps/%{name}/%{majorversion}/%{name}-%{version}.tar.bz2
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: dbus-glib-devel >= 0.34
  16. BuildRequires: gtk2-devel >= 2.20.0
  17. BuildRequires: libexo-devel >= 0.4.0
  18. BuildRequires: libexif-devel >= 0.6.0
  19. BuildRequires: libxfce4ui-devel >= %{xfceversion}
  20. BuildRequires: xfconf-devel >= %{xfceversion}
  21. BuildRequires: desktop-file-utils, gettext, intltool
  22. Requires: tumbler
  23. %description
  24. Ristretto is a fast and lightweight image-viewer for the Xfce desktop
  25. environment.
  26. %description -l de
  27. Ristretto ist ein schneller und leichtgewichtiger Bildbetrachter für die Xfce
  28. Desktop-Umgebung.
  29. %prep
  30. %setup -q
  31. %build
  32. %configure
  33. make %{?_smp_mflags}
  34. %install
  35. rm -rf %{buildroot}
  36. make install DESTDIR=%{buildroot} INSTALL='install -p'
  37. %find_lang %{name}
  38. desktop-file-install \
  39. --dir %{buildroot}%{_datadir}/applications \
  40. --add-mime-type=image/x-bmp \
  41. --add-mime-type=image/x-png \
  42. --add-mime-type=image/x-pcx \
  43. --add-mime-type=image/x-tga \
  44. --add-mime-type=image/xpm \
  45. --delete-original \
  46. %{buildroot}%{_datadir}/applications/%{name}.desktop
  47. %clean
  48. rm -rf %{buildroot}
  49. %post
  50. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  51. update-desktop-database &> /dev/null || :
  52. %postun
  53. if [ $1 -eq 0 ] ; then
  54. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  55. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  56. fi
  57. update-desktop-database &> /dev/null || :
  58. %posttrans
  59. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  60. %files -f %{name}.lang
  61. %defattr(-,root,root,-)
  62. %doc AUTHORS COPYING ChangeLog README
  63. %{_bindir}/%{name}
  64. %{_datadir}/appdata/%{name}.appdata.xml
  65. %{_datadir}/applications/*%{name}.desktop
  66. %{_datadir}/icons/hicolor/*/*/*
  67. %changelog
  68. * Sun Mar 1 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.8.0-1
  69. - Initial build for Vine Linux
  70. * Sat Feb 21 2015 Till Maas <opensource@till.name> - 0.6.3-7
  71. - Rebuilt for Fedora 23 Change
  72. https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
  73. * Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-6
  74. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  75. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-5
  76. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  77. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-4
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  79. * Wed May 01 2013 Jon Ciesla <limburgher@gmail.com> - 0.6.3-3
  80. - Drop desktop vendor tag.
  81. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-2
  82. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  83. * Tue Jan 01 2013 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.3-1
  84. - Update to 0.6.3 (#891037)
  85. * Fri Jul 27 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-2
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  87. * Sun Apr 29 2012 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.0
  88. - Update to 0.6.0
  89. * Fri Apr 27 2012 Kevin Fenzi <kevin@scrye.com> - 0.3.7-1
  90. - Update to 0.3.7
  91. * Wed Apr 04 2012 Kevin Fenzi <kevin@scrye.com> - 0.3.6-2
  92. - Rebuild for Xfce 4.10
  93. * Tue Apr 03 2012 Christoph Wickert <cwickert@fedoraproject.org> - 0.3.6-1
  94. - Update to 0.3.6
  95. - Add VCS key
  96. * Sat Mar 03 2012 Christoph Wickert <cwickert@fedoraproject.org> - 0.3.5-1
  97. - Update to 0.3.5
  98. * Sat Jan 28 2012 Christoph Wickert <cwickert@fedoraproject.org> - 0.3.4-1
  99. - Update to 0.3.4
  100. * Sat Jan 14 2012 Christoph Wickert <cwickert@fedoraproject.org> - 0.3.2-1
  101. - Update to 0.3.2
  102. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-3
  103. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  104. * Tue Nov 08 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.3.0-2
  105. - Require tumbler for thumbnail generation
  106. * Sun Nov 06 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.3.0-1
  107. - Update to 0.3.0
  108. * Sun Nov 06 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.2.3-1
  109. - Update to 0.2.3 (fixes #750657)
  110. * Sat Oct 29 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.2.2-1
  111. - Update to 0.2.2
  112. * Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.1-2
  113. - Rebuilt for glibc bug#747377
  114. * Sun Oct 23 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.2.1-1
  115. - Update to 0.2.1
  116. * Tue Oct 18 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.2.0-1
  117. - Update to 0.2.0
  118. * Sun Oct 09 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.1-1
  119. - Update to 0.1.1
  120. - Drop DSO patch, fixed upstream
  121. * Thu Oct 06 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.0-1
  122. - Update to 0.1.0
  123. * Wed Aug 16 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.93-2
  124. - Fix two major memory leaks (bugzilla.xfce.org #7882)
  125. * Thu Mar 03 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.93-1
  126. - Update to 0.0.93 (fixes #542141 and #679808)
  127. - No longer require xfce4-doc
  128. - Run update-desktop-database in %%post and %%postun
  129. * Wed Feb 09 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.91-2
  130. - BR xfconf-devel to fix build after Xfce 4.8 update
  131. * Tue Jul 13 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.91-1
  132. - Update to 0.0.91 (Development release for next major version)
  133. - Require xfce4-doc for directory ownership of the nex docs
  134. * Wed Feb 17 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.22-3
  135. - Add patch to fix DSO linking (#565114)
  136. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.22-2
  137. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  138. * Fri May 15 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.22-1
  139. - Update to 0.0.22
  140. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.21-2
  141. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  142. * Thu Nov 27 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.21-1
  143. - Update to 0.0.21
  144. - Remove marshaller fix, included upstream now
  145. * Tue Jul 01 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.20-2
  146. - Add patch to fix x86_64 bit bug caused by a wrong marshaller (#351531)
  147. * Sat May 24 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.20-1
  148. - Update to 0.0.20
  149. * Sat May 10 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.19-1
  150. - Update to 0.0.19
  151. * Sat Apr 05 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.18-1
  152. - Update to 0.0.18
  153. * Wed Feb 17 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.17-1
  154. - Update to 0.0.17
  155. * Wed Jan 30 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.16-1
  156. - Update to 0.0.16
  157. * Mon Dec 03 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.15-1
  158. - Update to 0.0.15
  159. * Mon Dec 03 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.14-1
  160. - Update to 0.0.14
  161. * Mon Nov 26 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.13-1
  162. - Update to 0.0.13
  163. * Wed Nov 21 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.12-2
  164. - Try manual_adjustments.patch
  165. * Tue Nov 20 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.12-1
  166. - Update to 0.0.12
  167. * Wed Nov 07 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.11-1
  168. - Update to 0.0.11
  169. - BuildRequire dbus-glib-devel
  170. * Sat Nov 03 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.10-1
  171. - Update to 0.0.10
  172. - Add more mimetypes: tiff, x-bmp, x-png, x-pcx, x-tga and xpm
  173. - Correct build requirements
  174. * Fri Oct 19 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.9-1
  175. - Update to 0.0.9
  176. * Sun Oct 14 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.8-1
  177. - Update to 0.0.8
  178. * Sun Sep 30 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.7-1
  179. - Update to 0.0.7
  180. * Sun Sep 09 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.4-1
  181. - Update to 0.0.4
  182. * Wed Sep 05 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.3-1
  183. - Initial RPM package