libwebp-vl.spec 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170
  1. %define ver 1.0.1
  2. %define rel 1
  3. Name: libwebp
  4. Version: %{ver}
  5. Release: %{rel}%{?_dist_release}
  6. Group: System Environment/Libraries
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. URL: http://webmproject.org/
  10. Summary: Library and tools for the WebP graphics format
  11. Summary(ja): WebP 画像フォーマットのためのライブラリとツール
  12. # Additional IPR is licensed as well. See PATENTS file for details
  13. License: BSD
  14. Source0: https://storage.googleapis.com/downloads.webmproject.org/releases/webp/libwebp-%{version}.tar.gz
  15. Source1: libwebp_jni_example.java
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: libjpeg-devel
  18. BuildRequires: libpng-devel
  19. BuildRequires: libtool
  20. BuildRequires: java-1.8.0-openjdk-devel
  21. BuildRequires: jpackage-utils
  22. BuildRequires: swig
  23. BuildRequires: freeglut-devel
  24. %description
  25. WebP is an image format that does lossy compression of digital
  26. photographic images. WebP consists of a codec based on VP8, and a
  27. container based on RIFF. Webmasters, web developers and browser
  28. developers can use WebP to compress, archive and distribute digital
  29. images more efficiently.
  30. %package tools
  31. Summary: The WebP command line tools
  32. Summary(ja): WebP コマンドラインツール
  33. Group: Development/Tools
  34. %description tools
  35. WebP is an image format that does lossy compression of digital
  36. photographic images. WebP consists of a codec based on VP8, and a
  37. container based on RIFF. Webmasters, web developers and browser
  38. developers can use WebP to compress, archive and distribute digital
  39. images more efficiently.
  40. %package devel
  41. Summary: Development files for libwebp, a library for the WebP format
  42. Summary(ja): WebP フォーマットのためのライブラリ libwebp の開発ファイル
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. %description devel
  46. WebP is an image format that does lossy compression of digital
  47. photographic images. WebP consists of a codec based on VP8, and a
  48. container based on RIFF. Webmasters, web developers and browser
  49. developers can use WebP to compress, archive and distribute digital
  50. images more efficiently.
  51. %package java
  52. Summary: Java bindings for libwebp, a library for the WebP format
  53. Summary(ja): WebP フォーマットのためのライブラリ libwebp の Java バインディング
  54. Group: Development/Libraries
  55. Requires: %{name} = %{version}-%{release}
  56. Requires: java
  57. Requires: jpackage-utils
  58. %description java
  59. Java bindings for libwebp.
  60. Vendor: Project Vine
  61. Distribution: Vine Linux
  62. Packager: iwaim
  63. %prep
  64. %setup -q
  65. %build
  66. %global optflags %{optflags} -fPIC
  67. mkdir -p m4
  68. ./autogen.sh
  69. %configure --disable-static --enable-libwebpmux \
  70. --enable-libwebpdemux --enable-libwebpdecoder \
  71. --disable-neon
  72. make %{?_smp_mflags}
  73. # swig generated Java bindings
  74. cp %{SOURCE1} .
  75. cd swig
  76. rm -rf libwebp.jar libwebp_java_wrap.c
  77. mkdir -p java/com/google/webp
  78. swig -ignoremissing -I../src -java \
  79. -package com.google.webp \
  80. -outdir java/com/google/webp \
  81. -o libwebp_java_wrap.c libwebp.swig
  82. gcc %{optflags} -shared \
  83. -I/usr/lib/jvm/java/include \
  84. -I/usr/lib/jvm/java/include/linux \
  85. -I../src \
  86. -L../src/.libs -lwebp libwebp_java_wrap.c \
  87. -o libwebp_jni.so
  88. cd java
  89. javac com/google/webp/libwebp.java
  90. jar cvf ../libwebp.jar com/google/webp/*.class
  91. %install
  92. make install DESTDIR=%{buildroot}
  93. find "%{buildroot}/%{_libdir}" -type f -name "*.la" -delete
  94. # swig generated Java bindings
  95. mkdir -p %{buildroot}/%{_libdir}/%{name}-java
  96. cp swig/*.jar swig/*.so %{buildroot}/%{_libdir}/%{name}-java/
  97. %post -n %{name} -p /sbin/ldconfig
  98. %postun -n %{name} -p /sbin/ldconfig
  99. %files tools
  100. %{_bindir}/*
  101. %{_mandir}/man*/*
  102. %files -n %{name}
  103. %license COPYING
  104. %doc README PATENTS NEWS AUTHORS
  105. %{_libdir}/%{name}*.so.*
  106. %files devel
  107. %{_libdir}/%{name}*.so
  108. %{_includedir}/*
  109. %{_libdir}/pkgconfig/*
  110. %files java
  111. %doc libwebp_jni_example.java
  112. %{_libdir}/%{name}-java/
  113. %changelog
  114. * Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1-1
  115. - new upstream release.
  116. * Sun Oct 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.3.1-3
  117. - moved libwebp to System Environment/Libraries Group
  118. * Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.1-2
  119. - rebuild with libpng-1.6.12
  120. * Sat Oct 12 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.3.1-1
  121. - new upstream release
  122. * Sat Jan 12 2013 IWAI, Masaharu <iwai@alib.jp> 0.2.1-1
  123. - initial build for Vine Linux
  124. * Thu Dec 27 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.2.1-1
  125. - new upstream release 0.2.1
  126. * Fri Dec 21 2012 Adam Tkac <atkac redhat com> - 0.1.3-3
  127. - rebuild against new libjpeg
  128. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.3-2
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  130. * Thu Feb 02 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.3-1
  131. - Several spec improvements by Scott Tsai <scottt.tw@gmail.com>
  132. * Wed May 25 2011 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.2-1
  133. - Initial spec. Based on openSUSE one