colord-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287
  1. %bcond_with firstbuild
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. Summary: Color daemon
  4. Name: colord
  5. Version: 1.4.3
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Daemons
  8. License: GPLv2+ and LGPLv2+
  9. URL: http://gitorious.org/colord
  10. Source0: http://www.freedesktop.org/software/%{name}/releases/%{name}-%{version}.tar.xz
  11. Patch0: colord-1.4.3-elogind.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: meson
  14. BuildRequires: dbus-devel
  15. BuildRequires: docbook-utils
  16. BuildRequires: gettext
  17. BuildRequires: glib2-devel
  18. BuildRequires: intltool
  19. BuildRequires: lcms2-devel
  20. BuildRequires: libgudev1-devel
  21. BuildRequires: libgusb-devel
  22. BuildRequires: polkit-devel
  23. BuildRequires: sqlite3-devel
  24. BuildRequires: bash-completion
  25. BuildRequires: elogind-devel
  26. %{!?with_firstbuild:BuildRequires: colord-devel, gobject-introspection-devel}
  27. Requires: shared-color-profiles
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. %description
  31. colord is a low level system activated daemon that maps color devices
  32. to color profiles in the system context.
  33. %package devel
  34. Summary: Development package for %{name}
  35. Group: Development/Libraries
  36. Requires: %{name} = %{version}-%{release}
  37. Requires: glib2-devel
  38. Requires: dbus-devel
  39. Requires: lcms2-devel
  40. %description devel
  41. Files for development with %{name}.
  42. # compat32
  43. %package -n compat32-%{name}
  44. Summary: Color daemon
  45. Group: System Environment/Daemons
  46. Requires: %{name} = %{version}-%{release}
  47. %description -n compat32-%{name}
  48. colord is a low level system activated daemon that maps color devices
  49. to color profiles in the system context.
  50. %package -n compat32-%{name}-devel
  51. Summary: Development package for %{name}
  52. Group: Development/Libraries
  53. Requires: compat32-%{name} = %{version}-%{release}
  54. %description -n compat32-%{name}-devel
  55. Files for development with %{name}.
  56. %prep
  57. %autosetup -p1
  58. %build
  59. %meson \
  60. -Dsystemd=false \
  61. -Delogind=true \
  62. -Dargyllcms_sensor=false \
  63. -Ddocs=false
  64. %meson_build
  65. %install
  66. rm -rf %{buildroot}
  67. %meson_install
  68. # databases
  69. touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/mapping.db
  70. touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/storage.db
  71. %find_lang %{name}
  72. %post -p /sbin/ldconfig
  73. %postun
  74. /sbin/ldconfig
  75. if [ $1 -eq 0 ]; then
  76. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  77. fi
  78. %posttrans
  79. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  80. %post -n compat32-%{name} -p /sbin/ldconfig
  81. %postun -n compat32-%{name} -p /sbin/ldconfig
  82. %files -f %{name}.lang
  83. %defattr(-,root,root,-)
  84. %license COPYING
  85. %doc AUTHORS NEWS README.md
  86. %{_libexecdir}/colord
  87. %{_libexecdir}/colord-session
  88. %dir %{_localstatedir}/lib/colord
  89. %{_bindir}/*
  90. %{_datadir}/dbus-1/system.d/org.freedesktop.ColorManager.conf
  91. %dir %{_datadir}/bash-completion
  92. %dir %{_datadir}/bash-completion/completions
  93. %{_datadir}/bash-completion/completions/colormgr
  94. %{_datadir}/color
  95. %{_datadir}/colord
  96. %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorHelper.xml
  97. %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager*.xml
  98. %{_datadir}/dbus-1/services/org.freedesktop.ColorHelper.service
  99. %{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
  100. %{_datadir}/glib-2.0/schemas/org.freedesktop.ColorHelper.gschema.xml
  101. %{_datadir}/polkit-1/actions/org.freedesktop.color.policy
  102. %{_datadir}/man/man1/*.1.gz
  103. %{_libdir}/libcolord.so.*
  104. %{_libdir}/libcolordprivate.so.*
  105. %{_libdir}/libcolorhug.so.*
  106. %{_libdir}/colord-plugins/libcolord_sensor_camera.so
  107. %{_libdir}/colord-plugins/libcolord_sensor_scanner.so
  108. %{!?with_firstbuild:%{_libdir}/girepository-1.0/Colord-1.0.typelib}
  109. %{!?with_firstbuild:%{_libdir}/girepository-1.0/Colorhug-1.0.typelib}
  110. /lib/udev/rules.d/*.rules
  111. %{_libdir}/colord-sensors
  112. %ghost %{_localstatedir}/lib/colord/*.db
  113. %files devel
  114. %defattr(-,root,root,-)
  115. %{_includedir}/colord-1
  116. %{_libdir}/libcolord.so
  117. %{_libdir}/libcolordprivate.so
  118. %{_libdir}/libcolorhug.so
  119. %{_libdir}/pkgconfig/colord.pc
  120. %{_libdir}/pkgconfig/colorhug.pc
  121. %{!?with_firstbuild:%{_datadir}/gir-1.0/Colord-1.0.gir}
  122. %{!?with_firstbuild:%{_datadir}/gir-1.0/Colorhug-1.0.gir}
  123. # compat32
  124. %if %{build_compat32}
  125. %files -n compat32-%{name}
  126. %defattr(-,root,root,-)
  127. %{_libdir}/libcolord.so.*
  128. %{_libdir}/libcolordprivate.so.*
  129. %{_libdir}/libcolorhug.so.*
  130. %files -n compat32-%{name}-devel
  131. %defattr(-,root,root,-)
  132. %{_libdir}/libcolord.so
  133. %{_libdir}/libcolordprivate.so
  134. %{_libdir}/libcolorhug.so
  135. %endif
  136. %changelog
  137. * Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.3-1
  138. - new upstream release.
  139. * Fri Dec 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.8-2
  140. - added libcolordprivate and libcolorhug to compat32-* subpackages
  141. * Mon Nov 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.8-1
  142. - new upstream release
  143. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.7-1
  144. - update to 1.1.7
  145. * Sat Jun 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
  146. - new upstream release
  147. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
  148. - new upstream release
  149. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
  150. - new upstream release
  151. * Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
  152. - new upstream release
  153. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  154. - new upstream release
  155. - add BuildRequires: bash-completion
  156. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.33-1
  157. - new upstream release
  158. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.26-1
  159. - new upstream release
  160. * Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.24-1
  161. - new upstream release
  162. - remove BuildRequires: sane-devel
  163. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.23-1
  164. - new upstream release
  165. - change BuildRequires: libgusb-devel instead of libusb1-devel
  166. - add BuildRequires: gobject-introspection-devel
  167. * Tue Jun 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.21-1
  168. - new upstream release
  169. * Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.19-1
  170. - new upstream release
  171. * Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.18-1
  172. - new upstream release
  173. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.15-1
  174. - new upstream release
  175. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.14-1
  176. - new upstream release
  177. * Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.13-1
  178. - new upstream release
  179. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.12-1
  180. - new upstream release
  181. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.11-1
  182. - new upstream release
  183. - create compat32 sub packages
  184. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.10-1
  185. - initial build for Vine Linux
  186. * Wed Jul 06 2011 Richard Hughes <richard@hughsie.com> 0.1.10-1
  187. - New upstream version
  188. * Mon Jun 13 2011 Richard Hughes <richard@hughsie.com> 0.1.9-1
  189. - New upstream version
  190. * Thu Jun 02 2011 Richard Hughes <richard@hughsie.com> 0.1.8-1
  191. - New upstream version
  192. - Add a webcam device kind
  193. - Add a timestamp when making profiles default
  194. - Add support for reading and writing ICC profile metadata
  195. - Allow the client to pass file descriptors out of band to CreateProfile
  196. - Prettify the device vendor and model names
  197. - Split out the sensors into runtime-loadable shared objects
  198. - Provide some GIO async variants for the methods in CdClient
  199. - Ensure GPhoto2 devices get added to the device list
  200. * Fri May 06 2011 Richard Hughes <richard@hughsie.com> 0.1.7-1
  201. - New upstream version.
  202. - Create /var/lib/colord at buildtime not runtime for SELinux
  203. - Ensure profiles with embedded profile checksums are parsed correctly
  204. - Move the colorimeter rules to be run before 70-acl.rules
  205. - Stop watching the client when the sensor is finalized
  206. - Ensure the source is destroyed when we unref CdUsb to prevent a crash
  207. - Only enable the volume mount tracking when searching volumes
  208. * Tue Apr 26 2011 Richard Hughes <rhughes@redhat.com> 0.1.6-2
  209. - Own /var/lib/colord and /var/lib/colord/*.db
  210. * Sun Apr 24 2011 Richard Hughes <richard@hughsie.com> 0.1.6-1
  211. - New upstream version.
  212. * Thu Mar 31 2011 Richard Hughes <richard@hughsie.com> 0.1.5-1
  213. - New upstream version.
  214. * Wed Mar 09 2011 Richard Hughes <richard@hughsie.com> 0.1.4-1
  215. - New upstream version.
  216. * Mon Feb 28 2011 Richard Hughes <richard@hughsie.com> 0.1.3-1
  217. - New upstream version.
  218. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-3
  219. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  220. * Fri Jan 28 2011 Richard Hughes <richard@hughsie.com> 0.1.1-2
  221. - Rebuild in the vain hope koji isn't broken today.
  222. * Wed Jan 26 2011 Richard Hughes <richard@hughsie.com> 0.1.1-1
  223. - New upstream version.
  224. * Thu Jan 13 2011 Richard Hughes <richard@hughsie.com> 0.1.0-1
  225. - Initial version for Fedora package review.