python3-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514
  1. %bcond_with run_test
  2. %define libvers 3.8
  3. %define binsuffix 3.8
  4. %define python_lib %{_libdir}/python%{libvers}
  5. %define config_htmldir /var/www/html/python
  6. Summary: An interpreted, interactive, object-oriented programming language.
  7. Summary(ja): オブジェクト指向 Python3 インタプリタ
  8. Name: python3
  9. Version: 3.8.6
  10. Release: 1%{?_dist_release}
  11. Group: programming
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. License: Python
  15. URL: http://www.python.org/download/releases/%{version}
  16. Source0: https://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
  17. Source1: https://docs.python.org/ftp/python/doc/%{version}/python-%{version}-docs-html.tar.bz2
  18. # (Patches taken from github.com/fedora-python/cpython)
  19. # 00001 # d06a8853cf4bae9e115f45e1d531d2dc152c5cc8
  20. # Fixup distutils/unixccompiler.py to remove standard library path from rpath
  21. # Was Patch0 in ivazquez' python3000 specfile
  22. Patch1: 00001-rpath.patch
  23. # 00102 # ec4353c0f646eb567cc0d63e1e41eb5e29cc3e81
  24. # Change the various install paths to use /usr/lib64/ instead or /usr/lib/
  25. #
  26. # Only used when "%%{_lib}" == "lib64".
  27. Patch102: 00102-lib64.patch
  28. # 00111 # 03918d404a40a50c9f5f93dc748b52e613d70d31
  29. # Don't try to build a libpythonMAJOR.MINOR.a
  30. #
  31. # Downstream only: not appropriate for upstream.
  32. #
  33. # See https://bugzilla.redhat.com/show_bug.cgi?id=556092
  34. Patch111: 00111-no-static-lib.patch
  35. # 00189 # adf51ed04ac74fd6fc39c642af35b87680c71dab
  36. # Instead of bundled wheels, use our RPM packaged wheels
  37. #
  38. # We keep them in /usr/share/python-wheels
  39. #
  40. # Downstream only: upstream bundles
  41. # We might eventually pursuit upstream support, but it's low prio
  42. Patch189: 00189-use-rpm-wheels.patch
  43. # The following versions of setuptools/pip are bundled when this patch is not applied.
  44. # The versions are written in Lib/ensurepip/__init__.py, this patch removes them.
  45. # When the bundled setuptools/pip wheel is updated, the patch no longer applies cleanly.
  46. # In such cases, the patch needs to be amended and the versions updated here:
  47. %global pip_version 20.1.1
  48. %global setuptools_version 47.1.0
  49. # 00251 # 2eabd04356402d488060bc8fe316ad13fc8a3356
  50. # Change user install location
  51. #
  52. # Set values of prefix and exec_prefix in distutils install command
  53. # to /usr/local if executable is /usr/bin/python* and RPM build
  54. # is not detected to make pip and distutils install into separate location.
  55. #
  56. # Fedora Change: https://fedoraproject.org/wiki/Changes/Making_sudo_pip_safe
  57. # Downstream only: Awaiting resources to work on upstream PEP
  58. Patch251: 00251-change-user-install-location.patch
  59. # 00274 # 1e9258f6e8f70e86d5130113d3eed22993cf3da9
  60. # Upstream uses Debian-style architecture naming, change to match Fedora
  61. Patch274: 00274-fix-arch-names.patch
  62. # 00328 # 367fdcb5a075f083aea83ac174999272a8faf75c
  63. # Restore pyc to TIMESTAMP invalidation mode as default in rpmbuild
  64. #
  65. # Since Fedora 31, the $SOURCE_DATE_EPOCH is set in rpmbuild to the latest
  66. # %%changelog date. This makes Python default to the CHECKED_HASH pyc
  67. # invalidation mode, bringing more reproducible builds traded for an import
  68. # performance decrease. To avoid that, we don't default to CHECKED_HASH
  69. # when $RPM_BUILD_ROOT is set (i.e. when we are building RPM packages).
  70. #
  71. # See https://src.fedoraproject.org/rpms/redhat-rpm-config/pull-request/57#comment-27426
  72. # Downstream only: only used when building RPM packages
  73. # Ideally, we should talk to upstream and explain why we don't want this
  74. Patch328: 00328-pyc-timestamp-invalidation-mode.patch
  75. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  76. BuildRequires: autoconf
  77. BuildRequires: bzip2-devel
  78. BuildRequires: expat-devel
  79. BuildRequires: findutils
  80. BuildRequires: gcc-c++
  81. BuildRequires: gdbm-devel
  82. BuildRequires: glibc-devel
  83. BuildRequires: libdb-devel
  84. BuildRequires: libffi-devel
  85. BuildRequires: libnsl2-devel
  86. BuildRequires: libtirpc-devel
  87. BuildRequires: libxcrypt-devel
  88. BuildRequires: ncurses-devel
  89. BuildRequires: openssl-devel
  90. BuildRequires: pkgconfig
  91. BuildRequires: readline-devel
  92. BuildRequires: sqlite3-devel
  93. BuildRequires: tar
  94. BuildRequires: valgrind-devel
  95. BuildRequires: xz-devel
  96. BuildRequires: zlib-devel
  97. %description
  98. Python is an interpreted, interactive, object-oriented programming
  99. language. It incorporates modules, exceptions, dynamic typing, very high
  100. level dynamic data types, and classes. Python combines remarkable power
  101. with very clear syntax. It has interfaces to many system calls and
  102. libraries, as well as to various window systems, and is extensible in C or
  103. C++. It is also usable as an extension language for applications that need
  104. a programmable interface. Finally, Python is portable: it runs on many
  105. brands of UNIX, on PCs under Windows, MS-DOS, and OS/2, and on the
  106. Mac.
  107. %package devel
  108. Summary: The libraries and header files needed for Python development.
  109. Group: programming
  110. Requires: %{name} = %{version}-%{release}
  111. Requires: libtirpc-devel
  112. %description devel
  113. The Python programming language's interpreter can be extended with
  114. dynamically loaded extensions and can be embedded in other programs.
  115. This package contains the header files and libraries needed to do
  116. these types of tasks.
  117. Install python-devel if you want to develop Python extensions. The
  118. python package will also need to be installed. You'll probably also
  119. want to install the python-docs package, which contains Python
  120. documentation.
  121. %package tkinter
  122. Summary: A graphical user interface for the Python scripting language.
  123. Group: programming
  124. Requires: %{name} = %{version}-%{release}
  125. Requires: tcl, tk, tix
  126. Requires: libX11, libxcb, libXau, libXdmcp
  127. BuildRequires: tcl-devel, tk-devel, tix
  128. BuildRequires: libX11-devel, libxcb-devel, libXau-devel, libXdmcp-devel
  129. %description tkinter
  130. The Tkinter (Tk interface) program is an graphical user interface for
  131. the Python scripting language.
  132. You should install the tkinter package if you'd like to use a graphical
  133. user interface for Python programming.
  134. %package tools
  135. Summary: A collection of development tools included with Python.
  136. Group: programming
  137. Requires: %{name} = %{version}-%{release}
  138. Requires: %{name}-tkinter = %{version}
  139. %description tools
  140. The Python package includes several development tools that are used
  141. to build python programs.
  142. %package docs
  143. Summary: Documentation for the Python programming language.
  144. Summary(ja): Python プログラミング言語のドキュメント
  145. Group: documentation
  146. %description docs
  147. The python-docs package contains documentation on the Python
  148. programming language and interpreter. The documentation is provided
  149. in ASCII text files and in LaTeX source files.
  150. Install the python-docs package if you'd like to use the documentation
  151. for the Python language.
  152. %debug_package
  153. %prep
  154. %setup -q -n Python-%{version}
  155. # Remove all exe files to ensure we are not shipping prebuilt binaries
  156. # note that those are only used to create Microsoft Windows installers
  157. # and that functionality is broken on Linux anyway
  158. find -name '*.exe' -print -delete
  159. # Remove bundled libraries to ensure that we're using the system copy.
  160. rm -r Modules/expat
  161. #
  162. # Apply patches:
  163. #
  164. %patch1 -p1
  165. %if "%{_lib}" == "lib64"
  166. %patch102 -p1
  167. %endif
  168. %patch111 -p1
  169. %if %{with rpmwheels}
  170. %patch189 -p1
  171. rm Lib/ensurepip/_bundled/*.whl
  172. %endif
  173. %patch251 -p1
  174. %patch274 -p1
  175. %patch328 -p1
  176. # Remove files that should be generated by the build
  177. # (This is after patching, so that we can use patches directly from upstream)
  178. rm configure pyconfig.h.in
  179. # Regenerate the configure script and pyconfig.h.in
  180. autoconf
  181. autoheader
  182. %build
  183. export CFLAGS="%{?extension_cflags} -D_GNU_SOURCE -fPIC -fwrapv"
  184. export CFLAGS_NODIST="%{?build_cflags} -D_GNU_SOURCE -fPIC -fwrapv%{?with_no_semantic_interposition: -fno-semantic-interposition}"
  185. export CXXFLAGS="%{?extension_cxxflags} -D_GNU_SOURCE -fPIC -fwrapv"
  186. export CPPFLAGS="$(pkg-config --cflags-only-I libffi)"
  187. export OPT="%{?extension_cflags} -D_GNU_SOURCE -fPIC -fwrapv"
  188. export LINKCC="gcc"
  189. export CFLAGS="$CFLAGS $(pkg-config --cflags openssl)"
  190. export LDFLAGS="%{?extension_ldflags} -g $(pkg-config --libs-only-L openssl)"
  191. export LDFLAGS_NODIST="%{?build_ldflags}%{?with_no_semantic_interposition: -fno-semantic-interposition} -g $(pkg-config --libs-only-L openssl)"
  192. ./configure \
  193. --prefix=%{_prefix} \
  194. --libdir=%{_libdir} \
  195. --enable-ipv6 \
  196. --enable-shared \
  197. --with-computed-gotos=yes \
  198. --with-dbmliborder=gdbm:ndbm:bdb \
  199. --with-system-expat \
  200. --with-system-ffi \
  201. --enable-loadable-sqlite-extensions \
  202. --with-lto \
  203. --with-ssl-default-suites=openssl \
  204. --with-valgrind \
  205. --without-ensurepip \
  206. --enable-optimizations \
  207. %{nil}
  208. make %{?_smp_mflags} CFLAGS_NODIST="$CFLAGS_NODIST" \
  209. regen-all PYTHON_FOR_REGEN="python%{binsuffix}"
  210. make %{?_smp_mflags} CFLAGS_NODIST="$CFLAGS_NODIST"
  211. %install
  212. [ -d "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  213. make DESTDIR=$RPM_BUILD_ROOT LIBDIR=%{_libdir} install
  214. # replace path in pydoc
  215. if [ ! -z "%{binsuffix}" ]
  216. then
  217. (
  218. cd $RPM_BUILD_ROOT%{_bindir}
  219. mv pydoc%{libvers} pydoc.old
  220. sed 's|#!.*|#!%{_bindir}/env python'%{libvers}'|' \
  221. pydoc.old > pydoc%{libvers}
  222. chmod 755 pydoc%{libvers}
  223. rm -f pydoc.old
  224. )
  225. fi
  226. # Tools
  227. echo '#!%{_bindir}/env python%{binsuffix}' > ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  228. echo 'import os, sys' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  229. echo 'os.execvp("%{_bindir}/python%{binsuffix}", ["%{_bindir}/python%{binsuffix}", "%{python_lib}/idlelib/idle.py"] + sys.argv[1:])' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  230. echo 'print "Failed to exec Idle"' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  231. echo 'sys.exit(1)' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  232. chmod 755 $RPM_BUILD_ROOT%{_bindir}/idle%{binsuffix}
  233. cp -a Tools $RPM_BUILD_ROOT%{python_lib}
  234. # make file lists
  235. rm -f mainpkg.files
  236. find "$RPM_BUILD_ROOT"%{python_lib} -type f |
  237. sed "s|^${RPM_BUILD_ROOT}|/|" |
  238. grep -v \
  239. -e '/python%{libvers}/config$' \
  240. -e '_tkinter.so$' \
  241. -e '_tkinter.cpython-' \
  242. >> mainpkg.files
  243. rm -f $RPM_BUILD_ROOT%{_prefix}/bin/2to3
  244. find "$RPM_BUILD_ROOT""%{_prefix}"/bin -type f -o -type l |
  245. sed "s|^${RPM_BUILD_ROOT}|/|" |
  246. grep -v -e '/bin/2to3%{binsuffix}$' |
  247. grep -v -e '/bin/pydoc%{binsuffix}$' |
  248. grep -v -e '/bin/smtpd.py%{binsuffix}$' |
  249. grep -v -e '/bin/idle%{binsuffix}$' >> mainpkg.files
  250. rm -f tools.files
  251. find "$RPM_BUILD_ROOT"%{python_lib}/idlelib \
  252. "$RPM_BUILD_ROOT"%{python_lib}/Tools -type f |
  253. sed "s|^${RPM_BUILD_ROOT}|/|" > tools.files
  254. echo %{_bindir}/2to3-%{binsuffix} >> tools.files
  255. echo %{_bindir}/pydoc%{binsuffix} >> tools.files
  256. ##echo %{_bindir}/smtpd.py%{binsuffix} >> tools.files
  257. echo %{_bindir}/idle%{binsuffix} >> tools.files
  258. # docs
  259. mkdir -p "$RPM_BUILD_ROOT"%{config_htmldir}
  260. (
  261. cd "$RPM_BUILD_ROOT"%{config_htmldir}
  262. bunzip2 < %{SOURCE1} | tar x
  263. )
  264. # fix the #! line in installed files
  265. find "$RPM_BUILD_ROOT" -type f -print0 |
  266. xargs -0 grep -l /usr/local/bin/python | while read file
  267. do
  268. FIXFILE="$file"
  269. sed 's|^#!.*python|#!%{_bindir}/env python'"%{binsuffix}"'|' \
  270. "$FIXFILE" >/tmp/fix-python-path.$$
  271. cat /tmp/fix-python-path.$$ > "$FIXFILE"
  272. rm -f /tmp/fix-python-path.$$
  273. done
  274. # check to see if there are any straggling #! lines
  275. find "$RPM_BUILD_ROOT" -type f | xargs egrep -n '^#! */usr/local/bin/python' \
  276. | grep ':1:#!' >/tmp/python-rpm-files.$$ || true
  277. if [ -s /tmp/python-rpm-files.$$ ]
  278. then
  279. echo '*****************************************************'
  280. cat /tmp/python-rpm-files.$$
  281. cat <<@EOF
  282. *****************************************************
  283. There are still files referencing /usr/local/bin/python in the
  284. install directory. They are listed above. Please fix the .spec
  285. file and try again. If you are an end-user, you probably want
  286. to report this to jafo-rpms@tummy.com as well.
  287. *****************************************************
  288. @EOF
  289. rm -f /tmp/python-rpm-files.$$
  290. exit 1
  291. fi
  292. rm -f /tmp/python-rpm-files.$$
  293. %if %{with run_test}
  294. %check
  295. make test
  296. %endif
  297. %clean
  298. rm -fr $RPM_BUILD_ROOT
  299. %post -p /sbin/ldconfig
  300. %postun -p /sbin/ldconfig
  301. %files -f mainpkg.files
  302. %defattr(-, root, root)
  303. %license LICENSE
  304. %doc Misc/ACKS Misc/HISTORY Misc/NEWS Misc/Porting Misc/README
  305. %attr(755,root,root) %dir %{python_lib}/
  306. %{_libdir}/libpython*
  307. %{_mandir}/man1/python%{libvers}.1*
  308. %{_mandir}/man1/%{name}.1*
  309. %files devel
  310. %defattr(-,root,root)
  311. %dir %{_includedir}/python%{libvers}
  312. %dir %{_includedir}/python%{libvers}/cpython
  313. %dir %{_includedir}/python%{libvers}/internal
  314. %{_includedir}/python%{libvers}/*.h
  315. %{_includedir}/python%{libvers}/cpython/*.h
  316. %{_includedir}/python%{libvers}/internal/*.h
  317. %{_libdir}/pkgconfig/*.pc
  318. %files -f tools.files tools
  319. %defattr(-,root,root)
  320. %files tkinter
  321. %defattr(-,root,root)
  322. %{python_lib}/tkinter
  323. %{python_lib}/lib-dynload/_tkinter.*.so*
  324. %files docs
  325. %defattr(-,root,root)
  326. %{config_htmldir}/*
  327. %changelog
  328. * Fri Oct 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.6-1
  329. - new upstream release.
  330. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.5-1
  331. - new upstream release.
  332. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.9-1
  333. - new upstream release.
  334. * Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-5
  335. - fixed %%files.
  336. * Tue Oct 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-4
  337. - rebuilt with tix-8.4.3-5.
  338. * Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-3
  339. - rebuilt with tcl/tk-8.6.9.
  340. * Sat Aug 31 2019 Toshiaki Ara <ara_t@384.jp> 3.5.7-2
  341. - rebuild with readline-8.0 and ncurses-6.1
  342. * Sun May 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-1
  343. - new upstream release.
  344. - rebuilt with gdbm-1.18.1.
  345. - added R:libtirpc-devel to python3-devel.
  346. * Thu Feb 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.6-3
  347. - added BR:libxcrypt-devel.
  348. - added BR:libtirpc-devel.
  349. - added BR:libnsl2-devel.
  350. * Sat Jan 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.6-2
  351. - rebuilt with new toolchain.
  352. * Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.6-1
  353. - new upstream release.
  354. - really rebuilt with openssl-1.1.1.
  355. * Fri Nov 02 2018 Toshiaki Ara <ara_t@384.jp> 3.5.2-2
  356. - rebuild with openssl-1.1.1
  357. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-1
  358. - new upstream release
  359. - update Patch1 (python-3.5.2-lib64.patch)
  360. * Sun Mar 27 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-2
  361. - rebuild with openssl-1.0.2g
  362. * Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
  363. - new upstream release
  364. - add Patch2 (python3-3.4.4-revert-makefile.patch)
  365. * Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
  366. - new upstream release
  367. * Sun Mar 22 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.4.2-2
  368. - rebuilt with readline 6.3
  369. - changed BuildRequires: tcl-devel, tk-devel instead of tcl, tk respectively
  370. - changed BuildRequires: libdb-devel instead of db4-devel
  371. * Sun Jan 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  372. - new upstream release
  373. - update Patch1 (python-3.4.2-lib64.patch)
  374. * Sun Sep 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-3
  375. - remove configure option "--enable-profiling"
  376. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-2
  377. - rebuild with libffi-3.0.13
  378. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-1
  379. - new upstream release
  380. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.2-1
  381. - updated python to 3.3.2
  382. * Sun Jan 6 2013 IWAI, Masaharu <iwai@alib.jp> 3.3.0-2
  383. - build with Tcl/Tk 8.5.7-1
  384. * Wed Oct 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.0-1
  385. - updated python to 3.3.0
  386. - update Patch1 (python-3.3.0-lib64.patch)
  387. - add BuildRequires: valgrind-devel
  388. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 3.2-1
  389. - updated python to 3.2
  390. - updated python-*-docs-html to 3.2
  391. - dropt all patchs
  392. - added python-3.2b2-lib64.patch
  393. - referred to the review Python-3.2/Misc/RPM/python-3.2.spec
  394. * Fri Jan 14 2011 Shu KONNO <owa@bg.wakwak.com> 3.1.3-2
  395. - rebuilt with openssl-1.0.0c
  396. * Mon Nov 29 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.3-1
  397. - updated python to 3.1.3
  398. - added python-3.1.3-locale.patch
  399. - dropt python-3.1.2-lib64.patch
  400. - added python-3.1.3-lib64-*.patchs
  401. python-3.1.3-lib64-Makefile.patch
  402. python-3.1.3-lib64-setup.patch
  403. python-3.1.3-lib64-site.patch
  404. python-3.1.3-lib64-install.patch
  405. python-3.1.3-lib64-sysconfig.patch
  406. python-3.1.3-lib64-getpath.patch
  407. python-3.1.3-lib64-test_install.patch
  408. - added run_test macro to run unit test
  409. - added BR: libffi
  410. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-4
  411. - rebuilt with rpm-4.8.1 for pkg-config
  412. * Sun Jun 20 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-3
  413. - spec in utf-8
  414. * Sun Jun 20 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-2
  415. - added missings in BuildRequires, Requires
  416. * Fri Jun 18 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-1
  417. - initial build for VineSeed