yelp-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364
  1. %define glib2_version 2.26.0
  2. %define pango_version 1.28.3
  3. %define gtk2_version 2.22.0
  4. %define desktop_file_utils_version 0.17
  5. %define gnome_doc_utils_version 0.20.0
  6. %define rarian_version 0.7.0
  7. %define xulrunner_version 2.0
  8. %define gnome_common_version 2.28.0
  9. Summary: A system documentation reader from the Gnome project.
  10. Summary(ja): GNOME プロジェクトのシステムドキュメントリーダ
  11. Name: yelp
  12. Version: 2.30.2
  13. Release: 3%{?_dist_release}
  14. URL: http://live.gnome.org/Yelp
  15. Source0: %{name}-%{version}.tar.bz2
  16. Source10: man-convert-helper
  17. # http://bugzilla.gnome.org/show_bug.cgi?id=319096
  18. Patch1: yelp-2.15.5-fedora-docs.patch
  19. Patch2: yelp-2.30.2-add-mime-handling.patch
  20. Patch3: yelp-2.15.91-use-pango.patch
  21. # http://bugzilla.gnome.org/show_bug.cgi?id=497559
  22. Patch6: hp.patch
  23. Patch7: yelp-libxul.patch
  24. Patch10: yelp-2.26.0-convert-euc-manpages.patch
  25. Patch11: yelp-2.30.2-xul20.patch
  26. License: GPL
  27. Group: User Interface/Desktops
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. Requires: gtk2 >= %{gtk2_version}
  30. Requires: gnome-doc-utils >= %{gnome_doc_utils_version}
  31. Requires: xulrunner >= %{xulrunner_version}
  32. Requires: nkf
  33. BuildRequires: glib2-devel >= %{glib2_version}
  34. BuildRequires: pango-devel >= %{pango_version}
  35. BuildRequires: gtk2-devel >= %{gtk2_version}
  36. BuildRequires: GConf2-devel
  37. BuildRequires: libxml2-devel >= 2.6.5
  38. BuildRequires: libxslt-devel >= 1.1.4
  39. BuildRequires: zlib-devel
  40. BuildRequires: lzma-devel
  41. BuildRequires: bzip2-devel
  42. BuildRequires: startup-notification-devel >= 0.8
  43. BuildRequires: dbus-glib-devel
  44. BuildRequires: rarian-devel >= %{rarian_version}
  45. BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
  46. BuildRequires: xulrunner-devel >= %{xulrunner_version}
  47. BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
  48. BuildRequires: gnome-common >= %{gnome_common_version}
  49. %description
  50. Yelp is the Gnome 2 help/documentation browser. It is designed
  51. to help you browse all the documentation on your system in
  52. one central tool.
  53. %description -l ja
  54. Yelp は Gnome 2 のヘルプ/ドキュメントブラウザです。このツール
  55. によってシステム内の全てのドキュメントを参照できることを目標に
  56. 作られています。
  57. %prep
  58. %setup -q
  59. %patch1 -p1 -b .fedora-docs
  60. %patch2 -p1 -b .add-mime-handling
  61. %patch3 -p1 -b .use-pango
  62. %patch6 -p1 -b .hp
  63. %patch7 -p1 -b .libxul
  64. %patch10 -p1 -b .convert
  65. %patch11 -p1 -b .xul20
  66. autoreconf -f -i
  67. %build
  68. %configure \
  69. --with-gecko=libxul-embedding \
  70. --with-search=basic \
  71. --disable-schemas-install
  72. make
  73. %install
  74. rm -rf $RPM_BUILD_ROOT
  75. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  76. %makeinstall
  77. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  78. desktop-file-install --vendor=gnome --delete-original \
  79. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  80. --add-only-show-in GNOME \
  81. $RPM_BUILD_ROOT%{_datadir}/applications/*
  82. mkdir -p -m 755 $RPM_BUILD_ROOT/%{_datadir}/gnome/help
  83. install -m755 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/yelp/
  84. %find_lang %{name}
  85. %clean
  86. rm -rf $RPM_BUILD_ROOT
  87. %post
  88. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  89. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/yelp.schemas > /dev/null
  90. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  91. update-mime-database %{_datadir}/mime >& /dev/null ||:
  92. touch %{_datadir}/icons/hicolor
  93. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  94. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  95. fi
  96. %pre
  97. if [ "$1" -eq 0 ]; then
  98. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  99. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/yelp.schemas >& /dev/null || :
  100. fi
  101. %preun
  102. if [ "$1" -eq 0 ]; then
  103. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  104. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/yelp.schemas >& /dev/null || :
  105. fi
  106. %postun
  107. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  108. update-mime-database %{_datadir}/mime >& /dev/null ||:
  109. %files -f %{name}.lang
  110. %defattr(-,root,root)
  111. %{_sysconfdir}/gconf/schemas/yelp.schemas
  112. %{_bindir}/*
  113. %{_datadir}/applications/*
  114. %dir %{_datadir}/gnome/help
  115. %{_datadir}/icons/hicolor/*
  116. %{_datadir}/yelp
  117. %changelog
  118. * Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
  119. - update Patch2: yelp-2.30.2-add-mime-handling.patch
  120. * Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.2-2
  121. - rebuild with xulrunner-2.0
  122. - add Patch11 to build with xulrunner-2.0
  123. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  124. - new upstream release
  125. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  126. - new upstream release
  127. * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  128. - new upstream release
  129. - change Requires: gecko-libs -> xulrunner
  130. - change BuildRequires: gecko-devel -> xulrunner-devel
  131. - drop Patch11
  132. * Mon Mar 01 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-1
  133. - new upstream release
  134. - build with xulrunner-1.9.2 (gecko-1.9.2)
  135. - BR: gecko-devel instead of gecko-unstable-devel
  136. - add patch11 to fix xulrunner-1.9.2 problem
  137. - https://bugzilla.gnome.org/show_bug.cgi?id=603561
  138. - http://git.gnome.org/browse/yelp/commit/?id=a5588114ed94d00ca64913aa5b248e09a5e13edc
  139. * Sun Nov 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
  140. - new upstream release
  141. * Tue Aug 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
  142. - convert manpages from euc to utf8
  143. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  144. - rebuild with gecko-1.9.1
  145. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  146. - new upstream release
  147. - remove BR: libgnomeprintui-devel
  148. * Mon Jun 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1-2
  149. - use xulrunner-1.9 for gecko libs instead of firefox
  150. - add Patch7,8,9 to build with xulrunner-1.9
  151. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  152. - new upstream release
  153. * Sun Apr 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  154. - new upstream release
  155. - added Patches from Fedora Core
  156. * Mon Mar 31 2008 Jon McCann <jmccann@redhat.com> - 2.22.0-4
  157. - Disallow launchers when running under GDM.
  158. * Thu Mar 13 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2
  159. - Add patch for RH bug #437328 (searching with Beagle broken).
  160. * Fri Nov 16 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-7
  161. - Handle .HP tags in man pages
  162. * Wed Sep 6 2006 Matthias Clasen <mclasen@redhat.com> - 2.16.0-2.fc6
  163. - Actually apply the Pango patch
  164. * Thu Dec 15 2005 David Malcolm <dmalcolm@redhat.com> - 2.13.2-2
  165. - Patched to include DocBook mimetype in desktop file, and added preun and
  166. post hooks to update-desktop-database (#175880)
  167. - Patched to ensure that Yelp recognizes that it can handle the mimetype of
  168. the documentation as reported by gnomevfs (also #175880)
  169. * Sat Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
  170. - new upstream release
  171. - added BuildRequires: rarian-devel
  172. * Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
  173. - rebuild with new environment/toolchain
  174. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  175. - new upstream release
  176. - drop Patch20
  177. * Thu Nov 16 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl3
  178. - added Patch20 (<BTS:0314>)
  179. - add BuildRequires: libgnomeprintui-devel
  180. * Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
  181. - rebuild with firefox-2.0
  182. * Sun Oct 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
  183. - updated to 2.14.3
  184. - changed Group to User Interface/Desktops
  185. * Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl2
  186. - add Patch10 to fix corruption of help option message.
  187. - add Japanese summary and description
  188. * Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
  189. - new upstream release
  190. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
  191. - rebuild with firefox-1.5.0.2-0vl4
  192. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  193. - new upstream release
  194. - build with firefox-1.5.0.2
  195. * Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
  196. - run gtk-update-icon-cache in %%post script.
  197. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  198. - new upstream release
  199. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.6-0vl1
  200. - new upstream release
  201. * Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl2
  202. - rebuild with firefox-1.5.0.1
  203. * Fri Dec 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
  204. - new upstream release
  205. - build with firefox-1.5
  206. * Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
  207. - new upstream release
  208. - build with mozilla-1.7.12
  209. * Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
  210. - new upstream release
  211. * Sat Aug 20 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl4
  212. - rebuilt with mozilla-1.7.11 (doh! 0vl3 had stupid mistake in the changelog)
  213. * Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
  214. - rebuild with mozilla-1.7.8
  215. * Mon May 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  216. - new upstream release
  217. * Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl4
  218. - rebuild with mozilla-1.7.7
  219. * Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl3
  220. - add Requires/BuildRequires to gnome-doc-utils
  221. * Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl2
  222. - include yelp.schemas
  223. - add versioned requires to mozilla
  224. * Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl1
  225. - new upstream version
  226. - use mozilla's gecko engine, add Requires: mozilla
  227. * Mon Nov 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
  228. - new upstream release
  229. * Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
  230. - new upstream release
  231. - rebuild with new toolchains
  232. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  233. - new upstream release
  234. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
  235. - new upstream release
  236. * Thu May 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0-0vl1
  237. - new upstream release
  238. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  239. - new upstream release
  240. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
  241. - new upstream release
  242. - build for Vine Linux
  243. * Mon Nov 18 2002 Tim Powers <timp@redhat.com>
  244. - rebuild for all arches
  245. * Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com>
  246. - Remove the strange copyright on the start page. Fixes #69106
  247. * Thu Aug 8 2002 Havoc Pennington <hp@redhat.com>
  248. - 1.0.2
  249. - include libexecdir stuff
  250. * Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
  251. - rebuild with new gail
  252. - 1.0.1
  253. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  254. - automated rebuild
  255. * Tue Jun 18 2002 Havoc Pennington <hp@redhat.com>
  256. - put all the binaries in the file list... why is this package so hard?
  257. * Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
  258. - put images in file list, this thing will be non-ugly yet
  259. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  260. - 1.0
  261. - use desktop-file-install to install/munge .desktop files
  262. - put the sgml stuff in file list
  263. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  264. - rebuild in different environment
  265. * Wed Jun 5 2002 Havoc Pennington <hp@redhat.com>
  266. - 0.10
  267. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  268. - automated rebuild
  269. * Tue May 21 2002 Havoc Pennington <hp@redhat.com>
  270. - rebuild in different environment
  271. * Tue May 21 2002 Havoc Pennington <hp@redhat.com>
  272. - 0.8
  273. * Fri May 3 2002 Havoc Pennington <hp@redhat.com>
  274. - 0.6.1
  275. * Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
  276. - 0.6
  277. * Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
  278. - Rebuild for new gnome2 libraries
  279. * Mon Jan 28 2002 Alex Larsson <alexl@redhat.com>
  280. - Initial build.