aspell-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450
  1. %define _noVersionedDependencies 1
  2. %define ver 0.60.6
  3. %define rel 2
  4. Summary: A spelling checker.
  5. Summary(ja): スペルチェッカ
  6. Name: aspell
  7. Version: %{ver}
  8. Release: %{rel}%{?_dist_release}
  9. License: LGPL
  10. Group: Applications/Text
  11. URL: http://aspell.net/
  12. Source0: ftp://ftp.gnu.org/gnu/aspell/aspell-%{version}.tar.gz
  13. Source10: %{name}-install.sh
  14. Source11: %{name}-remove.sh
  15. Source12: %{name}-init.el
  16. Source100: aspell.conf
  17. Patch1003: aspell-0.60.3-install_info.patch
  18. Patch1005: aspell-0.60.5-fileconflict.patch
  19. Patch1007: aspell-0.60.5-pspell_conf.patch
  20. Patch1008: aspell-0.60.6-zero.patch
  21. Buildrequires: gcc-c++
  22. Requires(post,preun): %{_syssbindir}/install-info
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. Provides: pspell
  25. Obsoletes: ispell, pspell
  26. %description
  27. GNU Aspell is a spell checker designed to eventually replace Ispell. It can
  28. either be used as a library or as an independent spell checker. Its main
  29. feature is that it does a much better job of coming up with possible
  30. suggestions than just about any other spell checker out there for the
  31. English language, including Ispell and Microsoft Word. It also has many
  32. other technical enhancements over Ispell such as using shared memory for
  33. dictionaries and intelligently handling personal dictionaries when more
  34. than one Aspell process is open at once.
  35. %package devel
  36. Summary: Static libraries and header files for Aspell development.
  37. Group: Development/Libraries
  38. Requires: aspell = %{version}-%{release}
  39. Obsoletes: pspell-devel
  40. %description devel
  41. Aspell is a spelling checker. The aspell-devel package includes the
  42. static libraries and header files needed for Aspell development.
  43. %package el
  44. Summary: Emacs lisp for aspell
  45. Group: Applications/Editors/Emacs
  46. Requires: aspell = %{version}-%{release}
  47. Requires: emacsen-common
  48. %description el
  49. Aspell is a spelling checker. The aspell-el package includes the
  50. elisp for using aspell within emacsen.
  51. %prep
  52. rm -rf $RPM_BUILD_ROOT
  53. %setup -q
  54. %patch1003 -p1 -b .iinfo
  55. %patch1005 -p1 -b .fc
  56. %patch1007 -p1 -b .mlib
  57. %patch1008 -p1 -b .zero
  58. iconv -f windows-1252 -t utf-8 manual/aspell.info -o manual/aspell.info.aux
  59. mv manual/aspell.info.aux manual/aspell.info
  60. %build
  61. %configure
  62. make %{?_smp_mflags}
  63. %install
  64. %makeinstall
  65. mv ${RPM_BUILD_ROOT}%{_libdir}/aspell-*/ispell ${RPM_BUILD_ROOT}%{_bindir}
  66. mv ${RPM_BUILD_ROOT}%{_libdir}/aspell-*/spell ${RPM_BUILD_ROOT}%{_bindir}
  67. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libaspell.la
  68. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libpspell.la
  69. rm -f ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60/*-filter.la
  70. # Add by H.Irokawa(2004.02.23)
  71. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
  72. install -m 644 %{SOURCE100} $RPM_BUILD_ROOT%{_sysconfdir}/aspell.conf
  73. mkdir -p $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/aspell
  74. mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
  75. mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
  76. install -m 644 %{SOURCE12} $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/%{name}
  77. # install script( bytecompile el and install elc , remove )
  78. %_installemacsenscript %{name} %{SOURCE10}
  79. %_removeemacsenscript %{name} %{SOURCE11}
  80. rm -f $RPM_BUILD_ROOT/usr/share/doc/aspell/manual.aux
  81. %find_lang %{name}
  82. %post
  83. /sbin/ldconfig
  84. # info
  85. if [ "$1" = 0 ] ; then
  86. %{_syssbindir}/install-info %{_infodir}/aspell.info.gz %{_infodir}/dir
  87. fi
  88. %post devel
  89. /sbin/ldconfig
  90. # info
  91. if [ "$1" = 0 ] ; then
  92. %{_syssbindir}/install-info %{_infodir}/aspell-dev.info.gz %{_infodir}/dir
  93. fi
  94. %post el
  95. if [ "$1" = 2 ]; then
  96. %_emacsenPackageRemove %{name}
  97. fi
  98. %_addemacsenlist %{name}
  99. %_emacsenPackageInstall %{name}
  100. %postun
  101. /sbin/ldconfig
  102. %preun
  103. if [ $1 = 0 ]; then
  104. %{_syssbindir}/install-info --delete %{_infodir}/aspell.info.gz %{_infodir}/dir
  105. fi
  106. %preun devel
  107. if [ $1 = 0 ]; then
  108. %{_syssbindir}/install-info --delete %{_infodir}/aspell-dev.info.gz %{_infodir}/dir
  109. fi
  110. %preun el
  111. if [ "$1" = 0 ]; then
  112. %_emacsenPackageRemove %{name}
  113. %_removeemacsenlist %{name}
  114. fi
  115. %clean
  116. rm -rf $RPM_BUILD_ROOT
  117. %files -f %{name}.lang
  118. %defattr(-,root,root)
  119. %config(noreplace) %{_sysconfdir}/aspell.conf
  120. %doc README TODO
  121. %{_bindir}/*
  122. %{_libdir}/lib*.so.*
  123. %{_libdir}/aspell-*
  124. %{_infodir}/aspell.info*
  125. %{_mandir}/man1/*
  126. %files devel
  127. %defattr(-,root,root)
  128. %{_includedir}/aspell.h
  129. %{_includedir}/pspell
  130. %{_infodir}/aspell-dev.info*
  131. %{_libdir}/lib*spell.so
  132. %{_libdir}/pkgconfig/aspell.pc
  133. %files el
  134. %{_datadir}/emacs/site-lisp/%{name}/
  135. %{_prefix}/lib/emacsen-common/packages/install/%{name}
  136. %{_prefix}/lib/emacsen-common/packages/remove/%{name}
  137. %changelog
  138. * Tue May 3 2011 IWAI, Masaharu <iwai@alib.jp> 0.60.6-2
  139. - update aspell.conf (Source100)
  140. * Sat Apr 16 2011 IWAI, Masaharu <iwai@alib.jp> 0.60.6-1
  141. - new upstream release
  142. - sync Fedora 0.60.6-14
  143. - split English dictionary package: create aspell-en package
  144. - drop unnecessary patches
  145. - prefix patch (Patch0)
  146. - fix compress patch (Patch1)
  147. - add some patches (Patch1003, 1005, 1007, 1008)
  148. - create aspell.pc file
  149. - update files
  150. - add post, preun scripts for info file
  151. - add Requires(post,preun) for installing info file
  152. - noreplace aspell.conf
  153. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.50.5-1vl5
  154. - applied new versioning policy, spec in utf-8
  155. * Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl3
  156. - rebuilt with new toolchain
  157. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl2
  158. - changed aspell-el Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  159. * Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.5-0vl1
  160. - upgrade to new upstream
  161. - drop aspell-0.50.3-gcc33.patch
  162. - update prefix.patch
  163. * Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl8
  164. - merged with errata package
  165. * Wed Oct 6 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.50.3-0vl5.1
  166. - added aspell-compress-bug.patch (CAN-2004-0548).
  167. * Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl7
  168. - fixed typo (s/%postun el/%preun el/)
  169. * Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl6
  170. - split elisp-related files into the aspell-el subpackage
  171. * Thu Mar 4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl5
  172. - add PreReq: emacsen-common
  173. * Mon Feb 23 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.50.3-0vl4
  174. - add /etc/aspell.conf
  175. - modded aspell-init.el(Japanese blended English spell check)
  176. * Wed Feb 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl3
  177. - add %{_bindir}/{ispell,spell} for compatibility script
  178. - enable site-start.d stuff
  179. * Mon Nov 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.3-0vl2
  180. - fixed spec file character code to EUC-JP
  181. * Wed Jun 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl1
  182. - build for Vine Linux
  183. - merge aspell-en
  184. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  185. - rebuilt
  186. * Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-10
  187. - rebuild again to fix libpspell deps
  188. * Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-9
  189. - remove ExcludeArch
  190. * Thu May 22 2003 Jeremy Katz <katzj@redhat.com> 7:0.50.3-8
  191. - fix build with gcc 3.3
  192. * Wed May 22 2003 Adrian Havill <havill@redhat.com> 0.50.3-7
  193. - require aspell-en for upgrades
  194. * Sun May 11 2003 Jeremy Katz <katzj@redhat.com> 6:0.50.3-6
  195. - -devel should obsolete pspell-devel
  196. * Tue May 6 2003 Joe Orton <jorton@redhat.com> 0.50.3-5
  197. - include libpspell.so in devel package
  198. * Wed May 1 2003 Adrian Havill <havill@redhat.com> 0.50.3-4
  199. - removed .la files
  200. * Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-3
  201. - Changed the header for provides, obsoletes, epoch
  202. - fixed config prefix in dirs.h
  203. * Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-1
  204. - upgrade to 0.50.3
  205. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  206. - rebuilt
  207. * Fri Nov 8 2002 Tim Powers <timp@redhat.com>
  208. - fix broken pspell epoch dep
  209. - create $RPM_BUILD_ROOT/usr/bin by hand
  210. - remove /usr/doc
  211. - fix hardcoding of /usr/lib so that we can build on x86_64
  212. * Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.33.7.1-16
  213. - require pspell and pspell-devel using the proper epoch
  214. * Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
  215. - rebuilt with gcc-3.2 (we hope)
  216. * Mon Jul 22 2002 Tim Powers <timp@redhat.com> 0.33.7.1-14
  217. - rebuild using gcc-3.2-0.1
  218. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 0.33.7.1-13
  219. - automated rebuild
  220. * Thu Jun 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-12
  221. - Rebuild to make it work again... #66708
  222. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  223. - automated rebuild
  224. * Mon May 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-10
  225. - Rebuild
  226. * Thu Feb 21 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-9
  227. - Disable evil patch
  228. * Mon Jan 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-8
  229. - Build on more archs (doh)
  230. * Tue Jan 22 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-7
  231. - Make it compile with new compiler (evil workaround)
  232. * Wed Jan 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-5
  233. - Rebuild
  234. - Unexclude alpha
  235. * Fri Dec 14 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-3
  236. - Rebuild
  237. - Don't build on alpha
  238. * Mon Oct 29 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.7.1-2
  239. - "make it work with gcc 3.1" ;)
  240. * Tue Sep 18 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-1
  241. - 0.33.7.1, which is a "make it work with gcc 3" release
  242. * Wed Sep 12 2001 Tim Powers <timp@redhat.com>
  243. - rebuild with new gcc and binutils
  244. * Thu Aug 9 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7-1
  245. - 0.33.7 bugfix release. Requested by the author, it fixes
  246. coredumps in sug-mode and when not using typo-analyses.
  247. It also contains code cleanups so it compiles with -ansi
  248. - should fix coredump on IA64 (#49746)
  249. * Wed Jul 11 2001 Trond Eivind Glomsrød <teg@redhat.com>
  250. - Add the .la files in the main package - used for dynamic loading
  251. * Sun Jun 3 2001 Trond Eivind Glomsrød <teg@redhat.com>
  252. - 0.33.6.3, which includes the fix made yesterday
  253. * Sat Jun 2 2001 Trond Eivind Glomsrød <teg@redhat.com>
  254. - Make it search for directories in the correct location
  255. * Wed May 30 2001 Trond Eivind Glomsrød <teg@redhat.com>
  256. - No more workarounds at the specfile level
  257. * Tue May 29 2001 Trond Eivind Glomsrød <teg@redhat.com>
  258. - Use custom ltmain.sh to work around buggy bundled libtool
  259. * Sun May 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
  260. - 0.33.6
  261. - use standard %%configure macro - it works now.
  262. * Fri May 11 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.5-2
  263. - Rebuild with new libltdl
  264. * Mon Apr 23 2001 Trond Eivind Glomsrød <teg@redhat.com>
  265. - 0.33.5
  266. * Thu Nov 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
  267. - use new emacs init scheme for Emacs and XEmacs
  268. * Wed Nov 22 2000 Trond Eivind Glomsrød <teg@redhat.com>
  269. - .32.6
  270. * Sat Aug 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
  271. - .32.5 bugfix release (also contains improved documentation),
  272. obsolete old patch
  273. - the compatibility scripts are now part of the package itself
  274. - clean up build procedure
  275. - remove manual.aux file from docs (#16424)
  276. * Sun Aug 06 2000 Trond Eivind Glomsrød <teg@redhat.com>
  277. - .32.1 bugfix release, obsolete old patch
  278. - rename to 0.32.1
  279. - add patch from author to change his email address
  280. - add spell and ispell compatibility scripts
  281. * Fri Aug 04 2000 Trond Eivind Glomsrød <teg@redhat.com>
  282. - rebuild
  283. * Tue Aug 01 2000 Trond Eivind Glomsrød <teg@redhat.com>
  284. - remember to obsolete ispell
  285. - build the Canadian and British dictionaries here now,
  286. as part of the main package. Same package names and
  287. descriptions.
  288. * Mon Jul 24 2000 Trond Eivind Glomsrød <teg@redhat.com>
  289. - .32
  290. - remove old patches, add a patch since namespace isn't
  291. polluted as much anymore (as opposed to older toolchain)
  292. * Wed Jul 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
  293. - rebuild
  294. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  295. - automatic rebuild
  296. * Tue Jul 4 2000 Jakub Jelinek <jakub@redhat.com>
  297. - Rebuild with new C++
  298. * Fri Jun 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
  299. - use RPM_OPT_FLAGS, not just -O0
  300. - dont include .la-files
  301. * Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
  302. - excludearch ia64
  303. * Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
  304. - patch to work around compiler bug(?) wrt. inline functions
  305. - use CFLAGS and CXXFLAGS
  306. - set them to -O0 to work around YACB
  307. - copy libtool files for IA64 support
  308. * Sun Jun 18 2000 Trond Eivind Glomsrød <teg@redhat.com>
  309. - update to .31.1. My patch was upstreamed and is no longer needed.
  310. - new patch added so DESTDIR works properly
  311. * Fri Jun 16 2000 Trond Eivind Glomsrød <teg@redhat.com>
  312. - (this entry includes some old ones...)
  313. - update to .31
  314. - added patch to make it compile with a pickier compiler
  315. - include /usr/share/pspell
  316. * Mon May 1 2000 Tim Powers <timp@redhat.com>
  317. - updated to .30.1
  318. - used build fixes from Ryan Weaver's 0.30.1-1 package on sourceforge
  319. - updated URL, download/ftp location
  320. - removed redundant define's at top of spec file
  321. * Thu Jul 8 1999 Tim Powers <timp@redhat.com>
  322. - built for Powertools 6.1
  323. - removed %serial definitions from spec file to make versioning
  324. consistant with the other packages we ship.
  325. - changed build root path
  326. - general spec file cleanups
  327. * Tue Mar 2 1999 Ryan Weaver <ryanw@infohwy.com>
  328. [aspell-.27.2-2]
  329. - Changes from .27.1 to .27.2 (Mar 1, 1999)
  330. - Fixed a major bug that caused aspell to dump core when used
  331. without any arguments
  332. - Fixed another major bug that caused aspell to do nothing when used
  333. in interactive mode.
  334. - Added an option to exit in Aspell's interactive mode.
  335. - Removed some old documentation files from the distribution.
  336. - Minor changes on to the section on using Aspell with egcs.
  337. - Minor changes to remove -Wall warnings.