qca-ossl-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124
  1. %define beta 3
  2. %define qt4_ver 4.8.0
  3. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  4. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  5. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  6. Name: qca-ossl
  7. Summary: OpenSSL plugin for the Qt Cryptographic Architecture v2
  8. Version: 2.0.0
  9. Release: 0.beta%{beta}.14%{?_dist_release}
  10. License: LGPLv2+
  11. Group: System Environment/Libraries
  12. URL: http://delta.affinix.com/qca/
  13. Source0: http://delta.affinix.com/download/qca/2.0/plugins/qca-ossl-%{version}-beta%{beta}.tar.bz2
  14. Patch1: qca-ossl-2.0.0-no-whirlpool.patch
  15. Patch2: qca-ossl-2.0.0-openssl100.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: qt4-devel
  18. BuildRequires: qca2-devel >= 2.0.0-1
  19. BuildRequires: openssl-devel >= 0.9.8
  20. Requires: qt4 >= %{_qt4_version}
  21. Provides: qca2-ossl = %{version}-%{release}
  22. %description
  23. This is a plugin to provide SSL/TLS capability to programs that use the Qt
  24. Cryptographic Architecture (QCA). QCA is a library providing an easy API
  25. for several cryptographic algorithms to Qt programs. This package only
  26. contains the TLS plugin.
  27. %prep
  28. %setup -q -n %{name}-%{version}-beta%{beta}
  29. %patch1 -p1 -b .no-whirlpool
  30. %patch2 -p1 -b .openssl100
  31. %build
  32. unset QTDIR
  33. MAKE=%{_bindir}/make \
  34. ./configure \
  35. --qtdir=%{_qt4_prefix} \
  36. --no-separate-debug-info \
  37. --verbose
  38. make %{?_smp_mflags}
  39. %install
  40. rm -rf $RPM_BUILD_ROOT
  41. export INSTALL_ROOT=$RPM_BUILD_ROOT
  42. mkdir -p $RPM_BUILD_ROOT%{_qt4_plugindir}/crypto
  43. make install
  44. %clean
  45. rm -rf $RPM_BUILD_ROOT
  46. %files
  47. %defattr(-,root,root,-)
  48. %doc README COPYING
  49. %{_qt4_plugindir}/crypto/libqca-ossl.so
  50. %changelog
  51. * Mon Jan 9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.0-0.beta3.14
  52. - rebuilt with qt-4.8.0
  53. * Tue Mar 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.0-0.beta3.13
  54. - rebuilt with qt4-4.7.2
  55. * Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.0-0.beta3.12
  56. - built with qt4-4.7.1 for VineSeed
  57. - added Patch2 to build with oepnssl-1.0.0
  58. * Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.0-0.beta3.11
  59. - Initial build for Vine Linux
  60. * Thu Apr 29 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.0.0-0.10.beta3
  61. - add minimal qt4 dep
  62. - don't own %%{_qt4_plugindir}/crypto/
  63. * Fri Jan 29 2010 Alexey Kurov <nucleo@fedoraproject.org> - 2.0.0-0.9.beta3
  64. - Provides: qca2-ossl (fixes bug #512000)
  65. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.0-0.8.beta3
  66. - rebuilt with new openssl
  67. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-0.7.beta3
  68. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  69. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-0.6.beta3
  70. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  71. * Mon Jan 26 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.0-0.5.beta3
  72. - rebuild with new openssl
  73. - fix the test for whirlpool support
  74. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.0-0.4.beta3
  75. - Autorebuild for GCC 4.3
  76. * Thu Dec 13 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.3.beta3
  77. - version 2.0.0 beta 3
  78. * Fri Dec 07 2007 Release Engineering <rel-eng at fedoraproject dot org> - 2.0.0-0.2.beta1
  79. - Rebuild for deps
  80. * Tue Nov 06 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.1.beta1
  81. - version 2.0.0 beta 1
  82. * Sat Oct 27 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.1-4.20070904
  83. - update Source1 URL
  84. * Thu Oct 25 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.1-3.20070904
  85. - update to 20070904
  86. * Thu Sep 13 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.1-2.20070706
  87. - fixes from review in bug 289701 (thanks Rex)
  88. * Thu Sep 13 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.1-1.20070706
  89. - initial package