libmicrohttpd-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185
  1. Summary: Lightweight library for embedding a webserver in applications
  2. Name: libmicrohttpd
  3. Version: 0.9.39
  4. Release: 1%{?_dist_release}
  5. Group: System Environment/Libraries
  6. License: LGPLv2+
  7. URL: http://www.gnu.org/software/libmicrohttpd/
  8. Source0: ftp://ftp.gnu.org/gnu/libmicrohttpd/%{name}-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  10. BuildRequires: autoconf, automake, libtool
  11. BuildRequires: curl-devel
  12. BuildRequires: gnutls-devel
  13. BuildRequires: libgcrypt-devel
  14. BuildRequires: openssl-devel
  15. BuildRequires: zlib-devel
  16. BuildRequires: graphviz
  17. BuildRequires: doxygen
  18. Requires(post): info
  19. Requires(preun): info
  20. %description
  21. GNU libmicrohttpd is a small C library that is supposed to make it
  22. easy to run an HTTP server as part of another application.
  23. Key features that distinguish libmicrohttpd from other projects are:
  24. * C library: fast and small
  25. * API is simple, expressive and fully reentrant
  26. * Implementation is http 1.1 compliant
  27. * HTTP server can listen on multiple ports
  28. * Support for IPv6
  29. * Support for incremental processing of POST data
  30. * Creates binary of only 25k (for now)
  31. * Three different threading models
  32. %package devel
  33. Summary: Development files for libmicrohttpd
  34. Summary(ja): libmicrohttpd の開発用ファイル
  35. Group: Development/Libraries
  36. Requires: %{name} = %{version}-%{release}
  37. %description devel
  38. Development files for libmicrohttpd
  39. %package doc
  40. Summary: Documentation for libmicrohttpd
  41. Summary(ja): libmicrohttpd のドキュメント
  42. Group: Documentation
  43. Buildarch: noarch
  44. Requires: %{name} = %{version}-%{release}
  45. %description doc
  46. Doxygen documentation for libmicrohttpd and some example source code
  47. %prep
  48. %setup -q
  49. %build
  50. %configure --disable-static --with-gnutls
  51. make %{?_smp_mflags}
  52. make full -C doc/doxygen
  53. # Disabled for now due to problems reported at
  54. # https://gnunet.org/bugs/view.php?id=1619
  55. #check
  56. #make check %{?_smp_mflags}
  57. %install
  58. rm -rf %{buildroot}
  59. make install DESTDIR=%{buildroot}
  60. rm -f %{buildroot}%{_libdir}/libmicrohttpd.la
  61. rm -f %{buildroot}%{_libdir}/libmicrospdy.la
  62. rm -f %{buildroot}%{_infodir}/dir
  63. # Install some examples in /usr/share/doc/libmicrohttpd-${version}/examples
  64. rm -rf examples
  65. mkdir -p examples
  66. install -m 644 src/examples/*.c examples
  67. # Install the doxygen documentation in /usr/share/doc/libmicrohttpd-${version}/html
  68. rm -rf html
  69. cp -R doc/doxygen/html .
  70. %clean
  71. rm -rf %{buildroot}
  72. %post -p /sbin/ldconfig
  73. %postun -p /sbin/ldconfig
  74. %post doc
  75. /sbin/install-info %{_infodir}/libmicrohttpd.info.gz %{_infodir}/dir || :
  76. /sbin/install-info %{_infodir}/libmicrohttpd-tutorial.info.gz %{_infodir}/dir || :
  77. %preun doc
  78. if [ $1 = 0 ] ; then
  79. /sbin/install-info --delete %{_infodir}/libmicrohttpd.info.gz %{_infodir}/dir || :
  80. /sbin/install-info --delete %{_infodir}/libmicrohttpd-tutorial.info.gz %{_infodir}/dir || :
  81. fi
  82. %files
  83. %defattr(-,root,root,-)
  84. %doc COPYING
  85. %{_bindir}/microspdy2http
  86. %{_libdir}/libmicro*.so.*
  87. %files devel
  88. %defattr(-,root,root,-)
  89. %{_includedir}/micro*.h
  90. %{_libdir}/libmicro*.so
  91. %{_libdir}/pkgconfig/libmicro*.pc
  92. %files doc
  93. %doc AUTHORS README ChangeLog
  94. %doc examples
  95. %doc html
  96. %defattr(-,root,root,-)
  97. %{_mandir}/man3/libmicrohttpd.3.gz
  98. %{_infodir}/libmicrohttpd.info.gz
  99. %{_infodir}/libmicrohttpd-tutorial.info.gz
  100. %changelog
  101. * Mon Jan 12 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.9.39-1
  102. - updated to 0.9.39
  103. - built with libgcrypt 1.6.0 and gnutls 3.2.20
  104. * Mon Jan 17 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9.2-1
  105. - initial build for Vine Linux based on fedora development
  106. * Tue Nov 16 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-3
  107. - Add missing BR gnutls-devel and libgcrypt-devel
  108. - Added patch to fix test apps (NSS instead of GnuTLS/OpenSSL curl,
  109. implicit DSO linking)
  110. - Disable test cases for now due to false errors, reported upstream
  111. * Tue Nov 16 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-2
  112. - Re-enable HTTPS, configure flags had unexpected result
  113. * Sun Nov 7 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-1
  114. - Update to 0.9.2
  115. * Sun Jun 4 2010 Erik van Pienbroek <epienbro@fedoraproject.org> - 0.4.6-1
  116. - Update to 0.4.6
  117. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.2-2
  118. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  119. * Tue Jul 21 2009 Erik van Pienbroek <epienbro@fedoraproject.org> - 0.4.2-1
  120. - Update to version 0.4.2
  121. - Drop upstreamed patch
  122. * Fri Feb 27 2009 Erik van Pienbroek <info@nntpgrab.nl> - 0.4.0a-1
  123. - Update to version 0.4.0a
  124. - Drop upstreamed patch
  125. - Added a new patch to fix a 64bit issue
  126. - The -devel package now contains a pkgconfig file
  127. - The configure script is now run with '--enable-messages --enable-https'
  128. - Made the -doc subpackage noarch (F11+)
  129. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-2
  130. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  131. * Sat Feb 14 2009 Erik van Pienbroek <info@nntpgrab.nl> - 0.4.0-1
  132. - Update to version 0.4.0
  133. - This version introduces a API bump (which is required for
  134. supporting large files on 32bit environments)
  135. - The license issues we had with version 0.3.1 of this package (as
  136. discussed in #457924) are resolved in this version. The license
  137. of this package is now changed to LGPLv2+
  138. - Added a patch to fix two testcases on 64bit environments (upstream bug #1454)
  139. * Sat Sep 6 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-3
  140. - Changed license to GPLv3+ and added some comments
  141. regarding the license issues with this package
  142. * Sun Aug 10 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-2
  143. - Changed license to LGPLv2+
  144. - Moved the COPYING file to the main package
  145. * Tue Aug 5 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-1
  146. - Initial release