shotwell-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183
  1. Name: shotwell
  2. Version: 0.8.1
  3. Release: 2%{?_dist_release}
  4. Summary: A photo organizer for the GNOME desktop
  5. Summary(ja): GNOME デスクトップ向けの画像整理ソフト
  6. Group: Applications/Graphics
  7. # LGPLv2+ for the code
  8. # CC-BY-SA for some of the icons
  9. License: LGPLv2+ and CC-BY-SA
  10. URL: http://www.yorba.org/shotwell/
  11. Source0: http://www.yorba.org/download/shotwell/0.8/shotwell-%{version}.tar.bz2
  12. # svn co svn://svn.yorba.org/shotwell/branches/shotwell-0.4, make dist
  13. Patch0: workaround_desktop.patch
  14. Patch1: shotwell-0.8.1-vala.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: GConf2-devel
  17. BuildRequires: LibRaw-devel
  18. BuildRequires: WebKit-gtk-devel
  19. BuildRequires: dbus-glib-devel
  20. BuildRequires: desktop-file-utils
  21. BuildRequires: gettext
  22. BuildRequires: gtk2-devel
  23. BuildRequires: gstreamer-devel
  24. BuildRequires: hal-devel
  25. BuildRequires: json-glib-devel
  26. BuildRequires: libexif-devel
  27. BuildRequires: libgee-devel
  28. BuildRequires: libgphoto2-devel
  29. BuildRequires: libgudev1-devel
  30. BuildRequires: libgexiv2-devel >= 0.2.0
  31. BuildRequires: libsoup-devel
  32. BuildRequires: libxml2-devel
  33. BuildRequires: sqlite3-devel
  34. BuildRequires: unique-devel
  35. BuildRequires: vala-devel >= 0.9.5
  36. %description
  37. Shotwell is a new open source photo organizer designed for the GNOME desktop
  38. environment. It allows you to import photos from your camera, view and edit
  39. them, and share them with others.
  40. %description -l ja
  41. Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
  42. 画像整理ソフトです。
  43. あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
  44. 他の人々と共有するなどができます。
  45. %prep
  46. %setup -q -n %{name}-%{version}
  47. #%patch0 -p1
  48. %patch1 -p1
  49. %build
  50. ./configure --prefix=/usr --disable-schemas-install --assume-pkgs
  51. sed -i -e 's/\\n/\n/g' configure.mk
  52. sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
  53. sed -i -e 's|LIB_DIRS=.*$|LIB_DIRS=%{_libdir}|' libraw-config
  54. make %{?_smp_mflags}
  55. %install
  56. rm -rf $RPM_BUILD_ROOT
  57. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  58. export XDG_DISABLE_MAKEFILE_UPDATES=1
  59. make install DESTDIR=$RPM_BUILD_ROOT
  60. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
  61. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
  62. %find_lang %{name}
  63. %clean
  64. rm -rf $RPM_BUILD_ROOT
  65. %post
  66. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  67. update-desktop-database &> /dev/null || :
  68. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  69. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
  70. %pre
  71. if [ "$1" -gt 1 ]; then
  72. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  73. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
  74. fi
  75. %preun
  76. if [ "$1" -eq 0 ]; then
  77. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  78. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
  79. fi
  80. %postun
  81. if [ $1 -eq 0 ] ; then
  82. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  83. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  84. fi
  85. update-desktop-database &> /dev/null || :
  86. %posttrans
  87. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  88. %files -f %{name}.lang
  89. %defattr(-,root,root,-)
  90. %doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
  91. %{_sysconfdir}/gconf/schemas/shotwell.schemas
  92. %{_bindir}/shotwell
  93. %{_datadir}/gnome/help/
  94. %{_datadir}/shotwell
  95. %{_datadir}/applications/shotwell.desktop
  96. %{_datadir}/applications/shotwell-viewer.desktop
  97. %{_datadir}/icons/hicolor/*
  98. %exclude %{_datadir}/icons/hicolor/icon-theme.cache
  99. %changelog
  100. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
  101. - add Patch1 (shotwell-0.8.1-vala.patch)
  102. * Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
  103. - new upstream release
  104. - added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
  105. * Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
  106. - rebuilt with rpm-4.8.1 for pkg-config
  107. - fixed %%changelog in Tue Sep 14 2010
  108. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
  109. - new upstream release
  110. - changed source URL
  111. - added Patch0 to work around desktop file incorrect comment
  112. - changed BuildRequires: vala-devel >= 0.9.5
  113. * Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
  114. - new upstream release
  115. * Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
  116. - new upstream release
  117. - changed BuildRequires: libgexiv2-devel >= 0.2.0
  118. * Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
  119. - fixed LIB_DIRS in libraw-config (for lib64)
  120. * Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
  121. - new upstream release
  122. - added BuildRequires: LibRaw-devel, libgexiv2-devel
  123. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
  124. - new upstream release
  125. * Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
  126. - new upstream release
  127. - added BuildRequires: libgudev1-devel
  128. - applied new naming policy to spec
  129. * Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
  130. - new upstream release
  131. - proved Japanese description
  132. * Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
  133. - new upstrema release
  134. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
  135. - intial build for VineSeed
  136. * Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
  137. * Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  138. - Update to 0.3.2
  139. * Tue Nov 3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
  140. - Version 0.3.0
  141. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
  142. - Rebuild against new libgee
  143. * Sun Aug 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
  144. - Bring icon cache handling in sync with current guidelines
  145. * Sun Aug 9 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
  146. - Initial packaging