libexo-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197
  1. %define srcname exo
  2. Summary: extension library to Xfce
  3. Summary(ja): Xfce の拡張ライブラリ
  4. Name: libexo
  5. Version: 0.6.0
  6. Release: 2%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: LGPLv2
  9. URL: http://www.xfce.org/
  10. Source0: http://www.xfce.org/archive/xfce-%{version}/src/%{srcname}-%{version}.tar.bz2
  11. # FIXME: upstream this patch
  12. Patch0: exo-0.5.4-x86_64-build.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: glib2-devel >= 2.27.0
  15. BuildRequires: gtk2-devel >= 2.14.0
  16. BuildRequires: libSM-devel
  17. BuildRequires: intltool >= 0.31
  18. BuildRequires: libxfce4util-devel >= 4.8.0
  19. BuildRequires: libnotify-devel >= 0.4.0
  20. BuildRequires: python-devel
  21. BuildRequires: pygtk2-devel
  22. BuildRequires: perl-URI
  23. BuildRequires: chrpath
  24. Requires(post): gtk2
  25. Requires(postun): gtk2
  26. Provides: %{srcname} = %{version}-%{release}
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. %description
  30. libexo is the extension library to Xfce developed by os-cillation.
  31. While Xfce ships with quite a few libraries that are primarly targeted
  32. at desktop development, libexo is targeted at application development,
  33. with a focus on applications for Xfce.
  34. %description -l ja
  35. libexo は os-cillation により開発された Xfce の拡張ライブラリです.
  36. Xfce はデスクトップ環境の開発を第一の目的としたごくわずかのライブラリ
  37. と共に作成されていますが,libexo はアプリケーションの開発,それも
  38. Xfce 用のアプリケーション開発に焦点を定めています.
  39. %package -n %{name}-devel
  40. Summary: Header files and libraries for developing apps which will use %{name}
  41. Summary(ja): libexo の開発用ヘッダファイル及びライブラリ
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}-%{release}
  44. Requires: gtk2-devel >= 2.6.0
  45. Requires: libxfce4util-devel >= 4.2.2
  46. Provides: %{srcname}-devel = %{version}-%{release}
  47. %description -n %{name}-devel
  48. The libexo-devel package contains the header files and libraries needed
  49. to develop programs that use the libexo library.
  50. %description -n %{name}-devel -l ja
  51. libexo-develはlibexoライブラリを用いるプログラムの開発に
  52. 必要なヘッダファイル及びライブラリを含むパッケージです。
  53. %prep
  54. %setup -q -n %{srcname}-%{version}
  55. %patch0 -p1 -b .x86_64-build
  56. %build
  57. %configure --disable-static
  58. %__make
  59. %install
  60. rm -rf $RPM_BUILD_ROOT
  61. make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
  62. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  63. rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  64. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/exo-desktop-item-edit
  65. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/exo-open
  66. chrpath --delete $RPM_BUILD_ROOT%{_libdir}/xfce4/exo-*/exo-helper-*
  67. chrpath --delete $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/exo-*/_exo.so
  68. #chrpath --delete $RPM_BUILD_ROOT%{_libdir}/gio/modules/libexo-module-*.so
  69. rm -rf _docs_to_include
  70. mkdir -p _docs_to_include
  71. mv $RPM_BUILD_ROOT%{_docdir}/exo/html _docs_to_include/
  72. rm -rf $RPM_BUILD_ROOT%{_docdir}/exo
  73. %find_lang exo-1
  74. %clean
  75. rm -rf $RPM_BUILD_ROOT
  76. %post
  77. /sbin/ldconfig
  78. touch --no-create %{_datadir}/icons/hicolor
  79. %postun
  80. /sbin/ldconfig
  81. if [ $1 -eq 0 ]; then
  82. touch --no-create %{_datadir}/icons/hicolor
  83. /usr/bin/gtk-update-icon-cache -qf %{_datadir}/icons/hicolor;
  84. fi
  85. %posttrans
  86. gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
  87. %files -f exo-1.lang
  88. %defattr(-,root,root)
  89. %doc AUTHORS COPYING ChangeLog README THANKS TODO
  90. %doc _docs_to_include/*
  91. %config(noreplace) %{_sysconfdir}/xdg/xfce4/helpers.rc
  92. %{_bindir}/*
  93. %{_libdir}/lib*.so.*
  94. %{_libdir}/python?.?/site-packages/*
  95. %{_libdir}/xfce4/*
  96. %{_datadir}/applications/*.desktop
  97. %{_datadir}/icons/hicolor/*/apps/*.png
  98. %{_datadir}/pixmaps/exo-1
  99. %{_datadir}/pygtk/2.0/*
  100. %{_datadir}/xfce4/helpers
  101. %{_mandir}/man1/*
  102. %files -n %{name}-devel
  103. %defattr(-,root,root)
  104. %{_libdir}/lib*.so
  105. %{_libdir}/pkgconfig/*.pc
  106. %{_includedir}/exo-1
  107. %{_datadir}/gtk-doc/html/exo-1
  108. %changelog
  109. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.0-2
  110. - add BuildRequires: libSM-devel
  111. * Mon Mar 28 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-1
  112. - new upstrem release
  113. * Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.107-2
  114. - rebuilt with rpm-4.8.1 for pkg-config
  115. * Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.107-1
  116. - new upstrem release
  117. - built with new toolchain
  118. * Mon Feb 8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.106-1
  119. - new upstrem release
  120. - added BR: perl-URI
  121. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.3.105-2
  122. - rebuilt with python-2.6.4
  123. * Sun Nov 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.105-1
  124. - new upstrem release
  125. * Fri May 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.101-1
  126. - new upstrem release
  127. - removed lib*.a from devel package
  128. * Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.4-1
  129. - applied with new versioning policy
  130. - spec in UTF-8
  131. * Fri Jan 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3.4-0vl3
  132. - add BuildRequires: libnotify >= 0.4.0, xfce-mcs-plugins >= 4.2.2
  133. * Sun Dec 23 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.4-0vl2
  134. - new upstream release.
  135. * Sun Jul 29 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.2-0vl2
  136. - build for VineSeed
  137. * Sat Jul 28 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.2-0vl1
  138. - new upstream version
  139. - add %{_sysconfdir}/xdg/xfce4/helpers.rc in files section.
  140. - add %{_bindir}/* in files section.
  141. - add %{_libdir}/xfce4 in files section.
  142. - add %{_libexecdir}/* in files section.
  143. - add %{_datadir}/icons/hicolor/*/apps/*.png in files section.
  144. - add %{_mandir}/man1/* in files section.
  145. - add %{_datadir}/xfce4/doc/*/* in files section.
  146. - add %{_datadir}/xfce4/helpers in files section.
  147. - remove %{_datadir}/gtk-doc/html/exo in files section.
  148. - update icon-cache in %post and %postun.
  149. * Fri Aug 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl3
  150. - changed Group to System Environment/Libraires
  151. - changed devel Group to Development/Libraries
  152. - added %post and %postun section
  153. * Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.3.0-0vl2
  154. - rebuild for VineSeed
  155. * Sun Apr 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.3.0-0vl1
  156. - initial build for Vine Linux