sablotron-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211
  1. %define name sablotron
  2. %define version 1.0.3
  3. %define release 4%{?_dist_release}
  4. %define altname Sablot
  5. %define builddir $RPM_BUILD_DIR/%{altname}-%{version}
  6. %define lib_name_orig libsablotron
  7. %define lib_major 0
  8. %define lib_name %{lib_name_orig}%{lib_major}
  9. Summary: XSLT processor
  10. Summary(ja): XSLT プロセッサ
  11. Name: %{name}
  12. Version: %{version}
  13. Release: %{release}
  14. License: MPL/GPL
  15. Group: Applications/Text
  16. URL: http://sourceforge.net/projects/sablotron/
  17. Source0: %{url}/files/sablotron-%{version}/Sablot-%{version}.tar.gz
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: expat-devel >= 1.95.2
  20. BuildRequires: perl-XML-Parser
  21. Requires: expat >= 1.95.2
  22. Requires: %{lib_name}
  23. %description
  24. Sablotron is a fast, compact and portable XML toolkit
  25. implementing XSLT, DOM and XPath.
  26. The goal of this project is to create a lightweight,
  27. reliable and fast XML library processor conforming to the W3C
  28. specification, which is available for public and can be used as a base
  29. for multi-platform XML applications.
  30. %package -n %{lib_name}
  31. Summary: Main library for sablotron
  32. Summary(ja): sablotron ライブラリ
  33. Group: System Environment/Libraries
  34. Provides: %{name} = %{version}-%{release}
  35. %description -n %{lib_name}
  36. Contains the library for sablotron.
  37. %package -n %{lib_name}-devel
  38. Summary: The development libraries and header files for Sablotron
  39. Summary(ja): Sablotron の開発ライブラリおよびヘッダファイル
  40. Requires: sablotron = %{version}
  41. Group: Development/Libraries
  42. Requires: %{lib_name} = %{version}
  43. Provides: %{lib_name_orig}-devel = %{version}-%{release}
  44. %description -n %{lib_name}-devel
  45. These are the development libraries and header files for Sablotron
  46. %prep
  47. %setup -q -n %{altname}-%{version}
  48. %build
  49. export CXXFLAGS="${RPM_OPT_FLAGS}"
  50. %configure --disable-static
  51. make %{?_smp_mflags}
  52. %install
  53. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  54. make install DESTDIR=$RPM_BUILD_ROOT
  55. ## remove unuse files
  56. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  57. # docs
  58. rm -rf _docs_to_include
  59. mkdir -p _docs_to_include
  60. mv $RPM_BUILD_ROOT/%{_docdir}/html/* _docs_to_include
  61. %clean
  62. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  63. %post -n %{lib_name} -p /sbin/ldconfig
  64. %postun -n %{lib_name} -p /sbin/ldconfig
  65. %files
  66. %defattr(755,root,root)
  67. %doc _docs_to_include/*
  68. %{_bindir}/sabcmd
  69. %{_mandir}/man1/sabcmd.*
  70. #{_docdir}/html/jsdom-ref
  71. #{_docdir}/html/sablot
  72. #{_docdir}/html/sxp
  73. %files -n %{lib_name}
  74. %defattr(-,root,root)
  75. %{_libdir}/libsablot.so.*
  76. %doc README RELEASE
  77. %files -n %{lib_name}-devel
  78. %defattr(-,root,root)
  79. %{_bindir}/sablot-config
  80. #{_libdir}/lib*.a
  81. #{_libdir}/lib*.la
  82. %{_libdir}/lib*.so
  83. %{_includedir}/*.h
  84. %changelog
  85. * Mon Dec 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.3-4
  86. - rebuilt on current VineSeed
  87. - excluded static library from libsablotron-devel package
  88. - moved html document to %{_docdir}/%{name}-%{version}
  89. * Sun Feb 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-3
  90. - rebuild with Vine6 environment
  91. * Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.3-2
  92. - rebuilt with new toolchain
  93. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.3-1vl5
  94. - applied new versioning policy, spec in utf-8
  95. - removed *.la
  96. * Wed Feb 27 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl2
  97. - rebuild with expat-2.0.1
  98. * Sun Jan 6 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.3-0vl1
  99. - updated Sablot to 1.0.3
  100. - dropt sablot-lib-0.71.patch.bz2
  101. * Sat Jul 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.97-0vl5
  102. - rebuilt with new toolchain
  103. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.97-0vl4
  104. - changed Group to Applications/Text
  105. * Sat Mar 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.97-0vl3
  106. - added Japanese summary
  107. - changed Group:
  108. * Sat Jan 25 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.97-0vl2
  109. - added BuildRequires: perl-XML-Parser
  110. * Thu Jan 21 2003 Satoshi MACHINO <machino@vinelinux.org> 0.97-0vl1
  111. - new upstream version
  112. * Thu May 16 2002 Satoshi MACHINO <machino@vinelinux.org> 0.90-1vl1
  113. - build on Vine Linux
  114. -- modified spec
  115. * Wed Apr 03 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.90-1mdk
  116. - release 0.90.
  117. - patch to add -lexpat and -lstdc++ in libsablot.so (required for php4)
  118. * Mon Feb 04 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.82-1mdk
  119. - release 0.82.
  120. * Wed Jan 16 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.81-1mdk
  121. - release 0.81.
  122. - Removed patch for 0.80.
  123. * Tue Jan 15 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.80-1mdk
  124. - release 0.80.
  125. * Wed Nov 21 2001 Christian Belisle <cbelisle@mandrakesoft.com> 0.71-1mdk
  126. - release 0.71.
  127. - bzip2 the source.
  128. - remove the patch.
  129. * Tue Nov 06 2001 Philippe Libat <philippe@mandrakesoft.com> 0.70-2mdk
  130. - %macros
  131. - move sabcmd in sablotron rpm
  132. * Mon Nov 05 2001 Christian Belisle <cbelisle@mandrakesoft.com> 0.70-1mdk
  133. - first mdk release.
  134. * Tue Sep 18 2001 Petr Cimprich <petr@gingerall.cz>
  135. - sablotron 0.70 RPM release 1
  136. * Wed Aug 15 2001 Petr Cimprich <petr@gingerall.cz>
  137. - sablotron 0.65 RPM release 1
  138. * Thu Jun 14 2001 Petr Cimprich <petr@gingerall.cz>
  139. - sablotron 0.60 RPM release 1
  140. - build under RedHat 7.1 with rpm 4.0.2
  141. * Wed Apr 22 2001 Petr Cimprich <petr@gingerall.cz>
  142. - sablotron 0.52 RPM release 1
  143. - based on 0.51-5 spec by Henri Gomez
  144. * Thu Feb 22 2001 Henri Gomez <hgomez@slib.fr>
  145. - sablotron 0.51 RPM release 5
  146. - apply patch to add -lexpat and -lstdc++ in libsablot.so
  147. REQUIRED for use with PHP4
  148. * Thu Feb 22 2001 Henri Gomez <hgomez@slib.fr>
  149. - sablotron 0.51 RPM release 4
  150. - follow Redhat way to dispatch between pack and pack-devel
  151. * Tue Feb 20 2001 Henri Gomez <hgomez@slib.fr>
  152. - sablotron 0.51 RPM release 3
  153. - added ldconfig is post/preun and cleanup stuff
  154. - build under Redhat 6.2 + updates with rpm 3.0.5
  155. * Mon Feb 19 2001 Henri Gomez <hgomez@slib.fr>
  156. - sablotron 0.51 RPM release 2
  157. - added Requires expat >= 1.95.1
  158. * Mon Feb 19 2001 Henri Gomez <hgomez@slib.fr>
  159. - sablotron 0.51 RPM release 1
  160. - updated spec file