nss-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define nspr_version 4.10.6
  3. %define unsupported_tools_directory %{_libdir}/nss/unsupported-tools
  4. Summary: Network Security Services
  5. Name: nss
  6. Version: 3.16.1
  7. Release: 1%{?_dist_release}
  8. License: MPLv1.1 or GPLv2+ or LGPLv2+
  9. URL: http://www.mozilla.org/projects/security/pki/nss/
  10. Group: System Environment/Libraries
  11. Source0: %{name}-%{version}.tar.gz
  12. Source1: nss.pc.in
  13. Source2: nss-config.in
  14. Source3: blank-cert8.db
  15. Source4: blank-key3.db
  16. Source5: blank-secmod.db
  17. Source12: %{name}-pem-20130828.tar.bz2
  18. Source101: nss-util.pc.in
  19. Source102: nss-util-config.in
  20. Patch2: add-relro-linker-option.patch
  21. Patch3: renegotiate-transitional.patch
  22. Patch6: nss-enable-pem.patch
  23. Patch16: nss-539183.patch
  24. Patch18: nss-646045.patch
  25. # TODO: Remove this patch when the ocsp test are fixed
  26. Patch40: nss-3.14.0.0-disble-ocsp-test.patch
  27. # Fedora / RHEL-only patch, the templates directory was originally
  28. # introduced to support mod _revocator
  29. Patch47: utilwrap-include-templates.patch
  30. # TODO submit this patch upstream
  31. Patch48: nss-versus-softoken-tests.patch
  32. # TODO remove when we switch to building nss without softoken
  33. Patch49: nss-skip-bltest-and-fipstest.patch
  34. Patch50: iquote.patch
  35. Patch100: nss-3.16.1-rsawrapr.patch
  36. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  37. BuildRequires: nspr-devel >= %{nspr_version}
  38. BuildRequires: sqlite3-devel
  39. BuildRequires: zlib-devel
  40. BuildRequires: pkgconfig
  41. BuildRequires: gawk
  42. Provides: mozilla-nss
  43. Obsoletes: mozilla-nss
  44. Requires: nspr >= %{nspr_version}
  45. %description
  46. Network Security Services (NSS) is a set of libraries designed to
  47. support cross-platform development of security-enabled client and
  48. server applications. Applications built with NSS can support SSL v2
  49. and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509
  50. v3 certificates, and other security standards.
  51. %package tools
  52. Summary: Tools for the Network Security Services
  53. Group: System Environment/Base
  54. Requires: nss = %{version}-%{release}
  55. %description tools
  56. Network Security Services (NSS) is a set of libraries designed to
  57. support cross-platform development of security-enabled client and
  58. server applications. Applications built with NSS can support SSL v2
  59. and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509
  60. v3 certificates, and other security standards.
  61. Install the nss-tools package if you need command-line tools to
  62. manipulate the NSS certificate and key database.
  63. %package devel
  64. Summary: Development libraries for Network Security Services
  65. Group: Development/Libraries
  66. Requires: nss = %{version}-%{release}
  67. Requires: nspr-devel >= %{nspr_version}
  68. Provides: mozilla-nss-devel
  69. Obsoletes: mozilla-nss-devel
  70. %description devel
  71. Header and Library files for doing development with Network Security Services.
  72. %package pkcs11-devel
  73. Summary: Development libraries for PKCS #11 (Cryptoki) using NSS
  74. Group: Development/Libraries
  75. Requires: nss-devel = %{version}-%{release}
  76. %description pkcs11-devel
  77. Library files for developing PKCS #11 modules using basic NSS
  78. low level services.
  79. ## to build compat32 for x86_64 architecture support
  80. %package -n compat32-%{name}
  81. Summary: Network Security Services
  82. Group: System Environment/Libraries
  83. %description -n compat32-%{name}
  84. Network Security Services (NSS) is a set of libraries designed to
  85. support cross-platform development of security-enabled client and
  86. server applications. Applications built with NSS can support SSL v2
  87. and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509
  88. v3 certificates, and other security standards.
  89. %prep
  90. %setup -q
  91. %setup -q -T -D -n %{name}-%{version} -a 12
  92. %patch2 -p0 -b .relro
  93. %patch3 -p0 -b .transitional
  94. %patch6 -p0 -b .libpem
  95. %patch16 -p0 -b .539183
  96. %patch18 -p0 -b .646045
  97. %patch40 -p0 -b .noocsptest
  98. %patch47 -p0 -b .templates
  99. %patch48 -p0 -b .crypto
  100. %patch49 -p0 -b .skipthem
  101. %patch50 -p0 -b .iquote
  102. %patch100 -p0 -b .buildfix
  103. pemNeedsFromSoftoken="lowkeyi lowkeyti softoken softoknt"
  104. for file in ${pemNeedsFromSoftoken}; do
  105. %{__cp} ./nss/lib/softoken/${file}.h ./nss/lib/ckfw/pem/
  106. done
  107. %{__cp} ./nss/lib/softoken/lowkeyi.h ./nss/cmd/rsaperf
  108. %{__cp} ./nss/lib/softoken/lowkeyti.h ./nss/cmd/rsaperf
  109. %build
  110. #NSS_NO_PKCS11_BYPASS=1
  111. #export NSS_NO_PKCS11_BYPASS
  112. #FREEBL_NO_DEPEND=1
  113. #export FREEBL_NO_DEPEND
  114. # Enable compiler optimizations and disable debugging code
  115. BUILD_OPT=1
  116. export BUILD_OPT
  117. # Generate symbolic info for debuggers
  118. XCFLAGS=$RPM_OPT_FLAGS
  119. export XCFLAGS
  120. PKG_CONFIG_ALLOW_SYSTEM_LIBS=1
  121. PKG_CONFIG_ALLOW_SYSTEM_CFLAGS=1
  122. export PKG_CONFIG_ALLOW_SYSTEM_LIBS
  123. export PKG_CONFIG_ALLOW_SYSTEM_CFLAGS
  124. NSPR_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nspr | sed 's/-I//'`
  125. NSPR_LIB_DIR=`/usr/bin/pkg-config --libs-only-L nspr | sed 's/-L//'`
  126. export NSPR_INCLUDE_DIR
  127. export NSPR_LIB_DIR
  128. #export FREEBL_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nss-softokn | sed 's/-I//'`
  129. #export FREEBL_LIB_DIR=%{_libdir}
  130. #export USE_SYSTEM_FREEBL=0
  131. NSS_USE_SYSTEM_SQLITE=1
  132. export NSS_USE_SYSTEM_SQLITE
  133. %ifarch x86_64 ppc64 ia64 s390x
  134. USE_64=1
  135. export USE_64
  136. %endif
  137. # uncomment if the iquote patch is activated
  138. export IN_TREE_FREEBL_HEADERS_FIRST=1
  139. export NSS_BLTEST_NOT_AVAILABLE=1
  140. #
  141. %{__make} -C ./nss/coreconf
  142. %{__make} -C ./nss/lib/dbm
  143. %{__make} -C ./nss
  144. # Set up our package file
  145. %{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
  146. %{__cat} %{SOURCE1} | sed -e "s,%%libdir%%,%{_libdir},g" \
  147. -e "s,%%prefix%%,%{_prefix},g" \
  148. -e "s,%%exec_prefix%%,%{_prefix},g" \
  149. -e "s,%%includedir%%,%{_includedir}/nss3,g" \
  150. -e "s,%%NSPR_VERSION%%,%{nspr_version},g" \
  151. -e "s,%%NSS_VERSION%%,%{version},g" \
  152. -e "s,%%NSSUTIL_VERSION%%,%{version},g" > \
  153. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nss.pc
  154. NSS_VMAJOR=`cat nss/lib/nss/nss.h | grep "#define.*NSS_VMAJOR" | awk '{print $3}'`
  155. NSS_VMINOR=`cat nss/lib/nss/nss.h | grep "#define.*NSS_VMINOR" | awk '{print $3}'`
  156. NSS_VPATCH=`cat nss/lib/nss/nss.h | grep "#define.*NSS_VPATCH" | awk '{print $3}'`
  157. export NSS_VMAJOR
  158. export NSS_VMINOR
  159. export NSS_VPATCH
  160. %{__mkdir_p} $RPM_BUILD_ROOT/%{_bindir}
  161. %{__cat} %{SOURCE2} | sed -e "s,@libdir@,%{_libdir},g" \
  162. -e "s,@prefix@,%{_prefix},g" \
  163. -e "s,@exec_prefix@,%{_prefix},g" \
  164. -e "s,@includedir@,%{_includedir}/nss3,g" \
  165. -e "s,@MOD_MAJOR_VERSION@,$NSS_VMAJOR,g" \
  166. -e "s,@MOD_MINOR_VERSION@,$NSS_VMINOR,g" \
  167. -e "s,@MOD_PATCH_VERSION@,$NSS_VPATCH,g" \
  168. > $RPM_BUILD_ROOT/%{_bindir}/nss-config
  169. chmod 755 $RPM_BUILD_ROOT/%{_bindir}/nss-config
  170. %{__cat} %{SOURCE101} | sed -e "s,%%libdir%%,%{_libdir},g" \
  171. -e "s,%%prefix%%,%{_prefix},g" \
  172. -e "s,%%exec_prefix%%,%{_prefix},g" \
  173. -e "s,%%includedir%%,%{_includedir}/nss3,g" \
  174. -e "s,%%NSPR_VERSION%%,%{nspr_version},g" \
  175. -e "s,%%NSSUTIL_VERSION%%,%{version},g" > \
  176. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nss-util.pc
  177. NSSUTIL_VMAJOR=`cat nss/lib/util/nssutil.h | grep "#define.*NSSUTIL_VMAJOR" | awk '{print $3}'`
  178. NSSUTIL_VMINOR=`cat nss/lib/util/nssutil.h | grep "#define.*NSSUTIL_VMINOR" | awk '{print $3}'`
  179. NSSUTIL_VPATCH=`cat nss/lib/util/nssutil.h | grep "#define.*NSSUTIL_VPATCH" | awk '{print $3}'`
  180. export NSSUTIL_VMAJOR
  181. export NSSUTIL_VMINOR
  182. export NSSUTIL_VPATCH
  183. %{__cat} %{SOURCE102} | sed -e "s,@libdir@,%{_libdir},g" \
  184. -e "s,@prefix@,%{_prefix},g" \
  185. -e "s,@exec_prefix@,%{_prefix},g" \
  186. -e "s,@includedir@,%{_includedir}/nss3,g" \
  187. -e "s,@MOD_MAJOR_VERSION@,$NSSUTIL_VMAJOR,g" \
  188. -e "s,@MOD_MINOR_VERSION@,$NSSUTIL_VMINOR,g" \
  189. -e "s,@MOD_PATCH_VERSION@,$NSSUTIL_VPATCH,g" \
  190. > $RPM_BUILD_ROOT/%{_bindir}/nss-util-config
  191. chmod 755 $RPM_BUILD_ROOT/%{_bindir}/nss-util-config
  192. %install
  193. # There is no make install target so we'll do it ourselves.
  194. %{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/nss3
  195. %{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/nss3/templates
  196. %{__mkdir_p} $RPM_BUILD_ROOT/%{_bindir}
  197. %{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}
  198. %{__mkdir_p} $RPM_BUILD_ROOT/%{unsupported_tools_directory}
  199. %{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
  200. # Copy the binary libraries we want
  201. for file in libsoftokn3.so libfreebl3.so libnss3.so libnssutil3.so \
  202. libssl3.so libsmime3.so libnssckbi.so libnsspem.so libnssdbm3.so
  203. do
  204. %{__install} -m 755 dist/*.OBJ/lib/$file $RPM_BUILD_ROOT/%{_libdir}
  205. done
  206. # These ghost files will be generated in the post step
  207. touch $RPM_BUILD_ROOT/%{_libdir}/libsoftokn3.chk
  208. touch $RPM_BUILD_ROOT/%{_libdir}/libfreebl3.chk
  209. # Install the empty NSS db files
  210. %{__mkdir_p} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb
  211. %{__install} -m 644 %{SOURCE3} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/cert8.db
  212. %{__install} -m 644 %{SOURCE4} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/key3.db
  213. %{__install} -m 644 %{SOURCE5} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/secmod.db
  214. # Copy the development libraries we want
  215. for file in libcrmf.a libnssb.a libnssckfw.a
  216. do
  217. %{__install} -m 644 dist/*.OBJ/lib/$file $RPM_BUILD_ROOT/%{_libdir}
  218. done
  219. # Copy the binaries we want
  220. for file in certutil cmsutil crlutil modutil pk12util signtool signver ssltap
  221. do
  222. %{__install} -m 755 dist/*.OBJ/bin/$file $RPM_BUILD_ROOT/%{_bindir}
  223. done
  224. # Copy the binaries we ship as unsupported
  225. for file in atob btoa derdump ocspclnt pp selfserv shlibsign strsclnt symkeyutil tstclnt vfyserv vfychain
  226. do
  227. %{__install} -m 755 dist/*.OBJ/bin/$file $RPM_BUILD_ROOT/%{unsupported_tools_directory}
  228. done
  229. # Copy the include files
  230. for file in dist/public/nss/*.h
  231. do
  232. %{__install} -m 644 $file $RPM_BUILD_ROOT/%{_includedir}/nss3
  233. done
  234. %clean
  235. %{__rm} -rf $RPM_BUILD_ROOT
  236. %post
  237. /sbin/ldconfig >/dev/null 2>/dev/null
  238. %{unsupported_tools_directory}/shlibsign -i %{_libdir}/libsoftokn3.so >/dev/null 2>/dev/null
  239. %{unsupported_tools_directory}/shlibsign -i %{_libdir}/libfreebl3.so >/dev/null 2>/dev/null
  240. %postun
  241. /sbin/ldconfig >/dev/null 2>/dev/null
  242. %files
  243. %defattr(-,root,root)
  244. %{_libdir}/libnss3.so
  245. %{_libdir}/libnssutil3.so
  246. %{_libdir}/libnssdbm3.so
  247. %{_libdir}/libssl3.so
  248. %{_libdir}/libsmime3.so
  249. %{_libdir}/libsoftokn3.so
  250. %{_libdir}/libnssckbi.so
  251. %{_libdir}/libnsspem.so
  252. %{_libdir}/libfreebl3.so
  253. %{unsupported_tools_directory}/shlibsign
  254. %ghost %{_libdir}/libsoftokn3.chk
  255. %ghost %{_libdir}/libfreebl3.chk
  256. %dir %{_sysconfdir}/pki/nssdb
  257. %config(noreplace) %{_sysconfdir}/pki/nssdb/cert8.db
  258. %config(noreplace) %{_sysconfdir}/pki/nssdb/key3.db
  259. %config(noreplace) %{_sysconfdir}/pki/nssdb/secmod.db
  260. %files tools
  261. %defattr(-,root,root)
  262. %{_bindir}/certutil
  263. %{_bindir}/cmsutil
  264. %{_bindir}/crlutil
  265. %{_bindir}/modutil
  266. %{_bindir}/pk12util
  267. %{_bindir}/signtool
  268. %{_bindir}/signver
  269. %{_bindir}/ssltap
  270. %{unsupported_tools_directory}/atob
  271. %{unsupported_tools_directory}/btoa
  272. %{unsupported_tools_directory}/derdump
  273. %{unsupported_tools_directory}/ocspclnt
  274. %{unsupported_tools_directory}/pp
  275. %{unsupported_tools_directory}/selfserv
  276. %{unsupported_tools_directory}/strsclnt
  277. %{unsupported_tools_directory}/symkeyutil
  278. %{unsupported_tools_directory}/tstclnt
  279. %{unsupported_tools_directory}/vfyserv
  280. %{unsupported_tools_directory}/vfychain
  281. %files devel
  282. %defattr(-,root,root)
  283. %{_libdir}/libcrmf.a
  284. %{_libdir}/pkgconfig/nss.pc
  285. %{_libdir}/pkgconfig/nss-util.pc
  286. %{_bindir}/nss-config
  287. %{_bindir}/nss-util-config
  288. %dir %{_includedir}/nss3
  289. %{_includedir}/nss3/base64.h
  290. %{_includedir}/nss3/blapit.h
  291. %{_includedir}/nss3/cert.h
  292. %{_includedir}/nss3/certdb.h
  293. %{_includedir}/nss3/certt.h
  294. %{_includedir}/nss3/ciferfam.h
  295. %{_includedir}/nss3/cmmf.h
  296. %{_includedir}/nss3/cmmft.h
  297. %{_includedir}/nss3/cms.h
  298. %{_includedir}/nss3/cmsreclist.h
  299. %{_includedir}/nss3/cmst.h
  300. %{_includedir}/nss3/crmf.h
  301. %{_includedir}/nss3/crmft.h
  302. %{_includedir}/nss3/cryptohi.h
  303. %{_includedir}/nss3/cryptoht.h
  304. %{_includedir}/nss3/ecl-exp.h
  305. %{_includedir}/nss3/hasht.h
  306. %{_includedir}/nss3/jar-ds.h
  307. %{_includedir}/nss3/jar.h
  308. %{_includedir}/nss3/jarfile.h
  309. %{_includedir}/nss3/key.h
  310. %{_includedir}/nss3/keyhi.h
  311. %{_includedir}/nss3/keyt.h
  312. %{_includedir}/nss3/keythi.h
  313. %{_includedir}/nss3/nss.h
  314. %{_includedir}/nss3/nssb64.h
  315. %{_includedir}/nss3/nssb64t.h
  316. %{_includedir}/nss3/nssckbi.h
  317. %{_includedir}/nss3/nssilckt.h
  318. %{_includedir}/nss3/nssilock.h
  319. %{_includedir}/nss3/nsslocks.h
  320. %{_includedir}/nss3/nsslowhash.h
  321. %{_includedir}/nss3/nsspem.h
  322. %{_includedir}/nss3/nssrwlk.h
  323. %{_includedir}/nss3/nssrwlkt.h
  324. %{_includedir}/nss3/nssutil.h
  325. %{_includedir}/nss3/ocsp.h
  326. %{_includedir}/nss3/ocspt.h
  327. %{_includedir}/nss3/p12.h
  328. %{_includedir}/nss3/p12plcy.h
  329. %{_includedir}/nss3/p12t.h
  330. %{_includedir}/nss3/pk11func.h
  331. %{_includedir}/nss3/pk11pqg.h
  332. %{_includedir}/nss3/pk11priv.h
  333. %{_includedir}/nss3/pk11pub.h
  334. %{_includedir}/nss3/pk11sdr.h
  335. %{_includedir}/nss3/pkcs11.h
  336. %{_includedir}/nss3/pkcs11f.h
  337. %{_includedir}/nss3/pkcs11n.h
  338. %{_includedir}/nss3/pkcs11p.h
  339. %{_includedir}/nss3/pkcs11t.h
  340. %{_includedir}/nss3/pkcs11u.h
  341. %{_includedir}/nss3/pkcs12.h
  342. %{_includedir}/nss3/pkcs12t.h
  343. %{_includedir}/nss3/pkcs7t.h
  344. %{_includedir}/nss3/portreg.h
  345. %{_includedir}/nss3/preenc.h
  346. %{_includedir}/nss3/secasn1.h
  347. %{_includedir}/nss3/secasn1t.h
  348. %{_includedir}/nss3/seccomon.h
  349. %{_includedir}/nss3/secder.h
  350. %{_includedir}/nss3/secdert.h
  351. %{_includedir}/nss3/secdig.h
  352. %{_includedir}/nss3/secdigt.h
  353. %{_includedir}/nss3/secerr.h
  354. %{_includedir}/nss3/sechash.h
  355. %{_includedir}/nss3/secitem.h
  356. %{_includedir}/nss3/secmime.h
  357. %{_includedir}/nss3/secmod.h
  358. %{_includedir}/nss3/secmodt.h
  359. %{_includedir}/nss3/secoid.h
  360. %{_includedir}/nss3/secoidt.h
  361. %{_includedir}/nss3/secpkcs5.h
  362. %{_includedir}/nss3/secpkcs7.h
  363. %{_includedir}/nss3/secport.h
  364. %{_includedir}/nss3/shsign.h
  365. %{_includedir}/nss3/smime.h
  366. %{_includedir}/nss3/ssl.h
  367. %{_includedir}/nss3/sslerr.h
  368. %{_includedir}/nss3/sslproto.h
  369. %{_includedir}/nss3/sslt.h
  370. %{_includedir}/nss3/utilrename.h
  371. %{_includedir}/nss3/utilmodt.h
  372. %{_includedir}/nss3/utilpars.h
  373. %{_includedir}/nss3/utilparst.h
  374. %files pkcs11-devel
  375. %defattr(-, root, root)
  376. %{_includedir}/nss3/nssbase.h
  377. %{_includedir}/nss3/nssbaset.h
  378. %{_includedir}/nss3/nssckepv.h
  379. %{_includedir}/nss3/nssckft.h
  380. %{_includedir}/nss3/nssckfw.h
  381. %{_includedir}/nss3/nssckfwc.h
  382. %{_includedir}/nss3/nssckfwt.h
  383. %{_includedir}/nss3/nssckg.h
  384. %{_includedir}/nss3/nssckmdt.h
  385. %{_includedir}/nss3/nssckt.h
  386. %{_libdir}/libnssb.a
  387. %{_libdir}/libnssckfw.a
  388. ## to build compat32 for x86_64 architecture support
  389. %if %{build_compat32}
  390. %files -n compat32-%{name}
  391. %defattr(-,root,root)
  392. %{_libdir}/*.so
  393. %ghost %{_libdir}/libsoftokn3.chk
  394. %ghost %{_libdir}/libfreebl3.chk
  395. %{unsupported_tools_directory}/shlibsign
  396. %endif
  397. %changelog
  398. * Thu Jun 12 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.16.1-1
  399. - update to 3.16.1
  400. * Thu Apr 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.14.3-1
  401. - update to 3.14.3
  402. - import patches from fedora package
  403. * Wed Jan 09 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.14.1-1
  404. - update to 3.14.1
  405. * Sat Sep 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.13.6-2
  406. - add Source101 (nss-util.pc.in)
  407. - add Source102 (nss-util-config.in)
  408. * Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.13.6-1
  409. - new upstream release
  410. * Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.13.3-1
  411. - new upstream release
  412. * Thu Dec 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.13.1-2
  413. - fix nss.pc
  414. * Wed Dec 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.13.1-1
  415. - new upstream release
  416. * Fri Sep 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.11-1
  417. - new upstram release
  418. * Wed Jun 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.10-1
  419. - update to 3.12.10
  420. * Tue Mar 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.9-1
  421. - update to 3.12.9.with.ckbi.1.82
  422. - update nss-pem source
  423. - define NSS_USE_SYSTEM_SQLITE, remove unneeded Patch2
  424. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-2
  425. - rebuild with rpm-4.8.1 for pkg-config file
  426. * Wed Apr 7 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.12.6-1
  427. - new upstream release
  428. - update nss-pem Source12 to 20091210 (from 3.12.6-2.fc14)
  429. * Sat Jan 23 2010 NAKAMURA Kenta <kenta@vinelinux.org> 3.12.5-2
  430. - built with FREEBL_NO_DEPEND environmental variable to include nsslowhash.h
  431. * Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.5-1
  432. - new upstream release
  433. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.3-4
  434. - rebuild to fix the package built with broken environment.
  435. * Sun Jul 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.12.3-3
  436. - fixed %%files for compat32
  437. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.12.3-2
  438. - added compat32 subpackages
  439. * Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.3-1
  440. - new upstream release
  441. * Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12-1
  442. - new upstream release
  443. * Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.11.4-0vl1
  444. - initial build for Vine Linux
  445. * Fri Mar 02 2007 Kai Engert <kengert@redhat.com> - 3.11.5-2
  446. - Fix rhbz#230545, failure to enable FIPS mode
  447. - Fix rhbz#220542, make NSS more tolerant of resets when in the
  448. middle of prompting for a user password.
  449. * Sat Feb 24 2007 Kai Engert <kengert@redhat.com> - 3.11.5-1
  450. - Update to 3.11.5
  451. - This update fixes two security vulnerabilities with SSL 2
  452. - Do not use -rpath link option
  453. - Added several unsupported tools to tools package
  454. * Tue Jan 9 2007 Bob Relyea <rrelyea@redhat.com> - 3.11.4-4
  455. - disable ECC, cleanout dead code
  456. * Tue Nov 28 2006 Kai Engert <kengert@redhat.com> - 3.11.4-1
  457. - Update to 3.11.4
  458. * Thu Sep 14 2006 Kai Engert <kengert@redhat.com> - 3.11.3-2
  459. - Revert the attempt to require latest NSPR, as it is not yet available
  460. in the build infrastructure.
  461. * Thu Sep 14 2006 Kai Engert <kengert@redhat.com> - 3.11.3-1
  462. - Update to 3.11.3
  463. * Thu Aug 03 2006 Kai Engert <kengert@redhat.com> - 3.11.2-2
  464. - Add /etc/pki/nssdb
  465. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.11.2-1.1
  466. - rebuild
  467. * Fri Jun 30 2006 Kai Engert <kengert@redhat.com> - 3.11.2-1
  468. - Update to 3.11.2
  469. - Enable executable bit on shared libs, also fixes debug info.
  470. * Wed Jun 14 2006 Kai Engert <kengert@redhat.com> - 3.11.1-2
  471. - Enable Elliptic Curve Cryptography (ECC)
  472. * Fri May 26 2006 Kai Engert <kengert@redhat.com> - 3.11.1-1
  473. - Update to 3.11.1
  474. - Include upstream patch to limit curves
  475. * Wed Feb 15 2006 Kai Engert <kengert@redhat.com> - 3.11-4
  476. - add --noexecstack when compiling assembler on x86_64
  477. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.11-3.2
  478. - bump again for double-long bug on ppc(64)
  479. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.11-3.1
  480. - rebuilt for new gcc4.1 snapshot and glibc changes
  481. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 3.11-3
  482. - rebuild
  483. * Fri Dec 16 2005 Christopher Aillon <caillon@redhat.com> 3.11-2
  484. - Update file list for the devel packages
  485. * Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 3.11-1
  486. - Update to 3.11
  487. * Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 3.11-0.cvs.2
  488. - Add patch to allow building on ppc*
  489. - Update the pkgconfig file to Require nspr
  490. * Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 3.11-0.cvs
  491. - Initial import into Fedora Core, based on a CVS snapshot of
  492. the NSS_3_11_RTM tag
  493. - Fix up the pkcs11-devel subpackage to contain the proper headers
  494. - Build with RPM_OPT_FLAGS
  495. - No need to have rpath of /usr/lib in the pc file
  496. * Thu Dec 15 2005 Kai Engert <kengert@redhat.com>
  497. - Adressed review comments by Wan-Teh Chang, Bob Relyea,
  498. Christopher Aillon.
  499. * Sat Jul 9 2005 Rob Crittenden <rcritten@redhat.com> 3.10-1
  500. - Initial build