libwebp-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157
  1. %define ver 0.3.1
  2. %define rel 3
  3. Name: libwebp
  4. Version: %{ver}
  5. Release: %{rel}%{?_dist_release}
  6. Group: System Environment/Libraries
  7. URL: http://webmproject.org/
  8. Summary: Library and tools for the WebP graphics format
  9. Summary(ja): WebP 画像フォーマットのためのライブラリとツール
  10. # Additional IPR is licensed as well. See PATENTS file for details
  11. License: BSD
  12. Source0: http://webp.googlecode.com/files/%{name}-%{version}.tar.gz
  13. Source1: libwebp_jni_example.java
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: libjpeg-devel
  16. BuildRequires: libpng-devel
  17. BuildRequires: libtool
  18. BuildRequires: java-devel
  19. BuildRequires: jpackage-utils
  20. BuildRequires: swig
  21. %description
  22. WebP is an image format that does lossy compression of digital
  23. photographic images. WebP consists of a codec based on VP8, and a
  24. container based on RIFF. Webmasters, web developers and browser
  25. developers can use WebP to compress, archive and distribute digital
  26. images more efficiently.
  27. %package tools
  28. Summary: The WebP command line tools
  29. Summary(ja): WebP コマンドラインツール
  30. Group: Development/Tools
  31. %description tools
  32. WebP is an image format that does lossy compression of digital
  33. photographic images. WebP consists of a codec based on VP8, and a
  34. container based on RIFF. Webmasters, web developers and browser
  35. developers can use WebP to compress, archive and distribute digital
  36. images more efficiently.
  37. %package devel
  38. Summary: Development files for libwebp, a library for the WebP format
  39. Summary(ja): WebP フォーマットのためのライブラリ libwebp の開発ファイル
  40. Group: Development/Libraries
  41. Requires: %{name} = %{version}-%{release}
  42. %description devel
  43. WebP is an image format that does lossy compression of digital
  44. photographic images. WebP consists of a codec based on VP8, and a
  45. container based on RIFF. Webmasters, web developers and browser
  46. developers can use WebP to compress, archive and distribute digital
  47. images more efficiently.
  48. %package java
  49. Summary: Java bindings for libwebp, a library for the WebP format
  50. Summary(ja): WebP フォーマットのためのライブラリ libwebp の Java バインディング
  51. Group: Development/Libraries
  52. Requires: %{name} = %{version}-%{release}
  53. Requires: java
  54. Requires: jpackage-utils
  55. %description java
  56. Java bindings for libwebp.
  57. Vendor: Project Vine
  58. Distribution: Vine Linux
  59. Packager: iwaim
  60. %prep
  61. %setup -q
  62. %build
  63. mkdir -p m4
  64. ./autogen.sh
  65. %configure --disable-static
  66. make %{?_smp_mflags}
  67. # swig generated Java bindings
  68. cp %{SOURCE1} .
  69. cd swig
  70. rm -rf libwebp.jar libwebp_java_wrap.c
  71. mkdir -p java/com/google/webp
  72. swig -ignoremissing -I../src -java \
  73. -package com.google.webp \
  74. -outdir java/com/google/webp \
  75. -o libwebp_java_wrap.c libwebp.i
  76. gcc %{optflags} -shared -fPIC -fno-strict-aliasing \
  77. -I/usr/lib/jvm/java/include \
  78. -I/usr/lib/jvm/java/include/linux \
  79. -I../src \
  80. -L../src/.libs -lwebp libwebp_java_wrap.c \
  81. -o libwebp_jni.so
  82. cd java
  83. javac com/google/webp/libwebp.java
  84. jar cvf ../libwebp.jar com/google/webp/*.class
  85. %install
  86. make install DESTDIR=%{buildroot}
  87. find "%{buildroot}/%{_libdir}" -type f -name "*.la" -delete
  88. # swig generated Java bindings
  89. mkdir -p %{buildroot}/%{_libdir}/%{name}-java
  90. cp swig/*.jar swig/*.so %{buildroot}/%{_libdir}/%{name}-java/
  91. %post -n %{name} -p /sbin/ldconfig
  92. %postun -n %{name} -p /sbin/ldconfig
  93. %files tools
  94. %{_bindir}/*
  95. %{_mandir}/man*/*
  96. %files -n %{name}
  97. %doc README PATENTS COPYING NEWS AUTHORS
  98. %{_libdir}/%{name}*.so.*
  99. %files devel
  100. %{_libdir}/%{name}*.so
  101. %{_includedir}/*
  102. %{_libdir}/pkgconfig/*
  103. %files java
  104. %doc libwebp_jni_example.java
  105. %{_libdir}/%{name}-java/
  106. %changelog
  107. * Sun Oct 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.3.1-3
  108. - moved libwebp to System Environment/Libraries Group
  109. * Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.1-2
  110. - rebuild with libpng-1.6.12
  111. * Sat Oct 12 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.3.1-1
  112. - new upstream release
  113. * Sat Jan 12 2013 IWAI, Masaharu <iwai@alib.jp> 0.2.1-1
  114. - initial build for Vine Linux
  115. * Thu Dec 27 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.2.1-1
  116. - new upstream release 0.2.1
  117. * Fri Dec 21 2012 Adam Tkac <atkac redhat com> - 0.1.3-3
  118. - rebuild against new libjpeg
  119. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.3-2
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  121. * Thu Feb 02 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.3-1
  122. - Several spec improvements by Scott Tsai <scottt.tw@gmail.com>
  123. * Wed May 25 2011 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.2-1
  124. - Initial spec. Based on openSUSE one