libldb-vl.spec 7.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263
  1. %define talloc_version 2.1.1
  2. %define tdb_version 1.3.3
  3. %define tevent_version 0.9.22
  4. Name: libldb
  5. Summary: A schema-less, ldap like, API and database
  6. Version: 1.1.18
  7. Release: 1%{?_dist_release}
  8. Group: System Environment/Libraries
  9. License: LGPLv3+
  10. URL: http://ldb.samba.org/
  11. Source: http://samba.org/ftp/ldb/ldb-%{version}.tar.gz
  12. # Patches
  13. Patch1001: FED01-fix-tevent-check.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: libtalloc-devel >= %{talloc_version}
  16. BuildRequires: libtdb-devel >= %{tdb_version}
  17. BuildRequires: libtevent-devel >= %{tevent_version}
  18. BuildRequires: popt-devel
  19. BuildRequires: autoconf
  20. BuildRequires: libxslt
  21. BuildRequires: docbook-style-xsl
  22. BuildRequires: python-devel
  23. BuildRequires: python-tdb
  24. BuildRequires: pytalloc-devel
  25. BuildRequires: python-tevent
  26. BuildRequires: doxygen
  27. Requires: libtalloc >= %{talloc_version}
  28. Requires: libtdb >= %{tdb_version}
  29. Requires: libtevent >= %{tevent_version}
  30. Provides: bundled(libreplace)
  31. Provides: bundled(libtdb_compat)
  32. Provides: bundled(libccan)
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. Packager: tomop
  36. %description
  37. An extensible library that implements an LDAP like API to access remote LDAP
  38. servers, or use local tdb databases.
  39. %package -n ldb-tools
  40. Group: Applications/System
  41. Summary: Tools to manage LDB files
  42. Requires: libldb = %{version}-%{release}
  43. %description -n ldb-tools
  44. Tools to manage LDB files
  45. %package devel
  46. Group: Development/Libraries
  47. Summary: Developer tools for the LDB library
  48. Requires: libldb = %{version}-%{release}
  49. Requires: libtdb-devel >= %{tdb_version}
  50. Requires: libtalloc-devel >= %{talloc_version}
  51. Requires: libtevent-devel >= %{tevent_version}
  52. Requires: pkgconfig
  53. %description devel
  54. Header files needed to develop programs that link against the LDB library.
  55. %package -n pyldb
  56. Group: System Environment/Libraries
  57. Summary: Python bindings for the LDB library
  58. Requires: libldb = %{version}-%{release}
  59. Requires: python-tdb >= %{tdb_version}
  60. %description -n pyldb
  61. Python bindings for the LDB library
  62. %package -n pyldb-devel
  63. Group: Development/Libraries
  64. Summary: Development files for the Python bindings for the LDB library
  65. Requires: pyldb = %{version}-%{release}
  66. %description -n pyldb-devel
  67. Development files for the Python bindings for the LDB library
  68. %prep
  69. %setup -q -n ldb-%{version}
  70. %patch1001 -p1
  71. %build
  72. # tdb_compat and ccan have no upstream releases to link against yet and their
  73. # API is in flux. It is unsafe to make them public and shared at this time.
  74. %configure --disable-rpath \
  75. --disable-rpath-install \
  76. --bundled-libraries=NONE \
  77. --builtin-libraries=tdb_compat,ccan,replace \
  78. --with-modulesdir=%{_libdir}/ldb/modules \
  79. --with-privatelibdir=%{_libdir}/ldb
  80. make V=1 %{?_smp_mflags}
  81. doxygen Doxyfile
  82. %install
  83. make install DESTDIR=%{buildroot}
  84. rm -f %{buildroot}%{_libdir}/libldb.a
  85. # Remove _tevent.so (it's managed by python-tevent)
  86. #rm -f %{buildroot}/%{python_sitearch}/_tevent.so
  87. # Shared libraries need to be marked executable for
  88. # rpmbuild to strip them and include them in debuginfo
  89. find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
  90. # Install API docs
  91. cp -a apidocs/man/* $RPM_BUILD_ROOT/%{_mandir}
  92. %clean
  93. rm -rf %{buildroot}
  94. %post -p /sbin/ldconfig
  95. %postun -p /sbin/ldconfig
  96. %files
  97. %defattr(-,root,root,-)
  98. %dir %{_libdir}/ldb
  99. %{_libdir}/libldb.so.*
  100. %dir %{_libdir}/ldb/modules
  101. %dir %{_libdir}/ldb/modules/ldb
  102. %{_libdir}/ldb/libldb-cmdline.so
  103. %{_libdir}/ldb/modules/ldb/*.so
  104. %files -n ldb-tools
  105. %defattr(-,root,root,-)
  106. %{_bindir}/ldbadd
  107. %{_bindir}/ldbdel
  108. %{_bindir}/ldbedit
  109. %{_bindir}/ldbmodify
  110. %{_bindir}/ldbrename
  111. %{_bindir}/ldbsearch
  112. %{_mandir}/man1/ldbadd.1.*
  113. %{_mandir}/man1/ldbdel.1.*
  114. %{_mandir}/man1/ldbedit.1.*
  115. %{_mandir}/man1/ldbmodify.1.*
  116. %{_mandir}/man1/ldbrename.1.*
  117. %{_mandir}/man1/ldbsearch.1.*
  118. %files devel
  119. %defattr(-,root,root,-)
  120. %{_includedir}/ldb_module.h
  121. %{_includedir}/ldb_handlers.h
  122. %{_includedir}/ldb_errors.h
  123. %{_includedir}/ldb_version.h
  124. %{_includedir}/ldb.h
  125. %{_libdir}/libldb.so
  126. %{_libdir}/pkgconfig/ldb.pc
  127. %{_mandir}/man3/ldb*.gz
  128. %files -n pyldb
  129. %defattr(-,root,root,-)
  130. %{python_sitearch}/ldb.so
  131. %{_libdir}/libpyldb-util.so.1*
  132. %files -n pyldb-devel
  133. %defattr(-,root,root,-)
  134. %{_includedir}/pyldb.h
  135. %{_libdir}/libpyldb-util.so
  136. %{_libdir}/pkgconfig/pyldb-util.pc
  137. %{_mandir}/man*/Py*.gz
  138. %post -n pyldb
  139. /sbin/ldconfig
  140. %postun -n pyldb
  141. /sbin/ldconfig
  142. %changelog
  143. * Wed Dec 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.18-1
  144. - new upstream release.
  145. * Fri Oct 3 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.17-2
  146. - moved libldb and pyldb to System Environment/Libraries Group
  147. - moved ldb-tool to Applications/System Group
  148. * Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.17-1
  149. - new upstream release.
  150. * Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-2
  151. - rebuilt with current environment.
  152. * Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-1
  153. - new upstream release.
  154. * Sun Mar 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-1
  155. - new upstream release.
  156. * Thu Dec 20 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-3
  157. - moved libldb-cmdline.so to main package.
  158. * Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-2
  159. - fixed dependency.
  160. * Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-1
  161. - new upstream release.
  162. - initial build for Vine Linux.
  163. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-2
  164. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  165. * Tue Dec 06 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.4-1
  166. - New upstream release
  167. - Add ldb_module_error() routine
  168. - Fedora: work around unreliable configure check for pytevent
  169. - Drop patch to ignore --disable-silent-rules (included in tarball)
  170. * Thu Dec 01 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-4
  171. - Add patch to ignore --disable-silent-rules
  172. * Wed Nov 23 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-3
  173. - Add explicit mention of the bundled libreplace
  174. - https://fedorahosted.org/fpc/ticket/120
  175. - Add explicit mention of bundled libtdb_compat and libccan
  176. - https://fedorahosted.org/fpc/ticket/119
  177. * Mon Nov 21 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-2
  178. - Build and install API documentation
  179. - Build tdb_compat and ccan statically. They have no upstream releases to
  180. link against yet and their API is in flux. It is unsafe to make them
  181. public and shared at this time.
  182. * Wed Nov 09 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-1
  183. - New upstream release
  184. - Required for building newer samba4 packages
  185. * Tue Aug 2 2011 Simo Sorce <ssorce@redhat.com> - 1.1.0-1
  186. - Update to 1.1.0
  187. (dependency for samba4 alpha16 snapshot)
  188. * Tue Feb 22 2011 Simo Sorce <ssorce@redhat.com> - 1.0.2-1
  189. - Update to 1.0.2
  190. (dependency for samba4 alpha15 snapshot)
  191. * Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-2
  192. - Disable rpath
  193. * Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-1
  194. - New upstream release 1.0.0
  195. - SOname bump to account for module loading changes
  196. - Rename libldb-tools to ldb-tools to make upgrades easier
  197. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.22-9
  198. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  199. * Fri Feb 04 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-8
  200. - Fixes from package review
  201. - Change Requires: on tools subpackage to be the exact version/release
  202. - Remove unnecessary BuildRoot directive
  203. * Mon Jan 17 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-7
  204. - Update to 0.9.22 (first independent release of libldb upstream)