libkkc-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265
  1. %define ver 0.3.4
  2. %define rel 1
  3. %define dataver 0.2.7
  4. %define datarel 4
  5. %define from_git 0
  6. %if %{from_git}
  7. %define githash ccfd5c6d
  8. %endif
  9. %if "%{?_dist_release}" == "vl6"
  10. %define with_vala 0
  11. %else
  12. %define with_vala 1
  13. %endif
  14. Summary: Japanese Kana Kanji conversion library (libkkc)
  15. Name: libkkc
  16. Version: %{ver}
  17. %if %{from_git}
  18. Release: %{rel}.git%{githash}%{_dist_release}
  19. %else
  20. Release: %{rel}%{_dist_release}
  21. %endif
  22. License: GPLv3+
  23. Group: System Environment/Libraries
  24. URL: https://bitbucket.org/libkkc/libkkc/
  25. %if %{from_git}
  26. Source0: libkkc-%{githash}.tar.gz
  27. %else
  28. Source0: https://bitbucket.org/libkkc/libkkc/downloads/%{name}-%{version}.tar.gz
  29. %endif
  30. Source1: https://bitbucket.org/libkkc/libkkc-data/downloads/%{name}-data-%{dataver}.tar.xz
  31. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
  32. BuildRequires: pkgconfig(gee-0.8)
  33. BuildRequires: json-glib-devel
  34. BuildRequires: marisa-trie-devel
  35. # for libkkc-data
  36. BuildRequires: marisa-trie-python
  37. %if %{with_vala}
  38. BuildRequires: vala-devel
  39. BuildRequires: vala-tools
  40. %endif
  41. Requires: libkkc-data = %{dataver}-%{datarel}%{_dist_release}
  42. Requires: libkkc-common = %{version}-%{release}
  43. Vendor: Project Vine
  44. Distribution: Vine Linux
  45. Packager: iwaim
  46. %description
  47. libkkc provides a converter from Kana-string to
  48. Kana-Kanji-mixed-string. It was named after kkc.el in GNU Emacs, a
  49. simple Kana Kanji converter, while libkkc tries to convert sentences
  50. in a bit more complex way using N-gram language models.
  51. %package devel
  52. Summary: Header files and libraries for developing apps which will use libkkc
  53. Group: Development/Libraries
  54. Requires: %{name} = %{version}-%{release}
  55. %description devel
  56. The libkkc-devel package contains the header files and libraries.
  57. %package tools
  58. Summary: Tools for %{name}
  59. Group: Applications/Accessories
  60. Requires: %{name} = %{version}-%{release}
  61. %description tools
  62. The %{name}-tools package contains tools for developing applications
  63. that use %{name}.
  64. %package common
  65. Summary: Common data files for %{name}
  66. %description common
  67. The %{name}-common package contains the arch-independent data that
  68. %{name} uses at run time.
  69. %package data
  70. Summary: Data files for %{name}
  71. Version: %{dataver}
  72. Release: %{datarel}%{_dist_release}
  73. %description data
  74. The %{name}-data package contains the language model data that %{name}
  75. uses at run time.
  76. %prep
  77. %if %{from_git}
  78. %setup -q -n %{name}-%{githash}
  79. %else
  80. %setup -q
  81. %endif
  82. # for libkkc-data
  83. tar xf %{SOURCE1}
  84. %build
  85. %if %{from_git}
  86. ./autogen.sh
  87. %endif
  88. %configure --enable-shared \
  89. --disable-silent-rules \
  90. %if %{with_vala}
  91. --enable-vala=yes \
  92. %else
  93. --enable-vala=no \
  94. %endif
  95. %__make
  96. # for libkkc-data
  97. pushd %{name}-data-%{dataver}
  98. %configure
  99. %__make
  100. popd
  101. %install
  102. %__rm -rf $RPM_BUILD_ROOT
  103. %makeinstall
  104. # for libkkc-data
  105. pushd %{name}-data-%{dataver}
  106. %makeinstall
  107. popd
  108. %find_lang %{name}
  109. # remove files
  110. %__rm -f $RPM_BUILD_ROOT%{_libdir}/libkkc.la
  111. %clean
  112. %__rm -rf $RPM_BUILD_ROOT
  113. %post -p /sbin/ldconfig
  114. %postun -p /sbin/ldconfig
  115. %files -f %{name}.lang
  116. %defattr(-,root,root,-)
  117. %doc README ChangeLog COPYING AUTHORS NEWS
  118. %doc data/rules/README.rules
  119. %{_libdir}/libkkc.so.*
  120. %{_libdir}/girepository-1.0/Kkc-1.0.typelib
  121. %dir %{_datadir}/libkkc
  122. %{_datadir}/libkkc/rules
  123. %files devel
  124. %defattr(-,root,root,-)
  125. %doc COPYING AUTHORS
  126. %dir %{_includedir}/libkkc
  127. %{_includedir}/libkkc/libkkc.h
  128. %{_libdir}/libkkc.so
  129. %{_libdir}/pkgconfig/kkc-1.0.pc
  130. %{_datadir}/gir-1.0/Kkc-1.0.gir
  131. %{_datadir}/vala/vapi/kkc-1.0.deps
  132. %{_datadir}/vala/vapi/kkc-1.0.vapi
  133. %files tools
  134. %defattr(-,root,root,-)
  135. %doc COPYING AUTHORS
  136. %{_bindir}/kkc
  137. %{_bindir}/kkc-package-data
  138. %files common
  139. %defattr(-,root,root,-)
  140. %doc COPYING AUTHORS
  141. %dir %{_datadir}/libkkc
  142. %dir %{_datadir}/libkkc/templates
  143. %{_datadir}/libkkc/templates/libkkc-data
  144. %files data
  145. %defattr(-,root,root,-)
  146. %doc COPYING AUTHORS
  147. %dir %{_libdir}/libkkc
  148. %dir %{_libdir}/libkkc/models
  149. %{_libdir}/libkkc/models/sorted3
  150. %changelog
  151. * Mon Jul 7 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.4-1
  152. - update to libkkc 0.3.4
  153. - update BuildRequires for libgee
  154. * Sun Jun 15 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.3-1
  155. - update to libkkc 0.3.3
  156. * Wed Dec 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.2-1
  157. - update to libkkc 0.3.2
  158. * Thu Nov 7 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.1-1
  159. - update to libkkc 0.3.1
  160. - update to libkkc-data 0.2.7
  161. - fix changelog for 0.2.6-1
  162. * Sat Jul 27 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.6-1
  163. - update to libkkc 0.2.6
  164. - update to libkkc-data 0.2.5
  165. * Tue Jun 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.4-1
  166. - update to libkkc 0.2.4
  167. - update to libkkc-data 0.2.0
  168. - add Version tag for libkkc-data sub package
  169. * Tue Mar 26 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.10-1
  170. - update to libkkc 0.1.10
  171. * Sat Mar 16 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.9-1
  172. - update to libkkc 0.1.9
  173. * Sun Mar 3 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.8-1
  174. - update to libkkc 0.1.8
  175. * Sat Feb 23 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.7-1
  176. - update to libkkc 0.1.7
  177. * Fri Feb 15 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.6-1
  178. - update to libkkc 0.1.6
  179. - update to libkkc-data 0.1.6
  180. * Mon Feb 11 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.5-1
  181. - update to libkkc 0.1.5
  182. * Fri Feb 8 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.3-1
  183. - update to 0.1.3
  184. - update License value: GPLv3 -> GPLv3+
  185. - add BuildRequires: marisa-trie-python for libkkc-data
  186. - sync upstream spec: http://ueno.fedorapeople.org/libkkc/libkkc.spec 0.1.3-2
  187. - create tools sub package
  188. - move %%{_bindir}/kkc
  189. - add %%{_bindir}/kkc-package-data
  190. - create common sub package
  191. - add template for generating libkkc-data
  192. - merge libkkc-data SRPM file
  193. - add libkkc-data source file (Source1)
  194. - create data sub package
  195. - add '--disable-silent-rules' option for configure
  196. - add Requires libkkc-data and libkkc-common
  197. - add document: data/rules/README.rules
  198. * Wed Feb 6 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.2-1
  199. - update to 0.1.2
  200. * Tue Feb 5 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.1-1
  201. - update to 0.1.1
  202. * Fri Feb 1 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.0-1
  203. - update to 0.1.0
  204. - rename libkkc.pc to kkc-1.0.pc by upstream
  205. * Fri Feb 1 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-3.gitccfd5c6d
  206. - update to git ccfd5c6d9f913e0a413fe5d0c45bb70032382f68
  207. - add post and postun script
  208. - add translate file
  209. * Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-2
  210. - support Vine Linux 6
  211. - without Vala
  212. - BR: libgee-devel
  213. * Mon Jan 28 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-1
  214. - initial build for Vine Linux