gwget-vl.spec 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133
  1. %define name gwget
  2. %define version 1.0.4
  3. %define release 4%{?_dist_release}
  4. Summary: Download manager for Gnome
  5. Summary(ja): Gnome 用ダウンロードマネージャ
  6. Name: %{name}
  7. Version: %{version}
  8. Release: %{release}
  9. License: GPLv2+
  10. Group: Applications/Internet
  11. URL: http://www.gnome.org/projects/gwget/
  12. Source0: http://ftp.gnome.org/pub/GNOME/sources/gwget/1.0/%{name}-%{version}.tar.bz2
  13. Patch1: gwget-1.0.4-libnotify-0.7.0.patch
  14. Patch2: gwget-glib.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: gtk2-devel >= 2.10
  17. BuildRequires: libgnomeui-devel
  18. BuildRequires: libglade2-devel, gnome-vfs2-devel
  19. BuildRequires: dbus-devel
  20. BuildRequires: libnotify-devel
  21. BuildRequires: libSM-devel
  22. BuildRequires: intltool >= 0.35.0
  23. BuildRequires: gettext >= 0.14.1
  24. BuildRequires: desktop-file-utils
  25. Requires: wget >= 1.9
  26. Requires(post): GConf2
  27. Requires(preun): GConf2
  28. %description
  29. Gwget is a Download Manager for Gnome 2. It uses wget as a backend.
  30. Currently, very basic wget options are available, supporting multiple
  31. downloads, drag&drop and display the errors from wget process.
  32. %description -l ja
  33. Gwget は Gnome 2 向けのダウンロードマネージャです。バックエンドに wget を使用します。現在は基本的な wget オプションを利用することができ、複数のダウンロード、ドラッグ&ドロップ、wget プロセスからのエラー表示に対応しています。
  34. %prep
  35. %setup -q
  36. %patch1 -p1 -b .libnotify-0.7.0
  37. %patch2 -p1 -b .glib
  38. # convert files to UTF-8 with preserving the timestamps
  39. for file in ChangeLog README; do
  40. mv $file timestamp
  41. iconv -f ISO-8859-1 -t UTF-8 -o $file timestamp
  42. touch -r timestamp $file
  43. done
  44. %build
  45. %configure --disable-epiphany-extension --disable-static
  46. make %{?_smp_mflags}
  47. %install
  48. %{__rm} -rf ${RPM_BUILD_ROOT}
  49. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  50. make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
  51. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  52. desktop-file-install \
  53. --dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
  54. --delete-original \
  55. ${RPM_BUILD_ROOT}%{_datadir}/applications/%{name}.desktop
  56. %find_lang %{name}
  57. #remove unnecessary files.
  58. %{__rm} -rf ${RPM_BUILD_ROOT}/%{_includedir}/gwget
  59. %clean
  60. %{__rm} -rf ${RPM_BUILD_ROOT}
  61. %post
  62. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  63. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gwget.schemas > /dev/null
  64. %pre
  65. if [ "$1" -gt 1 ]; then
  66. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  67. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwget.schemas > /dev/null
  68. fi
  69. %preun
  70. if [ "$1" = "0" ] ; then
  71. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  72. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwget.schemas > /dev/null
  73. fi
  74. %postun
  75. update-desktop-database -q
  76. %files -f %{name}.lang
  77. %defattr(-,root,root)
  78. %doc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
  79. %{_bindir}/gwget
  80. %{_sysconfdir}/gconf/schemas/gwget.schemas
  81. %{_datadir}/applications/gwget.desktop
  82. %{_datadir}/gwget
  83. %{_datadir}/pixmaps/gwget.png
  84. %{_datadir}/dbus-1/services/org.gnome.gwget.service
  85. %changelog
  86. * Mon Dec 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.4-4
  87. - added Patch1 and 2 to build with current VineSeed
  88. * Sun Feb 12 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.4-3
  89. - rebuilt with rpm-4.8.1
  90. * Sun Jan 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.4-2
  91. - added BuildRequires: libSM-devel (see [BTS:VineLinux:0900])
  92. * Tue Oct 20 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.4-1
  93. - new upstream release
  94. * Sun Oct 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.2-1
  95. - new upstream release
  96. - added --disable-static in configure option
  97. - changed make %{?_smp_mflags}
  98. - added BuildRequires: libnotify-devel, intltool >= 0.35.0, gettext >= 0.14.1, desktop-file-utils
  99. * Sat May 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-1
  100. - applied new versioning policy, spec in UTF-8
  101. - new upstream release
  102. * Wed Jul 25 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.99-0vl1
  103. - rebuild for Vine Seed.
  104. - add requried gtk2 version >= 2.10.
  105. * Wed Jul 25 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.98.2-0vl1
  106. - initial build for Vine Plus/4.0.