avogadro-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277
  1. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.2)
  2. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
  3. %define ENABLE_TESTS -DENABLE_TESTS:BOOL=ON
  4. Name: avogadro
  5. Summary: An advanced molecular editor for chemical purposes
  6. Version: 1.0.3
  7. Release: 1%{?_dist_release}
  8. Group: Applications/Editors
  9. License: GPLv2
  10. URL: http://avogadro.openmolecules.net/
  11. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
  12. Patch0: avogadro-1.0.3-mkspecs-dir.patch
  13. BuildRequires: cmake >= 2.6.0
  14. BuildRequires: qt4-devel >= 4.5.1
  15. BuildRequires: qt4-tools
  16. BuildRequires: eigen2-devel >= 2.0.3
  17. BuildRequires: openbabel-devel >= 2.2.2
  18. BuildRequires: libboost-devel >= 1.35
  19. BuildRequires: libboost-python >= 1.35
  20. BuildRequires: glew-devel >= 1.5.0
  21. BuildRequires: desktop-file-utils
  22. BuildRequires: docbook-utils
  23. BuildRequires: sip-devel >= 4.11
  24. BuildRequires: numpy
  25. Requires: %{name}-libs = %{version}-%{release}
  26. %description
  27. An advanced molecular editor designed for
  28. cross-platform use in computational chemistry,
  29. molecular modeling, bioinformatics, materials science,
  30. and related areas, which offers flexible rendering and
  31. a powerful plugin architecture.
  32. %package libs
  33. Summary: Shared libraries for Avogadro
  34. Summary(ja): Avogadro の共用ライブラリ
  35. Group: System Environment/Libraries
  36. Requires: sip
  37. %description libs
  38. This package contains the shared libraries for the
  39. molecular editor Avogadro.
  40. %package devel
  41. Summary: Development files for Avogadro
  42. Summary(ja): Avogadro の開発用ファイル
  43. Group: Development/Libraries
  44. Requires: %{name}-libs = %{version}-%{release}
  45. Requires: qt4-devel = %{_qt4_version}
  46. Requires: eigen2-devel >= 2.0.3
  47. Requires: glew-devel >= 1.5.0
  48. %description devel
  49. This package contains files to develop applications using
  50. Avogadros libraries.
  51. %prep
  52. %setup -q
  53. %patch0 -p1 -b .mkspecs-dir
  54. # nuke unpatched copy, use working version included in cmake instead -- Rex
  55. rm -f cmake/modules/FindPythonLibs.cmake
  56. %build
  57. mkdir -p %{_target_platform}
  58. pushd %{_target_platform}
  59. %cmake -Wno-dev \
  60. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  61. -DBIN_INSTALL_DIR:PATH=bin \
  62. -DLIB_INSTALL_DIR:PATH=%{_lib} \
  63. -DENABLE_GLSL:BOOL=ON \
  64. -DENABLE_PYTHON:BOOL=ON \
  65. %{?ENABLE_TESTS} ..
  66. popd
  67. make %{?_smp_mflags} -C %{_target_platform}
  68. %install
  69. rm -rf $RPM_BUILD_ROOT
  70. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  71. %check
  72. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/avogadro.desktop
  73. # all of these currently require an active X session, so will fail
  74. # in mock
  75. %{?ENABLE_TESTS:make test -C %{_target_platform} ||:}
  76. %post libs -p /sbin/ldconfig
  77. %postun libs -p /sbin/ldconfig
  78. %files
  79. %defattr(-,root,root,-)
  80. %doc AUTHORS ChangeLog COPYING
  81. %{_bindir}/avogadro
  82. %{_bindir}/avopkg
  83. # TODO: %lang'ify stuff under %%{_datadir}/avogadro/i18n/
  84. %{_datadir}/avogadro/
  85. %{_datadir}/pixmaps/avogadro-icon.png
  86. %{_datadir}/applications/avogadro.desktop
  87. %{_mandir}/man1/avogadro.1*
  88. %{_mandir}/man1/avopkg.1*
  89. %files devel
  90. %defattr(-,root,root,-)
  91. %{_includedir}/avogadro/
  92. %{_libdir}/libavogadro.so
  93. %{_libdir}/avogadro/*.cmake
  94. %{_libdir}/avogadro/1_0/*.cmake
  95. # these look like dups of system copies?, take a closer look and/or ask upstream -- Rex
  96. %{_libdir}/avogadro/1_0/cmake/
  97. %{_qt4_prefix}/mkspecs/features/avogadro.prf
  98. %files libs
  99. %defattr(-,root,root,-)
  100. %{python_sitearch}/Avogadro.so
  101. %{_datadir}/libavogadro/
  102. %{_libdir}/libavogadro.so.*
  103. %dir %{_libdir}/avogadro/
  104. %dir %{_libdir}/avogadro/1_0/
  105. %{_libdir}/avogadro/1_0/colors/
  106. %{_libdir}/avogadro/1_0/extensions/
  107. %{_libdir}/avogadro/1_0/engines/
  108. %{_libdir}/avogadro/1_0/tools/
  109. %changelog
  110. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.3-1
  111. - update to 1.0.3
  112. - remove old patches
  113. - add Patch0 (avogadro-1.0.3-mkspecs-dir.patch) from fedora
  114. * Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-13
  115. - rebuild with qt4-4.8.5
  116. * Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-12
  117. - rebuild with qt4-4.8.3
  118. * Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-11
  119. - rebuild with qt4-4.8.2
  120. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-10
  121. - rebuild with python-2.7.2
  122. * Tue Jan 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-9
  123. - rebuild with qt4-4.8.0 and glew-1.7.0
  124. * Wed Mar 9 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-8
  125. - rebuilt with qt4-4.7.2
  126. - BR: qt4-tools instead of qt4-designer
  127. * Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-7
  128. - added BR: libboost-python
  129. - added R: glew-devel, eigen2-devel to devel package
  130. * Wed Feb 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-6
  131. - rebuilt with qt4-4.7.1
  132. - added Patch0 and 1 from Fedora
  133. * Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 1.0.1-5
  134. - rebuilt with libboost-1.45.0
  135. * Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
  136. - Initial build for Vine Linux
  137. * Wed Aug 04 2010 Rahul Sundaram <sundaram@fedoraproject.org> - 1.0.1-3
  138. - Rebuild for Boost soname bump
  139. - Update to match current guidelines
  140. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.0.1-2
  141. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  142. * Mon May 24 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.1-1
  143. - avogadro-1.0.1
  144. - -devel: move cmake-related files here
  145. - -devel: Req: qt4-devel
  146. - %%files: track lib sonames
  147. - %%check section
  148. * Wed Feb 10 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.0-6
  149. - reenable plugin builds and libs subpackage
  150. - fix their build with sip 4.10
  151. * Fri Jan 08 2010 Sebastian Dziallas <sebastian@when.com> - 1.0.0-5
  152. - disable plugin builds and libs subpackage
  153. * Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-4
  154. - rebuild (sip)
  155. * Mon Nov 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-3
  156. - rebuild (for qt-4.6.0-rc1, f13+)
  157. * Mon Nov 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-2
  158. - -libs: Requires: sip-api(%%_sip_api_major) >= %%_sip_api (#538124)
  159. - Requires: %%{name}-libs ...
  160. * Thu Oct 29 2009 Sebastian Dziallas <sebastian@when.com> 1.0.0-1
  161. - update to new upstream release
  162. * Tue Oct 20 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.8-3
  163. - rebuild (eigen2)
  164. * Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-2
  165. - fix typo in file list
  166. * Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-1
  167. - update to new upstream release
  168. - enable python and glsl support again
  169. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-2
  170. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  171. * Sat Jun 06 2009 Sebastian Dziallas <sebastian@when.com> 0.9.6-1
  172. - new upstream release to fix issue with qt 4.5.0 and earlier
  173. * Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-3
  174. - remove remaining python parts
  175. - fix files section finally
  176. * Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-2
  177. - disable python and glsl for now
  178. - fix files section
  179. * Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-1
  180. - update to new release
  181. * Tue May 12 2009 Sebastian Dziallas <sebastian@when.com> 0.9.4-1
  182. - update to new release
  183. * Fri Apr 10 2009 Sebastian Dziallas <sebastian@when.com> 0.9.3-1
  184. - update to new release
  185. * Sat Mar 21 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-2
  186. - get desktop file properly installed
  187. * Sat Mar 14 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-1
  188. - update to new release
  189. * Wed Feb 25 2009 Sebastian Dziallas <sebastian@when.com> 0.9.1-1
  190. - update to new release
  191. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
  192. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  193. * Thu Jan 22 2009 Sebastian Dziallas <sebastian@when.com> 0.9.0-1
  194. - update to new release
  195. * Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-6
  196. - add handbook to docs
  197. * Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-5
  198. - add build requirements and fix group names
  199. * Wed Aug 13 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-4
  200. - fix typos
  201. * Sat Aug 9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-3
  202. - reorganize spec file
  203. * Sat Aug 9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-2
  204. - rename shared library package and structure spec file
  205. * Sun Aug 3 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-1
  206. - initial pacakging release based on PackMan release