python-pillow-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626
  1. %global py2_incdir %(python2 -c 'import distutils.sysconfig; print(distutils.sysconfig.get_python_inc())')
  2. %global py2_libbuilddir %(python2 -c 'import sys; import sysconfig; print("lib.{p}-{v[0]}.{v[1]}".format(p=sysconfig.get_platform(), v=sys.version_info))')
  3. %global with_python3 1
  4. %global py3_incdir %(python3 -c 'import distutils.sysconfig; print(distutils.sysconfig.get_python_inc())')
  5. %global py3_libbuilddir %(python3 -c 'import sys; import sysconfig; print("lib.{p}-{v[0]}.{v[1]}".format(p=sysconfig.get_platform(), v=sys.version_info))')
  6. %global srcname pillow
  7. # bootstrap building docs (pillow is required by docutils, docutils are
  8. # required by sphinx; pillow build-requires sphinx)
  9. %global with_docs 0
  10. Name: python-%{srcname}
  11. Version: 6.2.0
  12. Release: 3%{?_dist_release}
  13. Summary: Python image processing library
  14. Group: Development/Libraries
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. # License: see http://www.pythonware.com/products/pil/license.htm
  18. License: MIT
  19. URL: http://python-pillow.github.io/
  20. Source0: https://github.com/python-pillow/Pillow/archive/%{version}/Pillow-%{version}.tar.gz
  21. BuildRequires: freetype2-devel
  22. BuildRequires: gcc
  23. BuildRequires: ghostscript
  24. BuildRequires: lcms2-devel
  25. #BuildRequires: libimagequant-devel
  26. BuildRequires: libjpeg-devel
  27. #BuildRequires: libraqm-devel
  28. BuildRequires: libtiff-devel
  29. BuildRequires: libwebp-devel
  30. BuildRequires: openjpeg2-devel
  31. BuildRequires: tk-devel
  32. BuildRequires: zlib-devel
  33. BuildRequires: python-devel
  34. BuildRequires: numpy
  35. #BuildRequires: python-olefile
  36. BuildRequires: python-setuptools
  37. %if 0%{?with_python3}
  38. BuildRequires: python3-rpm-macros
  39. BuildRequires: python3-cffi
  40. BuildRequires: python3-devel
  41. BuildRequires: python3-numpy
  42. #BuildRequires: python3-olefile
  43. BuildRequires: python3-qt5
  44. BuildRequires: python3-setuptools
  45. %if 0%{?with_docs}
  46. BuildRequires: python3-sphinx
  47. BuildRequires: python3-sphinx_rtd_theme
  48. %endif
  49. BuildRequires: python3-tkinter
  50. %endif
  51. # For EpsImagePlugin.py
  52. Requires: ghostscript
  53. %{?python_provide:%python_provide python2-%{srcname}}
  54. Obsoletes: python-imaging < 1.2.0
  55. Provides: python-imaging = %{version}-%{release}
  56. Provides: python2-imaging = %{version}-%{release}
  57. # For MicImagePlugin.py, FpxImagePlugin.py
  58. #Requires: python-olefile
  59. %global __provides_exclude_from ^%{python_sitearch}/PIL/.*\\.so$
  60. %global __provides_exclude_from ^%{python3_sitearch}/PIL/.*\\.so$
  61. %description
  62. Python image processing library, fork of the Python Imaging Library (PIL)
  63. This library provides extensive file format support, an efficient
  64. internal representation, and powerful image processing capabilities.
  65. There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
  66. devel (development) and doc (documentation).
  67. %package devel
  68. Summary: Development files for %{srcname}
  69. Requires: python-devel, libjpeg-devel, zlib-devel
  70. Requires: python-%{srcname}%{?_isa} = %{version}-%{release}
  71. %{?python_provide:%python_provide python-%{srcname}-devel}
  72. Provides: python-imaging-devel = %{version}-%{release}
  73. Provides: python2-imaging-devel = %{version}-%{release}
  74. %description devel
  75. Development files for %{srcname}.
  76. %if 0%{?with_python3}
  77. %package -n python3-%{srcname}
  78. Summary: Python 3 image processing library
  79. %{?python_provide:%python_provide python3-%{srcname}}
  80. Provides: python3-imaging = %{version}-%{release}
  81. # For MicImagePlugin.py, FpxImagePlugin.py
  82. #Requires: python3-olefile
  83. %description -n python3-%{srcname}
  84. Python image processing library, fork of the Python Imaging Library (PIL)
  85. This library provides extensive file format support, an efficient
  86. internal representation, and powerful image processing capabilities.
  87. There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
  88. devel (development) and doc (documentation).
  89. %package -n python3-%{srcname}-devel
  90. Summary: Development files for %{srcname}
  91. Requires: python3-devel, libjpeg-devel, zlib-devel
  92. Requires: python3-%{srcname}%{?_isa} = %{version}-%{release}
  93. %{?python_provide:%python_provide python3-%{srcname}-devel}
  94. Provides: python3-imaging-devel = %{version}-%{release}
  95. %description -n python3-%{srcname}-devel
  96. Development files for %{srcname}.
  97. %package -n python3-%{srcname}-doc
  98. Summary: Documentation for %{srcname}
  99. BuildArch: noarch
  100. Requires: python3-%{srcname} = %{version}-%{release}
  101. %{?python_provide:%python_provide python3-%{srcname}-doc}
  102. Provides: python3-imaging-doc = %{version}-%{release}
  103. Obsoletes: python-%{srcname}-doc < 5.4.1-4
  104. %description -n python3-%{srcname}-doc
  105. Documentation for %{srcname}.
  106. %package -n python3-%{srcname}-tk
  107. Summary: Tk interface for %{srcname}
  108. Requires: python3-tkinter
  109. Requires: python3-%{srcname}%{?_isa} = %{version}-%{release}
  110. %{?python_provide:%python_provide python3-%{srcname}-tk}
  111. Provides: python3-imaging-tk = %{version}-%{release}
  112. %description -n python3-%{srcname}-tk
  113. Tk interface for %{name}.
  114. %package -n python3-%{srcname}-qt
  115. Summary: Qt %{srcname} image wrapper
  116. Requires: python3-qt5
  117. Requires: python3-%{srcname}%{?_isa} = %{version}-%{release}
  118. %{?python_provide:%python_provide python3-%{srcname}-qt}
  119. Provides: python3-imaging-qt = %{version}-%{release}
  120. %description -n python3-%{srcname}-qt
  121. Qt %{srcname} image wrapper.
  122. %endif
  123. %prep
  124. %autosetup -p1 -n Pillow-%{version}
  125. %build
  126. # Build Python 2 modules
  127. %py_build
  128. %if 0%{?with_python3}
  129. # Build Python 3 modules
  130. %py3_build
  131. %if 0%{?with_docs}
  132. PYTHONPATH=$PWD/build/%py3_libbuilddir make -C docs html BUILDDIR=_build_py3 SPHINXBUILD=sphinx-build-%python3_version
  133. rm -f docs/_build_py3/html/.buildinfo
  134. %endif
  135. %endif
  136. %install
  137. # Install Python 2 modules
  138. install -d %{buildroot}/%{py2_incdir}/Imaging
  139. install -m 644 src/libImaging/*.h %{buildroot}/%{py2_incdir}/Imaging
  140. %py_install
  141. %if 0%{?with_python3}
  142. # Install Python 3 modules
  143. install -d %{buildroot}/%{py3_incdir}/Imaging
  144. install -m 644 src/libImaging/*.h %{buildroot}/%{py3_incdir}/Imaging
  145. %py3_install
  146. %endif
  147. %check
  148. # Check Python 2 modules
  149. ln -s $PWD/Images $PWD/build/%py2_libbuilddir/Images
  150. cp -R $PWD/Tests $PWD/build/%py2_libbuilddir/Tests
  151. cp -R $PWD/selftest.py $PWD/build/%py2_libbuilddir/selftest.py
  152. pushd build/%py2_libbuilddir
  153. PYTHONPATH=$PWD %{__python} selftest.py
  154. popd
  155. %if 0%{?with_python3}
  156. # Check Python 3 modules
  157. ln -s $PWD/Images $PWD/build/%py3_libbuilddir/Images
  158. cp -R $PWD/Tests $PWD/build/%py3_libbuilddir/Tests
  159. cp -R $PWD/selftest.py $PWD/build/%py3_libbuilddir/selftest.py
  160. pushd build/%py3_libbuilddir
  161. PYTHONPATH=$PWD %{__python3} selftest.py
  162. popd
  163. %endif
  164. %files
  165. %doc README.rst CHANGES.rst
  166. %license docs/COPYING
  167. %{python_sitearch}/*
  168. # These are in subpackages
  169. %exclude %{python_sitearch}/PIL/_imagingtk*
  170. %exclude %{python_sitearch}/PIL/ImageTk*
  171. %exclude %{python_sitearch}/PIL/SpiderImagePlugin*
  172. %exclude %{python_sitearch}/PIL/ImageQt*
  173. %files devel
  174. %{py2_incdir}/Imaging/
  175. %if 0%{?with_python3}
  176. %files -n python3-%{srcname}
  177. %doc README.rst CHANGES.rst
  178. %license docs/COPYING
  179. %{python3_sitearch}/*
  180. # These are in subpackages
  181. %exclude %{python3_sitearch}/PIL/_imagingtk*
  182. %exclude %{python3_sitearch}/PIL/ImageTk*
  183. %exclude %{python3_sitearch}/PIL/SpiderImagePlugin*
  184. %exclude %{python3_sitearch}/PIL/ImageQt*
  185. %exclude %{python3_sitearch}/PIL/__pycache__/ImageTk*
  186. %exclude %{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
  187. %exclude %{python3_sitearch}/PIL/__pycache__/ImageQt*
  188. %files -n python3-%{srcname}-devel
  189. %{py3_incdir}/Imaging/
  190. %files -n python3-%{srcname}-doc
  191. %if 0%{?with_docs}
  192. %doc docs/_build_py3/html
  193. %endif
  194. %files -n python3-%{srcname}-tk
  195. %{python3_sitearch}/PIL/_imagingtk*
  196. %{python3_sitearch}/PIL/ImageTk*
  197. %{python3_sitearch}/PIL/SpiderImagePlugin*
  198. %{python3_sitearch}/PIL/__pycache__/ImageTk*
  199. %{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
  200. %files -n python3-%{srcname}-qt
  201. %{python3_sitearch}/PIL/ImageQt*
  202. %{python3_sitearch}/PIL/__pycache__/ImageQt*
  203. %endif
  204. %changelog
  205. * Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.0-3
  206. - initial build for Vine Linux.
  207. * Mon Oct 07 2019 Petr Viktorin <pviktori@redhat.com> - 6.2.0-2
  208. - Remove optional build dependency on python2-cffi
  209. * Tue Oct 01 2019 Sandro Mani <manisandro@gmail.com> - 6.2.0-1
  210. - Update to 6.2.0
  211. * Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 6.1.0-4
  212. - Rebuilt for Python 3.8
  213. * Mon Aug 12 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-3
  214. - Drop python2-pillow-qt, python2-pillow-tk
  215. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.0-2
  216. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  217. * Mon Jul 01 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-1
  218. - Update to 6.1.0
  219. * Fri May 31 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 6.0.0-2
  220. - Fix broken Python/C interop on s390x
  221. * Tue Apr 02 2019 Sandro Mani <manisandro@gmail.com> - 6.0.0-1
  222. - Update to 6.0.0
  223. * Sun Mar 10 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-4
  224. - Drop python2-pillow-doc
  225. * Mon Mar 04 2019 Yatin Karel <ykarel@redhat.com> - 5.4.1-3
  226. - Fix python3 conditional
  227. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.4.1-2
  228. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  229. * Mon Jan 07 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-1
  230. - Update to 5.4.1
  231. * Mon Oct 01 2018 Sandro Mani <manisandro@gmail.com> - 5.3.0-1
  232. - Update to 5.3.0
  233. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.0-3
  234. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  235. * Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 5.2.0-2
  236. - Rebuilt for Python 3.7
  237. * Mon Jul 02 2018 Sandro Mani <manisandro@gmail.com> - 5.2.0-1
  238. - Update to 5.2.0
  239. * Wed Jun 27 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-3
  240. - Fix the tkinter dependency
  241. * Sat Jun 16 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-2
  242. - Rebuilt for Python 3.7
  243. * Wed Apr 25 2018 Sandro Mani <manisandro@gmail.com> - 5.1.1-1
  244. - Update to 5.1.1
  245. * Thu Apr 05 2018 Sandro Mani <manisandro@gmail.com> - 5.1.0-1
  246. - Update to 5.1.0
  247. * Wed Mar 07 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-3
  248. - Add missing BR: gcc
  249. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.0-2
  250. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  251. * Wed Jan 03 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-1
  252. - Update to 5.0.0
  253. * Tue Oct 03 2017 Sandro Mani <manisandro@gmail.com> - 4.3.0-1
  254. - Update to 4.3.0
  255. * Tue Sep 05 2017 Troy Dawson <tdawson@redhat.com> - 4.2.1-5
  256. - Cleanup spec file conditionals
  257. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-4
  258. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  259. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-3
  260. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  261. * Fri Jul 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 4.2.1-2
  262. - Rebuild due to bug in RPM (RHBZ #1468476)
  263. * Thu Jul 06 2017 Sandro Mani <manisandro@gmail.com> - 4.2.1-1
  264. - Update to 4.2.1
  265. * Sat Jul 01 2017 Sandro Mani <manisandro@gmail.com> - 4.2.0-1
  266. - Update to 4.2.0
  267. * Fri Apr 28 2017 Sandro Mani <manisandro@gmail.com> - 4.1.1-1
  268. - Update to 4.1.1
  269. * Wed Apr 05 2017 Sandro Mani <manisandro@gmail.com> - 4.1.0-1
  270. - Update to 4.1.0
  271. * Wed Feb 15 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-3
  272. - Fix some __pycache__ files in wrong subpackage (#1422606)
  273. * Wed Feb 01 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-2
  274. - Rebuild (libwebp)
  275. * Tue Jan 03 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-1
  276. - Update to 4.0.0
  277. * Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-3
  278. - Enable docs build
  279. * Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-2
  280. - Rebuild for Python 3.6
  281. * Wed Oct 19 2016 Sandro Mani <manisandro@gmail.com> - 3.4.2-1
  282. - Update to 3.4.2
  283. * Tue Oct 04 2016 Sandro Mani <manisandro@gmail.com> - 3.4.1-1
  284. - Update to 3.4.1
  285. * Mon Oct 03 2016 Sandro Mani <manisandro@gmail.com> - 3.4.0-1
  286. - Update to 3.4.0
  287. * Thu Aug 18 2016 Sandro Mani <manisandro@gmail.com> - 3.3.1-1
  288. - Update to 3.3.1
  289. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.0-2
  290. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  291. * Sat Jul 02 2016 Sandro Mani <manisandro@gmail.com> - 3.3.0-1
  292. - Update to 3.3.0
  293. - Modernize spec
  294. * Fri Apr 01 2016 Sandro Mani <manisandro@gmail.com> - 3.2.0-1
  295. - Update to 3.2.0
  296. * Wed Feb 10 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-3
  297. - Fix broken python3-pillow package description
  298. * Sun Feb 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.1.1-2
  299. - Fix provides
  300. * Thu Feb 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-1
  301. - Update to 3.1.1
  302. - Fixes CVE-2016-0740, CVE-2016-0775
  303. * Mon Jan 11 2016 Toshio Kuratomi <toshio@fedoraproject.org> - 3.1.0-2
  304. - Fix executable files in doc package bringing in python 2 for the python3 doc
  305. packages
  306. * Mon Jan 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.0-1
  307. - Update to 3.1.0
  308. * Tue Dec 29 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-5
  309. - Build with docs
  310. * Mon Dec 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-4
  311. - Rebuilt for libwebp soname bump
  312. * Wed Oct 14 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-3
  313. - Rebuilt for Python3.5 rebuild with docs
  314. * Tue Oct 13 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-2
  315. - Rebuilt for Python3.5 rebuild without docs
  316. * Fri Oct 02 2015 Sandro Mani <manisandro@gmail.com> - 3.0.0-1
  317. - Update to 3.0.0
  318. * Wed Jul 29 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-2
  319. - Fix python3-pillow-tk Requires: tkinter -> python3-tkinter (#1248085)
  320. * Thu Jul 02 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-1
  321. - Update to 2.9.0
  322. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.2-2
  323. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  324. * Mon Jun 08 2015 Sandro Mani <manisandro@gmail.com> - 2.8.2-1
  325. - Update to 2.8.2
  326. * Thu Apr 02 2015 Sandro Mani <manisandro@gmail.com> - 2.8.1-1
  327. - Update to 2.8.1
  328. * Wed Apr 01 2015 Sandro Mani <manisandro@gmail.com> - 2.8.0-1
  329. - Update to 2.8.0
  330. * Mon Jan 12 2015 Sandro Mani <manisandro@gmail.com> - 2.7.0-1
  331. - Update to 2.7.0
  332. - Drop sane subpackage, is in python-sane now
  333. - Fix python3 headers directory
  334. - Drop Obsoletes: python3-pillow on python3-pillow-qt
  335. * Mon Oct 13 2014 Sandro Mani <manisandro@gmail.com> - 2.6.1-1
  336. - Update to 2.6.1
  337. * Thu Oct 02 2014 Sandro Mani <manisandro@gmail.com> - 2.6.0-1
  338. - Update to 2.6.0
  339. * Wed Aug 20 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-3
  340. - Rebuilding again to resolve transient build error that caused BZ#1131723
  341. * Tue Aug 19 2014 Stephen Gallagher <sgallagh@redhat.com> - 2.5.3-2
  342. - Rebuilding to resolve transient build error that caused BZ#1131723
  343. * Tue Aug 19 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-1
  344. - Update to 2.5.3 (Fix CVE-2014-3598, a DOS in the Jpeg2KImagePlugin)
  345. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.2-2
  346. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  347. * Wed Aug 13 2014 Sandro Mani <manisandro@gmail.com> - 2.5.2-1
  348. - Update to 2.5.2 (Fix CVE-2014-3589, a DOS in the IcnsImagePlugin)
  349. * Sat Jul 26 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-2
  350. - Reenable jpeg2k tests on big endian arches
  351. * Tue Jul 15 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-1
  352. - Update to 2.5.1
  353. * Wed Jul 02 2014 Sandro Mani <manisandro@gmail.com> - 2.5.0-1
  354. - Update to 2.5.0
  355. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-11
  356. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  357. * Wed May 28 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-10
  358. - Rebuild with docs enabled
  359. - Update python-pillow_openjpeg-2.1.0.patch
  360. * Tue May 27 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-9
  361. - Rebuild against openjpeg-2.1.0
  362. * Fri May 23 2014 Dan Horák <dan[at]danny.cz> - 2.4.0-8
  363. - skip jpeg2k tests on big endian arches (#1100762)
  364. * Wed May 21 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4.0-7
  365. - Rebuilt for https://fedoraproject.org/wiki/Changes/f21tcl86
  366. * Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-6
  367. - Set with_docs to 1 to build docs.
  368. * Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-5
  369. - Bootstrap building sphinx docs because of circular dependency with sphinx.
  370. * Fri May 9 2014 Orion Poplawski <orion@cora.nwra.com> - 2.4.0-4
  371. - Rebuild for Python 3.4
  372. * Tue Apr 22 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-3
  373. - Add patch: Have the tempfile use a suffix with a dot
  374. * Thu Apr 17 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-2
  375. - Enable Jpeg2000 support
  376. - Enable webp support also on s390* archs, bug #962091 is now fixed
  377. - Add upstream patch for ghostscript detection
  378. * Wed Apr 02 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-1
  379. - Update to 2.4.0
  380. * Wed Mar 19 2014 Sandro Mani <manisandro@gmail.com> - 2.3.1-1
  381. - Update to 2.3.1 (Fix insecure use of tempfile.mktemp (CVE-2014-1932 CVE-2014-1933))
  382. * Thu Mar 13 2014 Jakub Dorňák <jdornak@redhat.com> - 2.3.0-5
  383. - python-pillow does not provide python3-imaging
  384. (python3-pillow does)
  385. * Tue Jan 07 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-4
  386. - Add missing ghostscript Requires and BuildRequires
  387. * Mon Jan 06 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-3
  388. - Remove python-pillow_help-theme.patch, add python-sphinx-theme-better BR
  389. * Sun Jan 05 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-2
  390. - Rebuild with docs enabled
  391. - Change lcms BR to lcms2
  392. * Thu Jan 02 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-1
  393. - Update to 2.3.0
  394. - Build with doc disabled to break circular python-pillow -> python-sphinx -> python pillow dependency
  395. * Wed Oct 23 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-2
  396. - Backport fix for decoding tiffs with correct byteorder, fixes rhbz#1019656
  397. * Wed Oct 02 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-1
  398. - Update to 2.2.1
  399. - Really enable webp on ppc, but leave disabled on s390
  400. * Thu Aug 29 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-4
  401. - Add patch to fix incorrect PyArg_ParseTuple tuple signature, fixes rhbz#962091 and rhbz#988767.
  402. - Renable webp support on bigendian arches
  403. * Wed Aug 28 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-3
  404. - Add patch to fix memory corruption caused by invalid palette size, see rhbz#1001122
  405. * Tue Jul 30 2013 Karsten Hopp <karsten@redhat.com> 2.1.0-2
  406. - Build without webp support on ppc* archs (#988767)
  407. * Wed Jul 03 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-1
  408. - Update to 2.1.0
  409. - Run tests in builddir, not installroot
  410. - Build python3-pillow docs with python3
  411. - python-pillow_endian.patch upstreamed
  412. * Mon May 13 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-10
  413. - Build without webp support on s390* archs
  414. Resolves: rhbz#962059
  415. * Sat May 11 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-9.gitd1c6db8
  416. - Conditionaly disable build of python3 parts on RHEL system
  417. * Wed May 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-8.gitd1c6db8
  418. - Add patch to fix test failure on big-endian
  419. * Thu Apr 25 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 2.0.0-7.gitd1c6db8
  420. - Remove Obsoletes in the python-pillow-qt subpackage. Obsoletes isn't
  421. appropriate since qt support didn't exist in the previous python-pillow
  422. package so there's no reason to drag in python-pillow-qt when updating
  423. python-pillow.
  424. * Fri Apr 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-6.gitd1c6db8
  425. - Update to latest git
  426. - python-pillow_quantization.patch now upstream
  427. - python-pillow_endianness.patch now upstream
  428. - Add subpackage for ImageQt module, with correct dependencies
  429. - Add PyQt4 and numpy BR (for generating docs / running tests)
  430. * Mon Apr 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-5.git93a488e
  431. - Reenable tests on bigendian, add patches for #928927
  432. * Sun Apr 07 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-4.git93a488e
  433. - Update to latest git
  434. - disable tests on bigendian (PPC*, S390*) until rhbz#928927 is fixed
  435. * Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-3.gitde210a2
  436. - python-pillow_tempfile.patch now upstream
  437. - Add python3-imaging provides (bug #924867)
  438. * Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-2.git2e88848
  439. - Update to latest git
  440. - Remove python-pillow-disable-test.patch, gcc is now fixed
  441. - Add python-pillow_tempfile.patch to prevent a temporary file from getting packaged
  442. * Tue Mar 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-1.git2f4207c
  443. - Update to 2.0.0 git snapshot
  444. - Enable python3 packages
  445. - Add libwebp-devel BR for Pillow 2.0.0
  446. * Wed Mar 13 2013 Peter Robinson <pbrobinson@fedoraproject.org> 1.7.8-6.20130305git
  447. - Add ARM support
  448. * Tue Mar 12 2013 Karsten Hopp <karsten@redhat.com> 1.7.8-5.20130305git
  449. - add s390* and ppc* to arch detection
  450. * Tue Mar 05 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-4.20130305git7866759
  451. - Update to latest git snapshot
  452. - 0001-Cast-hash-table-values-to-unsigned-long.patch now upstream
  453. - Pillow-1.7.8-selftest.patch now upstream
  454. * Mon Feb 25 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-3.20130210gite09ff61
  455. - Really remove -fno-strict-aliasing
  456. - Place comment on how to retreive source just above the Source0 line
  457. * Mon Feb 18 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-2.20130210gite09ff61
  458. - Rebuild without -fno-strict-aliasing
  459. - Add patch for upstream issue #52
  460. * Sun Feb 10 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-1.20130210gite09ff61
  461. - Initial RPM package