clutter-vl.spec 8.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283
  1. %define clutter_version 1.4.2
  2. %define clutter_release 1%{?_dist_release}
  3. Name: clutter
  4. Version: %{clutter_version}
  5. Release: %{clutter_release}
  6. Summary: Open Source software library for creating rich graphical user interfaces
  7. Summary(ja): リッチなGUIを作成するためのオープンソースライブラリ
  8. Group: System Environment/Libraries
  9. License: LGPLv2+
  10. URL: http://www.clutter-project.org/
  11. Source0: http://www.clutter-project.org/sources/%{name}/1.4/%{name}-%{version}.tar.bz2
  12. # http://bugzilla.openedhand.com/show_bug.cgi?id=2100
  13. Patch0: Use-a-native-format-for-atlas-textures.patch
  14. # http://bugzilla.clutter-project.org/show_bug.cgi?id=2324
  15. Patch1: cogl-x11-Trap-glXDestroyPixmap.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. Requires: gobject-introspection
  18. # FIXME to remove when all the bits have been merged into their
  19. # libraries
  20. BuildRequires: glib2-devel
  21. BuildRequires: mesa-libGL-devel
  22. BuildRequires: gtk2-devel
  23. BuildRequires: pkgconfig
  24. BuildRequires: pango-devel
  25. BuildRequires: libXdamage-devel
  26. BuildRequires: gettext
  27. BuildRequires: gtk-doc
  28. BuildRequires: gobject-introspection-devel >= 0.9.5
  29. BuildRequires: json-glib-devel
  30. %description
  31. Clutter is an open source software library for creating fast,
  32. visually rich graphical user interfaces. The most obvious example
  33. of potential usage is in media center type applications.
  34. We hope however it can be used for a lot more.
  35. %description -l ja
  36. Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
  37. 最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
  38. しかしながら、我々はいろいろな分野で使用されることを願っています。
  39. %package devel
  40. Summary: Clutter development environment
  41. Summary(ja): Clutterの開発環境
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}-%{release}
  44. Requires: pkgconfig glib2-devel pango-devel fontconfig-devel gtk2-devel
  45. Requires: mesa-libGL-devel
  46. Requires: gobject-introspection-devel
  47. Requires: json-glib-devel
  48. %description devel
  49. Header files and libraries for building a extension library for the
  50. clutter
  51. %package doc
  52. Summary: Documentation for %{name}
  53. Summary(ja): %{name}用のドキュメント
  54. Group: Documentation
  55. Requires: %{name} = %{version}-%{release}
  56. %description doc
  57. Clutter is an open source software library for creating fast,
  58. visually rich graphical user interfaces. The most obvious example
  59. of potential usage is in media center type applications.
  60. We hope however it can be used for a lot more.
  61. This package contains documentation for clutter.
  62. %prep
  63. %setup -q
  64. %patch0 -p0 -b .atlas-textures
  65. #%patch1 -p1 -b .glXDestroyPixmap
  66. %build
  67. #%configure --enable-gtk-doc \
  68. # --enable-introspection=yes \
  69. # --disable-silent-rules \
  70. # --enable-xinput \
  71. # --disable-static
  72. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
  73. %configure $CONFIGFLAGS \
  74. --enable-introspection=yes \
  75. --disable-silent-rules \
  76. --enable-xinput \
  77. --disable-static
  78. # clutter git ships with some magic to put the git log in shipped tarballs
  79. # which gets listed in files; don't blow up if it's missing
  80. if ! test -f ChangeLog; then
  81. echo "Created from snapshot" > ChangeLog
  82. fi
  83. )
  84. make V=0
  85. %install
  86. rm -rf $RPM_BUILD_ROOT
  87. #make DESTDIR=$RPM_BUILD_ROOT install
  88. make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
  89. %clean
  90. rm -rf $RPM_BUILD_ROOT
  91. %post -p /sbin/ldconfig
  92. %postun -p /sbin/ldconfig
  93. %files
  94. %defattr(-,root,root,-)
  95. %doc AUTHORS COPYING NEWS README
  96. %exclude %{_libdir}/*.la
  97. %{_libdir}/*.so.0
  98. %{_libdir}/*.so.0.*
  99. %{_libdir}/girepository-1.0/*.typelib
  100. %{_datadir}/locale/*/LC_MESSAGES/*
  101. %files devel
  102. %defattr(-, root, root)
  103. %doc ChangeLog
  104. %{_includedir}/*
  105. %{_libdir}/*.so
  106. %{_libdir}/pkgconfig/*.pc
  107. %{_datadir}/gir-1.0/*.gir
  108. %files doc
  109. %defattr(-, root, root)
  110. %{_datadir}/gtk-doc/html/clutter
  111. %{_datadir}/gtk-doc/html/cogl
  112. %{_datadir}/gtk-doc/html/cally
  113. %changelog
  114. * Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  115. - new upstream release
  116. - drop Patch1
  117. * Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  118. - new upstream release
  119. - add BuildRequires: json-glib-devel
  120. - delete Requires: gir-repository
  121. - delete BuildRequires: gir-repository-devel
  122. - add Requires: json-glib-devel (devel package)
  123. - add Patch0, Patch1
  124. - fix %build
  125. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
  126. - rebuild with rpm-4.8.1 for pkg-config file
  127. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
  128. - new upstream release
  129. * Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
  130. - new upstream release
  131. * Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
  132. - new upstream release
  133. - add configure option (--enable-xinput)
  134. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
  135. - new upstream release
  136. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
  137. - new upstream release
  138. * Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  139. - new upstream release
  140. * Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
  141. - new upstream release
  142. * Tue Dec 1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
  143. - new upstream release
  144. - build for Vine Linux
  145. - add Summary(ja)
  146. - fix BuildRoot
  147. - remove Obsolete and Provides
  148. * Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
  149. - Update to 1.0.6
  150. * Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
  151. - Update to 1.0.4, update gobject-introspection requirement
  152. * Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
  153. - Update to 1.0.2
  154. * Sun Aug 1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
  155. - Move ChangeLog to -devel to save some space
  156. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
  157. - Drop the gir-repository-devel dep, which pulls a bunch of -devel
  158. onto the live cd
  159. * Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
  160. - Update to 1.0.0
  161. * Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
  162. - fix bz #507389
  163. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
  164. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  165. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
  166. - Update to 0.9.8
  167. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
  168. - Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
  169. introspection support to clutter (#512260)
  170. * Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
  171. - Update to 0.9.6
  172. * Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
  173. - Update to 0.9.4
  174. * Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
  175. - Update to 0.9.2
  176. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
  177. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  178. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
  179. - Remove noarch from doc subpackage
  180. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
  181. - Added gtk-doc for cogl
  182. - Created doc subpackage
  183. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
  184. - Update to 0.8.6
  185. * Mon Oct 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
  186. - Update to 0.8.2
  187. - Removed clutter-0.8.0-clutter-fixed.patch
  188. * Sat Sep 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
  189. - Update to 0.8.0
  190. - Added clutter-0.8.0-clutter-fixed.patch
  191. * Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
  192. - Update to 0.6.4
  193. * Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
  194. - Update to 0.6.2
  195. * Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
  196. - Update to 0.6.0
  197. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
  198. - Autorebuild for GCC 4.3
  199. * Wed Oct 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
  200. - Update to 0.4.2
  201. * Mon Sep 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
  202. - Update to 0.4.1
  203. * Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
  204. - Update to 0.3.1
  205. * Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
  206. - Update to 0.2.3
  207. * Sun Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
  208. - Changed buildrequires and requires
  209. * Sun Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
  210. - Fix .spec
  211. * Sun Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
  212. - Fix .spec
  213. * Sun Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
  214. - Initial RPM release