123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299 |
- Name: augeas
- Version: 1.13.0
- Release: 1%{?_dist_release}
- Summary: A library for changing configuration files
- Group: system
- Vendor: Project Vine
- Distribution: Vine Linux
- License: LGPLv2+
- URL: http://augeas.net/
- # mkdir augeas-x.xx.x
- # pushd augeas-x.xx.x/
- # git clone --recursive https://github.com/hercules-team/augeas.git .
- # ./autogen.sh
- # make distclean
- # popd
- # tar --exclude=".*" -cvf - augeas-x.xx.x | gzip -9 > augeas-x.xx.x.tar.gz
- Source0: https://github.com/hercules-team/augeas/archive/refs/tags/release-%{version}.tar.gz#/augeas-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
- BuildRequires: bison flex readline-devel libxml2-devel
- Requires: %{name}-libs = %{version}-%{release}
- %description
- A library for programmatically editing configuration files. Augeas parses
- configuration files into a tree structure, which it exposes through its
- public API. Changes made through the API are written back to the initially
- read files.
- The transformation works very hard to preserve comments and formatting
- details. It is controlled by ``lens'' definitions that describe the file
- format and the transformation into a tree.
- %package devel
- Summary: Development files for %{name}
- Group: programming
- Requires: %{name}-libs = %{version}-%{release}
- Requires: pkgconfig
- %description devel
- The %{name}-devel package contains libraries and header files for
- developing applications that use %{name}.
- %package libs
- Summary: Libraries for %{name}
- Group: system
- %description libs
- The libraries for %{name}.
- Augeas is a library for programmatically editing configuration files. It parses
- configuration files into a tree structure, which it exposes through its
- public API. Changes made through the API are written back to the initially
- read files.
- %package vim
- Summary: The macro an syntax files of Augeas for vim.
- Group: programming
- Requires: %{name} = %{version}-%{release}
- Requires: vim-common
- %description vim
- This package contains macro an syntax files of Augeas for vim.
- %debug_package
- %prep
- %setup -q
- sed -i -e '/is_selinux_enabled/a typedef char *security_context_t;' \
- gnulib/lib/se-selinux.in.h
- %build
- %configure --disable-static --without-selinux
- make %{?_smp_mflags}
- %check
- # Disable test-preserve.sh SELinux testing. This fails when run under mock due
- # to differing SELinux labelling.
- export SKIP_TEST_PRESERVE_SELINUX=1
- make %{?_smp_mflags} check || {
- echo '===== tests/test-suite.log ====='
- cat tests/test-suite.log
- exit 1
- }
- %install
- rm -rf $RPM_BUILD_ROOT
- make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p"
- find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
- # The tests/ subdirectory contains lenses used only for testing, and
- # so it shouldn't be packaged.
- rm -r $RPM_BUILD_ROOT%{_datadir}/augeas/lenses/dist/tests
- %clean
- rm -rf $RPM_BUILD_ROOT
- %files
- %defattr(-,root,root,-)
- %{_bindir}/augmatch
- %{_bindir}/augtool
- %{_bindir}/augparse
- %{_bindir}/fadot
- %doc %{_mandir}/man1/*
- %files libs
- %defattr(-,root,root,-)
- # %{_datadir}/augeas and %{_datadir}/augeas/lenses are owned
- # by filesystem.
- %{_datadir}/augeas/lenses/dist
- %{_libdir}/*.so.*
- %doc AUTHORS HACKING* INSTALL NEWS README*
- %license COPYING
- %files devel
- %defattr(-,root,root,-)
- %{_includedir}/*
- %{_libdir}/*.so
- %{_libdir}/pkgconfig/augeas.pc
- %files vim
- %defattr(-,root,root,-)
- %{_datadir}/vim/vimfiles/syntax/augeas.vim
- %{_datadir}/vim/vimfiles/ftdetect/augeas.vim
- %changelog
- * Mon Oct 25 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.13.0-1
- - new upstream release.
- * Thu Sep 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.12.0-4
- - rebuilt with current environment.
- - dropped ldconfig scriptlets.
- * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.12.0-3
- - rebuilt with current environment.
- * Wed Mar 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.12.0-2
- - rebuilt with current environment.
- * Tue Sep 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.12.0-1
- - new upstream release.
- * Mon Nov 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.11.0-1
- - new upstream release.
- * Wed Jan 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.9.0-1
- - new upstream release.
- * Sun Jul 17 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.5.0-1
- - new upstream release.
- * Thu Nov 5 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.4.0-3
- - initial build for Vine Linux.
- * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
- * Tue Jun 02 2015 Dominic Cleal <dcleal@redhat.com> - 1.4.0-1
- - Update to 1.4.0
- * Sat Nov 08 2014 Dominic Cleal <dcleal@redhat.com> - 1.3.0-1
- - Update to 1.3.0; remove all patches
- * Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
- * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
- * Mon Mar 31 2014 Dominic Cleal <dcleal@redhat.com> - 1.2.0-2
- - Add patch for Krb5, parse braces in values (RHBZ#1079444)
- * Wed Feb 12 2014 Dominic Cleal <dcleal@redhat.com> - 1.2.0-1
- - Update to 1.2.0, add check section
- - Update source URL to download.augeas.net (RHBZ#996032)
- * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
- * Wed Jun 19 2013 David Lutterkort <lutter@redhat.com> - 1.1.0-1
- - Update to 1.1.0; remove all patches
- * Tue Jun 18 2013 Richard W.M. Jones <rjones@redhat.com> - 1.0.0-4
- - Fix /etc/sysconfig/network (RHBZ#904222).
- * Wed Jun 5 2013 Richard W.M. Jones <rjones@redhat.com> - 1.0.0-3
- - Don't package lenses in tests/ subdirectory.
- * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
- * Fri Jan 4 2013 David Lutterkort <lutter@redhat.com> - 1.0.0-1
- - New version; remove all patches
- * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.0-4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
- * Tue Jan 10 2012 David Lutterkort <lutter@redhat.com> - 0.10.0-3
- - Add patches for bugs 247 and 248 (JSON lens)
- * Sat Dec 3 2011 Richard W.M. Jones <rjones@redhat.com> - 0.10.0-2
- - Add patch to resolve missing libxml2 requirement in augeas.pc.
- * Fri Dec 2 2011 David Lutterkort <lutter@redhat.com> - 0.10.0-1
- - New version
- * Mon Jul 25 2011 David Lutterkort <lutter@redhat.com> - 0.9.0-1
- - New version; removed patch pathx-whitespace-ea010d8
- * Tue May 3 2011 David Lutterkort <lutter@redhat.com> - 0.8.1-2
- - Add patch pathx-whitespace-ea010d8.patch to fix BZ 700608
- * Fri Apr 15 2011 David Lutterkort <lutter@redhat.com> - 0.8.1-1
- - New version
- * Wed Feb 23 2011 David Lutterkort <lutter@redhat.com> - 0.8.0-1
- - New version
- * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Mon Nov 22 2010 Matthew Booth <mbooth@redhat.com> - 0.7.4-1
- - Update to version 0.7.4
- * Thu Nov 18 2010 Richard W.M. Jones <rjones@redhat.com> - 0.7.3-2
- - Upstream patch proposed to fix GCC optimization bug (RHBZ#651992).
- * Fri Aug 6 2010 David Lutterkort <lutter@redhat.com> - 0.7.3-1
- - Remove upstream patches
- * Tue Jun 29 2010 David Lutterkort <lutter@redhat.com> - 0.7.2-2
- - Patches based on upstream fix for BZ 600141
- * Tue Jun 22 2010 David Lutterkort <lutter@redhat.com> - 0.7.2-1
- - Fix ownership of /usr/share/augeas. BZ 569393
- * Wed Apr 21 2010 David Lutterkort <lutter@redhat.com> - 0.7.1-1
- - New version
- * Thu Jan 14 2010 David Lutterkort <lutter@redhat.com> - 0.7.0-1
- - Remove patch vim-ftdetect-syntax.patch. It's upstream
- * Tue Dec 15 2009 David Lutterkort <lutter@redhat.com> - 0.6.0-2
- - Fix ftdetect file for vim
- * Mon Nov 30 2009 David Lutterkort <lutter@redhat.com> - 0.6.0-1
- - Install vim syntax files
- * Mon Sep 14 2009 David Lutterkort <lutter@redhat.com> - 0.5.3-1
- - Remove separate xorg.aug, included in upstream source
- * Tue Aug 25 2009 Matthew Booth <mbooth@redhat.com> - 0.5.2-3
- - Include new xorg lens from upstream
- * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.2-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Mon Jul 13 2009 David Lutterkort <lutter@redhat.com> - 0.5.2-1
- - New version
- * Fri Jun 5 2009 David Lutterkort <lutter@redhat.com> - 0.5.1-1
- - Install fadot
- * Fri Mar 27 2009 David Lutterkort <lutter@redhat.com> - 0.5.0-2
- - fadot isn't being installed just yet
- * Tue Mar 24 2009 David Lutterkort <lutter@redhat.com> - 0.5.0-1
- - New program /usr/bin/fadot
- * Mon Mar 9 2009 David Lutterkort <lutter@redhat.com> - 0.4.2-1
- - New version
- * Fri Feb 27 2009 David Lutterkort <lutter@redhat.com> - 0.4.1-1
- - New version
- * Fri Feb 6 2009 David Lutterkort <lutter@redhat.com> - 0.4.0-1
- - New version
- * Mon Jan 26 2009 David Lutterkort <lutter@redhat.com> - 0.3.6-1
- - New version
- * Tue Dec 23 2008 David Lutterkort <lutter@redhat.com> - 0.3.5-1
- - New version
- * Mon Feb 25 2008 David Lutterkort <dlutter@redhat.com> - 0.0.4-1
- - Initial specfile
|