gnome-shell-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331
  1. %define pkg_version 3.16.2
  2. %define pkg_release 2%{?_dist_release}
  3. Summary: Window management and application launching for GNOME
  4. Summary(ja): GNOME 上でウィンドウの管理及びアプリケーションの起動を行うインターフェース
  5. Name: gnome-shell
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.16/%{name}-%{version}.tar.xz
  9. # settings for Vine
  10. Patch101: gnome-shell-3.14.1-vine-settings.patch
  11. Patch102: gnome-shell-3.16.0-revert-loginManager.patch
  12. Patch103: gnome-shell-3.16.2-disable-packagekit.patch
  13. License: GPLv2+
  14. Group: User Interface/Desktops
  15. URL: http://live.gnome.org/GnomeShell
  16. Requires: mutter
  17. Requires: caribou
  18. Requires: ca-certificates
  19. Requires: at-spi2-atk
  20. Requires: telepathy-logger
  21. Requires: network-manager-applet
  22. Requires: gnome-tweak-tool
  23. BuildRequires: gnome-common
  24. BuildRequires: libtool
  25. BuildRequires: automake
  26. BuildRequires: autoconf
  27. BuildRequires: pkgconfig
  28. BuildRequires: gtk2-devel
  29. BuildRequires: clutter-devel
  30. BuildRequires: mutter-devel
  31. BuildRequires: gjs-devel
  32. BuildRequires: gnome-desktop3-devel
  33. BuildRequires: gnome-menus-devel
  34. BuildRequires: libSM-devel
  35. BuildRequires: libffi-devel
  36. BuildRequires: startup-notification-devel
  37. BuildRequires: gnome-doc-utils
  38. BuildRequires: desktop-file-utils
  39. BuildRequires: libcroco-devel
  40. BuildRequires: librsvg2-devel
  41. BuildRequires: gobject-introspection-devel
  42. BuildRequires: control-center-devel
  43. BuildRequires: gcr-devel
  44. BuildRequires: gstreamer-devel
  45. BuildRequires: dbus-glib-devel
  46. BuildRequires: telepathy-logger-devel
  47. BuildRequires: polkit-devel
  48. BuildRequires: pulseaudio-libs-devel
  49. BuildRequires: evolution-data-server-devel
  50. BuildRequires: folks-devel
  51. BuildRequires: NetworkManager-glib-devel
  52. BuildRequires: libnm-gtk-devel
  53. BuildRequires: libgudev1-devel
  54. BuildRequires: libcanberra-gtk3-devel
  55. BuildRequires: caribou-devel
  56. BuildRequires: ca-certificates
  57. BuildRequires: python3-devel
  58. BuildRequires: intltool
  59. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  60. Vendor: Project Vine
  61. Distribution: Vine Linux
  62. Packager: Takemikaduchi
  63. %description
  64. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  65. It provides core interface functions like switching to windows and launching
  66. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  67. hardware and introduces innovative user interface concepts to provide a delightful
  68. and easy to use experience.
  69. %package docs
  70. Summary: Documentation for %{name}
  71. Summary(ja): %{name} 用のドキュメント
  72. Group: Documentation
  73. Requires: %{name} = %{version}-%{release}
  74. BuildArch: noarch
  75. %description docs
  76. This package contains documentation for %{name}.
  77. %prep
  78. %setup -q
  79. %patch101 -p1 -b .vine
  80. %patch102 -p1 -b .vine
  81. %patch103 -p1 -b .vine
  82. %build
  83. %configure \
  84. --disable-static \
  85. --disable-systemd
  86. %{__make} %{?_smp_mflags} V=1
  87. %install
  88. %{__rm} -rf ${RPM_BUILD_ROOT}
  89. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  90. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  91. rm $RPM_BUILD_ROOT%{_datadir}/applications/gnome-shell-wayland.desktop
  92. %find_lang %{name}
  93. %clean
  94. %{__rm} -rf ${RPM_BUILD_ROOT}
  95. %post
  96. /sbin/ldconfig
  97. touch --no-create %{_datadir}/icons/hicolor
  98. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  99. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  100. fi
  101. %postun
  102. /sbin/ldconfig
  103. touch --no-create %{_datadir}/icons/hicolor
  104. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  105. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  106. fi
  107. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  108. %posttrans
  109. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  110. %files -f %{name}.lang
  111. %defattr(-,root,root,-)
  112. %doc COPYING NEWS README
  113. %{_bindir}/gnome-shell
  114. %{_bindir}/gnome-shell-extension-tool
  115. %{_bindir}/gnome-shell-extension-prefs
  116. %{_bindir}/gnome-shell-perf-tool
  117. %{_libdir}/%{name}/*
  118. %{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
  119. %{_libexecdir}/gnome-shell-calendar-server
  120. %{_libexecdir}/gnome-shell-hotplug-sniffer
  121. %{_libexecdir}/gnome-shell-perf-helper
  122. %{_libexecdir}/gnome-shell-portal-helper
  123. %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
  124. %{_datadir}/applications/gnome-shell.desktop
  125. %{_datadir}/applications/gnome-shell-extension-prefs.desktop
  126. %{_datadir}/applications/evolution-calendar.desktop
  127. %{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
  128. %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
  129. %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
  130. %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
  131. %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
  132. %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
  133. %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
  134. %{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
  135. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  136. %{_datadir}/%{name}/*
  137. %{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
  138. %{_mandir}/man1/%{name}.1.gz
  139. %files docs
  140. %defattr(-,root,root,-)
  141. %{_datadir}/gtk-doc/html/shell
  142. %{_datadir}/gtk-doc/html/st
  143. %changelog
  144. * Sun May 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
  145. - add Patch103 (gnome-shell-3.16.2-disable-packagekit.patch)
  146. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
  147. - new upstream release
  148. * Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
  149. - new upstream release
  150. * Thu Apr 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
  151. - new upstream release
  152. - add BuildRequires: python3-devel
  153. - update Patch102 (gnome-shell-3.16.0-revert-loginManager.patch)
  154. * Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.3-2
  155. - rebuilt with libical 1.0.1
  156. * Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
  157. - new upstream release
  158. * Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
  159. - new upstream release
  160. * Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
  161. - new upstream release
  162. - update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
  163. - add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
  164. * Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
  165. - new upstream release
  166. * Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  167. - new upstream release
  168. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  169. - new upstream release
  170. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
  171. - new upstream release
  172. * Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
  173. - new upstream release
  174. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  175. - new upstream release
  176. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
  177. - new upstream release
  178. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
  179. - new upstream release
  180. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  181. - new upstream release
  182. * Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  183. - new upstream release
  184. - update Patch101 (gnome-shell-vine-settings.patch)
  185. - add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
  186. - add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
  187. - create %%{name}-docs subpackage
  188. * Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
  189. - new upstream release
  190. - remove Source102 (gnome-shell.gnome-3-6.ja.po)
  191. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  192. - new upstream release
  193. - add Source102 (gnome-shell.gnome-3-6.ja.po)
  194. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  195. - new upstream release
  196. - remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
  197. * Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
  198. - rebuild with telepathy-logger-0.6.0
  199. - add Patch0 (gnome-shell-3.4.1-git20121031.patch)
  200. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  201. - new upstream release
  202. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  203. - new upstream release
  204. - add Patch0 (gnome-shell-3.5.92-git20120921.patch)
  205. - update Patch101 (gnome-shell-vine-settings.patch)
  206. - change BuildRequires: ca-certificates instead of openssl
  207. - add BuildRequires: libcanberra-gtl3-devel
  208. * Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  209. - new upstream release
  210. - remove Patch103 (gnome-shell-ja.po-date.patch)
  211. * Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  212. - new upstream release
  213. - update Patch101,103
  214. - remove Patch0,102
  215. - add BuildRequires: gcr-devel
  216. - remove BuildRequires: GConf2-devel
  217. - add Requires: at-spi2-atk
  218. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
  219. - new upstream release
  220. - remove Patch1
  221. * Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
  222. - add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
  223. - add Patch1 (gnome-shell-3.2.1-ja.po.patch)
  224. - rename Patch103 (gnome-shell-ja.po-date.patch)
  225. - drop Patch102
  226. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  227. - new upstream release
  228. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  229. - new upstream release
  230. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  231. - new upstream release
  232. - update Patch101
  233. - update Patch102
  234. - update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
  235. - add BuildRequires: libgudev1-devel, openssl
  236. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  237. - new upstream release
  238. - add BuildRequires: folks-devel, NetworkManager-glib-devel
  239. - add Requires: caribou
  240. - remove Patch0
  241. - update Patch101
  242. - update Patch102
  243. - update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
  244. * Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
  245. - rebuild with gnome-menus-3.1.5
  246. - add Patch0 (gnome-shell-git20110821.patch)
  247. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  248. - new upstream release
  249. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  250. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  251. - remove BuildRequires: xulrunner-devel
  252. - add Patch101 (gnome-shell-vine-settings.patch)
  253. - add Patch102 (gnome-shell-vine-customize.patch)
  254. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  255. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  256. - add Requires: mutter
  257. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  258. - new upstream release
  259. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  260. - initial build for Vine Linux