dbus-python3-vl.spec 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869
  1. %{!?python3_sitearch: %define python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
  2. %{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
  3. %define dbus_glib_version 0.70
  4. %define dbus_version 1.6
  5. %define pkg_release 2%{?_dist_release}
  6. Name: dbus-python3
  7. Summary: D-Bus Python3 Bindings
  8. Summary(ja): D-Bus Python3 バインディング
  9. Version: 1.2.0
  10. Release: %{pkg_release}
  11. Group: System Environment/Libraries
  12. License: MIT
  13. URL: http://www.freedesktop.org/software/dbus/
  14. Source0: http://dbus.freedesktop.org/releases/dbus-python/dbus-python-%{version}.tar.gz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: dbus-devel >= %{dbus_version}
  17. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  18. BuildRequires: python3-devel
  19. %description
  20. D-Bus python3 bindings for use with python programs.
  21. %description -l ja
  22. D-Bus を python3 プログラムから使う為のバインディングです。
  23. %prep
  24. %setup -q -n dbus-python-%{version}
  25. %build
  26. %configure PYTHON=/usr/bin/python3
  27. %{__make} %{?_smp_mflags}
  28. %install
  29. %{__rm} -rf ${RPM_BUILD_ROOT}
  30. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  31. # remove unnecessary *.la files
  32. find ${RPM_BUILD_ROOT} -name '*.la' -exec rm -f {} \;
  33. # remove conflict files with dbus-python
  34. rm -f ${RPM_BUILD_ROOT}%{_includedir}/dbus-1.0/dbus/dbus-python.h
  35. rm -f ${RPM_BUILD_ROOT}%{_libdir}/pkgconfig/dbus-python.pc
  36. rm -f ${RPM_BUILD_ROOT}%{_docdir}/dbus-python/*
  37. %clean
  38. rm -rf ${RPM_BUILD_ROOT}
  39. %files
  40. %defattr(-,root,root)
  41. %doc COPYING ChangeLog README NEWS
  42. %{python3_sitearch}/*.so
  43. %{python3_sitelib}/dbus/*.py*
  44. %{python3_sitelib}/dbus/mainloop/*.py*
  45. %changelog
  46. * Sun May 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-2
  47. - rebuild with python3-3.4.3
  48. * Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  49. - initial build