freetds-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313
  1. %define git_commit 0a42888
  2. %ifarch alpha ia64 x86_64 ppc64 ppc64le sparc64 s390x aarch64
  3. %define bits 64
  4. %else
  5. %define bits 32
  6. %endif
  7. Name: freetds
  8. Summary: Implementation of the TDS (Tabular DataStream) protocol
  9. Version: 0.91.103
  10. Release: 17%{?_dist_release}
  11. Group: System Environment/Libraries
  12. License: LGPLv2+ and GPLv2+
  13. URL: http://www.freetds.org/
  14. # download the latest git source for 0.91 branch from
  15. # http://gitorious.org/freetds/freetds/archive-tarball/Branch-0_91
  16. # then
  17. # mv freetds-freetds-Branch-0_91.tar.gz freetds-%{version}-%{git_commit}.tar.gz
  18. #Source0: freetds-%{version}-%{git_commit}.tar.gz
  19. Source0: ftp://ftp.freetds.org/pub/freetds/stable/freetds-%{version}.tar.gz
  20. Source1: freetds-tds_sysdep_public.h
  21. Patch1: freetds-0.91-printf.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. BuildRequires: unixODBC-devel, readline-devel, gnutls-devel, krb5-devel
  24. BuildRequires: libgcrypt-devel
  25. BuildRequires: libtool
  26. BuildRequires: doxygen, docbook-style-dsssl
  27. %description
  28. FreeTDS is a project to document and implement the TDS (Tabular
  29. DataStream) protocol. TDS is used by Sybase(TM) and Microsoft(TM) for
  30. client to database server communications. FreeTDS includes call
  31. level interfaces for DB-Lib, CT-Lib, and ODBC.
  32. %package devel
  33. Summary: Header files and development libraries for %{name}
  34. Summary(ja): %{name} のヘッダファイル及び開発用ライブラリ
  35. Group: Development/Libraries
  36. Requires: %{name} = %{version}-%{release}
  37. %description devel
  38. This package contains the header files and development libraries
  39. for %{name}. If you like to develop programs using %{name}, you will need
  40. to install %{name}-devel.
  41. %package doc
  42. Summary: Development documentation for %{name}
  43. Summary(ha): %{name} の開発用ドキュメント
  44. Group: Documentation
  45. BuildArch: noarch
  46. %description doc
  47. This package contains the development documentation for %{name}.
  48. If you like to develop programs using %{name}, you will need to install
  49. %{name}-doc.
  50. %prep
  51. %setup -q
  52. %patch1 -p1
  53. # correct perl path
  54. sed -i '1 s,#!.*/perl,#!%{__perl},' samples/*.pl
  55. chmod -x samples/*.sh samples/*.pl
  56. find . -name .cvsignore -print | xargs rm -f
  57. find . -name .gitignore -print | xargs rm -f
  58. %build
  59. export LIBS=-lgcrypt
  60. [ -f configure ] || NOCONFIGURE=yes ./autogen.sh
  61. %configure \
  62. --disable-dependency-tracking \
  63. --disable-rpath \
  64. %{!?_with_static: --disable-static} \
  65. --with-tdsver="4.2" \
  66. --with-unixodbc="%{_prefix}" \
  67. --enable-msdblib \
  68. --enable-sybase-compat \
  69. --with-gnutls \
  70. --enable-krb5
  71. make %{?_smp_mflags} DOCBOOK_DSL="`rpm -ql docbook-style-dsssl | fgrep html/docbook.dsl`"
  72. %install
  73. rm -rf $RPM_BUILD_ROOT
  74. make install DOCDIR=doc/%{name} DESTDIR=$RPM_BUILD_ROOT
  75. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  76. rm -rf $RPM_BUILD_ROOT%{_docdir}/freetds
  77. mv -f $RPM_BUILD_ROOT%{_includedir}/tds_sysdep_public.h \
  78. $RPM_BUILD_ROOT%{_includedir}/tds_sysdep_public_%{bits}.h
  79. install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/tds_sysdep_public.h
  80. rm -f samples/Makefile* samples/*.in samples/README
  81. rm -f doc/doc/freetds-%{version}/reference/installdox
  82. mv -f samples/unixodbc.freetds.driver.template \
  83. samples/unixodbc.freetds.driver.template-%{bits}
  84. %post -p /sbin/ldconfig
  85. %postun -p /sbin/ldconfig
  86. %clean
  87. rm -rf $RPM_BUILD_ROOT
  88. %files
  89. %defattr(-, root, root, -)
  90. %{_bindir}/*
  91. %{_libdir}/*.so.*
  92. %config(noreplace) %{_sysconfdir}/*.conf
  93. %doc AUTHORS BUGS COPYING* NEWS README TODO doc/*.html
  94. %doc doc/doc/freetds-%{version}/userguide doc/images
  95. %{_mandir}/*/*
  96. %files devel
  97. %defattr (-, root, root, -)
  98. %doc samples
  99. %{?_with_static: %{_libdir}/*.a}
  100. %{_libdir}/*.so
  101. %{_includedir}/*
  102. %files doc
  103. %defattr (-, root, root, -)
  104. %doc doc/doc/freetds-%{version}/reference
  105. %changelog
  106. * Sun Apr 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.91.103-17
  107. - rebuilt with readline 6.3
  108. * Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.91.103-16
  109. - Initial build for Vine Linux
  110. - source as 0.91.103
  111. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-15.git0a42888
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  113. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-14.git0a42888
  114. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  115. * Tue Apr 22 2014 Tomáš Mráz <tmraz@redhat.com> - 0.91-13.git0a42888
  116. - Rebuild for new libgcrypt
  117. * Fri Jan 10 2014 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-12.git0a42888
  118. - add ppc64le to the list of 64bit arches (#1051199)
  119. * Tue Dec 3 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-11.git0a42888
  120. - update to the latest git source for 0_91 branch
  121. - fix format-security issue (#1037071)
  122. * Thu Aug 22 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-10.git748aa26
  123. - update to the latest git source for 0_91 branch
  124. - fix #999696
  125. * Wed Aug 7 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-9.gitb760a89
  126. - update to the latest git source for 0_91 branch
  127. - fix #992295, #993762
  128. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-8.gitf3ae29d
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  130. * Thu Jun 13 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-7.gitf3ae29d
  131. - add aarch64 to the list of 64bit arches (#966129)
  132. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-6.gitf3ae29d
  133. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  134. * Wed Nov 7 2012 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-5.gitf3ae29d
  135. - update to the latest git source for 0_91 branch
  136. - fix #870483
  137. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-4
  138. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  139. * Mon Feb 27 2012 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-3
  140. - Enable Kerberos support (#797276)
  141. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-2
  142. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  143. * Wed Oct 26 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-1
  144. - Upgrade to 0.91
  145. - Drop shared-libtds support
  146. * Wed Mar 9 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82.1-0.3.20110306dev
  147. - update to the latest stable snapshot 0.82.1.dev.20110306
  148. - make build with shared-libtds conditional
  149. - disable shared-libtds patch by default (seems noone uses it for now)
  150. * Mon Feb 14 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82.1-0.2.20100810dev
  151. - fix again shared-libtds patch to provide increased library version
  152. * Thu Feb 10 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82.1-0.1.20100810dev
  153. - update to the latest stable snapshot 0.82.1.dev.20100810
  154. - fix shared-libtds patch to provide properly library names
  155. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.82-7
  156. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  157. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.82-6
  158. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  159. * Thu Mar 26 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-5
  160. - add upstream patch cspublic.BLK_VERSION_150.patch (#492393)
  161. * Tue Feb 24 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-4
  162. - fix autoconf data for libtool2 (patch by Tom Lane <tgl@redhat.com>)
  163. * Fri Jan 30 2009 Karsten Hopp <karsten@redhat.com> 0.82-3
  164. - add s390x to 64 bit archs
  165. * Sun Jan 11 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-3
  166. - Use gnutls for SSL (#479148)
  167. * Tue Jun 17 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-2
  168. - Continue to provide an internal libtds library as public
  169. (patch from Hans de Goede, #451021). This shared library is needed
  170. for some existing applications (libgda etc.), which still use it directly.
  171. * Mon Jun 9 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-1
  172. - Upgrade to 0.82
  173. * Tue Feb 26 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-11
  174. - fix "64 or 32 bit" test (#434975)
  175. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.64-10
  176. - Autorebuild for GCC 4.3
  177. * Mon Jan 28 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-9
  178. - drop "Obsoletes:" from -doc subpackage to avoid extra complexity.
  179. * Fri Jan 25 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-8
  180. - resolve multiarch conflicts (#341181):
  181. - split references to separate freetds-doc subpackage
  182. - add arch-specific suffixes for arch-specific filenames in -devel
  183. - add wrapper for tds_sysdep_public.h
  184. - add readline support (#430196)
  185. * Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.64-7
  186. - Rebuild for selinux ppc32 issue.
  187. * Thu Aug 16 2007 Dmitry Butskoy <Dmitry@Butskoy.name>
  188. - Change License tag to "LGPLv2+ and GPLv2+"
  189. * Fri Jun 15 2007 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-6
  190. - bump release to provide update path over Livna
  191. * Wed Jun 13 2007 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-5
  192. - spec file cleanups
  193. - allowed for Fedora (no patent issues exist), clarification by
  194. James K. Lowden <jklowden [AT] freetds.org>
  195. - approved for Fedora (review by Hans de Goede <j.w.r.degoede@hhs.nl>)
  196. * Wed Aug 2 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-4
  197. - approved for Livna (review by Hans de Goede <j.w.r.degoede@hhs.nl>)
  198. * Tue Aug 1 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-4
  199. - add patch to fix sed scripts in the doc/ Makefile
  200. - avoid using rpath in binaries
  201. - cleanup in samples/ dir
  202. * Thu Jul 27 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-3
  203. - rebuild userguide too.
  204. - move reference docs to -devel
  205. * Mon Jul 24 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-2
  206. - Properly clear extra executable bit in source
  207. - Regenerate docs using doxygen
  208. * Thu Jul 20 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-1
  209. - Upgrade to 0.64
  210. - Some spec file and distro cleanups
  211. * Tue Sep 20 2005 V.C.G.Yeah <VCGYeah@iname.com> - 0.63-1
  212. - Upgrade to 0.63
  213. - spec file cleanups
  214. - build static libs conditional
  215. * Thu Sep 2 2004 V.C.G.Yeah <VCGYeah@iname.com> - 0.62.4-1Y
  216. - Updated to release 0.62.4.
  217. - Leave includes in system default include dir (needed for php-mssql build)
  218. * Mon May 17 2004 Dag Wieers <dag@wieers.com> - 0.62.3-1
  219. - Updated to release 0.62.3.
  220. * Wed Feb 04 2004 Dag Wieers <dag@wieers.com> - 0.61.2-0
  221. - Added --enable-msdblib configure option. (Dean Mumby)
  222. - Updated to release 0.61.2.
  223. * Fri Jun 13 2003 Dag Wieers <dag@wieers.com> - 0.61-0
  224. - Initial package. (using DAR)