ModemManager-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342
  1. #%define git_snapshot .git20130607
  2. %define git_snapshot %{nil}
  3. #define ppp_version 2.4.7
  4. %define glib2_version 2.40
  5. Name: ModemManager
  6. Summary: Mobile broadband modem management service
  7. Summary(ja): Mobile broadband modem management service
  8. Version: 1.2.0
  9. Release: 2%{git_snapshot}%{?_dist_release}
  10. License: GPLv2+
  11. Group: System Environment/Base
  12. URL: http://www.gnome.org/projects/NetworkManager/
  13. #
  14. # Source from git://anongit.freedesktop.org/ModemManager/ModemManager
  15. # tarball built with:
  16. # ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
  17. # make distcheck
  18. #
  19. #Source: %{name}-%{version}%{git_snapshot}.tar.bz2
  20. Source: http://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
  21. Patch0: buildsys-hates-openpty.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. BuildRequires: glib2-devel >= %{glib2_version}
  24. BuildRequires: eudev-libgudev1-devel
  25. BuildRequires: automake autoconf intltool libtool
  26. BuildRequires: gtk-doc
  27. # for xsltproc
  28. BuildRequires: libxslt
  29. Requires: dbus-glib
  30. %description
  31. The ModemManager service manages WWAN modems and provides a consistent API for
  32. interacting with these devices to client applications.
  33. %package devel
  34. Summary: Development tools for %{name}
  35. Summary(ja): %{name} の開発環境
  36. Group: Development/Libraries
  37. Requires: %{name} = %{version}-%{release}
  38. Requires: pkgconfig
  39. %description devel
  40. Header files and libraries for building a extension library for the %{name}.
  41. %package glib
  42. Summary: Libraries for adding ModemManager support to applications that use glib.
  43. Summary(ja): Glib を使用するアプリケーションに ModemManager サポートを追加するためのライブラリ
  44. Group: System Environment/Libraries
  45. Requires: glib2 >= %{glib2_version}
  46. %description glib
  47. This package contains the libraries that make it easier to use some ModemManager
  48. functionality from applications that use glib.
  49. %package glib-devel
  50. Summary: Development tools for %{name}-glib
  51. Summary(ja): %{name}-glib の開発環境
  52. Group: Development/Libraries
  53. Requires: %{name}-glib = %{version}-%{release}
  54. Requires: %{name}-devel = %{version}-%{release}
  55. Requires: glib2-devel
  56. Requires: pkgconfig
  57. %description glib-devel
  58. Header files and libraries for building a extension library for the %{name}-glib.
  59. %prep
  60. %setup -q
  61. %patch0 -p1 -b .pty
  62. %build
  63. autoreconf -if
  64. intltoolize --force
  65. #pppddir=`ls -1d %{_libdir}/pppd/2*`
  66. %configure \
  67. --disable-static \
  68. --enable-gtk-doc=yes \
  69. --enable-introspection=no \
  70. --enable-vala=no \
  71. --enable-more-warnings=yes \
  72. --with-udev-base-dir=/lib/udev \
  73. --with-polkit=none \
  74. --without-mbim \
  75. --without-qmi \
  76. --with-dist-version=%{version}-%{release}
  77. make %{?_smp_mflags}
  78. %check
  79. make check
  80. %install
  81. make install DESTDIR=$RPM_BUILD_ROOT
  82. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  83. #rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
  84. %find_lang %{name}
  85. %post
  86. /sbin/ldconfig
  87. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  88. %postun
  89. /sbin/ldconfig
  90. if [ $1 -eq 0 ]; then
  91. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  92. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  93. fi
  94. %posttrans
  95. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  96. %post glib -p /sbin/ldconfig
  97. %postun glib -p /sbin/ldconfig
  98. %files -f %{name}.lang
  99. %defattr(0644, root, root, 0755)
  100. %doc COPYING README
  101. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
  102. %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
  103. %attr(0755,root,root) %{_sbindir}/ModemManager
  104. %attr(0755,root,root) %{_bindir}/mmcli
  105. %dir %{_libdir}/%{name}
  106. %attr(0755,root,root) %{_libdir}/%{name}/*.so*
  107. /lib/udev/rules.d/*
  108. %{_datadir}/dbus-1/interfaces/*.xml
  109. %{_datadir}/icons/hicolor/22x22/apps/*.png
  110. %{_mandir}/man8/*
  111. %files devel
  112. %defattr(0644, root, root, 0755)
  113. %{_includedir}/ModemManager/*.h
  114. %dir %{_datadir}/gtk-doc/html/%{name}
  115. %{_datadir}/gtk-doc/html/%{name}/*
  116. %{_libdir}/pkgconfig/%{name}.pc
  117. %files glib
  118. %defattr(0644, root, root, 0755)
  119. %{_libdir}/libmm-glib.so.*
  120. %files glib-devel
  121. %defattr(0644, root, root, 0755)
  122. %{_libdir}/libmm-glib.so
  123. %dir %{_includedir}/libmm-glib
  124. %{_includedir}/libmm-glib/*.h
  125. %{_libdir}/pkgconfig/mm-glib.pc
  126. %dir %{_datadir}/gtk-doc/html/libmm-glib
  127. %{_datadir}/gtk-doc/html/libmm-glib/*
  128. %changelog
  129. * Tue Oct 7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-2
  130. - moved ModemManager-glib to System Environment/Libraries Group
  131. - removed BR: ppp, ppp-devel and dbus-glib-devel
  132. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  133. - new upstream release
  134. - remove Patch1 (ModemManager-1.0.0-git20130911.patch)
  135. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
  136. - add Patch1 (ModemManager-1.0.0-git20130911.patch)
  137. * Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  138. - new upstream release
  139. - update Patch0
  140. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
  141. - update to 0.7.991 snapshot
  142. - fix spec file based on FC package
  143. * Fri Jun 7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
  144. - Update to 0.7.991 snapshot
  145. - Fix SMS validity parsing
  146. - Allow registration changes to 'searching' without disconnecting
  147. - Fix reading SMS messages from some QMI-based devices
  148. - Increase connection timeout for Novatel E362
  149. - Fix PIN retries checking when unlocking Ericsson devices
  150. - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
  151. - add configure option (--enable-gtk-doc=yes, --without-qmi)
  152. * Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
  153. - new upstream release
  154. * Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
  155. - new upstream release
  156. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
  157. - delete Patch20
  158. * Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
  159. - update Patch20 (ModemManager-0.4-git20110428.patch)
  160. - delete Patch21,22
  161. * Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
  162. - update to 0.4
  163. - add Patch20 (ModemManager-0.4-git20100720.patch)
  164. - add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
  165. - add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
  166. * Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
  167. - initial build for Vine Linux
  168. * Sun May 2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
  169. - core: ignore some failures on disconnect (rh #578280)
  170. - core: add support for platform serial devices
  171. - gsm: better Blackberry DUN support
  172. - gsm: periodically poll access technology
  173. - cdma: prevent crash on modem removal (rh #571921)
  174. - mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
  175. - novatel: better signal strength reporting on CDMA cards
  176. - novatel: add access technology and mode preference support on GSM cards
  177. - zte: fix mode preference retrieval
  178. - longcheer: add support for Zoom modems (4595, 4596, etc)
  179. - longcheer: add access technology and mode preference support
  180. * Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
  181. - Silence %%post
  182. - Update scripts
  183. * Fri Apr 9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
  184. - gsm: fix parsing Blackberry supported character sets response
  185. * Thu Apr 8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
  186. - mbm: fix retrieval of current allowed mode
  187. - gsm: fix initialization issues with some devices (like Blackberries)
  188. * Mon Apr 5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
  189. - core: fix detection of some generic devices (rh #579247)
  190. - core: fix detection regression of some Huawei devices in 0.3-5
  191. - cdma: periodically poll registration state and signal quality
  192. - cdma: really fix registration detection on various devices (rh #569067)
  193. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
  194. - core: fix PPC/SPARC/etc builds
  195. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
  196. - core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
  197. - cdma: handle signal quality requests while connected for more devices
  198. - cdma: handle serving system requests while connected for more devices
  199. - gsm: determine current access technology earlier
  200. - huawei: work around automatic registration issues on some devices
  201. * Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
  202. - core: ensure enabled modems are disabled when MM stops
  203. - core: better capability detection for Blackberry devices (rh #573510)
  204. - cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
  205. - gsm: don't block modem when it requires PIN2
  206. - option: fix access technology updates
  207. * Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
  208. - mbm: add device IDs for C3607w
  209. - mbm: fail earlier during connection failures
  210. - mbm: fix username/password authentication when checked by the network
  211. - hso: implement asynchronous signal quality updates
  212. - option: implement asynchronous signal quality updates
  213. - novatel: correctly handle CDMA signal quality
  214. - core: basic PolicyKit support
  215. - core: fix direct GSM registration information requests
  216. - core: general GSM PIN/PUK unlock fixes
  217. - core: poll GSM registration state internally for quicker status updates
  218. - core: implement GSM 2G/3G preference
  219. - core: implement GSM roaming allowed/disallowed preference
  220. - core: emit signals on access technology changes
  221. - core: better handling of disconnections
  222. - core: fix simple CDMA status requests
  223. * Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
  224. - core: startup speed improvements
  225. - core: GSM PIN checking improvements
  226. - huawei: fix EVDO-only connections on various devices (rh #553199)
  227. - longcheer: add support for more devices
  228. * Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
  229. - anydata: new plugin for AnyData CDMA modems (rh #547294)
  230. - core: fix crashes when devices are unplugged during operation (rh #553953)
  231. - cdma: prefer primary port for status/registration queries
  232. - core: fix probing/detection of some PIN-locked devices (rh #551376)
  233. - longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
  234. - gsm: fix Nokia N80 network scan parsing
  235. * Fri Jan 1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
  236. - core: fix apparent hangs by limiting retried serial writes
  237. - gsm: ensure modem state is reset when disabled
  238. * Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
  239. - sierra: fix CDMA registration detection in some cases (rh #547513)
  240. * Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
  241. - sierra: ensure CDMA device is powered up when trying to use it
  242. - cdma: better signal quality parsing (fixes ex Huawei EC168C)
  243. - zte: handle unsolicited messages better during probing
  244. * Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
  245. - cdma: fix signal strength reporting on some devices
  246. - cdma: better registration state detection when dialing (ex Sierra 5275)
  247. - option: always use the correct tty for dialing commands
  248. * Mon Dec 7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
  249. - core: fix reconnect after manual disconnect (rh #541314)
  250. - core: fix various segfaults during registration
  251. - core: fix probing of various modems on big-endian architectures (ie PPC)
  252. - core: implement modem states to avoid duplicate operations
  253. - hso: fix authentication for Icera-based devices like iCON 505
  254. - zte: use correct port for new devices
  255. - nozomi: fix detection
  256. * Thu Nov 5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
  257. - Update to latest git
  258. - core: fix pppd 2.4.5 errors about 'baudrate 0'
  259. - cdma: wait for network registration before trying to connect
  260. - gsm: add cell access technology reporting
  261. - gsm: allow longer-running network scans
  262. - mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
  263. - nokia: don't power down phones on disconnect
  264. - hso: fix disconnection/disable
  265. * Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
  266. - Fixes for Motorola and Ericsson devices
  267. - Fixes for CDMA "serving-system" command parsing
  268. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
  269. - Fix a typo in one of the udev rules files
  270. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
  271. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  272. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
  273. - Fix source repo location
  274. - Fix directory ownership
  275. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
  276. - Initial version