tcl-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278
  1. %define majorver 8.4
  2. %define minorver 19
  3. %define version %{majorver}.%{minorver}
  4. %define htmlver %{majorver}.18
  5. Summary: A Tcl/Tk development environment: tcl
  6. Summary(ja): Tcl/Tk 開発環境: tcl
  7. Name: tcl
  8. Version: %{version}
  9. Release: 1%{?_dist_release}
  10. Group: Development/Languages
  11. License: BSD
  12. URL: http://tcl.sourceforge.net/
  13. Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
  14. Source1: http://prdownloads.sourceforge.net/tcl/%{name}%{htmlver}-html.tar.gz
  15. Patch1: tcl-8.3.5-tclm4-soname.patch
  16. Patch2: tcl-8.4.5-lib-perm.patch
  17. #Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
  18. Patch3: tcl8.4.16-configure.patch
  19. Patch4: tcl-8.4.12-no_rpath.patch
  20. Patch10: tcl-8.4.15-init.lib64.patch
  21. Buildroot: %{_tmppath}/%{name}-%{version}-root
  22. BuildRequires: libtool, util-linux, perl, gdbm, autoconf
  23. %description
  24. Tcl is a simple scripting language designed to be embedded into
  25. other applications. Tcl is designed to be used with Tk, a widget
  26. set, which is provided in the tk package. This package also includes
  27. tclsh, a simple example of a Tcl application.
  28. %description -l ja
  29. Tcl は様々なアプリケーションの実行を行うための、簡単なスクリプ
  30. ト言語です。Tclはウィジッド・セットであるTkとともに用いるように
  31. デザインしています。このパッケージにはTclの簡単な例として、tclsh
  32. も含んでいます。
  33. %prep
  34. #%setup -n %{name}%{version} -q -b1
  35. %setup -n %{name}%{version} -q -a 1
  36. mv tcl%{htmlver}/html .
  37. # define DT SONAME in shared lib
  38. # %patch1 -p1 -b .soname
  39. %patch2 -p1 -b .ro-lib
  40. %patch3 -p1 -b .pkgpath
  41. %patch4 -p1 -b .no_rpath
  42. # patch1 touches tcl.m4, and patch3 touches configure.in
  43. %ifarch x86_64
  44. %patch10 -p1 -b .init.lib64
  45. %endif
  46. cd unix
  47. #autoconf-2.13
  48. autoconf
  49. %build
  50. cd unix
  51. %configure \
  52. --enable-shared --disable-threads --enable-langinfo --enable-64bit
  53. make %{?_smp_mflags} TCL_LIBRARY=%{_datadir}/tcl%{majorver}
  54. %install
  55. rm -rf $RPM_BUILD_ROOT
  56. make install -C unix INSTALL_ROOT=%{buildroot} TCL_LIBRARY=%{_datadir}/tcl%{majorver}
  57. ln -s tclsh%{majorver} %{buildroot}%{_bindir}/tclsh
  58. # for linking with -ltcl
  59. ln -s libtcl%{majorver}.so %{buildroot}%{_libdir}/libtcl.so
  60. mkdirhier %buildroot/%{_includedir}/tcl-private/{generic,unix}
  61. cp -p generic/tcl{Int,IntDecls,IntPlatDecls,Math,Port}.h %buildroot/%{_includedir}/tcl-private/generic
  62. cp -p unix/tclUnixPort.h %buildroot/%{_includedir}/tcl-private/unix
  63. # Fix up the include files.
  64. install -m 644 generic/tclRegexp.h $RPM_BUILD_ROOT%{_includedir}
  65. cp generic/*.h $RPM_BUILD_ROOT%{_includedir}/tcl-private/generic
  66. cp unix/*.h $RPM_BUILD_ROOT%{_includedir}/tcl-private/unix
  67. # remove buildroot traces
  68. perl -pi -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/tcl-private|" %buildroot/%{_libdir}/tclConfig.sh
  69. %clean
  70. rm -rf $RPM_BUILD_ROOT
  71. %post -p /sbin/ldconfig
  72. %postun -p /sbin/ldconfig
  73. %files
  74. %defattr(-,root,root,-)
  75. %doc html/*
  76. %{_bindir}/tclsh*
  77. %{_datadir}/tcl%{majorver}
  78. %{_libdir}/libtcl%{majorver}.so
  79. %{_libdir}/tclConfig.sh
  80. %{_mandir}/man1/*
  81. %{_includedir}/*
  82. %{_libdir}/libtclstub%{majorver}.a
  83. %{_libdir}/libtcl.so
  84. %{_mandir}/man3/*
  85. %{_mandir}/mann/*
  86. %changelog
  87. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
  88. - new upstream release
  89. * Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.4.18-2
  90. - spec in UTF-8
  91. - configure with disabled threads. See:
  92. https://bugzilla.redhat.com/show_bug.cgi?id=443246
  93. http://groups.google.com/group/comp.lang.tcl/msg/ce6a1324bada8db0
  94. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
  95. - rebuild with new environment
  96. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
  97. - updated tcl to 8.4.18
  98. - updated tcl-html to 8.4.18
  99. * Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
  100. - updated tcl to 8.4.16
  101. - updated tcl-html to 8.4.16
  102. - dropt Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
  103. - added Patch3: tcl8.4.16-configure.patch
  104. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
  105. - updated tcl to 8.4.15
  106. - updated tcl-html to 8.4.15
  107. - dropt Patch1: tcl-8.3.5-tclm4-soname.patch
  108. - added Patch10: tcl-8.4.15-init.lib64.patch
  109. - rebuilt with new toolchain
  110. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
  111. - updated tcl to 8.4.13
  112. - updated tcl-html to 8.4.13
  113. * Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
  114. - updated tcl to 8.4.12
  115. - updated patch4
  116. * Sat Aug 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.4.11-0vl1
  117. - updated tcl to 8.4.11
  118. - updated Patch4
  119. * Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
  120. - updated tcl to 8.4.6
  121. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
  122. - merged with fedora
  123. * Mon Dec 1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-3
  124. - removed rpath (patch 4)
  125. * Fri Nov 28 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-2
  126. - put private header files under generic and unix subdirs
  127. - include real generic/tclPort.h not just a symlink to tclUnixPort.h
  128. - add tclMath.h to %{_includedir}/tcl-private/generic for building tk
  129. * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
  130. - new package split out from tcltk
  131. - update to tcl 8.4.5 (#88429)
  132. - drop tcl-8.3.3-heiierarchy.patch, tcl-8.3.3-dlopen.patch
  133. and tcl8.3.5-koi8-u.enc-88806.patch
  134. - include private include headers under %{_includedir}/tcl-private
  135. - filtered changelog for tcl
  136. - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
  137. * Sat Mar 29 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
  138. - update based on BitWalk's tcltk-8.4.2-83bw
  139. * Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
  140. - split source package.
  141. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  142. - expand some macros.. (FIXME)
  143. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  144. - use %configure macros
  145. - add Patch 47,50
  146. * Thu May 31 2001 <sagami@vinelinux.org>
  147. - 8.0.5_jp-10
  148. - unexpand old %%{configure}, new one causes build failure
  149. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  150. - install manpages into %%{_mandir} and mode 644
  151. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  152. - 8.0.5_jp-9
  153. - modified %install section to handle compressed man pages
  154. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  155. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  156. - changed default fonts
  157. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  158. - added defattr
  159. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  160. - added some symlinks, such as libtcl8.0.so.
  161. - obsoletes version number using _jp, now 8.0.5-31vl1
  162. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  163. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  164. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  165. - fix tclX symlinks.
  166. - compile on systems where SIGPWR == SIGLOST.
  167. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  168. - update tcl/tk to 8.0.5.
  169. - avoid "containing" in Tix (#2332).
  170. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  171. - use /usr/bin/write in kibitz (#1320).
  172. - use cirrus.sprl.umich.edu in weather (#1926).
  173. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  174. - auto rebuild in the new build environment (release 28)
  175. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  176. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  177. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  178. - expect does unaligned access on alpha (#989)
  179. - upgrade tcl/tk/tclX to 8.0.4
  180. - upgrade expect to 5.28.
  181. - add itcl 3.0.1
  182. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  183. - call libtoolize to allow building on the arm
  184. - build for glibc 2.1
  185. - strip binaries
  186. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  187. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  188. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  189. - expect: mkpasswd needs delay before sending password (problem #576)
  190. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  191. - translations modified for de, fr, tr
  192. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  193. - fixed expect binaries exec permissions
  194. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  195. - updated to Tix 4.1.0.006
  196. - updated version numbers of tcl/tk to relflect includsion of p2
  197. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  198. - updated tcl/tk to patch level 2
  199. - updated tclX to 8.0.2
  200. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  201. - fixed filelist for tix... replacing path to the expect binary in scripts
  202. was leaving junk files around.
  203. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  204. - added patch to remove libieee test in configure.in for tcl and tk.
  205. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  206. solution for all systems
  207. - fixed src urls
  208. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  209. - removed version numbers from descriptions
  210. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  211. - updated to tcl/tk 8.0 and related versions of packages
  212. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  213. - built against glibc
  214. - fixed dangling tclx/tkx symlinks