qedje-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. Name: qedje
  4. Version: 0.4.0
  5. Release: 5%{?_dist_release}
  6. Summary: A library combining the benefits of Edje and Qt
  7. Group: System Environment/Libraries
  8. License: GPLv3+
  9. URL: http://code.openbossa.org/projects/%{name}
  10. Source0: http://code.openbossa.org/projects/%{name}/repos/mainline/archive/0206ec8f2a802bf51455179933d8b7ab3e41a38b.tar.gz
  11. Patch0: qedje-0.4.0-fix_python_install.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: qt4-devel
  14. BuildRequires: eet-devel
  15. BuildRequires: qzion-devel
  16. BuildRequires: qzion-python-devel
  17. BuildRequires: cmake
  18. BuildRequires: pkgconfig
  19. BuildRequires: python-devel
  20. BuildRequires: sip-devel
  21. BuildRequires: PyQt4-devel
  22. %description
  23. The main purpose of the QEdje project is to build a bridge among components
  24. that proved to have great value for open source developers: Edje and Qt. This
  25. will extend the Qt toolkit with the flexibility of a declarative language, such
  26. as Edje, and also enable Qt widgets to be embedded into Edje UI design.
  27. %package devel
  28. Summary: Development files for %{name}
  29. Group: Development/Libraries
  30. Requires: cmake
  31. Requires: pkgconfig
  32. Requires: %{name} = %{version}-%{release}
  33. Requires: qzion-devel
  34. Requires: eet-devel
  35. %description devel
  36. The %{name}-devel package contains libraries and header files for
  37. developing applications that use %{name}.
  38. %package python
  39. Summary: Python bindings for %{name}
  40. Group: Development/Libraries
  41. Requires: PyQt4
  42. Requires: qzion-python
  43. %description python
  44. The %{name}-python package contains python bindings for %{name}
  45. %package python-devel
  46. Summary: Python bindings for %{name}
  47. Group: Development/Libraries
  48. Requires: sip
  49. Requires: PyQt4-devel
  50. Requires: qzion-python-devel
  51. Requires: %{name}-python = %{version}-%{release}
  52. %description python-devel
  53. The %{name}-python-devel package contains the development files
  54. for the python bindings for %{name}
  55. %prep
  56. %setup -q -n %{name}-mainline
  57. %patch0 -p1
  58. %build
  59. mkdir -p %{_target_platform}
  60. pushd %{_target_platform}
  61. %cmake \
  62. -DPYTHON_SITE_PACKAGES_DIR=%{python_sitearch} \
  63. -DQZION_SIP_DIR=%{_datadir}/sip/qzion \
  64. ..
  65. popd
  66. make %{?_smp_mflags} -C %{_target_platform}
  67. %install
  68. rm -rf %{buildroot}
  69. make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
  70. %clean
  71. rm -rf %{buildroot}
  72. %post -p /sbin/ldconfig
  73. %postun -p /sbin/ldconfig
  74. %files
  75. %defattr(-,root,root,-)
  76. %doc README COPYING
  77. %{_bindir}/qedje_viewer
  78. %{_libdir}/*.so.*
  79. %files devel
  80. %defattr(-,root,root,-)
  81. %{_libdir}/*.so
  82. %{_includedir}/*
  83. %{_libdir}/pkgconfig/%{name}.pc
  84. %files python
  85. %defattr(-,root,root,-)
  86. %{python_sitearch}/%{name}
  87. %files python-devel
  88. %defattr(-,root,root,-)
  89. %{_datadir}/sip/%{name}
  90. %changelog
  91. * Mon Apr 19 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.0-5
  92. - rebuilt with python-2.6
  93. * Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> -0.4.0-3
  94. - use %%cmake macro
  95. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.4.0-3
  96. - Initial build for Vine Linux
  97. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-2
  98. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  99. * Fri Mar 06 2009 John5342 <john5342 at, fedoraproject.org> 0.4.0-1
  100. - Updated to new upstream release (0.4.0)
  101. * Fri Mar 06 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.3.0-5
  102. - revert (previous borkage probably due to qt-4.5-rc1)
  103. * Wed Mar 05 2009 Caolán McNamara <caolanm@redhat.com> - 0.3.0-4
  104. - BR: phonon-devel
  105. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-3
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  107. * Fri Dec 19 2008 John5342 <john5342 at, fedoraproject.org> 0.3.0-2
  108. - Fixed a license
  109. - BR: qzion-devel
  110. - devel R: qzion-devel, eet-devel
  111. * Fri Dec 19 2008 John5342 <john5342 at, fedoraproject.org> 0.3.0-1
  112. - Initial package