gd-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351
  1. %bcond_with libvpx
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. Summary: A graphics library for drawing .png files.
  4. Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
  5. Name: gd
  6. Version: 2.2.1
  7. Release: 1%{_dist_release}
  8. Source0: https://bitbucket.org/libgd/gd-libgd/downloads/libgd-%{version}.tar.xz
  9. Patch0: gd-2.1.0-multilib.patch
  10. License: BSD-style
  11. URL: http://www.libgd.org/
  12. Group: System Environment/Libraries
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: freetype2-devel
  15. BuildRequires: fontconfig-devel
  16. BuildRequires: gettext-devel
  17. BuildRequires: libjpeg-turbo-devel
  18. BuildRequires: libpng-devel
  19. BuildRequires: libtiff-devel
  20. %if %{with libvpx}
  21. BuildRequires: libvpx-devel
  22. %endif
  23. BuildRequires: libX11-devel
  24. BuildRequires: libXpm-devel
  25. BuildRequires: zlib-devel
  26. BuildRequires: pkgconfig
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. Packager: daisuke
  30. %description
  31. Gd is a graphics library for drawing .png files. Gd allows your code to
  32. quickly draw images (lines, arcs, text, multiple colors, cutting and
  33. pasting from other images, flood fills) and write out the result as a
  34. .png file. Gd is particularly useful in web applications, where .pngs
  35. are commonly used as inline images. Note, however, that gd is not a
  36. paint program.
  37. Install gd if you are developing applications which need to draw .png
  38. files. If you install gd, you'll also need to install the gd-devel
  39. package.
  40. %description -l ja
  41. GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
  42. 画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
  43. 簡単に描写して、PNGファイルへ結果を出力することができます。
  44. Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
  45. 便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
  46. ん。
  47. PNGファイルを描写する必要のあるアプリケーションを開発する場合、
  48. Gdをインストールしてください。gdをインストールした場合、gd-devel
  49. パッケージも必要になります。
  50. %package progs
  51. Summary: Utility programs that use libgd.
  52. Summary(ja): libgd を用いたユーティリティプログラム
  53. Group: Applications/Graphics
  54. Requires: gd = %{version}
  55. Requires: perl
  56. %description progs
  57. These are utility programs supplied with gd, the .png graphics library.
  58. If you install these, you must install gd.
  59. %description progs -l ja
  60. これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
  61. プログラムです。これをインストールするには, gdをインストールする必要
  62. があります。
  63. %package devel
  64. Summary: The development libraries and header files for gd.
  65. Summary(ja): Gd用の開発ライブラリとヘッダファイル
  66. Group: Development/Libraries
  67. Requires: gd = %{version}
  68. Requires: freetype2-devel
  69. Requires: fontconfig-devel
  70. Requires: libjpeg-turbo-devel
  71. Requires: libpng-devel
  72. Requires: libtiff-devel
  73. %if %{with libvpx}
  74. Requires: libvpx-devel
  75. %endif
  76. Requires: libX11-devel
  77. Requires: libXpm-devel
  78. Requires: zlib-devel
  79. %description devel
  80. These are the development libraries and header files for gd, the .png
  81. graphics library.
  82. If you're installing the gd graphics library, you must install gd-devel.
  83. %description devel -l ja
  84. これらは開発ライブラリです。
  85. PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
  86. です。
  87. gdをインストールした場合、gd-develパッケージも必要になります。
  88. ## to build compat32 for x86_64 architecture support
  89. %package -n compat32-%{name}
  90. Summary: A graphics library for drawing .png files.
  91. Group: System Environment/Libraries
  92. %description -n compat32-%{name}
  93. Gd is a graphics library for drawing .png files. Gd allows your code to
  94. quickly draw images (lines, arcs, text, multiple colors, cutting and
  95. pasting from other images, flood fills) and write out the result as a
  96. .png file. Gd is particularly useful in web applications, where .pngs
  97. are commonly used as inline images. Note, however, that gd is not a
  98. paint program.
  99. Install gd if you are developing applications which need to draw .png
  100. files. If you install gd, you'll also need to install the gd-devel
  101. package.
  102. %package -n compat32-%{name}-devel
  103. Summary: The development libraries and header files for gd.
  104. Group: Development/Libraries
  105. Requires: compat32-freetype2-devel
  106. Requires: compat32-fontconfig-devel
  107. Requires: compat32-libjpeg-turbo-devel
  108. Requires: compat32-libpng-devel
  109. Requires: compat32-libtiff-devel
  110. %if %{with libvpx}
  111. Requires: compat32-libvpx-devel
  112. %endif
  113. Requires: compat32-libX11-devel
  114. Requires: compat32-libXpm-devel
  115. Requires: compat32-zlib-devel
  116. %description -n compat32-%{name}-devel
  117. These are the development libraries and header files for gd, the .png
  118. graphics library.
  119. If you're installing the gd graphics library, you must install gd-devel.
  120. %prep
  121. %setup -q -n libgd-%{version}
  122. %patch0 -p1 -b .mlib
  123. : regenerate autotool stuff
  124. if [ -f configure ]; then
  125. libtoolize --copy --force
  126. autoreconf -vif
  127. else
  128. ./bootstrap.sh
  129. fi
  130. %build
  131. # Provide a correct default font search path
  132. CFLAGS="$RPM_OPT_FLAGS -DDEFAULT_FONTPATH='\"\
  133. /usr/share/fonts/alias/TrueType/:\
  134. /usr/share/fonts/TrueType-vlgothic/:\
  135. /usr/share/fonts/bitstream-vera/:\
  136. /usr/share/fonts/TrueType-dejavu/:\
  137. /usr/share/fonts/TrueType-ipafont/:\
  138. /usr/share/fonts/TrueType-ipaexfont/:\
  139. /usr/share/fonts/default/Type1/:\
  140. /usr/share/X11/fonts/Type1/:\
  141. /usr/share/fonts/TrueType-linux-liberation/\
  142. \"'"
  143. %configure CPPFLAGS="-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H" \
  144. --with-freetype \
  145. --with-tiff=%{_prefix} \
  146. %if %{with libvpx}
  147. --with-vpx=%{_prefix} \
  148. %endif
  149. --disable-rpath
  150. make %{?_smp_mflags}
  151. %install
  152. [ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
  153. make DESTDIR=$RPM_BUILD_ROOT install
  154. ## remove unuse files
  155. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
  156. %check
  157. make %{?_smp_mflags} check
  158. %clean
  159. [ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
  160. %post -p /sbin/ldconfig
  161. %postun -p /sbin/ldconfig
  162. %if %{build_compat32}
  163. %post -n compat32-%{name} -p /sbin/ldconfig
  164. %postun -n compat32-%{name} -p /sbin/ldconfig
  165. %endif
  166. %files
  167. %defattr(-,root,root)
  168. %doc ChangeLog COPYING NEWS docs/*
  169. %{_libdir}/*.so.*
  170. %files progs
  171. %defattr(-,root,root)
  172. %{_bindir}/*
  173. %exclude %{_bindir}/gdlib-config
  174. %files devel
  175. %defattr(-,root,root)
  176. %{_bindir}/gdlib-config
  177. %{_includedir}/*
  178. %{_libdir}/*.so
  179. %{_libdir}/pkgconfig/*.pc
  180. %if %{build_compat32}
  181. %files -n compat32-%{name}
  182. %defattr(-,root,root)
  183. %{_libdir}/*.so.*
  184. %files -n compat32-%{name}-devel
  185. %defattr(-,root,root)
  186. %{_libdir}/*.so
  187. %endif
  188. %changelog
  189. * Wed May 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.1-1
  190. - new upstream release.
  191. - removed Patch1000 (fixed in upstream).
  192. * Wed May 4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-2
  193. - added Patch1000 to fix CVE-2016-3074.
  194. * Wed Mar 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
  195. - new upstream release.
  196. * Wed Oct 29 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.1.0-3
  197. - BR: freetype2-devel instead of freetype-devel on devel package
  198. * Mon Jun 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-2
  199. - fixed version in gd.h.
  200. - added fontconfig and tiff support.
  201. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
  202. - new upstream release.
  203. - dropped unnecessary patches.
  204. * Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
  205. - import patches from fedora package
  206. - modified font path patch for Vine Linux
  207. - drop static library
  208. - remove "-DJISX0208"
  209. - add "-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H""
  210. * Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
  211. - move gdlib-config from gd-progs subpackage to gd-devel subpackage
  212. * Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
  213. - build on current VineSeed
  214. * Tue Nov 3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
  215. - fix build_compat32 if-endif sections
  216. * Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
  217. - add patch2 for fix CVE-2009-3546 (_gdGetColors())
  218. * Wed Apr 8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
  219. - updated URL
  220. - changed progs Group to Applications/Graphics
  221. - added %%postun section
  222. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
  223. - removed *.la
  224. - spec in utf-8
  225. * Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
  226. - add patch1 from centos5
  227. - new versioning policy
  228. * Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
  229. - new upstream release with security fix (CVE-2007-2756)
  230. * Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
  231. - new upstream release with security fix
  232. - change source tarball format gz -> bz2
  233. * Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
  234. - added compat32-* packages for x86_64 architecture support
  235. * Sat Nov 6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
  236. - source upgrade
  237. * Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
  238. - source update
  239. - added -DJISX0208 flag
  240. * Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
  241. - source upgrade
  242. - BuildPrereq: XOrg-devel instead of XFree86-devel
  243. * Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
  244. - source upgrade
  245. - remove patch0 (no need for freetype2-2.1.7)
  246. * Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
  247. - add patch0 to build against freetype2-2.1.7
  248. * Sat Jun 7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
  249. - source upgrade
  250. - add URL
  251. - remove all patches
  252. - use %%configure script
  253. - add BuildPrereq: freetype2-devel XFree86-devel
  254. - remove BuildPrereq: VFlib-devel
  255. - update %%files
  256. - update Requires:
  257. - use License tag instead of Copyright
  258. * Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
  259. - rebuild with libpng-devel-1.2.5-0vl1
  260. * Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
  261. - rebuild with new toolchain
  262. * Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  263. - 1.8.3-0vl2
  264. - symlink to libgd.so.1 (for backward compatibility)
  265. * Tue Jun 6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  266. - first gd 1.8.x release for Vine from rawhide.
  267. - enable freetype support and defined JISX208 macro.
  268. * Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
  269. - break out a -progs subpackage
  270. - disable freetype support
  271. * Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  272. - update to latest version (1.8.2)
  273. - disable xpm support
  274. * Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
  275. - auto rebuild in the new build environment (release 6)
  276. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  277. - auto rebuild in the new build environment (release 5)
  278. * Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
  279. - buiuld for glibc 2.1
  280. * Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
  281. - built for 5.2