123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164 |
- Summary: A barcode generator and library
- Summary(ja): Zintバーコード作成プログラム
- Name: zint
- Version: 2.4.2
- Release: 2%{?_dist_release}
- License: GPLv3+
- URL: http://www.zint.org.uk
- Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
- Patch0: zint-2.4.0-qr-kanji.patch
- Patch1: %{name}-rpath.patch
- Patch2: %{name}-2.4.2-libpng16.patch
- Group: Applications/Engineering
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildRequires: cmake
- BuildRequires: libpng-devel
- BuildRequires: zlib-devel
- BuildRequires: qt4-devel
- BuildRequires: desktop-file-utils
- Distribution: Vine Linux
- Vendor: Project Vine
- Packager: owa
- %description
- Zint is a C library for encoding data in several barcode variants. The
- bundled command-line utility provides a simple interface to the library.
- Features of the library:
- - Over 50 symbologies including all ISO/IEC standards, like QR codes.
- - Unicode translation for symbologies which support Latin-1 and
- Kanji character sets.
- - Full GS1 support including data verification and automated insertion of
- FNC1 characters.
- - Support for encoding binary data including NULL (ASCII 0) characters.
- - Health Industry Barcode (HIBC) encoding capabilities.
- - Output in PNG, EPS and SVG formats with user adjustable sizes and colors.
- - Verification stage for SBN, ISBN and ISBN-13 data.
- %package devel
- Summary: Library and header files for %{name}
- Summary(ja): Zintバーコードの開発用ライブラリとヘッダファイル
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- %description devel
- C library and header files needed to develop applications using %{name}.
- The API documentation can be found ont the project website:
- http://www.zint.org.uk/zintSite/Manual.aspx
- %package qt
- Summary: Zint Barcode Studio GUI and library
- Summary(ja): Zintバーコード作成GUI(QT)とライブラリ
- Group: Applications/Engineering
- Requires: %{name} = %{version}-%{release}
- BuildRequires: qt4-devel >= 4.4
- BuildRequires: desktop-file-utils
- %description qt
- Zint Barcode Studio is a Qt-based GUI which allows desktop users to generate
- barcodes which can then be embedded in documents or HTML pages, and a library
- which can be used to incorporate barcode generation functionality into other
- software.
- %package qt-devel
- Summary: Library and header files for %{name}-qt
- Summary(ja): ZintバーコードのGUI(QT)開発用ライブラリとヘッダファイル
- Group: Development/Libraries
- Requires: %{name}-devel = %{version}-%{release}
- Requires: %{name}-qt = %{version}-%{release}
- %description qt-devel
- C library and header files needed to develop applications using %{name}-qt.
- %prep
- %setup -q
- %patch0 -p 1 -b .qr-kanji
- %patch1 -p 1 -b .rpath
- %patch2 -p1 -b .libpng16
- # remove BSD-licensed file required for Windows only
- # (just to ensure that this package is plain GPLv3+)
- rm -f backend/ms_stdint.h
- # remove bundled getopt sources (we use the corresponding Fedora package instead)
- rm -f frontend/getopt*.*
- %build
- %cmake CMakeLists.txt
- make VERBOSE=1 %{?_smp_mflags}
- %install
- rm -rf $RPM_BUILD_ROOT
- make install DESTDIR=$RPM_BUILD_ROOT
- rm -rf $RPM_BUILD_ROOT/%{_datadir}/cmake
- cat <<EOF >%{name}-qt.desktop
- [Desktop Entry]
- Encoding=UTF-8
- Name=Zint Barcode Studio
- Name[ja]=Zintバーコードスタジオ
- Comment=Zint Barcode Studio
- Comment[ja]=バーコードを作成するツールです
- GenericName=Zint Barcode Studio
- Exec=zint-qt
- Icon=zint
- Terminal=false
- Type=Application
- Categories=Utility;
- EOF
- install -D -p -m 644 %{name}.png %{buildroot}/usr/share/pixmaps/%{name}.png
- install -D -p -m 644 %{name}-qt.desktop %{buildroot}%{_datadir}/applications/%{name}-qt.desktop
- desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}-qt.desktop
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %post qt -p /sbin/ldconfig
- %postun qt -p /sbin/ldconfig
- %files
- %defattr(-,root,root,-)
- %doc COPYING readme
- %{_bindir}/%{name}
- %{_libdir}/libzint.so.*
- %files devel
- %defattr(-,root,root,-)
- %{_includedir}/%{name}.h
- %{_libdir}/libzint.so
- %files qt
- %defattr(-,root,root,-)
- %{_bindir}/%{name}-qt
- %{_libdir}/libQZint.so.*
- %{_datadir}/applications/%{name}-qt.desktop
- %{_datadir}/pixmaps/%{name}.png
- %files qt-devel
- %defattr(-,root,root,-)
- %{_includedir}/qzint.h
- %{_libdir}/libQZint.so
- %changelog
- * Sun Jul 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.2-2
- - rebuilt with current environment.
- - added Patch2 for libpng16.
- * Sat May 07 2011 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
- - updated zint to 2.4.2
- - added %{name}-rpath.patch
- - added BR: qt4-devel, desktop-file-utils
- * Sat Nov 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.4.0-2
- - added zint-2.4.0-qr-kanji.patch (BTS:1062)
- - install %{name}.png
- * Thu Oct 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.4.0-1
- - initial build for Vine
|