libcap-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Library for getting and setting POSIX.1e capabilities
  3. Summary(ja): POSIX.1e ケーパビリティを取得・設定するためのライブラリ
  4. Name: libcap
  5. Version: 2.49
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2
  11. Source: https://mirrors.edge.kernel.org/pub/linux/libs/security/linux-privs/libcap2/%{name}-%{version}.tar.xz
  12. Source1: getpcaps.8
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: libattr-devel
  15. BuildRequires: pam-devel
  16. BuildRequires: glibc-static
  17. %description
  18. libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
  19. draft 15 capabilities.
  20. %package devel
  21. Summary: Development files for libcap
  22. Summary(ja): libcap の開発用ファイル
  23. Group: programming
  24. Requires: %{name} = %{version}-%{release}
  25. %description devel
  26. Development files (Headers, libraries for static linking, etc) for libcap.
  27. libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
  28. draft 15 capabilities.
  29. Install libcap-devel if you want to develop or compile applications using
  30. libcap.
  31. %package static
  32. Summary: static library of libcap
  33. Summary(ja): libcap のスタティックライブラリ
  34. Group: programming
  35. Requires: %{name}-devel = %{version}-%{release}
  36. %description static
  37. This package includes the static library of libpcap
  38. # compat32
  39. %package -n compat32-%{name}
  40. Summary: Library for getting and setting POSIX.1e capabilities
  41. Summary(ja): POSIX.1e ケーパビリティを取得・設定するためのライブラリ
  42. Group: system,legacy
  43. %description -n compat32-%{name}
  44. libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
  45. draft 15 capabilities.
  46. %package -n compat32-%{name}-devel
  47. Summary: Development files for libcap
  48. Summary(ja): libcap の開発用ファイル
  49. Group: programming,legacy
  50. Requires: compat32-%{name} = %{version}-%{release}
  51. Requires: %{name}-devel = %{version}-%{release}
  52. %description -n compat32-%{name}-devel
  53. Development files (Headers, libraries for static linking, etc) for libcap.
  54. libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
  55. draft 15 capabilities.
  56. Install libcap-devel if you want to develop or compile applications using
  57. libcap.
  58. %debug_package
  59. %prep
  60. %setup -q
  61. # %patch0 -p1
  62. sed -i \
  63. -e 's| -O2| $(RPM_OPT_FLAGS)|' \
  64. -e 's| #-g| $(RPM_LD_FLAGS) #-g|' \
  65. Make.Rules
  66. %build
  67. # libcap can not be build with _smp_mflags:
  68. make PREFIX=%{_prefix} lib=%{_lib} LIBDIR=/%{_lib} SBINDIR=%{_sbindir} \
  69. INCDIR=%{_includedir} MANDIR=%{_mandir} PKGCONFIGDIR=%{_libdir}/pkgconfig/
  70. %install
  71. make install RAISE_SETFCAP=no \
  72. DESTDIR=${RPM_BUILD_ROOT} \
  73. LIBDIR=/%{_lib} \
  74. SBINDIR=%{_sbindir} \
  75. INCDIR=%{_includedir} \
  76. MANDIR=%{_mandir} \
  77. PKGCONFIGDIR=%{_libdir}/pkgconfig/
  78. mkdir -p ${RPM_BUILD_ROOT}/%{_mandir}/man{2,3,8}
  79. mv -f doc/*.3 ${RPM_BUILD_ROOT}/%{_mandir}/man3/
  80. chmod +x $RPM_BUILD_ROOT/%{_lib}/*.so.*
  81. # need to build init.lxc.static
  82. mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}
  83. mv %{buildroot}/%{_lib}/libcap.a %{buildroot}/%{_libdir}/libcap.a
  84. mv %{buildroot}/%{_lib}/libpsx.a %{buildroot}/%{_libdir}/libpsx.a
  85. cp -f %{SOURCE1} %{buildroot}/%{_mandir}/man8/
  86. %clean
  87. rm -rf $RPM_BUILD_ROOT
  88. %files
  89. %defattr(-,root,root)
  90. %license License
  91. %doc doc/capability.notes
  92. /%{_lib}/*.so.*
  93. %{_sbindir}/*
  94. %{_mandir}/man1/*
  95. %{_mandir}/man8/*
  96. /%{_lib}/security/pam_cap.so
  97. %files devel
  98. %defattr(-,root,root)
  99. %{_includedir}/*
  100. /%{_lib}/*.so
  101. %{_libdir}/pkgconfig/*
  102. %{_mandir}/man3/*
  103. %files static
  104. %defattr(-,root,root)
  105. %{_libdir}/*.a
  106. # compat32
  107. %if %{build_compat32}
  108. %files -n compat32-%{name}
  109. %defattr(-,root,root)
  110. /%{_lib}/*.so.*
  111. %files -n compat32-%{name}-devel
  112. %defattr(-,root,root)
  113. /%{_lib}/*.so
  114. %endif
  115. %changelog
  116. * Wed Mar 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net>
  117. - new upstream release.
  118. - dropped scriptlets.
  119. * Fri Apr 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.33-1
  120. - new upstream release.
  121. - dropped Patch1: made to get same effect by another way.
  122. * Mon Sep 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.27-1
  123. - new upstream release.
  124. * Sun Jun 26 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.25-1
  125. - new upstream release.
  126. - added Source1.
  127. - added libcap-static.
  128. * Thu Jul 9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.24-1
  129. - new upstream release
  130. - change tarfile format
  131. - change flags in install section
  132. - add patch1, drop patch0 (patch1 from fedora)
  133. * Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16-4
  134. - rebuild with VineSeed environment
  135. * Tue Jun 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16-3
  136. - add BuildRequires: pam-devel
  137. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16-2
  138. - rebuilt with current VineSeed
  139. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16-1
  140. - new upstream release
  141. - remove compat library (libpcap-1.10)
  142. * Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.06-2
  143. - added compat32 package for x86_64 arch support
  144. * Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.06-1
  145. - source updated
  146. - built with libattr 2.4.41
  147. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl2
  148. - rebuilt
  149. * Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl1
  150. - initial build for Vine Linux based on FC package
  151. * Wed Mar 02 2005 Karsten Hopp <karsten@redhat.de> 1.10-22
  152. - build with gcc-4
  153. * Wed Feb 09 2005 Karsten Hopp <karsten@redhat.de> 1.10-21
  154. - rebuilt
  155. * Tue Aug 31 2004 Phil Knirsch <pknirsch@redhat.com> 1.10-20
  156. - Fix wrong typedef in userland patch (#98801)
  157. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  158. - rebuilt
  159. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  160. - rebuilt
  161. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  162. - rebuilt
  163. * Tue Jan 27 2004 Karsten Hopp <karsten@redhat.de> 1.10-17
  164. - use _manpath
  165. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  166. - rebuilt
  167. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  168. - rebuilt
  169. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 1.10-14
  170. - set execute bits on library so that requires are generated.
  171. * Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 1.10-13
  172. - Removed %%name macro sillyness from package Summary, description text, etc.
  173. - Removed archaic Prefix: tag
  174. - lib64 fixes everywhere to use _lib, _libdir, etc
  175. - Removed deletion of RPM_BUILD_DIR from %%clean section
  176. - Added -q flag to setup macro
  177. - Severely cleaned up spec file, and removed usage of perl
  178. * Fri Jul 19 2002 Jakub Jelinek <jakub@redhat.com> 1.10-12
  179. - CFLAGS was using COPTFLAG variable, not COPTFLAGS
  180. - build with -fpic
  181. - apply the IA-64 patch everywhere, use capget/capset from glibc,
  182. not directly as _syscall (as it is broken on IA-32 with -fpic)
  183. - reenable alpha
  184. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  185. - automated rebuild
  186. * Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-10
  187. - Exclude alpha for now, apparent gcc bug.
  188. * Fri Nov 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-6
  189. - Fix sys/capabilities.h header (#55727)
  190. - Move to /lib, some applications seem to be using this rather early
  191. (#55733)
  192. * Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  193. - Add post,postun scripts
  194. * Tue Jul 10 2001 Jakub Jelinek <jakub@redhat.com>
  195. - don't build libcap.so.1 with ld -shared, but gcc -shared
  196. * Wed Jun 20 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  197. - Rebuild - it was missing for alpha
  198. * Wed Jun 06 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  199. - add s390/s390x support
  200. * Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-1
  201. - initial RPM
  202. - fix build on ia64