elfutils-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719
  1. %define eu_version 0.135
  2. %define eu_release 2
  3. Summary: A collection of utilities and DSOs to handle compiled objects
  4. Name: elfutils
  5. Version: %{eu_version}
  6. Release: %{eu_release}%{?_dist_release}
  7. License: GPLv2 with exceptions
  8. Group: Development/Tools
  9. URL: https://fedorahosted.org/elfutils/
  10. Source: http://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.gz
  11. Patch1: elfutils-portability.patch
  12. Patch2: elfutils-robustify.patch
  13. ##VINE##
  14. Patch10: elfutils-0.131-readelf_c.patch
  15. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  16. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  18. BuildRequires: bison >= 1.875
  19. BuildRequires: flex >= 2.5.4a
  20. BuildRequires: bzip2
  21. BuildRequires: gcc >= 3.4
  22. # Need <byteswap.h> that gives unsigned bswap_16 etc.
  23. BuildRequires: glibc-headers >= 2.3.4-11
  24. %define _gnu %{nil}
  25. %define _program_prefix eu-
  26. %description
  27. Elfutils is a collection of utilities, including ld (a linker),
  28. nm (for listing symbols from object files), size (for listing the
  29. section sizes of an object or archive file), strip (for discarding
  30. symbols), readelf (to see the raw ELF file structures), and elflint
  31. (to check for well-formed ELF files).
  32. %package libs
  33. Summary: Libraries to handle compiled objects
  34. Group: System Environment/Libraries
  35. Provides: elfutils-libs-%{_arch} = %{version}-%{release}
  36. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  37. Conflicts: elfutils < %{version}-%{release}
  38. Conflicts: elfutils > %{version}-%{release}
  39. Conflicts: elfutils-devel < %{version}-%{release}
  40. Conflicts: elfutils-devel > %{version}-%{release}
  41. %description libs
  42. The elfutils-libs package contains libraries which implement DWARF, ELF,
  43. and machine-specific ELF handling. These libraries are used by the programs
  44. in the elfutils package. The elfutils-devel package enables building
  45. other programs using these libraries.
  46. %package devel
  47. Summary: Development libraries to handle compiled objects
  48. Group: Development/Libraries
  49. Provides: elfutils-devel-%{_arch} = %{version}-%{release}
  50. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  51. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  52. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  53. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  54. %description devel
  55. The elfutils-devel package contains the libraries to create
  56. applications for handling compiled objects. libebl provides some
  57. higher-level ELF access functionality. libdw provides access to
  58. the DWARF debugging information. libasm provides a programmable
  59. assembler interface.
  60. %package devel-static
  61. Summary: Static archives to handle compiled objects
  62. Group: Development/Libraries
  63. Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
  64. Requires: elfutils-devel-%{_arch} = %{version}-%{release}
  65. Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  66. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  67. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  68. %description devel-static
  69. The elfutils-devel-static package contains the static archives
  70. with the code to handle compiled objects.
  71. %package libelf
  72. Summary: Library to read and write ELF files
  73. Group: System Environment/Libraries
  74. Provides: libelf = %{version}-%{release}
  75. Obsoletes: libelf <= 0.8.2-2
  76. Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
  77. Conflicts: elfutils < %{version}-%{release}
  78. Conflicts: elfutils > %{version}-%{release}
  79. Conflicts: elfutils-libs < %{version}-%{release}
  80. Conflicts: elfutils-libs > %{version}-%{release}
  81. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  82. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  83. %description libelf
  84. The elfutils-libelf package provides a DSO which allows reading and
  85. writing ELF files on a high level. Third party programs depend on
  86. this package to read internals of ELF files. The programs of the
  87. elfutils package use it also to generate new ELF files.
  88. %package libelf-devel
  89. Summary: Development support for libelf
  90. Group: Development/Libraries
  91. Provides: libelf-devel = %{version}-%{release}
  92. Obsoletes: libelf-devel <= 0.8.2-2
  93. Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  94. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  95. Conflicts: libelf-devel < %{version}-%{release}
  96. %description libelf-devel
  97. The elfutils-libelf-devel package contains the libraries to create
  98. applications for handling compiled objects. libelf allows you to
  99. access the internals of the ELF object file format, so you can see the
  100. different sections of an ELF file.
  101. %package libelf-devel-static
  102. Summary: Static archive of libelf
  103. Group: Development/Libraries
  104. Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  105. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  106. %description libelf-devel-static
  107. The elfutils-libelf-static package contains the static archive
  108. for libelf.
  109. %prep
  110. %setup -q
  111. %patch2 -p1 -b .robustify
  112. %patch10 -p0 -b .readelf_c
  113. find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
  114. %build
  115. # Remove -Wall from default flags. The makefiles enable enough warnings
  116. # themselves, and they use -Werror. Appending -Wall defeats the cases where
  117. # the makefiles disable some specific warnings for specific code.
  118. RPM_OPT_FLAGS=${RPM_OPT_FLAGS/-Wall/}
  119. %configure CFLAGS="$RPM_OPT_FLAGS -fexceptions"
  120. make -s %{?_smp_mflags}
  121. %install
  122. rm -rf ${RPM_BUILD_ROOT}
  123. make -s install DESTDIR=${RPM_BUILD_ROOT}
  124. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
  125. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
  126. # XXX Nuke unpackaged files
  127. { cd ${RPM_BUILD_ROOT}
  128. rm -f .%{_bindir}/eu-ld
  129. }
  130. %check
  131. make -s check
  132. %clean
  133. rm -rf ${RPM_BUILD_ROOT}
  134. %post libs -p /sbin/ldconfig
  135. %postun libs -p /sbin/ldconfig
  136. %post libelf -p /sbin/ldconfig
  137. %postun libelf -p /sbin/ldconfig
  138. %files
  139. %defattr(-,root,root)
  140. %doc README TODO
  141. %{_bindir}/eu-addr2line
  142. %{_bindir}/eu-ar
  143. %{_bindir}/eu-elfcmp
  144. %{_bindir}/eu-elflint
  145. %{_bindir}/eu-findtextrel
  146. %{_bindir}/eu-nm
  147. %{_bindir}/eu-objdump
  148. %{_bindir}/eu-ranlib
  149. %{_bindir}/eu-readelf
  150. %{_bindir}/eu-size
  151. %{_bindir}/eu-strings
  152. %{_bindir}/eu-strip
  153. #%{_bindir}/eu-ld
  154. %{_bindir}/eu-unstrip
  155. %{_bindir}/eu-make-debug-archive
  156. %files libs
  157. %defattr(-,root,root)
  158. %{_libdir}/libasm-%{version}.so
  159. %{_libdir}/libasm.so.*
  160. %{_libdir}/libdw-%{version}.so
  161. %{_libdir}/libdw.so.*
  162. %dir %{_libdir}/elfutils
  163. %{_libdir}/elfutils/lib*.so
  164. %files devel
  165. %defattr(-,root,root)
  166. %{_includedir}/dwarf.h
  167. %dir %{_includedir}/elfutils
  168. %{_includedir}/elfutils/elf-knowledge.h
  169. %{_includedir}/elfutils/libasm.h
  170. %{_includedir}/elfutils/libebl.h
  171. %{_includedir}/elfutils/libdw.h
  172. %{_includedir}/elfutils/libdwfl.h
  173. %{_libdir}/libebl.a
  174. %{_libdir}/libasm.so
  175. %{_libdir}/libdw.so
  176. %files devel-static
  177. %defattr(-,root,root)
  178. %{_libdir}/libasm.a
  179. %{_libdir}/libdw.a
  180. %files libelf
  181. %defattr(-,root,root)
  182. %{_libdir}/libelf-%{version}.so
  183. %{_libdir}/libelf.so.*
  184. %files libelf-devel
  185. %defattr(-,root,root)
  186. %{_includedir}/libelf.h
  187. %{_includedir}/gelf.h
  188. %{_includedir}/nlist.h
  189. %{_libdir}/libelf.so
  190. %files libelf-devel-static
  191. %defattr(-,root,root)
  192. %{_libdir}/libelf.a
  193. %changelog
  194. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
  195. - elfutils-libs: changed Group to System Environment/Libraries
  196. - elfutils-libelf: changed Group to System Environment/Libraries
  197. - elfutils-devel: changed Group to Development/Libraries
  198. - elfutils-devel-static: changed Group to Development/Libraries
  199. - elfutils-libelf-devel: changed Group to Development/Libraries
  200. - elfutils-libelf-devel-static: changed Group to Development/Libraries
  201. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
  202. - merged with Fedora 9 0.135-1
  203. - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
  204. - applied new versioning policy
  205. - added elfutils-0.131-readelf_c.patch
  206. - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
  207. - new upstream release
  208. - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
  209. - remove Obsoletes: libelf, libelf-devel from elfutils
  210. - add Obsoletes: libelf to elfutils-libelf
  211. - add Obsoletes: libelf-devel to elfutils-libelf-devel
  212. * Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
  213. - Update to 0.135
  214. - libdwfl: bug fixes
  215. - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
  216. * Wed Apr 9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
  217. - Update to 0.134
  218. - elflint: backend improvements for sparc, alpha (#204170)
  219. - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
  220. - Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
  221. * Sun Mar 2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
  222. - Update to 0.133
  223. - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
  224. - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
  225. - libdwfl: bug fixes and optimization in relocation handling
  226. - elfcmp: bug fix for non-allocated section handling
  227. - ld: implement newer features of binutils linker.
  228. - Install eu-objdump and libasm, now has limited disassembler support.
  229. * Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
  230. - Update to 0.132
  231. - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
  232. - eu-readelf: Fix handling of ET_REL files in archives.
  233. - libcpu: Implement x86 and x86-64 disassembler.
  234. - libasm: Add interface for disassembler.
  235. - all programs: add debugging of branch prediction.
  236. - libelf: new function elf_scnshndx.
  237. * Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
  238. - Update to 0.131
  239. - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
  240. bug fixes for oddly-formatted DWARF
  241. - libdwfl: bug fixes in offline archive support, symbol table handling;
  242. apply partial relocations for dwfl_module_address_section on ET_REL
  243. - libebl: powerpc backend support for Altivec registers
  244. * Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
  245. - Fix ET_REL support.
  246. - Fix odd indentation in eu-readelf -x output.
  247. * Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
  248. - Update to 0.130
  249. - eu-readelf -p option can take an argument like -x for one section
  250. - eu-readelf --archive-index (or -c)
  251. - eu-readelf -n improved output for core dumps
  252. - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
  253. - eu-elflint: ditto
  254. - eu-elflint: stricter checks on debug sections
  255. - eu-unstrip: new options, --list (or -n), --relocate (or -R)
  256. - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
  257. new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
  258. - libebl: backend improvements (#324031)
  259. - libdwfl: build_id support, new functions for it
  260. - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
  261. - libdwfl offline archive support, new script eu-make-debug-archive
  262. * Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
  263. - Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
  264. * Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
  265. - Update to 0.129
  266. - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
  267. - addr2line: new option --symbols (or -S)
  268. - libdw: dwarf_getscopes fixes (#230235)
  269. - libdwfl: dwfl_module_addrsym fixes (#249490)
  270. * Fri Jun 8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
  271. - Update to 0.128
  272. - new program: unstrip
  273. - elfcmp: new option --hash-inexact
  274. - Replace Conflicts: with Provides/Requires using -arch
  275. * Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
  276. - Update to 0.127
  277. - libdw: new function dwarf_getsrcdirs
  278. - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
  279. dwfl_module_address_section
  280. * Mon Feb 5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
  281. - Update to 0.126
  282. - New program eu-ar.
  283. - libdw: fix missing dwarf_getelf (#227206)
  284. - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
  285. - Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
  286. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
  287. - Fix overeager warn_unused_result build failures.
  288. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
  289. - Update to 0.125
  290. - elflint: Compare DT_GNU_HASH tests.
  291. - move archives into -static RPMs
  292. - libelf, elflint: better support for core file handling
  293. - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
  294. - Resolves: RHBZ #220817, RHBZ #213792
  295. * Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
  296. - eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
  297. - Update to 0.124
  298. - libebl: fix ia64 reloc support (#206981)
  299. - libebl: sparc backend support for return value location
  300. - libebl, libdwfl: backend register name support extended with more info
  301. - libelf, libdw: bug fixes for unaligned accesses on machines that care
  302. - readelf, elflint: trivial bugs fixed
  303. * Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
  304. - Update to 0.123
  305. - libebl: Backend build fixes, thanks to Stepan Kasal.
  306. - libebl: ia64 backend support for register names, return value location
  307. - libdwfl: Handle truncated linux kernel module section names.
  308. - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
  309. - elflint: Fix checks to permit --hash-style=gnu format.
  310. * Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
  311. - Fix warnings in elflint compilation.
  312. * Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
  313. - Update to 0.122
  314. - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
  315. - libebl: add function to test for relative relocation
  316. - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
  317. - elflint, readelf: add support for DT_GNU_HASH
  318. - libelf: add elf_gnu_hash
  319. - elflint, readelf: add support for 64-bit SysV-style hash tables
  320. - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
  321. * Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
  322. - Update to 0.121
  323. - libelf: bug fixes for rewriting existing files when using mmap (#187618).
  324. - make all installed headers usable in C++ code (#193153).
  325. - eu-readelf: better output format.
  326. - eu-elflint: fix tests of dynamic section content.
  327. - libdw, libdwfl: handle files without aranges info.
  328. * Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
  329. - rebuild to pick up -devel deps
  330. * Tue Apr 4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
  331. - Update to 0.120
  332. - License changed to GPL, with some exceptions for using
  333. the libelf, libebl, libdw, and libdwfl library interfaces.
  334. Red Hat elfutils is an included package of the Open Invention Network.
  335. - dwarf.h updated for DWARF 3.0 final specification.
  336. - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
  337. - libdwfl: New function dwfl_version; fixes for offline.
  338. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
  339. - bump again for double-long bug on ppc(64)
  340. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
  341. - rebuilt for new gcc4.1 snapshot and glibc changes
  342. * Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
  343. - update to 0.119
  344. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  345. - rebuilt
  346. * Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
  347. - update to 0.118
  348. - elflint: more tests.
  349. - libdwfl: New function dwfl_module_register_names.
  350. - libebl: New backend hook for register names.
  351. - Make sure -fexceptions is always in CFLAGS.
  352. * Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
  353. - update to 0.117
  354. - libdwfl: New function dwfl_module_return_value_location (#166118)
  355. - libebl: Backend improvements for several CPUs
  356. * Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
  357. - update to 0.116
  358. - libdw fixes, API changes and additions
  359. - libdwfl fixes (#169672)
  360. - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
  361. * Fri Sep 9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
  362. - Update requires/conflicts for better biarch update behavior.
  363. * Mon Sep 5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
  364. - update to 0.115
  365. - New program eu-strings.
  366. - libdw: New function dwarf_getscopes_die.
  367. - libelf: speed-ups of non-mmap reading.
  368. - Implement --enable-gcov option for configure.
  369. * Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
  370. - update to 0.114
  371. - new program eu-ranlib
  372. - libdw: new calls for inlines
  373. - libdwfl: new calls for offline modules
  374. * Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
  375. - update to 0.113
  376. - elflint: relax a bit. Allow version definitions for defined symbols
  377. against DSO versions also for symbols in nobits sections.
  378. Allow .rodata section to have STRINGS and MERGE flag set.
  379. - strip: add some more compatibility with binutils.
  380. - libdwfl: bug fixes.
  381. - Separate libdw et al into elfutils-libs subpackage.
  382. * Sat Aug 6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
  383. - update to 0.112
  384. - elfcmp: some more relaxation.
  385. - elflint: many more tests, especially regarding to symbol versioning.
  386. - libelf: Add elfXX_offscn and gelf_offscn.
  387. - libasm: asm_begin interface changes.
  388. - libebl: Add three new interfaces to directly access machine, class,
  389. and data encoding information.
  390. * Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
  391. - update portability patch
  392. * Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
  393. - update to 0.111
  394. - libdwfl library now merged into libdw
  395. * Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
  396. - update to 0.110
  397. * Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
  398. - update to 0.109
  399. - verify that libebl modules are from the same build
  400. - new eu-elflint checks on copy relocations
  401. - new program eu-elfcmp
  402. - new experimental libdwfl library
  403. * Thu Jun 9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
  404. - robustification of eu-strip and eu-readelf
  405. * Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
  406. - more robustification
  407. * Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
  408. - robustification
  409. * Mon May 9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
  410. - update to 0.108
  411. - merge strip fixes
  412. - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
  413. - update elf.h from glibc
  414. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
  415. - fix strip -f byte-swapping bug
  416. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
  417. - update to 0.107
  418. - readelf: improve DWARF output format
  419. - elflint: -d option to support checking separate debuginfo files
  420. - strip: fix ET_REL debuginfo files (#156341)
  421. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
  422. - fix some bugs in new code, reenable make check
  423. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
  424. - disable make check for most arches, for now
  425. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
  426. - update to 0.106
  427. * Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
  428. - update to 0.104
  429. * Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
  430. - update to 0.103
  431. * Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
  432. - update to 0.101.
  433. - use %%configure macro to get CFLAGS etc. right
  434. * Sat Feb 5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
  435. - upgrade to 0.99.
  436. * Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
  437. - upgrade to 0.97.
  438. * Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
  439. - upgrade to 0.96.
  440. * Mon Jul 5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
  441. - rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
  442. warning
  443. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  444. - rebuilt
  445. * Fri Apr 2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
  446. - upgrade to 0.95.
  447. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  448. - rebuilt
  449. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  450. - rebuilt
  451. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
  452. - upgrade to 0.94
  453. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
  454. - upgrade to 0.93
  455. * Thu Jan 8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
  456. - full version
  457. - macroized spec file for GPL or OSL builds
  458. - include only libelf under GPL plus wrapper scripts
  459. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
  460. - macroized spec file for GPL or OSL builds
  461. * Wed Jan 7 2004 Ulrich Drepper <drepper@redhat.com>
  462. - split elfutils-devel into two packages.
  463. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
  464. - include only libelf under GPL plus wrapper scripts
  465. * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
  466. - readelf, not readline, in %%description (#111214).
  467. * Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
  468. - update to 0.89 (fix eu-strip)
  469. * Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
  470. - update to 0.86 (fix eu-strip on s390x/alpha)
  471. - libebl is an archive now; remove references to DSO
  472. * Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
  473. - upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
  474. * Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
  475. - upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
  476. * Wed Jul 9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
  477. - upgrade to 0.82 (strip tests fixed on big-endian).
  478. * Tue Jul 8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
  479. - upgrade to 0.81 (strip excludes unused symtable entries, test borked).
  480. * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
  481. - upgrade to 0.80 (debugedit changes for kernel in progress).
  482. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  483. - rebuilt
  484. * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
  485. - upgrade to 0.79 (correct formats for size_t, more of libdw "works").
  486. * Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
  487. - upgrade to 0.78 (libdwarf bugfix, libdw additions).
  488. * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
  489. - debuginfo rebuild
  490. * Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
  491. - use the correct way of identifying the section via the sh_info link.
  492. * Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
  493. - update to 0.75 (eu-strip -g fix)
  494. * Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
  495. - update to 0.74 (fix for writing with some non-dirty sections)
  496. * Thu Feb 6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
  497. - another -0.73 update (with sparc fixes).
  498. - do "make check" in %%check, not %%install, section.
  499. * Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
  500. - update to 0.73 (with s390 fixes).
  501. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  502. - rebuilt
  503. * Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
  504. - fix arguments to gelf_getsymshndx and elf_getshstrndx
  505. - fix other warnings
  506. - reenable checks on s390x
  507. * Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
  508. - temporarily disable checks on s390x, until someone has
  509. time to look at it
  510. * Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
  511. - update to 0.72
  512. * Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
  513. - update to 0.71
  514. * Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
  515. - update to 0.69.
  516. - add "make check" and segfault avoidance patch.
  517. - elfutils-libelf needs to run ldconfig.
  518. * Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
  519. - update to 0.68.
  520. * Fri Dec 6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
  521. - update to 0.67.
  522. * Tue Dec 3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
  523. - update to 0.65.
  524. * Mon Dec 2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
  525. - update to 0.64.
  526. * Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
  527. - split packages further into elfutils-libelf
  528. * Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
  529. - update to 0.63.
  530. * Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
  531. - Adjust for dropping libtool
  532. * Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
  533. - update to 0.59
  534. * Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
  535. - update to 0.56
  536. * Thu Nov 7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
  537. - update to 0.54
  538. * Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
  539. - update to 0.53
  540. - drop x86_64 hack, ICE fixed in gcc-3.2-11.
  541. * Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
  542. - get beehive to punch a rhpkg generated package.
  543. * Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
  544. - build in 8.0.1.
  545. - x86_64: avoid gcc-3.2 ICE on x86_64 for now.
  546. * Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
  547. - Add libelf-devel to conflicts for elfutils-devel
  548. * Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
  549. - Split into runtime and devel package
  550. * Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
  551. - integrate into official sources
  552. * Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
  553. - Swaddle.