linux-igd-vl.spec 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475
  1. %define name linux-igd
  2. %define source_name linuxigd
  3. %define version 1.0
  4. %define release 1%{?_dist_release}
  5. Summary: The Linux UPNP Internet GATEWAY DEVICE
  6. Summary(ja): ユニバーサルプラグアンドプレイゲートウェイデバイス
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. Source0: %{source_name}-%{version}.tar.gz
  11. Patch0: %{source_name}-%{version}.patch
  12. License: GPL
  13. Group: System Environment/Daemons
  14. URL: http://linux-igd.sourceforge.net/
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: libupnp-devel >= 1.3.1
  17. Requires: libupnp >= 1.3.1
  18. %description
  19. This is a deamon that emulates Microsoft's Internet Connection Service (ICS).
  20. It implements the UPnP Internet Gateway Device specification (IGD) and allows UPnP aware clients, such as MSN Messenger to work properly from behind a Linux NAT firewall.
  21. %prep
  22. %setup -q -n %{source_name}-%{version}
  23. %patch -p1
  24. %build
  25. %{__make}
  26. %install
  27. %{__rm} -rf ${RPM_BUILD_ROOT}
  28. %{__make} install DESTDIR="${RPM_BUILD_ROOT}"
  29. %post
  30. if [ $1 = 1 ] ; then
  31. /sbin/chkconfig --add upnpd
  32. fi
  33. %preun
  34. if [ $1 = 0 ] ; then
  35. /etc/rc.d/init.d/upnpd stop
  36. /sbin/chkconfig --del upnpd
  37. fi
  38. %clean
  39. %__rm -rf ${RPM_BUILD_ROOT}
  40. %files
  41. %defattr(-, root, root)
  42. %doc CHANGES LICENSE doc/config_options
  43. %dir %{_sysconfdir}/linuxigd/
  44. %attr(0644, root, root) %{_sysconfdir}/linuxigd/*.xml
  45. %{_sbindir}/upnpd
  46. %{_mandir}/man8/upnpd.8.gz
  47. %attr(0644, root, root) %config %{_sysconfdir}/upnpd.conf
  48. %attr(0755, root, root) %{_sysconfdir}/rc.d/init.d/upnpd
  49. %attr(0644, root, root) %config %{_sysconfdir}/sysconfig/upnpd
  50. %changelog
  51. * Sun Mar 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-1vl5
  52. - applied new versioning policy, spec in UTF-8
  53. - fixed Group tag
  54. - added files to %%doc section
  55. * Tue Feb 14 2008 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.0
  56. - initial build for Vine Linux
  57. * Mon Aug 14 2006 Tim Brody <tdb01r@ecs.soton.ac.uk>
  58. - Version 0.95 Release 1
  59. - first build for version 0.95 (Release)
  60. * Sun Sep 26 2004 Watanabe Keiji <k@elt.ne.jp>
  61. - Version 0.99 Release ELT1
  62. - first build for version 0.92 (CVS Version on Sep 25, 2004.)