freerdp-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254
  1. #define rcnumber rc4
  2. Name: freerdp
  3. Summary: Remote Desktop Protocol client
  4. Summary(ja): リモートデスクトッププロトコルクライアント
  5. Version: 2.11.1
  6. Release: 1%{?rcnumber:.%{rcnumber}}%{?_dist_release}
  7. Group: office,internet
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPLv2+
  11. URL: https://www.freerdp.com/
  12. Source0: https://pub.freerdp.com/releases/freerdp-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: cmake
  15. BuildRequires: xmlto
  16. BuildRequires: alsa-lib-devel
  17. BuildRequires: cups-devel
  18. BuildRequires: libX11-devel
  19. BuildRequires: libXcursor-devel
  20. BuildRequires: libXdamage-devel
  21. BuildRequires: libXext-devel
  22. BuildRequires: libXinerama-devel
  23. BuildRequires: libxkbfile-devel
  24. BuildRequires: libXv-devel
  25. BuildRequires: libusb1-devel
  26. BuildRequires: zlib-devel
  27. BuildRequires: openssl-devel
  28. BuildRequires: pulseaudio-libs-devel
  29. BuildRequires: pcsc-lite-devel
  30. BuildRequires: desktop-file-utils
  31. Provides: xfreerdp = %{version}-%{release}
  32. Obsoletes: freerdp-plugins < 2.0.0
  33. Requires: %{name}-libs = %{version}-%{release}
  34. %description
  35. The xfreerdp Remote Desktop Protocol (RDP) client from the FreeRDP
  36. project.
  37. xfreerdp can connect to RDP servers such as Microsoft Windows
  38. machines, xrdp and VirtualBox.
  39. %package libs
  40. Summary: Core libraries implementing the RDP protocol
  41. Summary(ja): RDPプロトコル実装のコアライブラリ
  42. Group: system
  43. %description libs
  44. libfreerdp implements the core of the RDP protocol.
  45. libfreerdpchanman can be used to load plugins that can handle channels
  46. in the RDP protocol.
  47. libfreerdpkbd implements functionality for handling keyboards in X.
  48. %package devel
  49. Summary: Development files for %{name}
  50. Summary(ja): %{name}の開発ファイル
  51. Group: programming
  52. Requires: %{name}-libs = %{version}-%{release}
  53. Requires: pkgconfig
  54. %description devel
  55. The %{name}-devel package contains libraries and header files for
  56. developing applications that use %{name}-libs.
  57. %debug_package
  58. %prep
  59. %setup -q
  60. cat << EOF > xfreerdp.desktop
  61. [Desktop Entry]
  62. Type=Application
  63. Name=X FreeRDP
  64. NoDisplay=true
  65. Comment=Connect to RDP server and display remote desktop
  66. Icon=%{name}
  67. Exec=/usr/bin/xfreerdp
  68. Terminal=false
  69. Categories=Network;RemoteAccess;
  70. EOF
  71. %build
  72. %cmake \
  73. -DCMAKE_BUILD_TYPE=Release \
  74. -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
  75. -DWITH_ALSA=ON \
  76. -DWITH_CUPS=ON \
  77. -DWITH_OPENSSL=ON \
  78. -DWITH_PCSC=ON \
  79. -DWITH_PULSE=ON \
  80. -DWITH_X11=ON \
  81. -DWITH_XCURSOR=ON \
  82. -DWITH_XEXT=ON \
  83. -DWITH_XINERAMA=ON \
  84. -DWITH_XKBFILE=ON \
  85. -DWITH_XV=ON \
  86. -DWITH_ZLIB=ON \
  87. -DWITH_CUNIT=OFF \
  88. -DWITH_DIRECTFB=OFF \
  89. -DWITH_FFMPEG=OFF \
  90. %ifarch x86_64
  91. -DWITH_SSE2=ON \
  92. %else
  93. -DWITH_SSE2=OFF \
  94. %endif
  95. %{nil}
  96. %cmake_build
  97. pushd %{_vpath_builddir}/winpr/tools/makecert-cli
  98. make %{?_smp_mflags}
  99. popd
  100. %install
  101. rm -rf %{buildroot}
  102. %cmake_install
  103. find %{buildroot} -name "*.a" -delete
  104. # No need for keymap files when using xkbfile
  105. rm -rf %{buildroot}/usr/share/freerdp
  106. desktop-file-install --dir=%{buildroot}%{_datadir}/applications xfreerdp.desktop
  107. install -p -D resources/FreeRDP_Icon_256px.png %{buildroot}%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
  108. %clean
  109. rm -rf %{buildroot}
  110. %files
  111. %defattr(-,root,root,-)
  112. %{_datadir}/applications/xfreerdp.desktop
  113. %{_datadir}/icons/hicolor/256x256/apps/%{name}.png
  114. %{_bindir}/winpr-hash
  115. %{_bindir}/winpr-makecert
  116. %{_bindir}/xfreerdp
  117. %{_mandir}/man1/winpr-hash.1.*
  118. %{_mandir}/man1/winpr-makecert.1.*
  119. %{_mandir}/man1/xfreerdp.1.*
  120. %files libs
  121. %defattr(-,root,root,-)
  122. %license LICENSE
  123. %doc README ChangeLog
  124. %{_libdir}/lib*.so.*
  125. %{_mandir}/man7/wlog.*
  126. %files devel
  127. %defattr(-,root,root,-)
  128. %{_includedir}/*
  129. %{_libdir}/cmake/*
  130. %{_libdir}/lib*.so
  131. %{_libdir}/pkgconfig/*.pc
  132. %changelog
  133. * Fri Sep 08 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.11.1-1
  134. - updated to 2.11.1.
  135. * Sun Nov 20 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.9.0-1
  136. - updated to 2.9.0.
  137. * Wed Oct 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.1-1
  138. - updated to 2.4.1.
  139. * Tue Aug 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.0-1
  140. - updated to 2.4.0.
  141. - dropped ldconfig scriptlets.
  142. * Sun Dec 13 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.0-1
  143. - updated to 2.2.0.
  144. * Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.2-1
  145. - updated to 2.1.2.
  146. * Wed May 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
  147. - updated to 2.1.1.
  148. * Sat May 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
  149. - updated to 2.1.0.
  150. * Sun Dec 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.0-1.rc4
  151. - updated to 2.0.0-RC4.
  152. - dropped all patches.
  153. - dropped subpackage 'freerdp-plugins'.
  154. * Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
  155. - add BuildRequires: alsa-lib-devel
  156. * Tue Sep 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.2-1
  157. - update to 1.0.2
  158. - fixed typo in Group
  159. - dropped Patch0 and Patch1
  160. - added Patch2 to build with current xmlto
  161. * Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  162. - update to 1.0.1
  163. - import patches from fedora package.
  164. - add BRs.
  165. * Fri May 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
  166. - initial build for Vine Linux
  167. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.2-3
  168. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  169. * Fri Jan 28 2011 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-2
  170. - rebuild on rawhide because of broken dependencies
  171. * Tue Nov 16 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-1
  172. - freerdp-0.8.2
  173. * Mon Nov 08 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-2
  174. - make -devel require pkgconfig
  175. - first official Fedora package
  176. * Sun Nov 07 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-1
  177. - freerdp-0.8.1
  178. * Sat Sep 25 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-2
  179. - hack the generated libtool to not set rpath on x86_64
  180. - configure with alsa explicitly
  181. * Tue Aug 24 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-1
  182. - freerdp-0.7.4
  183. - cleanup of packaging structure
  184. * Wed Jul 28 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.3-1
  185. - 0.7.3
  186. - fix some minor pylint warnings
  187. * Fri Jul 23 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.2-2
  188. - 0.7.2
  189. - Address many comments from cwickert:
  190. - - cleanup of old formatting, alignment with spectemplate-lib.spec and
  191. cwickert spec from #616193
  192. - - add alsa as build requirement
  193. - - remove superfluous configure options and disable static libs
  194. - - add missing rpm groups
  195. * Sun Jun 13 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.0-1
  196. - First official release, first review request