dbus-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881882883884885886887888889890891892893894895896897898899900901902903904905906907908909910911912913
  1. %bcond_with systemd
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define _unpackaged_files_terminate_build 1
  4. %define gettext_package dbus
  5. %define expat_version 2.0.1
  6. %define dbus_user_uid 81
  7. %global _localstatedir %{_var}
  8. %{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}}
  9. %{!?_unitdir:%global _unitdir /lib/systemd/system}
  10. %{!?_userunitdir:%global _userunitdir /usr/lib/systemd/user}
  11. Summary: D-BUS message bus
  12. Summary(ja): D-BUS メッセージバスシステム
  13. Name: dbus
  14. Version: 1.14.10
  15. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  16. Group: system
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. License: AFL/GPLv2
  20. URL: https://www.freedesktop.org/software/dbus/
  21. Source0: https://dbus.freedesktop.org/releases/dbus/%{name}-%{version}.tar.xz
  22. Source1: 00-start-message-bus.sh
  23. Source2: dbus.init
  24. Source3: dbus.service
  25. Source4: dbus.user.service
  26. Source5: dbus.socket
  27. Source6: dbus.user.socket
  28. # from fedora package
  29. # from gentoo
  30. Patch1000: dbus-enable-elogind.patch
  31. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  32. # default daemon
  33. Requires: %{name}-daemon = %{version}-%{release}
  34. BuildRequires: autoconf-archive
  35. BuildRequires: libtool
  36. BuildRequires: expat-devel >= %{expat_version}
  37. BuildRequires: libxml2-devel
  38. BuildRequires: python-devel
  39. BuildRequires: doxygen
  40. BuildRequires: xmlto
  41. BuildRequires: libxslt
  42. BuildRequires: gettext
  43. BuildRequires: libX11-devel
  44. BuildRequires: libSM-devel
  45. %if %{with systemd}
  46. BuildRequires: systemd-devel
  47. %else
  48. BuildRequires: elogind-devel
  49. %endif
  50. %description
  51. D-BUS is a system for sending messages between applications. It is
  52. used both for the systemwide message bus service, and as a
  53. per-user-login-session messaging facility.
  54. %description -l ja
  55. D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
  56. システム全体のメッセージバスサービスとしても利用されますが、同様に
  57. ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
  58. %package common
  59. Summary: D-BUS message bus configuration
  60. Group: system
  61. BuildArch: noarch
  62. %if %{with systemd}
  63. %{?systemd_requires}
  64. Requires: systemd
  65. %endif
  66. %description common
  67. The %{name}-common package provides the configuration and setup files for D-Bus
  68. implementations to provide a System and User Message Bus.
  69. %package daemon
  70. Summary: D-BUS message bus
  71. Group: system
  72. %{?systemd_requires}
  73. Requires: dbus-common = %{version}-%{release}
  74. Requires: dbus-libs%{?_isa} = %{version}-%{release}
  75. Requires: dbus-tools = %{version}-%{release}
  76. Requires(pre): shadow-utils
  77. %if %{with systemd}
  78. %{?systemd_requires}
  79. Requires: systemd
  80. %else
  81. Requires(post): chkconfig >= 1.3.34
  82. Requires(preun): chkconfig >= 1.3.34
  83. %endif
  84. %description daemon
  85. D-BUS is a system for sending messages between applications. It is
  86. used both for the system-wide message bus service, and as a
  87. per-user-login-session messaging facility.
  88. %package libs
  89. Summary: Libraries for accessing D-BUS
  90. Group: system
  91. %description libs
  92. This package contains lowlevel libraries for accessing D-BUS.
  93. %package tools
  94. Summary: D-BUS Tools and Utilities
  95. Group: admin-tools
  96. Requires: dbus-libs%{?_isa} = %{version}-%{release}
  97. %description tools
  98. Tools and utilities to interact with a running D-Bus Message Bus, provided by
  99. the reference implementation.
  100. %package devel
  101. Summary: Libraries and headers for D-BUS
  102. Summary(ja): D-BUS 用のライブラリとヘッダファイル
  103. Group: programming
  104. Requires: %{name}-libs = %{version}-%{release}
  105. Requires: xml-common
  106. %description devel
  107. Headers and static libraries for D-BUS.
  108. %package x11
  109. Summary: X11-requiring add-ons for D-BUS
  110. Summary(ja): X11 を利用する D-BUS 用ツール
  111. Group: admin-tools
  112. Requires: %{name} = %{version}-%{release}
  113. %description x11
  114. D-BUS contains some tools that require Xlib to be installed, those are
  115. in this separate package so server systems need not install X.
  116. %package doc
  117. Summary: Developer documentation for D-BUS
  118. Group: documentation
  119. Requires: %{name} = %{version}-%{release}
  120. BuildArch: noarch
  121. %description doc
  122. This package contains developer documentation for D-Bus along with
  123. other supporting documentation such as the introspect dtd file.
  124. # compat32
  125. %package -n compat32-%{name}
  126. Summary: D-BUS message bus
  127. Summary(ja): D-BUS メッセージバスシステム
  128. Group: system,legacy
  129. %description -n compat32-%{name}
  130. D-BUS is a system for sending messages between applications. It is
  131. used both for the systemwide message bus service, and as a
  132. per-user-login-session messaging facility.
  133. %description -n compat32-%{name} -l ja
  134. D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
  135. システム全体のメッセージバスサービスとしても利用されますが、同様に
  136. ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
  137. %package -n compat32-%{name}-devel
  138. Summary: Libraries and headers for D-BUS
  139. Summary(ja): D-BUS 用のライブラリとヘッダファイル
  140. Group: programming,legacy
  141. Requires: compat32-%{name} = %{version}-%{release}
  142. Requires: %{name}-devel = %{version}-%{release}
  143. %description -n compat32-%{name}-devel
  144. Headers and static libraries for D-BUS.
  145. %debug_package
  146. %prep
  147. %setup
  148. %if ! %{with systemd}
  149. %patch1000 -p1 -b .elogind
  150. %endif
  151. %build
  152. # Avoid rpath.
  153. if test -f autogen.sh; then env NOCONFIGURE=1 ./autogen.sh; else autoreconf --ve
  154. rbose --force --install; fi
  155. COMMON_ARGS="--enable-selinux=no \
  156. %if %{with systemd}
  157. SYSTEMCTL=/bin/systemctl \
  158. --enable-systemd \
  159. --with-init-scripts=redhat \
  160. --with-systemdsystemunitdir=%{_unitdir} \
  161. --with-systemduserunitdir=%{_userunitdir} \
  162. --enable-user-session \
  163. --with-system-pid-file=/run/messagebus.pid \
  164. --with-system-socket=/run/dbus/system_bus_socket
  165. %else
  166. --enable-elogind \
  167. --with-system-pid-file=%{_localstatedir}/run/messagebus.pid \
  168. %endif
  169. --disable-libaudit \
  170. --with-dbus-user=dbus \
  171. --libdir=/%{_lib} --bindir=/bin \
  172. --libexecdir=/lib/dbus-1 \
  173. --docdir=%{_pkgdocdir} \
  174. --sysconfdir=%{_sysconfdir} --exec-prefix=/"
  175. %configure $COMMON_ARGS --disable-tests --disable-verbose-mode --disable-asserts --enable-doxygen-docs --enable-xml-docs
  176. make V=1 %{?_smp_mflags}
  177. %install
  178. rm -rf %{buildroot}
  179. %__make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  180. find %{buildroot} -name '*.a' -type f -delete
  181. find %{buildroot} -name '*.la' -type f -delete
  182. install -Dp -m755 %{SOURCE1} %{buildroot}%{_sysconfdir}/X11/xinit/xinitrc.d/00-start-message-bus.sh
  183. # Obsolete, but still widely used, for drop-in configuration snippets.
  184. install --directory %{buildroot}%{_sysconfdir}/dbus-1/session.d
  185. install --directory %{buildroot}%{_sysconfdir}/dbus-1/system.d
  186. install --directory %{buildroot}%{_datadir}/dbus-1/interfaces
  187. %if %{with systemd}
  188. %__make install-data DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  189. # Make sure that when somebody asks for D-Bus under the name of the
  190. # old SysV script, that he ends up with the standard dbus.service name
  191. # now.
  192. ln -s dbus.service %{buildroot}%{_unitdir}/messagebus.service
  193. ## %find_lang %{gettext_package}
  194. # Delete the old legacy sysv init script
  195. #rm -rf %{buildroot}%{_initrddir}
  196. %else
  197. rm -rf %{buildroot}%{_sysconfdir}/systemd
  198. rm -rf %{buildroot}/lib/systemd
  199. rm -rf %{buildroot}%{_prefix}/lib/systemd
  200. rm -rf %{buildroot}%{_prefix}/lib/sysuserd.d
  201. rm -rf %{buildroot}%{_prefix}/lib/tmpfiles.d
  202. install -Dm755 %{SOURCE2} %{buildroot}%{_initrddir}/messagebus
  203. %endif
  204. install --directory %{buildroot}/var/lib/dbus
  205. install --directory %{buildroot}%{_pkgdocdir}
  206. install -pm 644 -t %{buildroot}%{_pkgdocdir} \
  207. doc/introspect.dtd doc/introspect.xsl doc/system-activation.txt
  208. # Make sure that the documentation shows up in Devhelp.
  209. install --directory %{buildroot}%{_datadir}/gtk-doc/html
  210. ln -s %{_pkgdocdir} %{buildroot}%{_datadir}/gtk-doc/html/dbus
  211. # Shell wrapper for installed tests, modified from Debian package.
  212. cat > dbus-run-installed-tests <<EOF
  213. #!/bin/sh
  214. # installed-tests wrapper for dbus. Outputs TAP format because why not
  215. set -e
  216. timeout="timeout 300s"
  217. ret=0
  218. i=0
  219. tmpdir=\$(mktemp --directory --tmpdir dbus-run-installed-tests.XXXXXX)
  220. for t in /lib/dbus-1/installed-tests/dbus/test-*; do
  221. i=\$(( \$i + 1 ))
  222. echo "# \$i - \$t ..."
  223. echo "x" > "\$tmpdir/result"
  224. ( set +e; \$timeout \$t; echo "\$?" > "\$tmpdir/result" ) 2>&1 | sed 's/^/#/'
  225. e="\$(cat "\$tmpdir/result")"
  226. case "\$e" in
  227. (0)
  228. echo "ok \$i - \$t"
  229. ;;
  230. (77)
  231. echo "ok \$i # SKIP \$t"
  232. ;;
  233. (*)
  234. echo "not ok \$i - \$t (\$e)"
  235. ret=1
  236. ;;
  237. esac
  238. done
  239. rm -rf tmpdir
  240. echo "1..\$i"
  241. exit \$ret
  242. EOF
  243. install -pm 755 -t %{buildroot}/lib/dbus-1 dbus-run-installed-tests
  244. ## vine stuff
  245. mkdir -p %{buildroot}%{_libdir}/cmake/DBus1
  246. mv -f \
  247. %{buildroot}/%{_lib}/cmake/DBus1/DBus1Config.cmake \
  248. %{buildroot}/%{_lib}/cmake/DBus1/DBus1ConfigVersion.cmake \
  249. %{buildroot}%{_libdir}/cmake/DBus1/
  250. mkdir -p %{buildroot}/%{_bindir}
  251. mv -f %{buildroot}/bin/dbus-launch %{buildroot}/%{_bindir}/
  252. mkdir -p %{buildroot}/%{_libdir}/dbus-1.0
  253. mv %{buildroot}/%{_lib}/dbus-1.0/include %{buildroot}/%{_libdir}/dbus-1.0/
  254. mkdir -p %{buildroot}/%{_libdir}/pkgconfig
  255. #change the arch-deps.h include directory to /usr/lib[64] instead of /lib[64]
  256. sed -e 's@-I${libdir}@-I${prefix}/%{_lib}@' %{buildroot}/%{_lib}/pkgconfig/dbus-1.pc > %{buildroot}/%{_libdir}/pkgconfig/dbus-1.pc
  257. rm -f %{buildroot}/%{_lib}/pkgconfig/dbus-1.pc
  258. rm -f %{buildroot}/lib/dbus-1/dbus-run-installed-tests
  259. %if %{with systemd}
  260. rm -rf %{buildroot}/var/run/dbus
  261. install -m644 %{SOURCE3} %{buildroot}%{_unitdir}/dbus.service
  262. install -m644 %{SOURCE4} %{buildroot}%{_userunitdir}/dbus.service
  263. install -m644 %{SOURCE5} %{buildroot}%{_unitdir}/dbus.socket
  264. install -m644 %{SOURCE6} %{buildroot}%{_userunitdir}/dbus.socket
  265. %endif
  266. %clean
  267. rm -rf %{buildroot}
  268. %pre daemon
  269. # Add the "dbus" user
  270. /usr/sbin/useradd -c 'System message bus' -u %{dbus_user_uid} \
  271. -s /sbin/nologin -r -d '/' dbus 2> /dev/null || :
  272. %post daemon
  273. %if %{with systemd}
  274. %systemd_post dbus.service
  275. %systemd_user_post dbus.service
  276. %else
  277. /sbin/chkconfig --add messagebus
  278. /sbin/chkconfig messagebus resetpriorities
  279. %endif
  280. %preun daemon
  281. %if %{with systemd}
  282. %systemd_preun dbus.service
  283. %systemd_user_preun dbus.service
  284. %else
  285. if [ $1 = 0 ]; then
  286. service messagebus stop > /dev/null 2>&1
  287. /sbin/chkconfig --del messagebus
  288. fi
  289. if [ -x /sbin/systemctl ]; then
  290. /sbin/chkconfig --del messagebus
  291. fi
  292. %endif
  293. %postun daemon
  294. %if %{with systemd}
  295. %systemd_postun dbus.service
  296. %systemd_user_postun dbus.service
  297. %endif
  298. %if !%{with systemd}
  299. %triggerpostun daemon -- dbus-daemon < 1.12.16-2
  300. /sbin/chkconfig --add messagebus
  301. /sbin/chkconfig messagebus resetpriorities
  302. %endif
  303. %if %{with systemd}
  304. %post common
  305. %systemd_post dbus.socket
  306. %systemd_user_post dbus.socket
  307. %preun common
  308. %systemd_preun dbus.socket
  309. %systemd_user_preun dbus.socket
  310. %postun common
  311. %systemd_postun dbus.socket
  312. %systemd_user_postun dbus.socket
  313. %endif
  314. %files
  315. # dummy package
  316. %files common
  317. %dir %{_sysconfdir}/dbus-1
  318. %dir %{_sysconfdir}/dbus-1/session.d
  319. %dir %{_sysconfdir}/dbus-1/system.d
  320. %config %{_sysconfdir}/dbus-1/session.conf
  321. %config %{_sysconfdir}/dbus-1/system.conf
  322. %dir %{_datadir}/dbus-1
  323. %dir %{_datadir}/dbus-1/session.d
  324. %dir %{_datadir}/dbus-1/system.d
  325. %{_datadir}/dbus-1/session.conf
  326. %{_datadir}/dbus-1/system.conf
  327. %{_datadir}/dbus-1/services
  328. %{_datadir}/dbus-1/system-services
  329. %{_datadir}/dbus-1/interfaces
  330. %if %{with systemd}
  331. %{_sysusersdir}/dbus.conf
  332. %{_unitdir}/dbus.socket
  333. %{_userunitdir}/dbus.socket
  334. %endif
  335. %files daemon
  336. %defattr(-,root,root)
  337. %{!?_licensedir:%global license %%doc}
  338. %license COPYING
  339. %doc AUTHORS ChangeLog NEWS README
  340. %config %{_sysconfdir}/dbus-1/*.conf
  341. %ghost %dir /run/%{name}
  342. %dir %{_localstatedir}/lib/dbus/
  343. /bin/dbus-daemon
  344. /bin/dbus-cleanup-sockets
  345. /bin/dbus-run-session
  346. /bin/dbus-test-tool
  347. %{_mandir}/man*/dbus-daemon.1.gz
  348. %{_mandir}/man*/dbus-cleanup-sockets.1.gz
  349. %{_mandir}/man*/dbus-run-session.1.gz
  350. %{_mandir}/man1/dbus-test-tool.1.gz
  351. %dir /lib/dbus-1
  352. %attr(4750,root,dbus) /lib/dbus-1/dbus-daemon-launch-helper
  353. %if %{with systemd}
  354. %{_tmpfilesdir}/dbus.conf
  355. %{_unitdir}/dbus.service
  356. %{_unitdir}/messagebus.service
  357. %{_unitdir}/multi-user.target.wants/dbus.service
  358. %{_unitdir}/sockets.target.wants/dbus.socket
  359. %{_userunitdir}/dbus.service
  360. %{_userunitdir}/sockets.target.wants/dbus.socket
  361. %else
  362. %dir %{_localstatedir}/run/dbus
  363. %{_sysconfdir}/rc.d/init.d/*
  364. %endif
  365. %files tools
  366. %license COPYING
  367. /bin/dbus-send
  368. /bin/dbus-monitor
  369. /bin/dbus-update-activation-environment
  370. /bin/dbus-uuidgen
  371. %{_mandir}/man*/dbus-send.1.gz
  372. %{_mandir}/man*/dbus-monitor.1.gz
  373. %{_mandir}/man1/dbus-update-activation-environment.1.gz
  374. %{_mandir}/man*/dbus-uuidgen.1.gz
  375. %files libs
  376. %{!?_licensedir:%global license %%doc}
  377. %license COPYING
  378. /%{_lib}/*dbus-1*.so.*
  379. %files devel
  380. %defattr(-,root,root)
  381. /%{_lib}/lib*.so
  382. %{_libdir}/dbus-1.0/include
  383. %{_libdir}/pkgconfig/*
  384. %{_includedir}/*
  385. %dir %{_libdir}/cmake/DBus1
  386. %{_libdir}/cmake/DBus1/*
  387. %dir %{_datadir}/xml
  388. %dir %{_datadir}/xml/dbus-1
  389. %{_datadir}/xml/dbus-1/*
  390. %files x11
  391. %defattr(-,root,root)
  392. %{_bindir}/dbus-launch
  393. %{_datadir}/man/man*/dbus-launch.1.gz
  394. %{_sysconfdir}/X11/xinit/xinitrc.d/00-start-message-bus.sh
  395. %files doc
  396. %defattr(-,root,root)
  397. %{_pkgdocdir}/*
  398. %{_datadir}/gtk-doc
  399. # compat32
  400. %if %{build_compat32}
  401. %files -n compat32-%{name}
  402. /%{_lib}/*dbus-1*.so.*
  403. %files -n compat32-%{name}-devel
  404. %defattr(-,root,root)
  405. /%{_lib}/lib*.so
  406. %{_libdir}/dbus-1.0/include
  407. %endif
  408. %changelog
  409. * Tue Sep 12 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.10-1
  410. - new upstream release.
  411. * Fri Jun 23 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.8-1
  412. - new upstream release.
  413. * Thu Oct 13 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.4-1
  414. - new upstream release.
  415. - dropped ldconfig scriptlets.
  416. * Wed Jul 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.20-1
  417. - new upstream release.
  418. - moved dbus-daemon-launch-helper from /lib64/dbus-1 to /lib/dbus-1.
  419. * Fri Jun 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.18-1
  420. - new upstream release.
  421. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.16-2
  422. - added subpackages: common, daemon, libs and tools.
  423. * Wed Sep 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.16-1
  424. - new upstream release.
  425. - built for systemd.
  426. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.12-1
  427. - new upstream release.
  428. - added elogind support.
  429. * Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.22-1
  430. - new upstream release.
  431. * Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.20-1
  432. - new upstream release
  433. * Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.18-1
  434. - new upstream release
  435. * Sun Mar 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.16-1
  436. - new upstream release
  437. * Sat Jan 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.14-1
  438. - new upstream release
  439. * Mon Dec 01 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.28-1
  440. - new upstream release
  441. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.24-1
  442. - new upstream release
  443. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.22-1
  444. - new upstream release
  445. * Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.20-1
  446. - new upstream release
  447. * Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.18-1
  448. - new upstream release
  449. * Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  450. - new upstream release
  451. * Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
  452. - new upstream release
  453. * Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-2
  454. - remove BuildRequires: audit-libs-devel, libcap-ng-devel
  455. * Sat Oct 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
  456. - new upstream release
  457. - remove old patches
  458. * Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.20-1
  459. - new upstream release
  460. - add BuildRequires: audit-libs-devel, libcap-ng-devel
  461. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.18-1
  462. - new upstream release
  463. - remove Requires: libxml2-python
  464. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.16-1
  465. - new upstream release
  466. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
  467. - new upstream release
  468. - drop Patch1
  469. - create -doc sub package
  470. * Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
  471. - new upstream release
  472. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  473. - new upstream release
  474. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.24-3
  475. - add BuildRequires: libSM-devel
  476. * Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.24-2
  477. - rebuilt with rpm-4.8.1
  478. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.24-1
  479. - new upstream release
  480. - drop Patch0
  481. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.16-2
  482. - rebuilt with new toolchain
  483. * Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.16-1
  484. - new upstream release
  485. * Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.14-1
  486. - new upstream release
  487. - do not restart dbus on upgrade
  488. * Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.12-3
  489. - added compat32 package for x86_64 arch support
  490. * Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.12-2
  491. - add Patch10 for workaround deny send_interface
  492. http://bugs.freedesktop.org/show_bug.cgi?id=18961
  493. Bug 18961: Skip bare <deny send_interface=""/> for not (method_call|signal)
  494. Bare <deny send_interface=""/> rules have a far larger impact than one would think.
  495. It's really always wrong to use them without also using send_destination.
  496. - XXX: this should be fixed in each dbus configuration.
  497. * Tue Mar 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1
  498. - new upstream release with security fix (CVE-2008-4311)
  499. * Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.4-1
  500. - new upstream release with security fix (CVE-2008-3834)
  501. * Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
  502. - new upstream release
  503. * Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3
  504. - own the directories /usr/share/dbus-1/{system-services,interfaces}
  505. - set 'dbus' instead of '81' to --with-dbus-user
  506. * Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
  507. - import some patches from fedora
  508. - move dbus-daemon-launch-helper to /%%{_lib}/dbus-1/
  509. * Wed May 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
  510. - new upstream release
  511. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl5
  512. - new upstream release
  513. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.2-0vl4
  514. - rebuild with expat-2.0.1
  515. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl3
  516. - rebuild with new environment/toolchain
  517. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
  518. - require new chkconfig to reset initscript priorities
  519. * Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
  520. - new upstream release
  521. - split out bindings
  522. - move base binaries and libraries to /bin and /%{_lib}
  523. * Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.62-0vl2
  524. - rebuilt for VineSeed
  525. * Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.2
  526. - add Vendor/Distribution tag
  527. * Thu Dec 14 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.1
  528. - add patch100 for fix CVE-2006-6107
  529. * Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.62-0vl1
  530. - new upstream release
  531. * Sat Jun 10 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.61-0vl2
  532. - disabled dbus-qt
  533. - added BuildConflicts: qt-devel
  534. - removed work around for 64 bit archs
  535. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.61-0vl1
  536. - new upstream release
  537. * Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.60-0vl1
  538. - new upstream release
  539. * Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
  540. - new upstream release
  541. * Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.34-0vl1
  542. - new upstream release
  543. - enable python bindings
  544. * Sat Mar 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-4vl1
  545. - initial build for Vine Linux based on FC package
  546. - disable python bindings
  547. - disable selinux
  548. * Tue Feb 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-4
  549. - Explicitly pass in the pid file location to ./configure instead of
  550. letting it guess based on the build enviornment
  551. * Mon Jan 31 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-3
  552. - Add patch to fix random users from connecting to a users session bus
  553. * Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-2
  554. - Add Steve Grubb's SE-Linux audit patch (Bug# 144920)
  555. * Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-1
  556. - Update to upstream version 0.23
  557. - Drop all patches except for the UDI patch as they have been
  558. integrated upstream
  559. - List of API changes:
  560. * add setgroups() to drop supplementary groups
  561. * removed dbus_bug_get_with_g_main since it's been replaced by dbus_g_bus_get
  562. * added support for int64 and uint64 to the python bindings
  563. * use SerivceOwnerChanges signal instead of ServiceCreated and ServiceDeleted
  564. * Mon Nov 8 2004 Jeremy Katz <katzj@redhat.com> - 0.22-12
  565. - rebuild against python 2.4
  566. * Tue Nov 02 2004 John (J5) Palmieri <johnp@redhat.com>
  567. - Add a requires for glib2-devel in the devel package
  568. - Add SE-Linux backport from Colin Walters that fixes
  569. messages getting lost in SE-Linux contexts
  570. * Wed Oct 13 2004 John (J5) Palmieri <johnp@redhat.com>
  571. - Bump up release and rebuild
  572. * Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com>
  573. - Run /sbin/ldconfig for glib sub-package (bug #134062).
  574. * Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
  575. - Fixed patch to use dbus-1 instead of dbus-1.0
  576. - (configure.in): Exported just the datadir instead of
  577. the full path to the dbus datadir for consistency
  578. * Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
  579. - Adding patch to move /usr/lib/dbus-1.0/services to
  580. /usr/share/dbus-1.0/services
  581. * Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
  582. - reverting BuildRequires: redhat-release because of issues with build system
  583. - added precompiled version of the messagebus init script
  584. * Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
  585. - changed /etc/redhat-release to the package redhat-release
  586. * Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
  587. - added python int64 patch from davidz
  588. * Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
  589. - added BuildRequires: /etc/redhat-release (RH Bug #132436)
  590. * Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com>
  591. - Added Steve Grubb's spec file patch (RH Bug #130201)
  592. * Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
  593. - Disabled dbus-gtk since dbus-viewer doesn't do anything right now
  594. * Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
  595. - Moved dbus-viewer to new dbus-gtk package so that dbus-glib
  596. no longer requires X or GTK libraries. (RH Bug #130029)
  597. * Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com>
  598. - Update to new 0.22 release
  599. * Thu Aug 05 2004 John (J5) Palmieri <johnp@redhat.com>
  600. - Added BuildRequires for libselinux-devel and Requires for libselinux
  601. * Mon Aug 02 2004 Colin Walters <walters@redhat.com>
  602. - Add SE-DBus patch
  603. * Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
  604. - Added lib64 workaround for python bindings installing to
  605. the wrong lib directory on 64 bit archs
  606. * Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
  607. - Updated console-auth patch
  608. - rebuild
  609. * Thu Jul 22 2004 John (J5) Palmieri <johnp@redhat.com>
  610. - Update to upstream CVS build
  611. - Added console-auth patch
  612. * Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
  613. - Workaround added to fix gcc-3.4 bug on ia64
  614. * Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
  615. - require new Pyrex version and see if it builds this time
  616. * Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
  617. - rebuild with updated Pyrex (0.9.2.1)
  618. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  619. - rebuilt
  620. * Fri Jun 04 2004 John (J5) Palmieri <johnp@redhat.com>
  621. - Moved dbus-viewer, dbus-monitor and dbus-glib-tool
  622. into the dbus-glib package so that the main dbus
  623. package does not depend on glib (Bug #125285)
  624. * Thu Jun 03 2004 John (J5) Palmieri <johnp@redhat.com>
  625. - rebuilt
  626. * Thu May 27 2004 John (J5) Palmieri <johnp@redhat.com>
  627. - added my Python patch
  628. - took out the qt build requires
  629. - added a gtk+ build requires
  630. * Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com>
  631. - Changed build requirement to version 0.9-3 of Pyrex
  632. to fix problem with builing on x86_64
  633. * Tue Apr 20 2004 John (J5) Palmieri <johnp@redhat.com>
  634. - update to upstream 0.21
  635. - removed dbus-0.20-varargs.patch patch (fixed upstream)
  636. * Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com>
  637. - added a dbus-python package to generate python bindings
  638. - added Pyrex build dependacy
  639. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  640. - rebuilt
  641. * Wed Feb 25 2004 Bill Nottingham <notting@redhat.com> 0.20-4
  642. - fix dbus error functions on x86-64 (#116324)
  643. - add prereq (#112027)
  644. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  645. - rebuilt
  646. * Fri Feb 13 2004 Tim Waugh <twaugh@redhat.com>
  647. - Conflict with cups prior to configuration file change, so that the
  648. %%postun service condrestart works.
  649. * Wed Feb 11 2004 Havoc Pennington <hp@redhat.com> 0.20-2
  650. - rebuild in fc2, cups now updated
  651. * Wed Jan 7 2004 Bill Nottingham <notting@redhat.com> 0.20-1
  652. - update to upstream 0.20
  653. * Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-6
  654. - hmm, dbus doesn't support uids in the config file. fix.
  655. * Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-5
  656. - put uid instead of username in the config file, to keep things working with name change
  657. * Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-4
  658. - make subpackages require the specific release, not just version, of base package
  659. * Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-3
  660. - change system user "messagebus" -> "dbus" to be under 8 chars
  661. * Mon Sep 29 2003 Havoc Pennington <hp@redhat.com> 0.13-2
  662. - see if removing qt subpackage for now will get us through the build system,
  663. qt bindings not useful yet anyway
  664. * Sun Sep 28 2003 Havoc Pennington <hp@redhat.com> 0.13-1
  665. - 0.13 fixes a little security oops
  666. * Mon Aug 4 2003 Havoc Pennington <hp@redhat.com> 0.11.91-3
  667. - break the tiny dbus-launch that depends on X into separate package
  668. so a CUPS server doesn't need X installed
  669. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  670. - rebuilt
  671. * Sat May 17 2003 Havoc Pennington <hp@redhat.com> 0.11.91-1
  672. - 0.11.91 cvs snap properly merges system.d
  673. * Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11.90-1
  674. - build a cvs snap with a few more fixes
  675. * Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11-2
  676. - fix a crash that was breaking cups
  677. * Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.11-1
  678. - 0.11
  679. * Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.10.90-1
  680. - use rc.d/init.d not init.d, bug #90192
  681. - include the new man pages
  682. * Fri Apr 11 2003 Havoc Pennington <hp@redhat.com> 0.9-1
  683. - 0.9
  684. - export QTDIR explicitly
  685. - re-enable qt, the problem was most likely D-BUS configure
  686. * Tue Apr 1 2003 Havoc Pennington <hp@redhat.com> 0.6.94-1
  687. - update from CVS with a fix to set uid after gid
  688. * Tue Apr 1 2003 Havoc Pennington <hp@redhat.com> 0.6.93-1
  689. - new cvs snap that actually forks to background and changes
  690. user it's running as and so forth
  691. - create our system user in pre
  692. * Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.92-1
  693. - fix for "make check" test that required a home directory
  694. * Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.91-1
  695. - disable qt for now because beehive hates me
  696. - pull a slightly newer cvs snap that creates socket directory
  697. - cat the make check log after make check fails
  698. * Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.90-1
  699. - initial build