OpenColorIO-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203
  1. # Filter provides from Python libraries
  2. %{?filter_setup:
  3. %filter_provides_in %{python_sitearch}.*\.so$
  4. %filter_setup
  5. }
  6. Name: OpenColorIO
  7. Version: 1.0.8
  8. Release: 8%{?_dist_release}
  9. Summary: Enables color transforms and image display across graphics apps
  10. Summary(ja): アプリケーション間での色変換と画像表示を行うためのライブラリ
  11. License: BSD
  12. Group: System Environment/Libraries
  13. URL: http://opencolorio.org/
  14. # Github archive was generated on the fly using the following URL:
  15. # https://github.com/imageworks/OpenColorIO/tarball/v1.0.8
  16. Source0: %{name}-%{version}.tar.gz
  17. Patch0: OpenColorIO-pull_300.patch
  18. Patch1: OpenColorIO-yaml_cpp3.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  20. BuildRequires: cmake
  21. BuildRequires: help2man
  22. BuildRequires: texlive-collection-fontsrecommended
  23. BuildRequires: texlive-collection-latexextra
  24. BuildRequires: texlive-collection-latexrecommended
  25. # Libraries
  26. BuildRequires: python-devel
  27. BuildRequires: mesa-libGL-devel mesa-libGLU-devel
  28. BuildRequires: libX11-devel libXmu-devel libXi-devel
  29. BuildRequires: freeglut-devel
  30. BuildRequires: glew-devel
  31. BuildRequires: zlib-devel
  32. #######################
  33. # Unbundled libraries #
  34. #######################
  35. BuildRequires: tinyxml-devel
  36. BuildRequires: lcms2-devel
  37. #BuildRequires: yaml-cpp-devel
  38. # The following bundled projects are only used for document generation.
  39. #BuildRequires: python-docutils
  40. #BuildRequires: python-jinja2
  41. #BuildRequires: python-pygments
  42. #BuildRequires: python-setuptools
  43. #BuildRequires: python-sphinx
  44. %description
  45. OCIO enables color transforms and image display to be handled in a consistent
  46. manner across multiple graphics applications. Unlike other color management
  47. solutions, OCIO is geared towards motion-picture post production, with an
  48. emphasis on visual effects and animation color pipelines.
  49. %package devel
  50. Summary: Development libraries and headers for %{name}
  51. Summary(ja): %{name} の開発用ライブラリおよびヘッダファイル
  52. Group: Development/Libraries
  53. Requires: %{name} = %{version}-%{release}
  54. %description devel
  55. Development libraries and headers for %{name}.
  56. %package doc
  57. Summary: API Documentation for %{name}
  58. Summary(ja): %{name} API のドキュメント
  59. Group: Documentation
  60. BuildArch: noarch
  61. Requires: %{name} = %{version}-%{release}
  62. %description doc
  63. API documentation for %{name}.
  64. %prep
  65. %setup -q
  66. %patch0 -p1 -b .pull300
  67. #patch1 -p1 -b .yaml3
  68. # Remove what bundled libraries
  69. rm -f ext/lcms*
  70. rm -f ext/tinyxml*
  71. #rm -f ext/yaml*
  72. %build
  73. rm -rf build && mkdir build && pushd build
  74. %cmake -DOCIO_BUILD_STATIC=OFF \
  75. -DOCIO_BUILD_DOCS=ON \
  76. -DOCIO_BUILD_TESTS=ON \
  77. -DOCIO_PYGLUE_SONAME=OFF \
  78. -DUSE_EXTERNAL_YAML=FALSE \
  79. -DUSE_EXTERNAL_TINYXML=TRUE \
  80. -DUSE_EXTERNAL_LCMS=TRUE \
  81. %ifnarch x86_64
  82. -DOCIO_USE_SSE=OFF \
  83. %endif
  84. -DCMAKE_SKIP_RPATH=OFF \
  85. ../
  86. # -DUSE_EXTERNAL_YAML=FALSE \
  87. make %{?_smp_mflags}
  88. %install
  89. rm -rf %{buildroot}
  90. pushd build
  91. make install DESTDIR=%{buildroot}
  92. # Generate man pages
  93. mkdir -p %{buildroot}%{_mandir}/man1
  94. help2man -N -s 1 --version-string=%{version} \
  95. -o %{buildroot}%{_mandir}/man1/ociocheck.1 \
  96. src/apps/ociocheck/ociocheck
  97. help2man -N -s 1 --version-string=%{version} \
  98. -o %{buildroot}%{_mandir}/man1/ociobakelut.1 \
  99. src/apps/ociobakelut/ociobakelut
  100. # Move installed documentation back so it doesn't conflict with the main package
  101. popd
  102. rm -rf _tmpdoc
  103. mkdir -p _tmpdoc
  104. mv %{buildroot}%{_docdir}/%{name}/* _tmpdoc/
  105. %check
  106. # Testing passes locally in mock but fails on the fedora build servers.
  107. #pushd build && make test
  108. %post -p /sbin/ldconfig
  109. %postun -p /sbin/ldconfig
  110. %clean
  111. rm -rf %{buildroot}
  112. %files
  113. %doc ChangeLog LICENSE README
  114. %{_bindir}/*
  115. %{_libdir}/*.so.*
  116. %dir %{_datadir}/ocio
  117. %{_datadir}/ocio/setup_ocio.sh
  118. %{_mandir}/man1/*
  119. %{python_sitearch}/*.so
  120. %files devel
  121. %{_includedir}/OpenColorIO/
  122. %{_includedir}/PyOpenColorIO/
  123. %{_libdir}/*.so
  124. %{_libdir}/pkgconfig/%{name}.pc
  125. %files doc
  126. %doc _tmpdoc/*
  127. %changelog
  128. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.8-8
  129. - rebuild with gcc-5.4.0
  130. * Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.0.8-7
  131. - Initial build for Vine Linux
  132. - used bundled yaml-cpp
  133. * Mon Sep 23 2013 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-6
  134. - Rebuild against yaml-cpp03 compatibility package.
  135. * Mon Aug 26 2013 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-5
  136. - Fix for new F20 feature, unversion doc dir. Fixes BZ#1001264
  137. * Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.8-3
  138. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  139. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.8-2
  140. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  141. * Tue Dec 11 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-1
  142. - Update to latest upstream release.
  143. * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-5
  144. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  145. * Thu Apr 26 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-4
  146. - Only use SSE instructions on x86_64.
  147. * Wed Apr 25 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-3
  148. - Misc spec cleanup for packaging guidelines.
  149. - Disable testing for now since it fails on the build servers.
  150. * Wed Apr 18 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-1
  151. - Latest upstream release.
  152. * Thu Apr 05 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.6-1
  153. - Latest upstream release.
  154. * Wed Nov 16 2011 Richard Shaw <hobbes1069@gmail.com> - 1.0.2-1
  155. - Initial release.