texlive-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779
  1. # -*- coding: utf-8-unix -*-
  2. %bcond_with firstbuild
  3. %global _use_internal_dependency_generator 0
  4. %global __find_provides %{SOURCE99}
  5. %global __find_requires %{SOURCE98}
  6. %global texlivesrcver 20160510
  7. #% global tlptexlivesrcver 20140507
  8. Summary: The TeX text formatting system
  9. Summary(ja): TeX 文書整形システム
  10. Name: texlive
  11. Version: 2016
  12. Release: 2%{?_dist_release}
  13. License: distributable
  14. Group: Applications/Publishing
  15. URL: http://www.tug.org/texlive/
  16. ## original TeX Live source
  17. # Source: http://ftp.tug.org/texlive/Images/test/%{name}-%{texlivesrcver}-source.tar.xz
  18. # Source: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
  19. ## snapshot
  20. # $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
  21. # $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
  22. Source: %{name}-source-%{texlivesrcver}.tar.xz
  23. ## our updmap{,-hdr}.cfg from collection-basic 20140524
  24. # NOTE: fmtutil.cnf, texmf.cnf: use the conf files generated from Source0
  25. Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
  26. Source7: updmap.cfg.texlive-%{texlivesrcver}
  27. ## desktop files
  28. Source11: texdoctk.desktop
  29. Source98: find-requires-texlive.sh
  30. ## find library sonames for libkpathsea, libptexenc, and libsynctex
  31. Source99: find-provides-texlive.sh
  32. ######
  33. # TeX patches
  34. ######
  35. ## vine
  36. Patch0: reautoconf-parallel.diff
  37. #Patch1: texlive-%{texlivesrcver}-vine.patch
  38. Patch2: texlive-%{texlivesrcver}-texmfcnf-vine.patch
  39. Patch3: texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
  40. #Patch4: texlive-%{texlivesrcver}-fmtutilcnf-vine.patch
  41. #Patch10: texlive-%{texlivesrcver}-pxdvik-vine.patch
  42. ## security
  43. Requires: perl-Tk perl-Tk-TableMatrix
  44. Requires: ghostscript >= 8.71
  45. Requires: nkf
  46. Requires(post,postun): fontconfig
  47. Requires(post): ed mktemp
  48. Requires(post): vutils >= 7.1
  49. %{!?with_firstbuild:Requires: texlive-common = %{version}}
  50. BuildRequires: autoconf >= 2.68
  51. BuildRequires: bison flex
  52. BuildRequires: bzip2-devel
  53. BuildRequires: cairo-devel >= 1.12
  54. BuildRequires: fontconfig-devel
  55. BuildRequires: freetype2-devel >= 2.1.10
  56. BuildRequires: gd-devel
  57. BuildRequires: libjpeg-devel
  58. BuildRequires: libpng-devel >= 1.6
  59. BuildRequires: ncurses-devel
  60. BuildRequires: nkf
  61. BuildRequires: openssl-devel
  62. BuildRequires: pixman-devel >= 0.18
  63. #BuildRequires: poppler-devel >= 0.26
  64. BuildRequires: xorg-x11-devel
  65. BuildRequires: zlib-devel
  66. ## use distro's libpaper
  67. #BuildRequires: libpaper-devel >= 1.1.24-2
  68. ## do not xdvi(k)
  69. #BuildRequires: XOrg-devel
  70. #BuildRequires: openMotif-devel
  71. ## needs to build pxdvi
  72. #BuildRequires: t1lib-devel
  73. BuildRequires: texlive-vtlpkg = %{version}
  74. Buildroot: %{_tmppath}/%{name}-%{version}-root
  75. Vendor: Project Vine
  76. Distribution: Vine Linux
  77. Packager: munepi
  78. %description
  79. The TeX Live software distribution offers a complete TeX system for a
  80. variety of Unix, Macintosh, Windows and other platforms. It
  81. encompasses programs for editing, typesetting, previewing and printing
  82. of TeX documents in many different languages, and a large collection
  83. of TeX macros and font libraries.
  84. The distribution includes extensive general documentation about TeX,
  85. as well as the documentation for the included software packages.
  86. %description -l ja
  87. TeX Live ソフトウェアディストリビューションは、
  88. さまざまな Unix, Macintosh, Windows、および
  89. 他のプラットホームに対して完全な TeX システムを提供します。
  90. 多くの異なった言語を含む TeX ドキュメントの
  91. 編集、組版、閲覧、印刷するためのプログラム、
  92. そして、TeX マクロやフォントライブラリの大きなコレクションを
  93. 同梱しています。
  94. このディストリビューションは
  95. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  96. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  97. %package doc
  98. Summary: TeX Live: Documentation files of %{name}
  99. Group: Applications/Publishing
  100. Requires: %{name} = %{version}-%{release}
  101. BuildArch: noarch
  102. %description doc
  103. This package contains documentation files of %{name}.
  104. %package -n libkpathsea
  105. Summary: path search library for the TeX Live
  106. Summary(ja): TeX Live 用パス検索ライブラリ
  107. Group: System Environment/Libraries
  108. %description -n libkpathsea
  109. This package includes runtime part of the Kpathsea library.
  110. %package -n libkpathsea-devel
  111. Summary: path search libary and header files for the TeX Live
  112. Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
  113. Group: Development/Libraries
  114. Requires: libkpathsea = %{version}-%{release}
  115. %description -n libkpathsea-devel
  116. This package includes static library and header files of the Kpathsea library.
  117. %package -n libptexenc
  118. Summary: Kanji code convert library for Japanese pTeX
  119. Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
  120. Group: System Environment/Libraries
  121. Requires: libkpathsea = %{version}-%{release}
  122. %description -n libptexenc
  123. This package includes runtime part of the ptexenc library.
  124. %package -n libptexenc-devel
  125. Summary: Kanji code convert library and header files for Japanese pTeX
  126. Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
  127. Group: Development/Libraries
  128. Requires: libptexenc = %{version}-%{release}
  129. %description -n libptexenc-devel
  130. This package includes header files of the ptexenc library.
  131. %package -n libsynctex
  132. Summary: SyncTeX library
  133. Group: System Environment/Libraries
  134. %description -n libsynctex
  135. This package includes the runtime part of SyncTeX library.
  136. %package -n libsynctex-devel
  137. Summary: SyncTeX header files
  138. Group: Development/Libraries
  139. Requires: libsynctex = %{version}-%{release}
  140. %description -n libsynctex-devel
  141. This package includes the header files of SyncTeX library.
  142. %prep
  143. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  144. # %setup -q -n %{name}-%{texlivesrcver}-source
  145. %setup -q -n %{name}-source-%{texlivesrcver}
  146. %patch0 -p0 -b .parallel
  147. # %patch1 -p1 -b .vine
  148. %patch2 -p1 -b .vine
  149. %patch3 -p1 -b .vine
  150. # %patch4 -p1 -b .vine
  151. # ## Applying tlptexlive that provides pxdvi(k) and pmpost
  152. # echo "applying patches"
  153. # cat "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/series" | while read p r ; do
  154. # echo $p | grep '^#' >/dev/null || \
  155. # patch -p1 $r < "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/$p" || exit 1
  156. # done
  157. ## Avoid pollution from internal libraries.
  158. #,paper,poppler,xpdf
  159. %__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,pixman,t1lib,unzip,zlib} || exit 1
  160. ./reautoconf || exit 1
  161. %build
  162. set -x
  163. unset TEXINPUTS || :
  164. unset HOME || :
  165. export CFLAGS="$RPM_OPT_FLAGS" \
  166. CXXFLAGS="$RPM_OPT_FLAGS" \
  167. LANG=C
  168. PREFIX=$(pwd)/work
  169. TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
  170. TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
  171. TL_CONFIGURE_ARGS=" \
  172. --disable-multiplatform \
  173. --disable-native-texlive-build \
  174. --with-banner-add=\"/Vine Linux\" \
  175. --enable-shared --disable-static \
  176. --enable-compiler-warnings=max \
  177. --without-cxx-runtime-hack \
  178. \
  179. --with-system-xpdf=no --with-system-poppler=no \
  180. --with-system-gd \
  181. --with-system-t1lib \
  182. --with-system-libpng \
  183. --with-system-zlib \
  184. --with-system-freetype2 \
  185. --with-system-pixman \
  186. --with-system-cairo \
  187. --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
  188. --with-pic \
  189. \
  190. --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
  191. --disable-xdvik \
  192. --disable-dvi2tty \
  193. --disable-t1utils --disable-psutils --disable-detex \
  194. --disable-dvipng --disable-lcdf-typetools \
  195. "
  196. export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
  197. TL_MAKE=%__make ./Build || exit 1
  198. %install
  199. ## prepare %%install session
  200. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  201. ## copy inst directory to /usr
  202. %__mkdir_p %{buildroot}
  203. %__cp -a inst %{buildroot}%{_prefix} || exit 1
  204. %ifarch x86_64
  205. %__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
  206. %endif
  207. if [ -f %{buildroot}%{_libdir}/kpathsea/c-auto.h ]; then
  208. %__mv %{buildroot}%{_libdir}/kpathsea/c-auto.h \
  209. %{buildroot}%{_includedir}/kpathsea/c-auto.h || exit 1
  210. %__rm -r %{buildroot}%{_libdir}/kpathsea || exit 1
  211. fi
  212. ## make some fundamental texmf trees
  213. %__mkdir_p %{buildroot}%{_tl_texmfvine}
  214. %__mkdir_p %{buildroot}%{_tl_texmfdist}
  215. %__mkdir_p %{buildroot}%{_tl_texmflocal}
  216. %__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
  217. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}
  218. %__mkdir_p %{buildroot}%{_tl_vartexfonts}
  219. %__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
  220. %__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
  221. cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
  222. The directory %{_tl_texmfdist} is the texmf tree of the TeX Live
  223. distribution wide.
  224. You must not do any changes in this directory.
  225. EOF
  226. cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
  227. The directory %{_tl_texmfvine} is the texmf tree of our distribution wide.
  228. You should not use this directory to manage any other packages because
  229. we Project Vine use this directory to manage non-CTAN packages, some
  230. enhancement packages and so on.
  231. EOF
  232. cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
  233. The directory %{_tl_texmflocal} is the texmf tree of the system wide.
  234. If you are a privileged user of this system,
  235. you can use this directory to manage your local packages.
  236. EOF
  237. ## our texmf-dist/web2c/updmap{,-hdr}.cfg
  238. %__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
  239. %__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
  240. %__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
  241. ## our map files for dvipdfmx
  242. %__mkdir_p %{buildroot}%{_tl_aliasttfdir}
  243. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
  244. for x in ptex uptex otf otf-up; do
  245. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
  246. done
  247. for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
  248. touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
  249. done
  250. ## desktop things
  251. %__mkdir_p %{buildroot}%{_datadir}/applications
  252. # %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
  253. %__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
  254. # for created fonts
  255. %__mkdir_p %{buildroot}%{_tl_vartexfonts}
  256. # %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
  257. # %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
  258. ## set executable bit for the library
  259. %__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
  260. %__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
  261. # configure ConTeXt
  262. for x in context luatools texexec texmfstart; do
  263. %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
  264. done
  265. for x in contextjit; do
  266. %__sed -i -e 's|luajittex --luaonly|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; luajittex --luaonly|' %{buildroot}%{_bindir}/${x} || exit 1
  267. done
  268. # touch ghosts
  269. touch %{buildroot}%{_tl_texmfvine}/ls-R
  270. touch %{buildroot}%{_tl_texmfdist}/ls-R
  271. touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
  272. touch %{buildroot}%{_tl_texmfsysvar}/ls-R
  273. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
  274. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
  275. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
  276. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
  277. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
  278. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
  279. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
  280. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
  281. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
  282. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
  283. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
  284. #touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
  285. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
  286. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
  287. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
  288. ## remove unpackaging files
  289. find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
  290. find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
  291. %__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
  292. find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
  293. find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
  294. %__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
  295. %__rm -f %{buildroot}%{_infodir}/*
  296. ## use external packages
  297. %__rm %{buildroot}/usr/bin/latexmk || exit 1
  298. ### Files list
  299. find %{buildroot} -type f -or -type l | \
  300. %__sed -e "s|%{buildroot}||g" | \
  301. %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
  302. %__grep -v "%{_includedir}" | \
  303. %__grep -v "%{_libdir}" | \
  304. %__grep -v "%{_infodir}" | \
  305. %__sed -e "s|.*ls-R$|%ghost &|" \
  306. -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
  307. -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
  308. -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
  309. -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
  310. -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
  311. -e "s|.*\.cnf$|%config(noreplace) &|" \
  312. -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
  313. -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
  314. -e "s|^.*/updmap/$|%config &|" \
  315. -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
  316. -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
  317. -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
  318. -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
  319. -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
  320. -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
  321. -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
  322. -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
  323. -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
  324. -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
  325. -e "s|%{_mandir}/.*|&*|" \
  326. > %{_builddir}/filelist.full
  327. find %{buildroot}%{_tl_texmfvine}* -type d | \
  328. %__sed -e "s|^%{buildroot}|%dir |" \
  329. -e "s|$|/|" >> %{_builddir}/filelist.full
  330. ## subpackages
  331. %__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
  332. cat %{_builddir}/filelist.doc \
  333. %{_builddir}/filelist.full | \
  334. sort | uniq -u > %{_builddir}/filelist.tmp
  335. %__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
  336. %clean
  337. %__rm -rf %{buildroot}
  338. %pretrans
  339. rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012 -e 2013 -e 2014
  340. [ $? -eq 1 ] && exit 0
  341. _trans_time=$(date +%Y%m%d)
  342. echo "Running some transitional processes on your TeX system ... "
  343. x=(
  344. /usr/share/texmf-local
  345. /usr/share/texmf-var
  346. /usr/share/texmf-config
  347. )
  348. for dir in ${x[@]}; do
  349. _trans_dir=${dir}.${_trans_time}.rpmorig
  350. [ -d ${_trans_dir}.old ] && \
  351. echo -n " " && \
  352. echo "Found ${_trans_dir}.old: " && \
  353. echo -n " " && \
  354. %__rm -rvf ${_trans_dir}.old
  355. [ -d ${_trans_dir} ] && \
  356. echo -n " " && \
  357. echo "Found ${_trans_dir}: " && \
  358. echo -n " " && \
  359. %__mv -v ${_trans_dir} ${_trans_dir}.old
  360. [ -d ${dir} ] && \
  361. echo -n " " && \
  362. echo "Found ${dir}: " && \
  363. echo -n " " && \
  364. %__mv -v ${dir} ${_trans_dir}
  365. done
  366. echo "done."
  367. %postun
  368. if [ "$1" = 0 ]; then
  369. %__rm -rf %{_tl_vartexfonts}
  370. fi
  371. exit 0
  372. %post
  373. %_tl_touch_run texhash
  374. %_tl_touch_run updmap
  375. %_tl_touch_run mtxrun
  376. %_tl_touch_run fmtutil
  377. exit 0
  378. %posttrans
  379. %__mkdir_p %{_tl_vartexfonts}
  380. %__chmod 1777 %{_tl_vartexfonts}
  381. ## create our map files {ptex,uptex,otf,otf-up}-vine.map
  382. ( %{_tl_exec_upddeffont} ) ||:
  383. %{_tl_exec_texhash}
  384. %{_tl_exec_mtxrun}
  385. %{_tl_exec_updmap}
  386. %{_tl_exec_fmtutil}
  387. exit 0
  388. %post -n libkpathsea
  389. /sbin/ldconfig
  390. # for x in kpathsea tds web2c; do
  391. # /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
  392. # done
  393. # %preun -n libkpathsea
  394. # if [ "$1" = 0 ]; then
  395. # for x in kpathsea tds web2c; do
  396. # /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
  397. # done
  398. # fi
  399. %postun -n libkpathsea
  400. /sbin/ldconfig
  401. %post -n libptexenc
  402. /sbin/ldconfig
  403. %postun -n libptexenc
  404. /sbin/ldconfig
  405. %triggerin -- ghostscript
  406. %__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
  407. if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
  408. %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
  409. elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
  410. %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
  411. fi
  412. %_tl_touch_run texhash
  413. exit 0
  414. %files -f %{_builddir}/filelist.full
  415. %defattr(-,root,root)
  416. %{_libdir}/libtexlua52.so.*
  417. %{_libdir}/libtexluajit.so.*
  418. %dir %{_tl_aliasttfdir}
  419. %attr(1777,root,root) %dir %{_tl_vartexfonts}
  420. # %config %{_sysconfdir}/cron.daily/texlive.cron
  421. %exclude %{_includedir}/texlua52/*.h
  422. %exclude %{_includedir}/texlua52/*.hpp
  423. %exclude %{_includedir}/texluajit/*.h
  424. %exclude %{_includedir}/texluajit/*.hpp
  425. %exclude %{_libdir}/libtexlua52.so
  426. %exclude %{_libdir}/libtexluajit.so
  427. %exclude %{_libdir}/pkgconfig/texlua52.pc
  428. %exclude %{_libdir}/pkgconfig/texluajit.pc
  429. %files doc -f %{_builddir}/filelist.doc
  430. %defattr(-,root,root)
  431. %files -n libkpathsea
  432. %defattr(-,root,root)
  433. %{_libdir}/libkpathsea.so.*
  434. # %{_infodir}/kpathsea.info*
  435. %files -n libkpathsea-devel
  436. %defattr(-,root,root)
  437. %{_libdir}/libkpathsea.so
  438. %dir %{_includedir}/kpathsea
  439. %{_includedir}/kpathsea/*.h
  440. %{_libdir}/pkgconfig/kpathsea.pc
  441. %files -n libptexenc
  442. %defattr(-,root,root)
  443. %{_libdir}/libptexenc.so.*
  444. %files -n libptexenc-devel
  445. %defattr(-,root,root)
  446. %{_libdir}/libptexenc.so
  447. %dir %{_includedir}/ptexenc
  448. %{_includedir}/ptexenc/*.h
  449. %{_libdir}/pkgconfig/ptexenc.pc
  450. %files -n libsynctex
  451. %defattr(-,root,root)
  452. %{_libdir}/libsynctex.so.*
  453. %files -n libsynctex-devel
  454. %defattr(-,root,root)
  455. %{_libdir}/libsynctex.so
  456. %dir %{_includedir}/synctex
  457. %{_includedir}/synctex/*.h
  458. %{_libdir}/pkgconfig/synctex.pc
  459. %changelog
  460. * Tue May 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2016-2
  461. - texlive-20160510-source (TeX Live 2016/pretest)
  462. * Thu Apr 28 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2016-1
  463. - texlive-20160427-source (TeX Live 2016/pretest)
  464. * Thu Jan 21 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-5
  465. - fixed some development files
  466. * Tue Jan 12 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-4
  467. - reverted to texlive-20150521-source (TeX Live 2015)
  468. * Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-3
  469. - texlive-source-20160110 (TeX Live 2016/dev)
  470. * Sun May 24 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-2
  471. - texlive-source-20150523 (TeX Live 2015/pretest)
  472. - configure ConTeXt/LuaTeX+LuaJIT
  473. * Sun Apr 26 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-1
  474. - texlive-source-20150426 (TeX Live 2015/pretest)
  475. * Tue Dec 30 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-3
  476. - texlive-source-20141230 (TeX Live 2015/dev)
  477. * Thu Jul 3 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-2
  478. - texlive-source-20140525 + tlptexlive 20140507
  479. - dropped texlive-20140524-vine.patch: built with libpng >= 1.6
  480. * Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
  481. - upgrade to TeX Live 2014
  482. - texlive-source-20140524 + tlptexlive 20140507
  483. * Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2013-7
  484. - rebuild with poppler-0.24.5
  485. * Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-6
  486. - rebuilt
  487. * Fri Nov 1 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-5
  488. - texlive-source-20131101 2014/dev + tlptexlive 20130815
  489. - added BuildRequires: libpaper-devel >= 1.1.24-2 :-(
  490. * Mon Oct 7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
  491. - updated texlive-20131002-texmfcnf-vine.patch:
  492. texmf.cnf (shell_escape_commands): added some programs
  493. * Wed Oct 2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
  494. - texlive-source-20131002 2014/dev + tlptexlive 20130815
  495. - defined %%global __find_requires find-requires-texlive.sh
  496. - dropped unused dependencies of Requires
  497. * Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
  498. - texlive-source-20130919 2014/dev + tlptexlive 20130815
  499. - correct some scripts of README.vine for each texmf trees
  500. * Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
  501. - upgrade to TeX Live 2013
  502. - texlive-source-20130823 2014/dev + tlptexlive 20130815
  503. - dropped Requires: jvf
  504. * Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
  505. - update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
  506. - fixed duplicated lw35 for updmap.pl
  507. - updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
  508. * Sat Mar 9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
  509. - touch the map files generated by updmap-sys
  510. * Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
  511. - fixed Source7: updmap.cfg.texlive-20120701
  512. (upto /etc/texmf/web2c/updmap.cfg)
  513. - fixex %%triggerin -- ghostscript
  514. - replaced %%exec_texhash with %%touch_run texhash
  515. * Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
  516. - TeX Live 2012 + tlptexlive 20121107
  517. * Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
  518. - drop BR: poppler-devel temporaly
  519. - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
  520. * Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
  521. - build with poppler-0.18.4
  522. - remove tlmgr
  523. * Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
  524. - updated to tl11supp-120120
  525. - run %%{exec_fmtutil} at %%post when upgrading
  526. * Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
  527. - updated to tl11supp-111214
  528. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
  529. - added BuildRequires: texlive-common
  530. - Babel needs docstrip.tex, which is contained in texlive-collection-latex
  531. - check japanese.ldf
  532. - updated tl11supp-111120-vine.patch
  533. - added the following options to $$TL_CONFIGURE_ARGS:
  534. --disable-detex
  535. --disable-dvipng
  536. --disable-lcdf-typetools
  537. - remove some files of asymptote
  538. - remove a man file of latexmk
  539. - remove man files of lcdf-typetools
  540. - remove man files of dvipng
  541. - remove a man file of detex
  542. * Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
  543. - added find-provides-texlive.sh and set it to %%__find_provides
  544. - use to find library sonames for libkpathsea and libptexenc
  545. - added cmex.enc (%%{SOURCE110})
  546. - do not install cmex.enc in our TDS, yet
  547. - removed some unused directories in texmf/fonts/map
  548. - removed man files of lcdf-typetools
  549. - moved texdoc{,tk} and its related files to texlive-doc
  550. * Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  551. - TeX Live 2011 + tl11supp-111120
  552. * Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
  553. - make the directory VARTEXFONTS (%%posttrans)
  554. - dropped %%triggerpostun -- texlive < 2009-17vl6
  555. * Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
  556. - fixed ptexlive-20100711-dvipdfmx-vine.patch
  557. - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
  558. * Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
  559. - added %%pre to avoid conflictions of texmf-{config,var}
  560. * Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
  561. - dropped Requires: texlive-common
  562. - added perl-Tk-TableMatrix
  563. - supported texdoctk
  564. - removed broken symbolic links in /usr/bin
  565. - for each these symbolic links, the package of its real file/path
  566. should be its owner.
  567. * Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
  568. - added %%triggerpostun -- texlive < 2009-17vl6
  569. - make the directory VARTEXFONTS
  570. * Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
  571. - fixed %%dir VARTEXFONTS around in %%files
  572. - dropped BuildRequires: t1utils
  573. * Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
  574. - updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
  575. - changed VARTEXFONTS to /var/lib/texmf/fonts
  576. * Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
  577. - fixed updmap.cfg
  578. * Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
  579. - dropped Requires: texlive-macros
  580. * Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
  581. - updated ptexlive-20100711-pxdvik-vine.patch
  582. and added texlive-20091107-xdvik-vine.patch
  583. - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
  584. * Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
  585. - supported Vine Linux 5
  586. - for vl5, changed a requirement of Japanese VF package
  587. - added Requires: texlive-jvf = 2009 (vl5)
  588. - dropped dependencies of Provides:/Obsoletes: tags
  589. - merged these dependencies in texlive-common-vl.spec
  590. * Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
  591. - rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
  592. * Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
  593. - applied some security patches from Debian
  594. - texlive-2009-CVE-2010-0827.patch
  595. - texlive-2009-CVE-2010-1440.patch
  596. - applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
  597. - applied texlive-2009-luatexdir-libpoppler-0.12.patch
  598. based on texlive-2009-pdftexdir-libpoppler-0.12.patch
  599. - fixed some dependencies
  600. * Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
  601. - added BuildArch: noarch in %%package doc
  602. - removed some comment-out sentences
  603. * Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
  604. - separeted texmf-dist to texlive-common package
  605. * Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
  606. - unpacked texlive-20091107-source.tar.xz
  607. - babel is available now
  608. - applied eptex-100420 and some patches:
  609. - eptex-100420-vine.patch
  610. - eptex-100420-patch1.diff
  611. * Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
  612. - updated ptexlive-20100711
  613. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
  614. - customized updmap.cfg to correspond installed fonts
  615. * Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  616. - fixed insttexfont()
  617. * Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  618. - added jvf of MORISAWA basic 5 fonts
  619. - added cm-super, mathdesign in fntlst
  620. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  621. - define insttexfont() in %%install
  622. - copy almost compatible tetex-3.0
  623. * Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  624. - ptexlive-20090322 + TeXLive 2009
  625. - added BuildRequires: openssl-devel
  626. * Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
  627. - ptexlive-20091009 + TeXLive 2008