texlive-sources-vl.spec 3.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110
  1. ## -*- coding: utf-8-unix -*-
  2. %define texlivesrcver 20091107
  3. %define texlivever 20091107
  4. %define texlivedir %{_datadir}/texlive
  5. %define build_texlive_src %{buildroot}%{texlivedir}-sources
  6. %define pkgname texlive
  7. %define __find_provides %{nil}
  8. %define __find_requires %{nil}
  9. %define __perl_provides %{nil}
  10. %define __perl_requires %{nil}
  11. Summary: A collection of sources for TeX Live packages
  12. Summary(ja): TeX Live のソース集
  13. Name: texlive-sources
  14. Version: 2009
  15. Release: 2%{?_dist_release}
  16. License: distributable
  17. Group: Applications/Publishing
  18. URL: http://www.tug.org/texlive/
  19. ## original TeX Live sources
  20. Source1: ftp://tug.org/historic/systems/texlive/2009/%{pkgname}-%{texlivesrcver}-source.tar.xz
  21. Source2: ftp://tug.org/historic/systems/texlive/2009/%{pkgname}-%{texlivever}-texmf.tar.xz
  22. Source3: ftp://tug.org/historic/systems/texlive/2009/%{pkgname}-%{texlivever}-extra.tar.xz
  23. # Source4: ftp://tug.org/historic/systems/texlive/2009/%{name}-%{texlivever}-bin.tar.xz
  24. # ## from texlive2009.iso:/tlpkg/texlive.tlpdb
  25. # Source10: texlive2009.tlpdb
  26. %{?nosrc:NoSource: 1}
  27. %{?nosrc:NoSource: 2}
  28. %{?nosrc:NoSource: 3}
  29. BuildRequires: tar
  30. BuildRequires: xz
  31. BuildArch: noarch
  32. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. Packager: munepi
  36. %description
  37. This package is a collection of sources for TeX Live packages.
  38. It contains
  39. %{pkgname}-%{texlivesrcver}-source.tar.xz,
  40. %{pkgname}-%{texlivever}-texmf.tar.xz,
  41. %{pkgname}-%{texlivever}-extra.tar.xz
  42. on ftp://tug.org/historic/systems/texlive/2009/.
  43. This package is used to build texlive package and its related packages
  44. of Vine Linux.
  45. %description -l ja
  46. このパッケージは TeX Live のソース集です。
  47. ftp://tug.org/historic/systems/texlive/2009/ 上の
  48. %{pkgname}-%{texlivesrcver}-source.tar.xz,
  49. %{pkgname}-%{texlivever}-texmf.tar.xz,
  50. %{pkgname}-%{texlivever}-extra.tar.xz
  51. を含んでいます。
  52. このパッケージは Vine Linux の texlive パッケージやその関連パッケージを
  53. ビルドするために使われます。
  54. %prep
  55. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  56. %build
  57. %install
  58. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  59. %__mkdir_p %{build_texlive_src}
  60. (cd %{build_texlive_src}
  61. %__mkdir_p source || exit 1
  62. %__install -m0644 %{SOURCE1} source/ || exit 1
  63. %__tar Jxf %{SOURCE2} || exit 1
  64. %__mv %{pkgname}-%{texlivever}-texmf/* . || exit 1
  65. %__tar Jxf %{SOURCE3} || exit 1
  66. %__mv %{pkgname}-%{texlivever}-extra/* . || exit 1
  67. # %__mkdir_p tlpkg || exit 1
  68. # %__install -m0644 %{SOURCE10} tlpkg/texlive.tlpdb || exit 1
  69. %__rm -r %{pkgname}-%{texlivever}-{texmf,extra} || exit 1
  70. ## remove arch dependent binaries
  71. %__rm -f texmf-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
  72. )
  73. %clean
  74. %__rm -rf %{buildroot}
  75. %files
  76. %defattr(-,root,root)
  77. %{texlivedir}-sources
  78. %changelog
  79. * Sat Nov 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  80. - supported Vine Linux 5
  81. * Sun May 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  82. - TeX Live 2009