texlive-common-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140
  1. ## -*- coding: utf-8-unix -*-
  2. %bcond_with firstbuild
  3. %if %{?_dist_release} == "vl6"
  4. Provides: jadetex
  5. Obsoletes: jadetex tetex dvipdfmx xdvik xdvik-motif
  6. %endif
  7. %if %{?_dist_release} == "vl5"
  8. Provides: jadetex
  9. Conflicts: tetex dvipdfmx xdvik xdvik-motif jvf
  10. %endif
  11. Obsoletes: tetex-latex tetex-afm tetex-type1 tetex-devel
  12. Obsoletes: pTeX pLaTeX2e pLaTeX2e_Macros dvipsk
  13. Obsoletes: dvipdfm texmacro-aps
  14. Obsoletes: makejvf <= 1.1a
  15. Conflicts: task-texmacro-phys < 1.1
  16. %define tex_destdir %{_datadir}
  17. %define texmf %{tex_destdir}/texmf
  18. %define texlive_src %{tex_destdir}/texlive-sources
  19. %define build_tex_destdir %{buildroot}%{tex_destdir}
  20. %define build_texmf %{buildroot}%{texmf}
  21. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  22. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  23. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
  24. ## NOTE: For only texlive-common, if %exec_fmtutil fails,
  25. ## we show the STDERR of %exec_fmtutil.
  26. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null
  27. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  28. %define vartexfonts %{_var}/lib/texmf
  29. %define __find_provides %{nil}
  30. %define __find_requires %{nil}
  31. %define __perl_provides %{nil}
  32. %define __perl_requires %{nil}
  33. Autoreq: 0
  34. Summary: Common base for all TeX Live packages
  35. Summary(ja): TeX Live パッケージの共通ベース
  36. Name: texlive-common
  37. Version: 2009
  38. Release: 3%{?_dist_release}
  39. License: distributable
  40. Group: Applications/Publishing
  41. URL: http://www.tug.org/texlive/
  42. Requires(pre): texlive-collection-basic = %{version}
  43. Requires(pre): texlive-collection-latex = %{version}
  44. Requires(pre): texlive-collection-latexrecommended = %{version}
  45. Requires(pre): texlive-collection-fontsrecommended = %{version}
  46. #### $ pdftex -ini -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini
  47. ## dehypht-x-2009-06-19.tex
  48. Requires(pre): texlive-collection-langgerman = %{version}
  49. ## catkoi
  50. Requires(pre): texlive-collection-langcyrillic = %{version}
  51. #### $ xetex -ini -jobname=xelatex -progname=xelatex -etex xelatex.ini
  52. ## unicode-letters
  53. Requires(pre): texlive-collection-xetex = %{version}
  54. BuildArch: noarch
  55. Buildroot: %{_tmppath}/%{name}-%{version}-root
  56. Vendor: Project Vine
  57. Distribution: Vine Linux
  58. Packager: munepi
  59. %description
  60. The TeX Live software distribution offers a complete TeX system for a
  61. variety of Unix, Macintosh, Windows and other platforms. It
  62. encompasses programs for editing, typesetting, previewing and printing
  63. of TeX documents in many different languages, and a large collection
  64. of TeX macros and font libraries.
  65. The distribution includes extensive general documentation about TeX,
  66. as well as the documentation for the included software packages.
  67. This package is a virtual package
  68. to provide a common base for all TeX Live packages.
  69. %description -l ja
  70. TeX Live ソフトウェアディストリビューションは、
  71. さまざまな Unix, Macintosh, Windows、および
  72. 他のプラットホームに対して完全な TeX システムを提供します。
  73. 多くの異なった言語を含む TeX ドキュメントの
  74. 編集、組版、閲覧、印刷するためのプログラム、
  75. そして、TeX マクロやフォントライブラリの大きなコレクションを
  76. 同梱しています。
  77. このディストリビューションは
  78. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  79. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  80. このパッケージは TeX Live パッケージの共通ベースを
  81. 提供ための仮想パッケージです。
  82. %files
  83. %post
  84. %{exec_texhash}
  85. echo -n " "
  86. echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
  87. rm -f %{texmf}/updmap.lock
  88. echo -n " "
  89. echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
  90. exit 0
  91. # %postun
  92. # %{exec_texhash}
  93. # echo -n " "
  94. # echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
  95. # echo -n " "
  96. # echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
  97. exit 0
  98. %changelog
  99. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  100. - added to remove %%{texmf}/updmap.lock in %%post
  101. - When texlive-common is installed, this lock generating
  102. texlive-collection-* leaves.
  103. - dropped %%postun
  104. - added some comments for the definition of %%exec_fmtutil
  105. * Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  106. - changed Requires: -> Requires(pre): for all requirements
  107. - merged dependencies of Provides:/Obsoletes: tags from texlive-vl.spec
  108. * Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  109. - TeX Live 2009