libffi-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define name libffi
  3. %define version 3.0.13
  4. %define release 1%{?_dist_release}
  5. Summary: Foreign function interface library
  6. Summary(ja): Foreign function interface ライブラリ
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. Source0: ftp://sourceware.org/pub/libffi/%{name}-%{version}.tar.gz
  11. License: Distributable
  12. Group: System Environment/Libraries
  13. URL: http://sourceware.org/libffi/
  14. BuildRequires: gcc
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. %description
  19. A foreign function interface is the popular name for the interface
  20. that allows code written in one language to call code written in
  21. another language.
  22. %description -l ja
  23. Foreign function interface は一般に普及しているインターフェイスで、
  24. ある言語で書かれたコードから、他の言語で書かれたコードを呼び出すこ
  25. とを可能にします。
  26. #-----------------------------------------------------------------------------
  27. %package devel
  28. Summary: Libraries and headers for %{name}
  29. Summary(ja): %{name} 用の開発ライブラリおよびヘッダファイル
  30. Group: Development/Libraries
  31. Requires: %{name} = %{version}
  32. Requires: pkgconfig
  33. %description devel
  34. This package includes the files needed for developing and compiling
  35. applications which use the ffi library.
  36. You should install the libffi-devel package if you would like to
  37. develop applications using libffi.
  38. %description devel -l ja
  39. このパッケージは ffi ライブラリを使用するアプリケーションを開発
  40. するのに必要なライブラリやヘッダファイルを含んでいます。
  41. libffi を使用したアプリケーションを開発するなら、このパッケージ
  42. をインストールしてください。
  43. #compat32
  44. %package -n compat32-%{name}
  45. Summary: Foreign function interface library
  46. Summary(ja): Foreign function interface ライブラリ
  47. Group: System Environment/Libraries
  48. Requires: %{name} = %{version}
  49. %description -n compat32-%{name}
  50. A foreign function interface is the popular name for the interface
  51. that allows code written in one language to call code written in
  52. another language.
  53. %description -n compat32-%{name} -l ja
  54. Foreign function interface は一般に普及しているインターフェイスで、
  55. ある言語で書かれたコードから、他の言語で書かれたコードを呼び出すこ
  56. とを可能にします。
  57. %package -n compat32-%{name}-devel
  58. Summary: Libraries and headers for %{name}
  59. Summary(ja): %{name} 用の開発ライブラリおよびヘッダファイル
  60. Group: Development/Libraries
  61. Requires: compat32-%{name} = %{version}
  62. Requires: %{name}-devel = %{version}
  63. %description -n compat32-%{name}-devel
  64. This package includes the files needed for developing and compiling
  65. applications which use the ffi library.
  66. You should install the libffi-devel package if you would like to
  67. develop applications using libffi.
  68. %description -n compat32-%{name}-devel -l ja
  69. このパッケージは ffi ライブラリを使用するアプリケーションを開発
  70. するのに必要なライブラリやヘッダファイルを含んでいます。
  71. libffi を使用したアプリケーションを開発するなら、このパッケージ
  72. をインストールしてください。
  73. #-----------------------------------------------------------------------------
  74. %prep
  75. %setup -q
  76. %build
  77. %configure
  78. %{__make}
  79. %install
  80. %{__rm} -rf ${RPM_BUILD_ROOT}
  81. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  82. # move include files.
  83. %{__mv} ${RPM_BUILD_ROOT}/%{_libdir}/libffi-%{version}/include ${RPM_BUILD_ROOT}/%{_includedir}
  84. sed -i -e "s|^includedir=.*include$|includedir=%{_includedir}|" \
  85. ${RPM_BUILD_ROOT}/%{_libdir}/pkgconfig/libffi.pc
  86. # remove unnecessary files.
  87. %{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/libffi.la
  88. %{__rm} -rf ${RPM_BUILD_ROOT}/%{_infodir}/dir
  89. %clean
  90. %{__rm} -rf ${RPM_BUILD_ROOT}
  91. %post -p /sbin/ldconfig
  92. %postun -p /sbin/ldconfig
  93. %files
  94. %defattr(-,root,root)
  95. %doc ChangeLog* LICENSE README
  96. %{_libdir}/libffi.so.*
  97. %{_infodir}/libffi.info*
  98. %{_mandir}/man3/ffi.3*
  99. %{_mandir}/man3/ffi_call.3*
  100. %{_mandir}/man3/ffi_prep_cif.3*
  101. %{_mandir}/man3/ffi_prep_cif_var.3*
  102. %files devel
  103. %defattr(-,root,root)
  104. %{_libdir}/pkgconfig/*
  105. %{_libdir}/libffi.a
  106. %{_libdir}/libffi.so
  107. %{_includedir}/*.h
  108. # compat32
  109. %if %{build_compat32}
  110. %files -n compat32-%{name}
  111. %defattr(-,root,root)
  112. %{_libdir}/libffi.so.*
  113. %files -n compat32-%{name}-devel
  114. %defattr(-,root,root)
  115. %{_libdir}/libffi.so
  116. %endif
  117. %changelog
  118. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.13-1
  119. - update to 3.0.13
  120. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-4
  121. - create compat32 sub packages
  122. * Fri Nov 26 2010 Shu KONNO <owa@bg.wakwak.com> 3.0.9-3
  123. - fixed includedir in libffi.pc
  124. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 3.0.9-2
  125. - build with rpm-4.8.1-1 for pkg-config file
  126. * Tue Feb 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.0.9-1
  127. - new upstream release
  128. - built with new toolchain
  129. * Wed Jan 21 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.8-1
  130. - new upstream release
  131. - spec in UTF-8
  132. * Thu Apr 17 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.0.5-1
  133. - updated to new upstream release
  134. * Wed Apr 02 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.0.4-1
  135. - apply new versioning policy
  136. * Sun Mar 02 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.0.4-0vl1
  137. - initial build for Vine Linux