cmake-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233
  1. # Set to bcond_without or use --with bootstrap if bootstrapping a new release
  2. # or architecture
  3. %bcond_with bootstrap
  4. # Set to bcond_with or use --without gui to disable qt4 gui build
  5. %bcond_without gui
  6. Name: cmake
  7. Summary: Cross-platform make system
  8. Summary(ja): クロスプラットフォームな Make システム
  9. Version: 2.8.12.1
  10. Release: 2%{?_dist_release}
  11. Group: Development/Tools
  12. License: BSD
  13. URL: http://www.cmake.org/
  14. Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
  15. Source1: macros.cmake
  16. # Patch to find DCMTK in Fedora (bug #720140)
  17. Patch0: cmake-dcmtk.patch
  18. Patch1: cmake-2.8.12.1-FindFreetype.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: curl-devel
  21. BuildRequires: expat-devel
  22. BuildRequires: gcc-gfortran
  23. BuildRequires: libarchive-devel
  24. BuildRequires: libidn-devel
  25. BuildRequires: ncurses-devel
  26. BuildRequires: openssl-devel
  27. BuildRequires: zlib-devel
  28. %if %{with gui}
  29. BuildRequires: qt4-devel, desktop-file-utils
  30. %define qt_gui --qt-gui
  31. %else
  32. %define qt_gui --no-qt-gui
  33. %endif
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. %description
  37. CMake is used to control the software compilation process using simple
  38. platform and compiler independent configuration files. CMake generates
  39. native makefiles and workspaces that can be used in the compiler
  40. environment of your choice. CMake is quite sophisticated: it is possible
  41. to support complex environments requiring system configuration, pre-processor
  42. generation, code generation, and template instantiation.
  43. %package gui
  44. Summary: Qt GUI for %{name}
  45. Group: Development/Tools
  46. Requires: %{name} = %{version}-%{release}
  47. Requires(post): desktop-file-utils, shared-mime-info
  48. Requires(postun): desktop-file-utils, shared-mime-info
  49. %description gui
  50. The %{name}-gui package contains the Qt based GUI for CMake.
  51. %prep
  52. %setup -q
  53. %patch0 -p1 -b .dcmtk
  54. %patch1 -p1 -b .freetype2
  55. # Fixup permissions
  56. #find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
  57. #fix desktop file warning
  58. sed -i 's:\(Icon=\)\(CMakeSetup32.png\):\1/usr/share/pixmaps/\2:' Source/QtDialog/CMake.desktop
  59. %build
  60. ./bootstrap \
  61. --prefix=%{_prefix} \
  62. --datadir=/share/%{name} \
  63. --mandir=/share/man \
  64. --%{?with_bootstrap:no-}system-libs \
  65. %{?qt_gui}
  66. sed -i 's/-lcurses/-lcurses -ltinfo/' Source/CMakeFiles/ccmake.dir/link.txt
  67. %if %{?_dist_release} == "vl5"
  68. sed -i 's/HAVE_SYS_WAIT_H:INTERNAL=/HAVE_SYS_WAIT_H:INTERNAL=1/' CMakeCache.txt
  69. %endif
  70. make VERBOSE=1 %{?_smp_mflags}
  71. %install
  72. rm -rf $RPM_BUILD_ROOT
  73. make install DESTDIR=$RPM_BUILD_ROOT
  74. find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
  75. rm -rf $RPM_BUILD_ROOT/usr/doc
  76. # RPM macros
  77. install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  78. sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  79. touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  80. %if %{with gui}
  81. # Desktop file
  82. desktop-file-install --delete-original \
  83. --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
  84. $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
  85. %endif
  86. %clean
  87. rm -rf $RPM_BUILD_ROOT
  88. %if %{with gui}
  89. %post gui
  90. update-desktop-database &> /dev/null || :
  91. update-mime-database %{_datadir}/mime &> /dev/null || :
  92. %postun gui
  93. update-desktop-database &> /dev/null || :
  94. update-mime-database %{_datadir}/mime &> /dev/null || :
  95. %endif
  96. %files
  97. %defattr(-,root,root)
  98. %doc CMakeLogo.gif ChangeLog.* Copyright.txt
  99. %doc Docs/*
  100. %doc Example/
  101. %config(noreplace) %{_sysconfdir}/rpm/macros.cmake
  102. %{_bindir}/ccmake
  103. %{_bindir}/cmake
  104. %{_bindir}/cpack
  105. %{_bindir}/ctest
  106. %{_datadir}/%{name}/
  107. %{_datadir}/aclocal/cmake.m4
  108. %{_mandir}/man1/*
  109. %if %{with gui}
  110. %files gui
  111. %defattr(-,root,root,-)
  112. %{_bindir}/cmake-gui
  113. %{_datadir}/applications/CMake.desktop
  114. %{_datadir}/mime/packages/cmakecache.xml
  115. %{_datadir}/pixmaps/CMakeSetup32.png
  116. %endif
  117. %changelog
  118. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-2
  119. - rebuild with libarchive-3.1.2
  120. * Mon Dec 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-1
  121. - new upstream release
  122. - add Patch1 (cmake-2.8.12.1-FindFreetype.patch)
  123. * Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11.2-1
  124. - new upstream release
  125. * Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11-1
  126. - new upstream release
  127. * Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10.2-1
  128. - new upstream release
  129. - fixed desktop file warning
  130. * Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
  131. - rebuild with libarchive-3.0.4
  132. * Sat Nov 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.6-1
  133. - new upstream release
  134. - forced to link with libtinfo.so (ccmake)
  135. - used --system-libs again
  136. * Sat Jan 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
  137. - new upstream release
  138. - used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
  139. * Sun Sep 5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
  140. - fixed typo (not --with-system-libs, but --system-libs)
  141. - added BR: curl-devel, expat-devel, zlib-devel
  142. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
  143. - add BuildRequires: ncurses-devel
  144. * Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
  145. - generate gui package
  146. - renamed module directory
  147. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
  148. - new upstream release
  149. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
  150. - rebuilt with new toolchain
  151. * Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
  152. - imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
  153. * Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
  154. - new upstream release
  155. - added Vendor/Distribution tag
  156. * Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
  157. - new upstream release
  158. * Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
  159. - new upstream release
  160. * Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
  161. - new upstream release
  162. * Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
  163. - new upstream release
  164. * Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
  165. - new upstream release
  166. - drop Patch100
  167. - use bootstrap script instead of configure
  168. - delete caches from %%doc
  169. * Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
  170. - rebuilt with new toolchain
  171. * Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
  172. - new upstream release
  173. - delete duped docs
  174. * Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
  175. - added Patch100 (especially for ppc to solve ppc/powerpc issue)
  176. * Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
  177. - source version up
  178. * Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
  179. - initial build for Vine Linux