sqlite-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165
  1. %define name sqlite
  2. %define version 2.8.17
  3. %define release 4%{?_dist_release}
  4. Name: %{name}
  5. Summary: SQLite is a C library that implements an embeddable SQL database engine
  6. Summary(ja): SQLite は組み込み型SQLデータベースエンジンを実装するCライブラリです。
  7. Version: %{version}
  8. Release: %{release}
  9. Group: System Environment/Libraries
  10. URL: http://www.sqlite.org
  11. License: Public Domain
  12. Source: %{name}-%{version}.tar.gz
  13. Patch0: %{name}-2.8.15-ja-patch
  14. Patch1: %{name}-2.8.14-lib64.patch.bz2
  15. Patch2: %{name}-64bit-fixes.patch.bz2
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: tcl-devel, chrpath, ncurses-devel, readline-devel
  18. %description
  19. SQLite is a C library that implements an embeddable SQL database engine.
  20. Programs that link with the SQLite library can have SQL database access
  21. without running a separate RDBMS process. The distribution comes with a
  22. standalone command-line access program (sqlite) that can be used to
  23. administer an SQLite database and which serves as an example of how to
  24. use the SQLite library.
  25. %description -l ja
  26. SQLite は組み込み型SQLデータベースエンジンを実装するCライブラリです。
  27. SQLiteライブラリにリンクされたプログラムではSQLデータベースアクセスが
  28. できるようになります。その際、別のRDBMSプロセスは不要です。
  29. %package devel
  30. Summary: Header files and libraries for developing apps which will use sqlite
  31. Summary(ja): SQLiteを使ってアプリを開発するためのヘッダファイルやライブラリ
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. %description devel
  35. The sqlite-devel package contains the header files and libraries needed
  36. to develop programs that use the sqlite database library.
  37. %description devel -l ja
  38. qlite-develパッケージはSQLiteデータベースライブラリを使ってプログラムを
  39. 開発するために必要なヘッダファイルやライブラリを含んでいます。
  40. %package static-devel
  41. Summary: Static development library for the SQLite library
  42. Summary(ja): SQLiteライブラリのstaticな開発用ライブラリ
  43. Group: Development/Libraries
  44. Requires: %{name}-devel = %{version}-%{release}
  45. Provides: %{name}-static-devel = %{version}-%{release}
  46. %description static-devel
  47. The sqlite-static-devel package contains the static header files
  48. and libraries needed to develop programs that use the sqlite database library.
  49. %description static-devel -l ja
  50. sqlite-static-develはSQLiteデータベースライブラリを使ってプログラムを開発する時に必要なstaticなヘッダファイルとライブラリを含んでいます
  51. %package tools
  52. Summary: Command line tools for managing the sqlite library.
  53. Summary(ja): SQLiteライブラリを管理するコマンドラインツール
  54. Group: Applications/Databases
  55. Requires: %{name} = %{version}-%{release}
  56. %description tools
  57. The sqlite-tool package contains command line tools for managing
  58. the sqlite library.
  59. %description tools -l ja
  60. sqlite-toolはSQLiteライブラリを管理するコマンドラインツールです。
  61. %prep
  62. %setup -q
  63. %patch0 -p0 -b .jp
  64. %patch1 -p0 -b .lib64
  65. %patch2 -p1 -b .64bit-fixes
  66. %build
  67. CFLAGS="%optflags -DNDEBUG=1" CXXFLAGS="%optflags -DNDEBUG=1" %configure -enable-utf8
  68. make
  69. make doc
  70. %install
  71. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  72. install -d %{buildroot}%{_bindir}
  73. install -d %{buildroot}%{_includedir}
  74. install -d %{buildroot}%{_libdir}
  75. install -d %{buildroot}%{_mandir}/man1
  76. %makeinstall
  77. install -m644 sqlite.1 %{buildroot}%{_mandir}/man1/
  78. chrpath -d %{buildroot}%{_bindir}/*
  79. ## remove unuse files
  80. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  81. %clean
  82. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  83. %post -p /sbin/ldconfig
  84. %postun -p /sbin/ldconfig
  85. %files
  86. %defattr(-, root, root)
  87. %doc README
  88. %{_libdir}/*.so.*
  89. %files devel
  90. %defattr(-, root, root)
  91. %doc doc/*.html doc/*.png
  92. %{_libdir}/*.a
  93. #%{_libdir}/*.la
  94. %{_libdir}/lib*.so
  95. %{_includedir}/*.h
  96. %{_libdir}/pkgconfig/*.pc
  97. %files static-devel
  98. %defattr(-, root, root)
  99. %{_libdir}/lib*.a
  100. %files tools
  101. %defattr(-, root, root)
  102. %{_bindir}/*
  103. %{_mandir}/man1/*
  104. %changelog
  105. * Sun Mar 22 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.8.17-4
  106. - rebuilt with readline 6.3
  107. - changed BuildRequires: tcl-devel instead of tcl
  108. * Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.17-3
  109. - rebuild with VineSeed environment
  110. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.17-2
  111. - rebuilt with rpm-4.8.1 for pkg-config
  112. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.8.17-1vl5
  113. - applied new versioning policy, spec in utf-8
  114. - removed *.la
  115. * Mon May 08 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.17-0vl1
  116. - updated to 2.8.17
  117. - changed Group:
  118. - run /sbin/ldconfig at %post, %postun
  119. * Mon Nov 08 2004 Satoshi MACHINO <machino@vinelinux.org> 2.8.15-0vl2
  120. - added BuildRequires: chrpath, ncurses-devel, readline-devel
  121. - separated sub packages to static-devel, tool
  122. - added ja subscription
  123. * Tue Aug 17 2004 HOTTA Michihide <hotta@net-newbie.com> 2.8.15-0vl1
  124. - add BuildRequires: tcl
  125. - upstream release
  126. * Tue Nov 11 2003 HOTTA Michihide <hotta@net-newbie.com> 2.8.6-0vl1
  127. - 1st release