rubygem-asciidoctor-vl.spec 7.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240
  1. %bcond_with test
  2. %global gem_name asciidoctor
  3. %global mandir %{_mandir}/man1
  4. %define pre %nil
  5. %global gittag v%{version}%{pre}
  6. Summary: A fast, open source AsciiDoc implementation in Ruby
  7. Name: rubygem-%{gem_name}
  8. Version: 2.0.16
  9. Release: 1%{?_dist_release}
  10. Group: publishing
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: MIT
  14. URL: https://asciidoctor.org
  15. Source0: https://github.com/asciidoctor/asciidoctor/archive/%{gittag}/%{gem_name}-%{version}%{pre}.tar.gz
  16. Requires: ruby(rubygems)
  17. BuildRequires: ruby-rubygems-devel
  18. BuildRequires: ruby(rubygems)
  19. %if %{with test}
  20. BuildRequires: rubygem(coderay)
  21. BuildRequires: rubygem(concurrent-ruby)
  22. BuildRequires: rubygem(erubi)
  23. BuildRequires: rubygem(haml)
  24. BuildRequires: rubygem(minitest)
  25. BuildRequires: rubygem(nokogiri)
  26. BuildRequires: rubygem(rouge)
  27. BuildRequires: rubygem(slim)
  28. BuildRequires: rubygem(tilt)
  29. %endif
  30. BuildArch: noarch
  31. Provides: asciidoctor = %{version}
  32. %if 0%{?el6} || 0%{?el7}
  33. Provides: rubygem(%{gem_name}) = %{version}
  34. %endif
  35. %description
  36. A fast, open source text processor and publishing toolchain, written in Ruby,
  37. for transforming AsciiDoc markup into HTML 5, DocBook 4.5, DocBook 5.0 and
  38. custom output formats. The transformation from AsciiDoc to custom output
  39. formats is performed by running the nodes in the parsed document tree through a
  40. collection of templates written in a template language supported by Tilt.
  41. %package doc
  42. Summary: Documentation for %{name}
  43. Group: documentation
  44. Requires: %{name} = %{version}-%{release}
  45. BuildArch: noarch
  46. %description doc
  47. Documentation for %{name}
  48. %prep
  49. %autosetup -n %{gem_name}-%{version}%{pre} -p1
  50. # Include tests in the gem, they're disabled by default
  51. sed -i -e 's/#\(s\.test_files\)/\1/' %{gem_name}.gemspec
  52. # Fix shebang (avoid Requires: /usr/bin/env)
  53. sed -i -e 's|#!/usr/bin/env ruby|#!/usr/bin/ruby|' bin/%{gem_name}
  54. %build
  55. gem build %{gem_name}.gemspec
  56. #gem_install -n %{gem_name}-%{version}%{pre}.gem
  57. %if %{with test}
  58. %check
  59. pushd .%{gem_instdir}
  60. LANG=C.UTF-8 ruby -I"lib:test" -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
  61. popd
  62. %endif
  63. %install
  64. %{__rm} -rf %{buildroot}
  65. %gem_install -d %{buildroot}%{gem_current_dir}
  66. mkdir -p %{buildroot}%{_bindir}
  67. cp -a %{buildroot}%{gem_instdir}/bin/* \
  68. %{buildroot}%{_bindir}/
  69. mkdir -p %{buildroot}%{mandir}
  70. cp -a %{buildroot}%{gem_instdir}/man/*.1 \
  71. %{buildroot}%{mandir}/
  72. %files
  73. %{!?_licensedir:%global license %%doc}
  74. %dir %{gem_instdir}
  75. %exclude %{gem_cache}
  76. %exclude %{gem_instdir}/asciidoctor.gemspec
  77. %exclude %{gem_instdir}/man
  78. %exclude %{gem_instdir}/test
  79. %exclude %{gem_instdir}/features
  80. %license %{gem_instdir}/LICENSE
  81. %doc %{gem_instdir}/CHANGELOG.adoc
  82. %doc %{gem_instdir}/README.*
  83. %lang(de) %doc %{gem_instdir}/README-de.*
  84. %lang(fr) %doc %{gem_instdir}/README-fr.*
  85. %lang(ja) %doc %{gem_instdir}/README-jp.*
  86. %lang(zh_CN) %doc %{gem_instdir}/README-zh_CN.*
  87. %{gem_instdir}/data
  88. %{_bindir}/*
  89. %{gem_current_dir}/bin/*
  90. %{gem_instdir}/bin
  91. %{gem_libdir}
  92. %{mandir}/*
  93. %{gem_spec}
  94. %files doc
  95. %doc %{gem_docdir}
  96. %changelog
  97. * Tue Oct 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.0.16-1
  98. - new upstream release.
  99. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.0.12-2
  100. - initial build for Vine Linux.
  101. * Wed Jan 27 2021 Pavel Valena <pvalena@redhat.com> - 2.0.12-1
  102. - Update to asciidoctor 2.0.12.
  103. Resolves: rhbz#1893940
  104. * Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.10-5
  105. - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
  106. * Wed Aug 19 2020 Vít Ondruch <vondruch@redhat.com> - 2.0.10-4
  107. - Replace build time Erubis dependency by Erubi.
  108. * Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.10-3
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  110. * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.10-2
  111. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  112. * Sun Sep 22 2019 Todd Zullinger <tmz@pobox.com> - 2.0.10-1
  113. - Update to Asciidoctor 2.0.10
  114. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.8-2
  115. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  116. * Tue Mar 19 2019 Todd Zullinger <tmz@pobox.com> - 1.5.8-1
  117. - Update to Asciidoctor 1.5.8 (resolves CVE-2018-18385)
  118. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.6.1-6
  119. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  120. * Sun Nov 18 2018 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1.5.6.1-5
  121. - Use C.UTF-8 locale
  122. See https://fedoraproject.org/wiki/Changes/Remove_glibc-langpacks-all_from_buildroot
  123. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.6.1-4
  124. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  125. * Wed May 23 2018 Vít Ondruch <vondruch@redhat.com> - 1.5.6.1-3
  126. - Enable entire test suite.
  127. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.6.1-2
  128. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  129. * Thu Aug 24 2017 Fabio Alessandro Locati <fale@fedoraproject.org> - 1.5.6.1-1
  130. - Update to Asciidoctor 1.5.6.1
  131. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.5-3
  132. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  133. * Mon Jun 05 2017 Vít Ondruch <vondruch@redhat.com> - 1.5.5-2
  134. - Fix FTBFS.
  135. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.5-2
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  137. * Fri Oct 14 2016 Fabio Alessandro Locati <fale@fedoraproject.org> - 1.5.5-1
  138. - Update to Asciidoctor 1.5.5
  139. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.4-2
  140. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  141. * Tue Jan 05 2016 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.4-1
  142. - Update to Asciidoctor 1.5.4 (rhbz#1295758)
  143. - Use %%license macro
  144. - Drop unnecessary "-p" flag to cp during %%install ("-a" already preserves
  145. timestamps)
  146. * Mon Nov 02 2015 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.3-1
  147. - Update to Asciidoctor 1.5.3 (rhbz#1276851)
  148. - Drop Fedora 19 and 20 macros (these distros are EOL)
  149. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2-2
  150. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  151. * Fri Dec 05 2014 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.2-1
  152. - Update to Asciidoctor 1.5.2
  153. * Fri Sep 19 2014 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.1-1
  154. - Update to Asciidoctor 1.5.1
  155. * Tue Sep 09 2014 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.0-1
  156. - Update to Asciidoctor 1.5.0 final
  157. * Fri Jun 06 2014 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.0-0.4.preview.7
  158. - Add %%{version} number to Provides: asciidoctor
  159. * Fri Jun 06 2014 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.0-0.3.preview.7
  160. - Provide: asciidoctor
  161. https://github.com/asciidoctor/rubygem-asciidoctor-rpm/issues/5
  162. * Tue May 20 2014 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.0-0.2.preview.7
  163. - Update to Asciidoctor 0.1.5.preview.7
  164. - Drop unused patch
  165. * Thu May 15 2014 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.0-0.1.preview.6
  166. - Update to Asciidoctor 0.1.5.preview.6
  167. - Use HTTPS URLs
  168. - Support Minitest 5
  169. - Adjustments for https://fedoraproject.org/wiki/Changes/Ruby_2.1
  170. - Mark CHANGELOG, LICENSE, READMEs as %%doc
  171. - Remove Rakefile in %%prep
  172. - Remove Requires: /usr/bin/env
  173. * Sun Sep 22 2013 Dan Allen <dan.j.allen@gmail.com> - 0.1.4-1
  174. - Update to Asciidoctor 0.1.4
  175. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.3-2
  176. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  177. * Sat Jun 08 2013 Dan Allen <dan.j.allen@gmail.com> - 0.1.3-1
  178. - Update to Asciidoctor 0.1.3
  179. * Fri Mar 01 2013 Dan Allen <dan.j.allen@gmail.com> - 0.1.1-1
  180. - Initial package