python-pyxml-vl.spec 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126
  1. %define module PyXML
  2. #%define pyver %(python -c 'import sys;print(sys.version[0:3])')
  3. #%define pysite %{_libdir}/python%{pyver}/site-packages
  4. %define pyinc %{_includedir}/python%{pyver}
  5. Summary: XML libraries for python
  6. Summary(ja): Python XML ライブラリ
  7. Name: python-pyxml
  8. Version: 0.8.4
  9. Release: 5%{?_dist_release}
  10. URL: http://pyxml.sourceforge.net/
  11. Source0: http://prdownloads.sourceforge.net/pyxml/PyXML-%{version}.tar.gz
  12. Patch0: PyXML-0.7.1-intern.patch
  13. Patch1: PyXML-0.8.4-cvs20041111-python2.4-backport.patch
  14. Patch2: PyXML-memmove.patch
  15. Patch3: PyXML-0.8.4-python2.6.patch
  16. License: Apacheish
  17. Group: Development/Libraries
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: python-devel, expat-devel
  20. BuildRequires: python-setuptools
  21. Requires: python, libexpat
  22. Obsoletes: %{module}
  23. Provides: %{module}
  24. %description
  25. An XML package for Python. The distribution contains a validating XML
  26. parser, an implementation of the SAX and DOM programming interfaces
  27. and an interface to the Expat parser.
  28. %prep
  29. %setup -q -n %{module}-%{version}
  30. %patch0 -p1 -b .intern
  31. %patch1 -p1 -b .python2.4-backport
  32. %patch2 -p1
  33. %patch3 -p1
  34. # iconv to use utf8
  35. for file in CREDITS ANNOUNCE doc/xml-howto.txt doc/xml-ref.txt README; do
  36. iconv -f iso8859-1 -t utf-8 -o tmp $file
  37. mv tmp $file
  38. done
  39. %build
  40. CFLAGS="%{optflags}" \
  41. %{_bindir}/python -c 'import setuptools; execfile("setup.py")' build --with-libexpat=%{_prefix}
  42. %install
  43. %__rm -rf %{buildroot}
  44. %{_bindir}/python -c 'import setuptools; execfile("setup.py")' install --skip-build install --root=%{buildroot}
  45. %{_bindir}/python -O %{_libdir}/python%{pyver}/compileall.py \
  46. %{buildroot}%{python_sitearch}
  47. %clean
  48. %__rm -rf %{buildroot}
  49. %files
  50. %defattr(-,root,root)
  51. %doc LICENCE ANNOUNCE CREDITS README README.* TODO doc/*
  52. %{_bindir}/*
  53. %{python_sitearch}/*
  54. %changelog
  55. * Sat Jun 06 2009 Shu KONNO <owa@bg.wakwak.com> 0.8.4-5
  56. - rebuilt with python-2.6
  57. - added Patch0-4 from Fedora
  58. * Wed Dec 24 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 0.8.4-12
  59. - Patch for 'as' reserved keyword (bug #477783)
  60. * Thu Jul 27 2006 Florian La Roche <laroche@redhat.com> - 0.8.4-4
  61. - don't check memmove
  62. * Thu Nov 11 2004 Miloslav Trmac <mitr@redhat.com> - 0.8.4-0.cvs20041111.1
  63. - Backport xml.sax.saxutils fix from Python 2.4b2
  64. * Fri Jun 28 2002 Trond Eivind Glomsrød <teg@redhat.com>
  65. - A fix for the expatreader
  66. * Sat Jun 06 2009 Shu KONNO <owa@bg.wakwak.com> 0.8.4-4
  67. - spec in utf-8 properly
  68. - use rpm macros: pyver, python_sitearch
  69. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.8.4-3vl5
  70. - rebuilt with python-2.5.2
  71. - applied new versioning policy and spec in utf-8
  72. * Wed Feb 27 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.8.4-2vl3
  73. - rebuild with expat-2.0.1
  74. * Mon May 8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.4-2vl2
  75. - fixed Japanese summary
  76. - changed Group:
  77. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.4-2vl1
  78. - initial build for Vine Linux
  79. * Wed May 4 2005 Gotz Waschk <waschk@mandriva.org> 0.8.4-2mdk
  80. - use external libexpat
  81. - enable xpath and xslt
  82. * Thu Dec 16 2004 Guillaume Rousse <guillomovitch@mandrake.org> 0.8.4-1mdk
  83. - new version
  84. - changed name
  85. * Sun Dec 05 2004 Michael Scherer <misc@mandrake.org> 0.8.3-4mdk
  86. - Rebuild for new python
  87. * Mon Nov 01 2004 Michael Scherer <misc@mandrake.org> 0.8.3-3mdk
  88. - [DIRM]
  89. * Sat Apr 10 2004 Michael Scherer <misc@mandrake.org> 0.8.3-2mdk
  90. - [DIRM]
  91. * Wed Aug 20 2003 Austin Acton <aacton@yorku.ca> 0.8.3-1mdk
  92. - 0.8.3
  93. * Tue Aug 12 2003 Per Oyvind Karlsen <peroyvind@linux-mandrake.com> 0.8.2-4mdk
  94. - rebuild for new python
  95. * Sat Mar 29 2003 David Walluck <walluck@linux-mandrake.com> 0.8.2-3mdk
  96. - release
  97. * Tue Mar 25 2003 David Walluck <david@anti-microsoft.org> 0.8.2-2plf
  98. - spec file cleanups
  99. * Sun Jan 26 2003 David Walluck <david@anti-microsoft.org> 0.8.2-1plf
  100. - release