perl-Gtk2-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189
  1. #
  2. # Rebuild option:
  3. #
  4. # --with testsuite - run the test suite (requires X)
  5. #
  6. Name: perl-Gtk2
  7. Version: 1.202
  8. Release: 2%{?_dist_release}
  9. Summary: Perl interface to the GTK+2
  10. Summary(ja): GTK+2 用の Perl インタフェース
  11. Group: Development/Libraries
  12. License: LGPLv2+
  13. URL: http://search.cpan.org/dist/Gtk2/
  14. Source0: http://www.cpan.org/authors/id/T/TS/TSCH/Gtk2-%{version}.tar.gz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: perl >= 5.8.0
  17. BuildRequires: gtk2-devel
  18. BuildRequires: perl(ExtUtils::Depends), perl(ExtUtils::PkgConfig)
  19. BuildRequires: perl(Glib) >= 1.160
  20. BuildRequires: perl(Cairo) >= 1.00
  21. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  22. Requires: perl(Glib)
  23. Requires: perl(Cairo)
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. %description
  27. This module allows you to write Gtk+ graphical user interfaces in a
  28. perlish and object-oriented way, freeing you from the casting and
  29. memory management in C, yet remaining very close in spirit to original
  30. API. Find out more about Gtk+ at http://www.gtk.org.
  31. %prep
  32. %setup -q -n Gtk2-%{version}
  33. iconv -f iso-8859-1 -t utf-8 -o pm/Helper.pm{.utf8,}
  34. mv pm/Helper.pm{.utf8,}
  35. # Provides: exclude perl(main)
  36. cat <<__EOF__ > %{name}-perl.prov
  37. #!/bin/sh
  38. /usr/lib/rpm/perl.prov \$* | grep -v '^perl(main)$'
  39. __EOF__
  40. %define __perl_provides %{_builddir}/Gtk2-%{version}/%{name}-perl.prov
  41. chmod +x %{__perl_provides}
  42. # Requires: exclude unversioned perl(Glib)
  43. cat <<__EOF__ > %{name}-perl.req
  44. #!/bin/sh
  45. /usr/lib/rpm/perl.req \$* | grep -v '^perl(Glib)$'
  46. __EOF__
  47. %define __perl_requires %{_builddir}/Gtk2-%{version}/%{name}-perl.req
  48. chmod +x %{__perl_requires}
  49. %build
  50. %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
  51. make %{?_smp_mflags}
  52. %install
  53. rm -rf $RPM_BUILD_ROOT
  54. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  55. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  56. find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
  57. find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null ';'
  58. chmod -R u+w $RPM_BUILD_ROOT/*
  59. %check
  60. %{?_with_testsuite:make test}
  61. %clean
  62. rm -rf $RPM_BUILD_ROOT
  63. %files
  64. %defattr(-,root,root,-)
  65. %doc AUTHORS ChangeLog LICENSE NEWS README TODO
  66. %doc examples/ gtk-demo/
  67. %{perl_vendorarch}/auto/Gtk2/
  68. %{perl_vendorarch}/Gtk2*
  69. %{_mandir}/man3/*.3pm*
  70. %changelog
  71. * Mon Mar 28 2011 IWAI, Masaharu <iwai@alib.jp> 1.202-2vl6
  72. - build with perl 5.12.3
  73. - add Vendor and Distribution tags
  74. * Tue Nov 04 2008 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 1.202-1
  75. - new upstream release
  76. * Mon Jul 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.162-1
  77. - initial build for Vine Linux
  78. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.162-4
  79. - Rebuild for perl 5.10 (again)
  80. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.162-3
  81. - Autorebuild for GCC 4.3
  82. * Tue Feb 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.162-2
  83. - rebuild for new perl
  84. * Wed Dec 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.162-1
  85. - Update to 1.162
  86. * Sun Mar 18 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.144-1
  87. - Update to 1.144.
  88. * Mon Feb 26 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.143-1
  89. - Update to 1.143.
  90. * Sun Jan 21 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.142-1
  91. - Update to 1.142.
  92. * Wed Nov 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.141-1
  93. - Update to 1.141.
  94. * Wed Sep 6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.140-1
  95. - Update to 1.140.
  96. * Mon May 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.122-1
  97. - Update to 1.122.
  98. * Mon May 1 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.121-2
  99. - Requires perl(Cairo) (distro >= FC-5).
  100. * Tue Apr 11 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.121-1
  101. - Update to 1.121.
  102. * Tue Mar 14 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.120-1
  103. - Update to 1.120.
  104. * Mon Feb 20 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.104-1
  105. - Update to 1.104.
  106. - Requires perl(Glib) >= 1.105 (1.104 had problems with perl 5.8.8).
  107. * Thu Jan 19 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.103-1
  108. - Update to 1.103.
  109. - Converted the Gtk2::Helper man page to utf8 (#177802).
  110. - Provides list: filtered out perl(main) (#177802).
  111. * Wed Nov 30 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.102-1
  112. - Update to 1.102.
  113. * Thu Oct 6 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.101-1
  114. - Update to 1.101.
  115. * Thu Sep 8 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.100-1
  116. - Update to 1.100.
  117. * Fri Jul 29 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.083-1
  118. - Update to 1.083.
  119. * Mon Jun 27 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.082-1
  120. - Update to 1.082.
  121. * Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
  122. - rebuilt
  123. * Thu Mar 10 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.080-2
  124. - Use perl-Glib for versioning control (patch by Ville Skyttä).
  125. * Tue Mar 8 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.080-1
  126. - Update to 1.080.
  127. * Tue Feb 15 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.062-1
  128. - Update to 1.062.
  129. * Mon Oct 25 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.061-0.fdr.2
  130. - Removed irrelevant or duplicated documentation files.
  131. - Description simplified (as suggested by Ville Skyttä).
  132. * Tue Oct 5 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.061-0.fdr.1
  133. - Update to 1.061.
  134. * Tue Oct 5 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.043-0.fdr.2
  135. - make test commented: needs X.
  136. * Sun Jul 18 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.043-0.fdr.1
  137. - First build.