perl-Crypt-SSLeay-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251
  1. # -*- coding: utf-8 -*-
  2. %define origname Crypt-SSLeay
  3. Name: perl-Crypt-SSLeay
  4. Summary: Crypt::SSLeay - OpenSSL glue that provides LWP https support
  5. Version: 0.57
  6. Release: 2%{?_dist_release}
  7. License: Perl's
  8. Group: Development/Libraries
  9. Source0: http://www.cpan.org/authors/id/D/DL/DLAND/%{origname}-%{version}.tar.gz
  10. Patch1: perl-Crypt-SSLeay-cryptdef.patch
  11. Patch2: perl-Crypt-SSLeay-0.57-live-tests.patch
  12. Patch3: perl-Crypt-SSLeay-Makefile_ssl1.patch
  13. URL: http://search.cpan.org/dist/Crypt-SSLeay/
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: openssl-devel
  16. BuildRequires: perl
  17. BuildRequires: perl-URI
  18. BuildRequires: perl-Test-Pod-Coverage
  19. BuildRequires: perl-libwww-perl
  20. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  21. Requires: openssl
  22. Distribution: Vine Linux
  23. Vendor: Project Vine
  24. Packager: iwaim
  25. %description
  26. This perl module provides support for the https protocol under LWP, so
  27. that a LWP::UserAgent can make https GET & HEAD & POST
  28. requests. Please see perldoc LWP for more information on POST
  29. requests.
  30. The Crypt::SSLeay package contains Net::SSL, which is automatically
  31. loaded by LWP::Protocol::https on https requests, and provides the
  32. necessary SSL glue for that module to work.
  33. %prep
  34. %setup -q -n %{origname}-%{version}
  35. %patch1 -p1 -b .cryptdef
  36. %patch2 -p1
  37. %patch3 -p1 -b .make
  38. # Filter unwanted Provides:
  39. cat << EOF > %{name}-prov
  40. #!/bin/sh
  41. %{__perl_provides} $* |\
  42. sed -e '/perl(DB)/d'
  43. EOF
  44. %define __perl_provides %{_builddir}/Crypt-SSLeay-%{version}/%{name}-prov
  45. chmod +x %{__perl_provides}
  46. %build
  47. if pkg-config openssl ; then
  48. export INC="$CFLAGS `pkg-config --cflags-only-I openssl`"
  49. export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
  50. fi
  51. %{__perl} Makefile.PL --default --no-live-tests INC="$INC" \
  52. LDFLAGS="$LDFLAGS" INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
  53. make %{?_smp_mflags}
  54. %clean
  55. rm -rf $RPM_BUILD_ROOT
  56. %install
  57. rm -rf $RPM_BUILD_ROOT
  58. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  59. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  60. find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  61. find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  62. chmod -R u+w $RPM_BUILD_ROOT/*
  63. chmod -R 644 eg/*
  64. chmod -R 644 certs/*
  65. #%check
  66. #make test
  67. %files
  68. %defattr(-,root,root,-)
  69. %doc README Changes eg/* certs/*
  70. %{perl_vendorarch}/auto/Crypt/
  71. %{perl_vendorarch}/Crypt/
  72. %{perl_vendorarch}/Net/
  73. %{_mandir}/man3/*.3*
  74. %changelog
  75. * Sun Apr 3 2011 IWAI, Masaharu <iwai@alib.jp> 0.57-2vl6
  76. - build with perl 5.12.3
  77. * Wed Apr 7 2010 IWAI, Masaharu <iwai@alib.jp> 0.57-1
  78. - initial build for Vine Linux
  79. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.57-16
  80. - rebuild against perl 5.10.1
  81. * Wed Nov 25 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.57-14
  82. - change Makefile for openssl 1.0, which couldn't be found properly before
  83. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.57-13
  84. - rebuilt with new openssl
  85. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.57-12
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  87. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.57-11
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  89. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.57-10
  90. - rebuild with new openssl
  91. * Mon Oct 6 2008 Marcela Maslanova <mmaslano@redhat.com> - 0.57-9
  92. - add examples into doc
  93. * Wed Sep 24 2008 Marcela Maslanova <mmaslano@redhat.com> - 0.57-8
  94. - fix patches for fuzz
  95. * Wed Mar 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.57-7
  96. - rebuild for new perl
  97. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.57-6
  98. - Autorebuild for GCC 4.3
  99. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.57-5
  100. - Rebuild for deps
  101. * Wed Dec 5 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-4
  102. - Rebuild for new openssl
  103. * Sat Oct 27 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-3
  104. - Remove unnecessary BR: pkgconfig
  105. * Fri Oct 26 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-2
  106. - Fix buildroot per package review
  107. - Resolves: bz#226248
  108. * Thu Oct 25 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-1
  109. - Update to latest upstream version.
  110. - Remove old patch (patch applied to upstream)
  111. - Several fixes for package review:
  112. - Fixed BuildRequires (added Test::Pod and LWP::UserAgent)
  113. - Apply patch to avoid prompting for input when building Makefile
  114. - Fix defattr line
  115. - Resolves: bz#226248
  116. * Mon Aug 27 2007 Robin Norwood <rnorwood@redhat.com> - 0.56-2
  117. - perl(ExtUtils::MakeMaker::Coverage) is now available
  118. * Mon Aug 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.56-1
  119. - 0.56 is the latest CPAN version, not 0.55
  120. * Mon Aug 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.55-2
  121. - Update to latest version from CPAN: 0.55
  122. - Remove two old patches, update lib64 patch for Makefile.PL changes.
  123. * Tue Feb 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.53-1
  124. - New version: 0.53
  125. * Mon Nov 27 2006 Robin Norwood <rnorwood@redhat.com> - 0.51-12
  126. - Resolves: bug#217138
  127. - fix a segfault on x86_64
  128. * Tue Oct 17 2006 Robin Norwood <rnorwood@redhat.com> - 0.51-10
  129. - Filter out Provides perl(DB)
  130. - bug #205562
  131. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.2.1
  132. - rebuild
  133. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.2
  134. - bump again for double-long bug on ppc(64)
  135. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.1
  136. - rebuilt for new gcc4.1 snapshot and glibc changes
  137. * Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 0.51-9.2
  138. - rebuild for new perl-5.8.8 / gcc / glibc
  139. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  140. - rebuilt for new gcc
  141. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  142. - rebuilt for new gcj
  143. * Thu Nov 10 2005 Tomas Mraz <tmraz@redhat.com> 0.51-9
  144. - rebuilt against new openssl
  145. - added missing SSL_library_init()
  146. * Sat Sep 24 2005 Ville Skyttä <ville.skytta at iki.fi> 0.51-8
  147. - Own more installed dirs (#73908).
  148. - Enable rpmbuild's internal dependency generator, drop unneeded dependencies.
  149. - Require perl(:MODULE_COMPAT_*).
  150. - Run tests in the %%check section.
  151. - Fix License, Source0, URL, and Group tags.
  152. * Wed Mar 30 2005 Warren Togami <wtogami@redhat.com> 0.51-7
  153. - remove brp-compress
  154. * Tue Mar 8 2005 Joe Orton <jorton@redhat.com> 0.51-6
  155. - rebuild
  156. * Tue Aug 31 2004 Chip Turner <cturner@redhat.com> 0.51-5
  157. - build for FC3
  158. * Tue Aug 31 2004 Chip Turner <cturner@redhat.com> 0.51-4
  159. - build for RHEL3 U4
  160. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  161. - rebuilt
  162. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  163. - rebuilt
  164. * Fri Feb 13 2004 Chip Turner <cturner@redhat.com> 0.51-1
  165. - update to upstream 0.51
  166. * Thu Jun 05 2003 Elliot Lee <sopwith@redhat.com>
  167. - rebuilt
  168. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com>
  169. - pass openssl includes to make as INC and ldflags in as LDFLAGS
  170. * Thu Nov 21 2002 Chip Turner <cturner@redhat.com>
  171. - patch to support /usr/lib64 before /usr/lib
  172. * Wed Nov 20 2002 Chip Turner <cturner@redhat.com>
  173. - rebuild
  174. * Tue Aug 6 2002 Chip Turner <cturner@redhat.com>
  175. - automated release bump and build
  176. * Thu Jun 27 2002 Chip Turner <cturner@redhat.com>
  177. - description update
  178. * Tue Jun 25 2002 Chip Turner <cturner@redhat.com>
  179. - move to 0.39
  180. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  181. - automated rebuild
  182. * Fri Dec 7 2001 root <root@redhat.com>
  183. - Spec file was autogenerated.