readline-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353
  1. Summary: A library for editing typed in command lines.
  2. Summary(ja): Readline ライブラリ
  3. Name: readline
  4. Version: 8.0
  5. Release: 1%{?_dist_release}
  6. License: GPLv3+
  7. Group: System Environment/Libraries
  8. URL: http://tiswww.tis.case.edu/~chet/readline/rltop.html
  9. Source: https://ftp.gnu.org/gnu/readline/readline-%{version}.tar.gz
  10. # upstream patches
  11. Patch1: https://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline80-001
  12. # fix file permissions, remove RPATH, use CFLAGS
  13. Patch10: readline-8.0-shlib.patch
  14. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: sed
  16. BuildRequires: ncurses-devel
  17. Requires(post): /sbin/install-info, /sbin/ldconfig
  18. Requires(preun): /sbin/install-info
  19. Requires(postun): /sbin/ldconfig
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  23. %description
  24. The Readline library provides a set of functions that allow users to
  25. edit command lines. Both Emacs and vi editing modes are available. The
  26. Readline library includes additional functions for maintaining a list
  27. of previously-entered command lines for recalling or editing those
  28. lines, and for performing csh-like history expansion on previous
  29. commands.
  30. %description -l ja
  31. Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
  32. Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
  33. これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
  34. %package devel
  35. Summary: Files needed to develop programs which use the readline library.
  36. Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
  37. Group: Development/Libraries
  38. Requires: readline = %{version}
  39. Requires: ncurses-devel
  40. %description devel
  41. The Readline library provides a set of functions that allow users to
  42. edit typed command lines. If you want to develop programs that will
  43. use the readline library, you need to have the readline-devel package
  44. installed. You also need to have the readline package installed.
  45. %package -n compat32-%{name}
  46. Summary: A library for editing typed in command lines.
  47. Summary(ja): Readline ライブラリ
  48. Group: System Environment/Libraries
  49. Requires: %{name} = %{version}-%{release}
  50. %description -n compat32-%{name}
  51. The Readline library provides a set of functions that allow users to
  52. edit command lines. Both Emacs and vi editing modes are available. The
  53. Readline library includes additional functions for maintaining a list
  54. of previously-entered command lines for recalling or editing those
  55. lines, and for performing csh-like history expansion on previous
  56. commands.
  57. %description -n compat32-%{name} -l ja
  58. Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
  59. Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
  60. これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
  61. %package -n compat32-%{name}-devel
  62. Summary: Files needed to develop programs which use the readline library.
  63. Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
  64. Group: Development/Libraries
  65. Requires: %{name} = %{version}-%{release}
  66. Requires: %{name}-devel = %{version}-%{release}
  67. Requires: compat32-ncurses-devel
  68. %description -n compat32-%{name}-devel
  69. The Readline library provides a set of functions that allow users to
  70. edit typed command lines. If you want to develop programs that will
  71. use the readline library, you need to have the readline-devel package
  72. installed. You also need to have the readline package installed.
  73. %prep
  74. %setup -q
  75. # upstream patches
  76. %patch1 -p0 -b .001
  77. %patch10 -p1 -b .shlib
  78. %build
  79. %configure --with-curses --disable-install-examples
  80. make %{?_smp_mflags}
  81. %install
  82. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  83. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  84. make DESTDIR=$RPM_BUILD_ROOT install
  85. mkdir $RPM_BUILD_ROOT/%{_lib}
  86. mv $RPM_BUILD_ROOT%{_libdir}/libreadline.so.* $RPM_BUILD_ROOT/%{_lib}
  87. for l in $RPM_BUILD_ROOT%{_libdir}/libreadline.so; do
  88. ln -sf $(echo %{_libdir} | \
  89. sed 's,\(^/\|\)[^/][^/]*,..,g')/%{_lib}/$(readlink $l) $l
  90. done
  91. rm -rf $RPM_BUILD_ROOT%{_docdir}/readline
  92. rm -rf $RPM_BUILD_ROOT%{_datadir}/readline
  93. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  94. %clean
  95. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  96. %post
  97. /sbin/ldconfig
  98. /sbin/install-info %{_infodir}/history.info.gz %{_infodir}/dir &> /dev/null
  99. /sbin/install-info %{_infodir}/rluserman.info.gz %{_infodir}/dir &> /dev/null
  100. :
  101. %postun -p /sbin/ldconfig
  102. %post -n compat32-%{name} -p /sbin/ldconfig
  103. %postun -n compat32-%{name} -p /sbin/ldconfig
  104. %preun
  105. if [ $1 = 0 ]; then
  106. /sbin/install-info --delete %{_infodir}/history.info.gz %{_infodir}/dir &> /dev/null
  107. /sbin/install-info --delete %{_infodir}/rluserman.info.gz %{_infodir}/dir &> /dev/null
  108. fi
  109. :
  110. %post devel
  111. /sbin/install-info %{_infodir}/readline.info.gz %{_infodir}/dir &> /dev/null
  112. :
  113. %preun devel
  114. if [ $1 = 0 ]; then
  115. /sbin/install-info --delete %{_infodir}/readline.info.gz %{_infodir}/dir &> /dev/null
  116. fi
  117. :
  118. %files
  119. %defattr(-,root,root)
  120. %license COPYING
  121. %doc CHANGES NEWS README USAGE
  122. /%{_lib}/libreadline*.so.*
  123. %{_libdir}/libhistory*.so.*
  124. %{_infodir}/history.info*
  125. %{_infodir}/rluserman.info*
  126. %files devel
  127. %defattr(-,root,root)
  128. %doc examples/*.c examples/*.h examples/rlfe
  129. %{_includedir}/readline
  130. %{_libdir}/lib*.a
  131. %{_libdir}/lib*.so
  132. %{_libdir}/pkgconfig/*.pc
  133. %{_infodir}/readline.info*
  134. %{_mandir}/man*/*
  135. %if %{build_compat32}
  136. %files -n compat32-%{name}
  137. %defattr(-,root,root)
  138. /%{_lib}/libreadline*.so.*
  139. %{_libdir}/libhistory*.so.*
  140. %files -n compat32-%{name}-devel
  141. %defattr(-,root,root)
  142. %{_libdir}/lib*.a
  143. %{_libdir}/lib*.so
  144. %{_libdir}/pkgconfig/*.pc
  145. %endif
  146. %changelog
  147. * Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0-1
  148. - new upstream release.
  149. - dropped all of official patches.
  150. - added Patch1.
  151. - dropped Patch9.
  152. - updated Patch10.
  153. * Sat Mar 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.3-1
  154. - new upstream release
  155. - update upstream patches (patch1-8)
  156. * Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2-5
  157. - rebuild with VineSeed environment
  158. * Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 5.2-4
  159. - add upstream patches 13,14 (Patch13,14)
  160. * Fri Mar 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.2-3
  161. - rebuilt with new toolchain
  162. - add Requires(post,pre): /sbin/ldconfig
  163. * Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2-2vl5
  164. - build with ncurses-devel
  165. - spec in utf8
  166. - move libncurses.so.* to %%_lib from %%_libdir
  167. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-1vl5
  168. - added upstream patches (patch8-12)
  169. * Fri Oct 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-0vl1
  170. - new upstream release
  171. - update upstream patches (patch1-7)
  172. * Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 5.1-0vl1
  173. - new upstream release
  174. - update upstream patches (patch1-4)
  175. - add doc/*.{html,pdf} instead of doc/
  176. * Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.3-5vl3
  177. - s/Copyright/License/
  178. - add URL
  179. - update source URL
  180. - add PreReq: ldconfig
  181. - move outdated.patch (patch1) to patch10
  182. - add upstream patches (patch1-5)
  183. - add no_rpath.patch (patch11)
  184. * Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 4.3-5vl2
  185. - added compat32- packages for x86_64 architecture support
  186. - fixed %files section (TODO* has been removed)
  187. * Sat Mar 8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3-5vl1
  188. - new upstream release 4.3
  189. - merged with rawhide package.
  190. * Wed Nov 20 2002 Tim Powers <timp@redhat.com>
  191. - rebuild in current collinst
  192. - BuildRequires autoconf only
  193. * Wed Aug 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-3
  194. - Fixed Esc-O-M stack overflow bug.
  195. * Mon Jul 22 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-1
  196. - Updated to latest readline release 4.3
  197. * Thu Jul 11 2002 Phil Knirsch <pknirsch@redhat.com> 4.2a-7
  198. - Fixed problem with alpha build.
  199. * Wed Jul 10 2002 Phil Knirsch <pknirsch@redhat.com>
  200. - Fixed utf8 problem (originally observed in bash).
  201. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 4.2a-6
  202. - automated rebuild
  203. * Thu May 23 2002 Tim Powers <timp@redhat.com> 4.2a-5
  204. - automated rebuild
  205. * Wed Mar 20 2002 Trond Eivind Glomsrod <teg@redhat.com> 4.2a-4
  206. - Use autoconf 2.53, not 2.52
  207. * Mon Mar 4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-3
  208. - Rebuild
  209. * Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 4.2a-2
  210. - removed the manual symlinking of .so, readline handles this by itself
  211. - call only %%makeinstall, not %%makeinstall install install-shared as
  212. this makes bogus .old files in the buildroot
  213. * Tue Nov 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-1
  214. - 4.2a
  215. * Tue Oct 2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-4
  216. - Work around autoconf bug
  217. * Mon Oct 1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-3
  218. - Don't use readline's internal re-implementation of strpbrk on systems
  219. that have strpbrk - the system implementation is faster and better maintained.
  220. * Tue Aug 7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-2
  221. - Make sure headers can be included from C++ applications (#51131)
  222. (Patch based on Debian's with the bugs removed ;) )
  223. * Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  224. - update to 4.2 and adapt patches
  225. * Fri Apr 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  226. - change the paths listed for the header files in the man page to reflect
  227. the location changes from previous versions (#35073)
  228. - note that "on" is acceptable instead of "On" in the man page (#21327)
  229. * Thu Mar 8 2001 Preston Brown <pbrown@redhat.com>
  230. - fix reading of end key termcap value (@7 is correct, was kH) (#30884)
  231. * Tue Jan 30 2001 Nalin Dahyabhai <nalin@redhat.com>
  232. - mark the man page as currently out-of-date (#25294)
  233. * Tue Sep 4 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl5
  234. - remove texi2dvi and texi2html from doc/
  235. * Fri Jun 29 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl4
  236. - added doc and examples
  237. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  238. - 4.1-6vl3
  239. - rebuilt for VineSeed
  240. * Wed Dec 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  241. - 4.1-6vl2
  242. - Oops, spec was written in SJIS...
  243. * Sat Dec 9 2000 Jun Nishii <jun@vinelinux.org>
  244. - 4.1-6vl1
  245. - got i18n patch from Kondara
  246. * Thu Sep 7 2000 Jeff Johnson <jbj@redhat.com>
  247. - FHS packaging (64bit systems need to use libdir).
  248. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  249. - summaries from specspo.
  250. * Wed Aug 2 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  251. - use "rm -f" in specfile
  252. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  253. - automatic rebuild
  254. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  255. - FHS packaging.
  256. * Tue Mar 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  257. - 4.1
  258. * Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
  259. - update to 4.0
  260. * Fri Apr 09 1999 Michael K. Johnson <johnsonm@redhat.com>
  261. - added guard patch from Taneli Huuskonen <huuskone@cc.helsinki.fi>
  262. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  263. - auto rebuild in the new build environment (release 4)
  264. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  265. - updated to 2.2.1
  266. * Wed May 06 1998 Prospector System <bugs@redhat.com>
  267. - translations modified for de, fr, tr
  268. * Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
  269. - don't package /usr/info/dir
  270. * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
  271. - devel package moved to Development/Libraries
  272. * Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
  273. - updated to 2.2
  274. * Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
  275. - spec file cleanups
  276. * Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
  277. - added proper sonames
  278. * Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
  279. - updated to readline 2.1
  280. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  281. - built against glibc