stunnel.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447
  1. Summary: An SSL-encrypting socket wrapper
  2. Name: stunnel
  3. Version: 4.54
  4. Release: 2%{?dist}
  5. License: GPLv2
  6. Group: Applications/Internet
  7. URL: http://stunnel.mirt.net/
  8. Source0: ftp://stunnel.mirt.net/stunnel/stunnel-%{version}.tar.gz
  9. Source1: ftp://stunnel.mirt.net/stunnel/stunnel-%{version}.tar.gz.asc
  10. Source2: Certificate-Creation
  11. Source3: sfinger.xinetd
  12. Source4: stunnel-sfinger.conf
  13. Source5: pop3-redirect.xinetd
  14. Source6: stunnel-pop3s-client.conf
  15. Patch0: stunnel-4-authpriv.patch
  16. Patch1: stunnel-4-sample.patch
  17. Buildroot: %{_tmppath}/stunnel-root
  18. # util-linux is needed for rename
  19. BuildRequires: openssl-devel, pkgconfig, tcp_wrappers-devel, util-linux
  20. %description
  21. Stunnel is a socket wrapper which can provide SSL (Secure Sockets
  22. Layer) support to ordinary applications. For example, it can be used
  23. in conjunction with imapd to create an SSL secure IMAP server.
  24. %prep
  25. %setup -q
  26. %patch0 -p1 -b .authpriv
  27. %patch1 -p1 -b .sample
  28. iconv -f iso-8859-1 -t utf-8 < doc/stunnel.fr.8 > doc/stunnel.fr.8_
  29. mv doc/stunnel.fr.8_ doc/stunnel.fr.8
  30. %build
  31. CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
  32. if pkg-config openssl ; then
  33. CFLAGS="$CFLAGS `pkg-config --cflags openssl`";
  34. LDFLAGS="`pkg-config --libs-only-L openssl`"; export LDFLAGS
  35. fi
  36. %configure --disable-fips --enable-ipv6 \
  37. CPPFLAGS="-UPIDFILE -DPIDFILE='\"%{_localstatedir}/run/stunnel.pid\"'"
  38. make LDADD="-pie -Wl,-z,defs,-z,relro,-z,now"
  39. %install
  40. rm -rf $RPM_BUILD_ROOT
  41. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stunnel
  42. touch $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.pem
  43. make install DESTDIR=$RPM_BUILD_ROOT
  44. # Move the translated man pages to the right subdirectories, and strip off the
  45. # language suffixes.
  46. for lang in fr pl ; do
  47. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8
  48. mv $RPM_BUILD_ROOT/%{_mandir}/man8/*.${lang}.8* $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/
  49. rename ".${lang}" "" $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/*
  50. done
  51. mkdir srpm-docs
  52. cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} srpm-docs
  53. %clean
  54. rm -rf $RPM_BUILD_ROOT
  55. %files
  56. %defattr(-,root,root)
  57. %doc AUTHORS BUGS ChangeLog COPY* CREDITS PORTS README TODO
  58. %doc tools/stunnel.conf-sample
  59. %doc srpm-docs/*
  60. %lang(en) %doc doc/en/*
  61. %lang(po) %doc doc/pl/*
  62. %{_bindir}/stunnel
  63. %exclude %{_bindir}/stunnel3
  64. %exclude %{_datadir}/doc/stunnel
  65. %{_libdir}/stunnel
  66. %exclude %{_libdir}/stunnel/libstunnel.la
  67. %{_mandir}/man8/stunnel.8*
  68. %lang(fr) %{_mandir}/fr/man8/stunnel.8*
  69. %lang(pl) %{_mandir}/pl/man8/stunnel.8*
  70. %dir %{_sysconfdir}/%{name}
  71. %exclude %{_sysconfdir}/stunnel/*
  72. %changelog
  73. *Mon Dec 10 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-2
  74. - 884183: support for full relro.
  75. *Tue Oct 16 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-1
  76. - New upstream realease 4.54
  77. - Updated local patches
  78. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.53-2
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  80. * Mon May 14 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.53-1
  81. - New upstream realease 4.53
  82. - Updated local patches
  83. * Tue Mar 6 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.52-1
  84. - New upstream realease 4.52
  85. - Updated local patches
  86. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.50-2
  87. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  88. * Tue Jan 3 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.50-1
  89. - New upstream realease 4.50
  90. - Updated local patches
  91. * Tue Sep 20 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.44-1
  92. - New upstream realease 4.44
  93. - Updated local patches
  94. * Fri Aug 19 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.42-1
  95. - New upstream realease 4.42
  96. - Updated local patches
  97. - Fixes #732069
  98. * Mon Aug 1 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.41-1
  99. - New upstream realease 4.41
  100. - Updated local patches to match the new release
  101. * Tue Jun 28 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.37-1
  102. - New upstream realease 4.37
  103. - Updated local patches to match the new release
  104. * Mon Apr 4 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.35-1
  105. - New upstream realease 4.35
  106. - Updated authpriv and sample patches to match the new release
  107. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.34-2
  108. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  109. * Mon Oct 4 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.34-1
  110. - New upstream realease 4.34
  111. - Updated authpriv and sample patches to match the new release
  112. * Wed Apr 7 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.33-1
  113. - New upstream realease 4.33
  114. - Updated authpriv and sample patches to match the new release
  115. - Addresses bz 580117 (inted mode support issue)
  116. * Mon Mar 29 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.32-1
  117. - New upstream realease 4.32
  118. - Updated authpriv and sample patches to match the new release
  119. * Tue Feb 16 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.31-1
  120. - New upstream realease 4.31
  121. - Updated authpriv and sample patches to match the new release
  122. * Tue Jan 26 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.30-1
  123. - New upstream realease 4.30
  124. - Updated authpriv and sample patches for the new release
  125. * Tue Dec 09 2009 Avesh Agarwal <avagarwa@redhat.com> - 4.29-1
  126. - New upstream realease 4.29
  127. - Updated authpriv and sample patches for the new release
  128. - Modified spec file to include dist tag
  129. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 4.27-5
  130. - rebuilt with new openssl
  131. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.27-4
  132. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  133. * Sun May 3 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-3
  134. - Fix the previous patch.
  135. * Wed Apr 29 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-2
  136. - Avoid aliasing undefined by ISO C
  137. * Thu Apr 16 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-1
  138. - Update to stunnel-4.27.
  139. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.26-3
  140. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  141. * Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 4.26-2
  142. - disable openssl upstream fips mode
  143. * Mon Sep 22 2008 Miloslav Trmač <mitr@redhat.com> - 4.26-1
  144. - Update to stunnel-4.26.
  145. * Sun Jun 8 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-2
  146. - Use a clearer error message if the service name is unknown in "accept"
  147. Resolves: #450344
  148. * Mon Jun 2 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-1
  149. - Update to stunnel-4.25
  150. * Tue May 20 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-2
  151. - Drop stunnel3
  152. Resolves: #442842
  153. * Mon May 19 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-1
  154. - Update to stunnel-4.24
  155. * Fri Mar 28 2008 Miloslav Trmač <mitr@redhat.com> - 4.22-1
  156. - Update to stunnel-4.22
  157. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.20-6
  158. - Autorebuild for GCC 4.3
  159. * Tue Dec 4 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-5
  160. - Rebuild with openssl-0.9.8g
  161. * Tue Oct 16 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-4
  162. - Revert the port to NSS, wait for NSS-based stunnel 5.x instead
  163. Resolves: #301971
  164. - Mark localized man pages with %%lang (patch by Ville Skyttä)
  165. Resolves: #322281
  166. * Tue Aug 28 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-3.nss
  167. - Port to NSS
  168. * Mon Dec 4 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-2
  169. - Update BuildRequires for the separate tcp_wrappers-devel package
  170. * Thu Nov 30 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-1
  171. - Update to stunnel-4.20
  172. * Sat Nov 11 2006 Miloslav Trmac <mitr@redhat.com> - 4.19-1
  173. - Update to stunnel-4.19
  174. * Wed Oct 25 2006 Miloslav Trmac <mitr@redhat.com> - 4.18-1
  175. - Update to stunnel-4.18
  176. - Remove unused stunnel.cnf from the src.rpm
  177. - Fix some rpmlint warnings
  178. * Fri Aug 18 2006 Jesse Keating <jkeating@redhat.com> - 4.15-2
  179. - rebuilt with latest binutils to pick up 64K -z commonpagesize on ppc*
  180. (#203001)
  181. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.15-1.1
  182. - rebuild
  183. * Sat Mar 18 2006 Miloslav Trmac <mitr@redhat.com> - 4.15-1
  184. - Update to stunnel-4.15
  185. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.2
  186. - bump again for double-long bug on ppc(64)
  187. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.1
  188. - rebuilt for new gcc4.1 snapshot and glibc changes
  189. * Tue Jan 31 2006 Miloslav Trmac <mitr@redhat.com> - 4.14-3
  190. - Use pthread threading to fix crash on x86_64 (#179236)
  191. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  192. - rebuilt
  193. * Wed Nov 9 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-2
  194. - Rebuild with newer openssl
  195. * Thu Nov 3 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-1
  196. - Update to stunnel-4.14
  197. - Override changed default pid file location, keep it in %%{_localstatedir}/run
  198. * Sat Oct 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.13-1
  199. - Update to stunnel-4.13
  200. * Fri Sep 30 2005 Miloslav Trmac <mitr@redhat.com> - 4.12-1
  201. - Update to stunnel-4.12
  202. * Thu Sep 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-2
  203. - Enable IPv6 (#169050, patch by Peter Bieringer)
  204. - Don't ship another copy of man pages in HTML
  205. * Tue Jul 12 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-1
  206. - Update to stunnel-4.11
  207. - Fix int/size_t mismatches in stack_info ()
  208. - Update Certificate-Creation for /etc/pki
  209. * Wed Jun 1 2005 Miloslav Trmac <mitr@redhat.com> - 4.10-2
  210. - Fix inetd mode
  211. - Remove unnecessary Requires: and BuildRequires:
  212. - Clean up the spec file
  213. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.10-1
  214. - update to 4.10
  215. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-2
  216. - add buildprereqs on libtool, util-linux; change textutils/fileutils dep to
  217. coreutils (#133961)
  218. * Wed Mar 16 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-1
  219. - update to 4.08
  220. - build stunnel as a PIE binary
  221. * Mon Nov 22 2004 Miloslav Trmac <mitr@redhat.com> - 4.05-4
  222. - Convert man pages to UTF-8
  223. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  224. - rebuilt
  225. * Thu May 27 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-2
  226. - move the sample configuration to %%doc, it shouldn't be used as-is (#124373)
  227. * Thu Mar 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-1
  228. - update to 4.05
  229. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  230. - rebuilt
  231. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  232. - rebuilt
  233. * Thu Aug 7 2003 Elliot Lee <sopwith@redhat.com> 4.04-6
  234. - Fix libtool
  235. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  236. - rebuilt
  237. * Fri Mar 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-4
  238. - fix xinetd configuration samples
  239. * Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-3
  240. - rebuild
  241. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  242. - rebuilt
  243. * Wed Jan 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-1
  244. - update to 4.04
  245. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.03-1
  246. - use pkgconfig for information about openssl, if available
  247. * Fri Jan 3 2003 Nalin Dahyabhai <nalin@redhat.com>
  248. - update to 4.03
  249. * Mon Oct 21 2002 Nalin Dahyabhai <nalin@redhat.com> 4.02-1
  250. - update to 4.02
  251. * Fri Oct 4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.00-1
  252. - don't create a dummy cert
  253. * Wed Sep 25 2002 Nalin Dahyabhai <nalin@redhat.com>
  254. - update to 4.00
  255. - remove textutils and fileutils as buildreqs, add automake/autoconf
  256. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  257. - automated rebuild
  258. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  259. - automated rebuild
  260. * Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-2
  261. - rebuild in new environment
  262. * Wed Jan 2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-1
  263. - update to 3.22, correcting a format-string vulnerability
  264. * Wed Oct 31 2001 Nalin Dahyabhai <nalin@redhat.com> 3.21a-1
  265. - update to 3.21a
  266. * Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 3.20-1
  267. - log using LOG_AUTHPRIV facility by default (#47289)
  268. - make permissions on stunnel binary 0755
  269. - implicitly trust certificates in %%{_datadir}/ssl/trusted (#24034)
  270. * Fri Aug 10 2001 Nalin Dahyabhai <nalin@redhat.com> 3.19-1
  271. - update to 3.19 to avoid problems with stunnel being multithreaded, but
  272. tcp wrappers not being thrad-safe
  273. * Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com>
  274. - update to 3.17
  275. * Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com>
  276. - update to 3.16
  277. * Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
  278. - update to 3.15
  279. - enable tcp-wrappers support
  280. * Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
  281. - remove explicit requirement on openssl (specific version isn't enough,
  282. we have to depend on shared library version anyway)
  283. * Fri Apr 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  284. - update to 3.14
  285. * Mon Mar 26 2001 Preston Brown <pbrown@redhat.com>
  286. - depend on make (#33148)
  287. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  288. - rebuild in new environment
  289. * Tue Feb 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  290. - update to 3.13 to get pthread, OOB, 64-bit fixes
  291. - don't need sdf any more
  292. * Thu Dec 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  293. - pull in sdf to build the man page (#22892)
  294. * Fri Dec 22 2000 Nalin Dahyabhai <nalin@redhat.com>
  295. - update to 3.11
  296. - chuck the SIGHUP patch (went upstream)
  297. - chuck parts of the 64-bit clean patch (went upstream)
  298. * Thu Dec 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  299. - update to 3.10
  300. - more 64-bit clean changes, hopefully the last bunch
  301. * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  302. - change piddir from the default /var/stunnel to /var/run
  303. - clean out pid file on SIGHUP
  304. * Fri Dec 15 2000 Nalin Dahyabhai <nalin@redhat.com>
  305. - update to 3.9 to get a security fix
  306. * Wed Oct 25 2000 Matt Wilson <msw@redhat.com>
  307. - change all unsigned longs to u_int32_t when dealing with network
  308. addresses
  309. * Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  310. - make stunnel.pem also be (missingok)
  311. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  312. - move to Applications/Internet group
  313. - clean up %%post script
  314. - make stunnel.pem %%ghost %%config(noreplace)
  315. - provide a sample file for use with xinetd
  316. * Thu Jun 8 2000 Nalin Dahyabhai <nalin@redhat.com>
  317. - FHS compliance fixes
  318. - modify defaults
  319. * Tue Mar 14 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  320. - update to 3.8
  321. - do not create certificate if one already exists
  322. * Mon Feb 21 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  323. - update to 3.7
  324. - add patch to find /usr/share/ssl
  325. - change some perms
  326. * Sat Oct 30 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  327. - Modify spec file to match Red Hat standards
  328. * Fri Aug 12 1999 Damien Miller <damien@ibs.com.au>
  329. - Updated to 3.4a
  330. - Patched for OpenSSL 0.9.4
  331. - Cleaned up files section
  332. * Sun Jul 11 1999 Damien Miller <dmiller@ilogic.com.au>
  333. - Updated to 3.3
  334. * Sat Nov 28 1998 Damien Miller <dmiller@ilogic.com.au>
  335. - Initial RPMification