123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178 |
- %define pkgname xbmc
- %define name self-build-%{pkgname}
- %define sourceurl http://mirrors.xbmc.org/releases/source/%{pkgname}-%{version}.tar.gz
- Summary: Package to automatically build %{pkgname} rpm package
- Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
- Name: %{name}
- Version: 10.0
- Release: 3%{?_dist_release}
- Source0: %{pkgname}-vl.spec
- Source1: %{pkgname}.desktop
- Source2: %{pkgname}-%{version}-strings.xml
- Source3: %{pkgname}-%{version}-Confluence-strings.xml
- Source4: %{pkgname}-%{version}-default-locale.patch
- License: GPL
- Group: Restricted Software
- Requires(post): self-build-setup >= 0.8
- # (build)requies of target package.
- Requires(post): lsb
- Requires(post): python-imaging
- Requires(post): pysqlite
- Requires(post): hicolor-icon-theme
- Requires(post): desktop-file-utils
- Requires(post): MySQL-devel
- Requires(post): SDL_image-devel
- Requires(post): SDL_mixer-devel
- Requires(post): alsa-lib-devel
- Requires(post): avahi-devel
- Requires(post): bzip2-devel
- Requires(post): cmake
- Requires(post): curl-devel
- Requires(post): cvs
- Requires(post): dbus-devel
- Requires(post): desktop-file-utils
- Requires(post): enca-devel
- Requires(post): flac-devel
- Requires(post): fontconfig-devel
- Requires(post): fribidi-devel
- Requires(post): glew-devel
- Requires(post): gperf
- Requires(post): hal-devel
- Requires(post): jasper-devel
- Requires(post): libXinerama-devel
- Requires(post): libXmu-devel
- Requires(post): libXrandr-devel
- Requires(post): libXtst-devel
- Requires(post): libboost-devel
- Requires(post): libcdio-devel
- Requires(post): expat-devel
- Requires(post): libjpeg-devel
- Requires(post): libmicrohttpd-devel
- Requires(post): libmms-devel
- Requires(post): libmodplug-devel
- Requires(post): libogg-devel
- Requires(post): libpng-devel
- Requires(post): libsamplerate-devel
- Requires(post): libsmbclient-devel
- Requires(post): libtiff-devel
- Requires(post): libvorbis-devel
- Requires(post): nasm
- Requires(post): openssl-devel
- Requires(post): lzo-devel
- Requires(post): pcre-devel
- Requires(post): pulseaudio-libs-devel
- Requires(post): sqlite3-devel
- Requires(post): unzip
- Requires(post): wavpack-devel
- Requires(post): zlib-devel
- Requires(post): self-build-faac
- Requires(post): self-build-faad2
- Requires(post): self-build-libmad
- Requires(post): self-build-libmpeg2
- Requires(post): libvdpau-devel
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- Packager: kazutaka
- %description
- XBMC is an award-winning free and open source (GPL) software
- media player and entertainment hub for digital media.
- If you install this package, it automaticaly downloads source
- code ,compile it, and create rpm packages of %{pkgname}-%{version}.
- And the created rpm packages are automatically installed
- if installation is executed by apt-get command or synaptic
- package manager.
- [Note]
- This package requires many other packages to compile
- targetsoftware. So it consume more disk space than usual.
- Also installation takes logner time because of compilation.
- (This will take a few minutes to quarter or half of an hour,
- depends on building environment)
- [About self-build package]
- For some kind of software, distributing of binary package
- may viorate the patent or law. Therefore we chose self-build
- packge, create binary package on your machine, for such kind
- of softwares instead of distributing binary package.
- Please obey the national law when you use the created binary
- packages. And if you want to use the softwares using patented
- thechnology, it may be required to get a permission, make an
- agreement or purchas a license. Please consider it with your
- purpose or way of use and take appropriate action.
- %description -l ja
- XBMC はいくつもの賞を受賞したフリーでオープンソース (GPL) な、
- デジタルメディア向けのメディアプレイヤー/メディアセンターです。
- このパッケージをインストールすると、自動的にソースコードを
- ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
- パッケージを作成します。
- また apt-get コマンドや synaptic パッケージマネージャから実行
- した場合は、作成された rpm パッケージのインストールも自動的に
- 行います。
- [注意]
- コンパイルに必要な多くの関連パッケージを要求するので通常より
- ディスクの領域を多く消費します。
- またインストール時にコンパイルを行うため、通常より時間がかか
- る場合があります。(環境にもよりますが数分から数十分程度)
- [self-build パッケージについて]
- ソフトウェアによってはバイナリパッケージの配布が特許や法律に
- 違反する可能性があるものがあります。その為、このような問題が
- 懸念されるソフトウェアについてはバイナリパッケージを直接配布
- せずに、ユーザの環境でバイナリを作成する self-build パッケー
- ジという方法を採っています。
- 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
- アのライセンス、および利用する国の各種法令に従ってください。
- また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
- センスの購入などが必要となる場合がありますので、利用する目的
- や形態に応じて各自で判断し適切な対応を取ってください。
- %prep
- [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
- %install
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
- %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
- %{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
- %{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
- %{__install} -m 644 %{SOURCE3} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
- %{__install} -m 644 %{SOURCE4} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
- %clean
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %posttrans
- /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 2447000
- %files
- %defattr(-,root,root)
- %{_datadir}/%{name}
- %changelog
- * Fri Feb 04 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 10.0-3
- - delete build_vine5 macro: libvdpau is now available on 5.2
- * Thu Jan 27 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 10.0-2
- - add --disable-ccache option (<BTS:VineLinux:1100>)
- - update Source4 to change default timezone
- * Sun Jan 23 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 10.0-1
- - initial build for Vine Linux
|