shotwell-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223
  1. Name: shotwell
  2. Version: 0.10.1
  3. Release: 2%{?_dist_release}
  4. Summary: A photo manager for the GNOME desktop
  5. Summary(ja): GNOME デスクトップ向けの写真管理ツール
  6. Group: Applications/Graphics
  7. # LGPLv2+ for the code
  8. # CC-BY-SA for some of the icons
  9. License: LGPLv2+ and CC-BY-SA
  10. URL: http://www.yorba.org/shotwell/
  11. Source0: http://www.yorba.org/download/shotwell/0.10/shotwell-%{version}.tar.bz2
  12. # http://trac.yorba.org/ticket/3379
  13. Source1: shotwell-icons.tar.bz2
  14. Source2: shotwell-0.8.1-vine2-ja.po
  15. Patch1: shotwell-0.8.1-vala.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: GConf2-devel
  18. BuildRequires: LibRaw-devel
  19. BuildRequires: LibRaw-static
  20. BuildRequires: WebKit-gtk-devel
  21. BuildRequires: dbus-glib-devel
  22. BuildRequires: desktop-file-utils
  23. BuildRequires: gettext
  24. BuildRequires: gtk2-devel
  25. BuildRequires: gstreamer-devel
  26. BuildRequires: hal-devel
  27. BuildRequires: json-glib-devel
  28. BuildRequires: libexif-devel
  29. BuildRequires: libgee-devel
  30. BuildRequires: libgphoto2-devel
  31. BuildRequires: libgudev1-devel
  32. BuildRequires: libgexiv2-devel >= 0.2.0
  33. BuildRequires: libsoup-devel
  34. BuildRequires: libxml2-devel
  35. BuildRequires: sqlite3-devel
  36. BuildRequires: unique-devel
  37. BuildRequires: vala-devel >= 0.9.5
  38. Vendor: Project Vine
  39. Distribution: Vine Linux
  40. Packager: kudoh
  41. %description
  42. Shotwell is a new open source photo manager designed for the GNOME desktop
  43. environment. It allows you to import photos from your camera, view and edit
  44. them, and share them with others.
  45. %description -l ja
  46. Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
  47. 画像管理ツールです。
  48. あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
  49. 他の人々と共有するなどができます。
  50. %prep
  51. %setup -q -n %{name}-%{version}
  52. #%patch0 -p1
  53. #%patch1 -p1
  54. pushd po
  55. %__rm -f ja.po
  56. %__cp %{SOURCE2} ja.po
  57. popd
  58. %build
  59. ./configure --prefix=%{_prefix} --lib=%{_lib} --disable-schemas-install --assume-pkgs
  60. sed -i -e 's/\\n/\n/g' configure.mk
  61. sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
  62. sed -i -e 's|LIB_DIRS=.*$|LIB_DIRS=%{_libdir}|' libraw-config
  63. make %{?_smp_mflags}
  64. %install
  65. rm -rf $RPM_BUILD_ROOT
  66. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  67. export XDG_DISABLE_MAKEFILE_UPDATES=1
  68. # otherwise gettext always returns English text regardless of LANGUAGE asked
  69. export LANG=en_US.utf8
  70. make install DESTDIR=$RPM_BUILD_ROOT
  71. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
  72. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
  73. # put hi-res icons in place
  74. (
  75. cd $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
  76. rm -rf 16x16 24x24 scalable
  77. tar xf %{SOURCE1}
  78. )
  79. %find_lang %{name} --all-name
  80. %clean
  81. rm -rf $RPM_BUILD_ROOT
  82. %post
  83. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  84. update-desktop-database &> /dev/null || :
  85. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  86. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
  87. %pre
  88. if [ "$1" -gt 1 ]; then
  89. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  90. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
  91. fi
  92. %preun
  93. if [ "$1" -eq 0 ]; then
  94. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  95. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
  96. fi
  97. %postun
  98. if [ $1 -eq 0 ] ; then
  99. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  100. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  101. fi
  102. update-desktop-database &> /dev/null || :
  103. %posttrans
  104. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  105. %files -f %{name}.lang
  106. %defattr(-,root,root,-)
  107. %doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
  108. %{_sysconfdir}/gconf/schemas/shotwell.schemas
  109. %{_bindir}/shotwell
  110. %{_bindir}/shotwell-video-thumbnailer
  111. %{_libdir}/shotwell/plugins/builtin
  112. %{_datadir}/gnome/help/
  113. %{_datadir}/shotwell
  114. %{_datadir}/applications/shotwell.desktop
  115. %{_datadir}/applications/shotwell-viewer.desktop
  116. %{_datadir}/icons/hicolor/*
  117. %exclude %{_datadir}/icons/hicolor/icon-theme.cache
  118. %changelog
  119. * Sat Aug 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.1-2
  120. - rebuilt with libgexiv2-0.2.2-2
  121. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
  122. - new upstream release
  123. * Sat Jun 18 2011 IWAI, Masaharu <iwai@alib.jp> 0.8.1-5
  124. - add ja.po (Source2): fix <BTS:VineLinux:1142>
  125. - update Summary and description
  126. * Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
  127. - add hi-res icons (SOURCE1)
  128. - add LANG=en_US.utf8 to get gettext to actually generate translated strings
  129. * Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
  130. - dropt Patch0
  131. - added BuildRequires: LibRaw-static
  132. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
  133. - add Patch1 (shotwell-0.8.1-vala.patch)
  134. * Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
  135. - new upstream release
  136. - added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
  137. * Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
  138. - rebuilt with rpm-4.8.1 for pkg-config
  139. - fixed %%changelog in Tue Sep 14 2010
  140. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
  141. - new upstream release
  142. - changed source URL
  143. - added Patch0 to work around desktop file incorrect comment
  144. - changed BuildRequires: vala-devel >= 0.9.5
  145. * Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
  146. - new upstream release
  147. * Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
  148. - new upstream release
  149. - changed BuildRequires: libgexiv2-devel >= 0.2.0
  150. * Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
  151. - fixed LIB_DIRS in libraw-config (for lib64)
  152. * Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
  153. - new upstream release
  154. - added BuildRequires: LibRaw-devel, libgexiv2-devel
  155. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
  156. - new upstream release
  157. * Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
  158. - new upstream release
  159. - added BuildRequires: libgudev1-devel
  160. - applied new naming policy to spec
  161. * Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
  162. - new upstream release
  163. - proved Japanese description
  164. * Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
  165. - new upstrema release
  166. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
  167. - intial build for VineSeed
  168. * Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
  169. * Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  170. - Update to 0.3.2
  171. * Tue Nov 3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
  172. - Version 0.3.0
  173. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
  174. - Rebuild against new libgee
  175. * Sun Aug 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
  176. - Bring icon cache handling in sync with current guidelines
  177. * Sun Aug 9 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
  178. - Initial packaging